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About This Guide

In About this Guide . . . 

This section of the installation guide contains the following topics: 

• Purpose.....2

• Audience.....2

• User Guide Content.....2

• Conventions.....3

• Related Manuals.....4

• Online Help.....4

• SmartBits Hardware Handling/Cleaning Practices.....4

• How to Contact Us.....5
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About This Guide

Purpose

Purpose 

This user guide provides information on first-time SmartBits chassis connections and 

installation.

Audience

This user guide is designed for engineers and technicians who are familiar with PCs and 

have a working knowledge of telecommunications equipment. 

User Guide Content

This guide contains the following sections: 

Chapter 1, “About SmartBits 600/

6000B”

Introduces the SmartBits 600 and SmartBits 6000B 

chassis.

Chapter 2, “Installation and Setup” Describes the installation and set up of the 

SmartBits chassis. 

Chapter 3, “LED Indicators” Describes the LED status indicators of the chassis 

and different module types.

Chapter 4, “Troubleshooting” Describes error messages and various 

troubleshooting conditions.

Appendix A, “Connecting Multiple 

Chassis Locally”

Provides details for setup, connecting, and 

powering up multiple chassis used in stacking and 

expansion configurations. Also provides details for 

various Multi-chassis Extension Unit connections 

and configurations.

Appendix B, “Downloading and 

Installing Applications”

Provides the general steps for downloading and 

updating Spirent Communications software 

applications. 

Appendix C, “Debug Console” Describes how to access SmartWindow Debug 

console and outlines procedures for debugging 

specific SmartCards/modules.

Appendix D, “ESD Requirements” Provides ESD guidelines and procedures.

Appendix E, “Fiber Optic Cleaning 

Guidelines”

Provides cleaning guidelines for fiber optic 

equipment.

Index Provides a comprehensive index listing.
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Conventions 

This guide uses the following typographical conventions: 

• Italics is used for parameter and field names, chapter names, document titles, areas 

within windows, and words of emphasis. 

• Bold is used in procedures to indicate the menu, option, button, key, or tab being 

selected, as well as any parameter values. 

• The terms DUT and device under test as well as SUT and system under test are used 

interchangeably in this guide. 

• Text you enter or input is shown in Courier. 

• Directory and file names are shown in Helvetica.

• The terms packet and frame are used interchangeably.

• The term "SmartCard" refers to a printed circuit board used in an SMB-200/2000 

chassis. The term "module" generally refers to a printed circuit board used in an 

SMB-600/6000B chassis. The term "card" is often used in SmartBits software 

applications and in this manual to refer to either type of circuit board.

Notes, cautions, and other important user information are shown as follows: 

Note: Includes related information and tips. 

!
Caution: Includes related precautions.

Important:  Includes related important details.

Warning:  Includes related warnings to prevent damage to equipment and or injury. 

www.valuetronics.com
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About This Guide

Related Manuals

Related Manuals 

Additional manuals related to the Product NameSmartBits 600/6000B User Guide 

include:

• SmartBits System Reference: Explains SmartBits system architecture and hardware, 

basic concepts for using SmartBits systems, and additional maintenance/upgrade 

procedures. 

• All user guides supplied with both core and optional software applications.

Online Help 

In each SmartBits GUI application, you can access online Help in two ways:

• Press the F1 key in the window for which you require information.

• From the menu bar, select Help > Contents to view the entire contents of the Help 

file.

SmartBits Hardware Handling/Cleaning Practices

SmartBits SmartCards/modules contain electronic components that are sensitive to 

Electrostatic Discharge (ESD) damage. To prevent premature component failure or latent 

product damage, it is crucial that you handle this equipment following industry standard 

ESD handling practices. Refer to Appendix D, “ESD Requirements”of this document for 

further information.

Some SmartBits equipment contains fibre optic components that are very susceptible to 

contamination from particles of dirt and dust. Product performance may be damaged if 

these components are not kept clean. Refer to Appendix E, “Fiber Optic Cleaning 

Guidelines” for proper cleaning practices for these components.

www.valuetronics.com
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How to Contact Us

Technical support is available Monday through Friday between 07:00 and 18:00 Pacific 

Standard Time.

To obtain technical support for any product, please contact our Technical Support 

Department using any of the following methods:

Phone: +1 800.886.8842 (available in the U.S. and Canada)

+1 818.676.2589

Fax: +1 818.880.9154

E-mail: smartbits.support@spirentcom.com

In addition, the latest versions of application Help files, application notes, and software 

and firmware updates are available on our website at:

http://www.spirentcom.com

Company Address

Spirent Communications of Calabasas

26750 Agoura Road

Calabasas, CA 91302

USA

 +1 818.676.2300

www.valuetronics.com
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About SmartBits 600/6000B1

In this chapter . . . 

This chapter contains the following topics:

• Introduction.....8

• What is SmartBits?.....8

• What are the SmartBits Models?.....9

• SMB-600/6000B Features and Benefits.....10

• SmartBits Applications.....12

• Supported Modules.....13

• Specifications and Safety Requirements.....15
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Introduction

Networks and the communications industry are growing in size and complexity. Switches 

and routers contain faster ports and in response to this growth, networks have a greater 

number of nodes, with each node carrying more flows of traffic. In response to this 

growth, test system capabilities must also grow. Testing under real-world conditions can 

involve generating more than 64,000 flows of traffic. The SmartBits 600 and SmartBits 

6000B (referred to as SMB-600/6000B in this guide) are the next generation of test 

platforms that meet these growing requirements.

The SMB-600 and SMB-6000B chassis are high-density network performance analysis 

test systems. Both chassis support the same features and functionalities, and use SmartBits 

modules to support a variety of port types.

This installation guide explains how to install and set up the SMB-600/6000B after a brief 

introduction to the systems’ features. For more information about the SmartBits chassis 

and for hardware descriptions of the modules used in these chassis, refer to the SmartBits 

System Reference manual.

For installation details and a description of each software application, refer to each 

applications specific user guide and online help file.

What is SmartBits?

SMB-600/6000B Multiport Performance Analysis Systems allow you to test, simulate, 

analyze, troubleshoot, quality assure, develop, and certify the following protocols:

• 10/100/1000 Mbps Ethernet

• 10 Gigabit Ethernet

• OC-3c, OC-12c, OC-48c, and OC-192c Packet over SONET (POS)

• Fibre Channel

The following network types are supported:

• Switching hubs, routers, repeaters, and bridges

• Live networks

• Network interface cards (NICs)

• VLANs and ELANs

www.valuetronics.com
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What are the SmartBits Models?

SmartBits systems are comprised of five different chassis models. This user guide 

describes the following two models:

• SmartBits 600 chassis (SMB-600) with 2 slots, up to 16 ports.

• SmartBits 6000B chassis (SMB-6000B) high-density model, 12 slots, up to 96 ports.

Additional SmartBits models that are also available are listed below. Refer to the 

SmartBits 200/2000 User Guide for the description of these chassis.

• SmartBits 200 chassis (SMB-200), 4 slots.

• SmartBits 2000 chassis (SMB-2000), 20 slots.

SMB-600

The SMB-600 (see Figure 1-1) is a portable and compact high-density-for-its-size 

network performance analysis test system. Compatible with the SMB-6000B system, the 

SMB-600 holds up to two modules that can support up to:

• 16 10/100 Mbps Ethernet ports

• 4 Gigabit Ethernet ports

• 1 10 Gigabit Ethernet port

• 2 POS (Packet over SONET) ports

• 4 Fibre Channel ports

or a mixture of these port types.

Figure 1-1. SmartBits 600 Chassis
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SMB-6000B

The SMB-6000B is an ultra high-port density network performance analysis test system. 

Each chassis holds up to 12 modules that can support up to:

• 96 10/100/1000 Mbps Ethernet ports

• 24 Gigabit Ethernet ports

• 6 10 Gigabit Ethernet ports

• 12 POS (Packet over SONET) ports

• 12 Fibre Channel ports

or a mixture of these port types.

Figure 1-2. SmartBits 6000B Chassis

SMB-600/6000B Features and Benefits

The SMB-600/6000B provides the following features and capabilities:

• Control via an Ethernet port.

– Default IP Address allows quick and easy connection of your chassis without the 

need of a serial cable connection.

– The 10/100/1000 Mbps Ethernet port allows you to test a remote device by 

connecting it to the SmartBits chassis over a local Ethernet network. A serial port 

only permits a short point-to-point connection. 

– The Ethernet or Telnet port provides a link to your PC or UNIX workstation. The 

Ethernet port decreases the time it takes to update SmartBits chassis and module 

firmware, or to download configurations or upload data.

• High resolution and accuracy with internal clock.

This clock is used for latency and timestamps. The clock’s oscillator is specified for 

an error rating of less than 2 parts per million (ppm). The high level of accuracy 

provides long-term measurements, which are especially important when using higher 

speed interfaces such as Gigabit Ethernet.

www.valuetronics.com



Chapter 1: About SmartBits 600/6000B

SMB-600/6000B Features and Benefits

SmartBits 600/6000B Installation Guide 11

• Higher performance levels than the SMB-2000.

– Faster downloads of test configurations.

– Faster statistics data and captured traffic transfers to a PC or UNIX workstation.

• External clock support.

You can use a standard 10 MHz external clock. Once the SmartBits detects the 

external clock through the BNC connector, it automatically switches to the external 

clock for timestamping of latency measurement tests.

The external clock allows you to:

– Synchronize measurements between different systems.

– Use the high-accuracy reference clock often available in large network control 

centers.

• Clock Synchronization on Multiple Connected SmartBits.

You can synchronize different systems to one clock by connecting multiple chassis. 

Refer to Appendix A, “Connecting Multiple Chassis Locally,”for details.

Reset Button

The Reset Button is located above the LEDs on the front of the SMB-600/6000B chassis. 

When pushed in, such as with a paper clip or other small object, the Reset Button resets 

the chassis hardware and firmware and functions as a warm boot. If the chassis and 

module LEDs do not flicker uniformly during the reset, power cycle the chassis with the 

ON/OFF power switch.

Figure 1-3. Location of the Reset Button on the SMB-600/6000B Chassis

Reset
Button

Reset
Button
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SmartBits Applications 

SmartBits software applications that are available for use on the SMB-600/6000B include:

• SmartWindow

• SmartLib Programming Library

• ScriptCenter

• SmartApplications 

• SmartMulticastIP 

• SmartFlow

• SmartVoIPQoS

• SmartFabric

• AST II (Advanced Switch Tests)

• SmartxDSL

• SmartCableModemTest

• SmartTCP

• WebSuite 

• TeraRouting Tester

• TeraVPN

Note: For the latest software applications, release notes, online help, and updates to 

manuals, check the Spirent Communications website at www.spirentcom.com.
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Supported Modules

Table 1-1 shows a list of SMB-600/6000B supported modules and their connector types. 

For a complete description of each module, plus cabling information, refer to the 

SmartBits System Reference manual.

Table 1-1. SMB-600/6000B Supported Modules

Module Description Connector

LAN-3100A 10/100Base-TX Ethernet, 8 port module RJ-45

LAN-3101A 10/100Base-TX Ethernet, 6-port, SmartMetrics module RJ-45

LAN-3102A 10/100Base-TX Ethernet, 2-port, SmartMetrics module RJ-45

LAN-3111A 100Base-FX Ethernet, 6-port, multi-mode, 1300nm, SmartMetrics module SC Fiber

LAN-3150A 10/100Base Ethernet, 8-port, RMII/SMII module 80-pin 

LAN-3200A 1000Base-SX Ethernet, 2-port, multi-mode, 850nm module SC Fiber

LAN-3200As 1000Base-LX Ethernet, 2-port, single mode, 1310nm module SC Fiber

LAN-3201B 1000Base Ethernet, GBIC, 1-port, SmartMetrics module GBIC 

LAN-3300A 10/100/1000Base-T Ethernet Copper, 2-port, SmartMetrics module RJ-45

LAN-3301A 10/100/1000Base-T Ethernet Copper, 2-port, TeraMetrics module RJ-45

LAN-3302A 10/100Base-T Ethernet Copper, 2-port, TeraMetrics module RJ-45

LAN-3310A 1000Base-X Ethernet, GBIC, 2-port, SmartMetrics module GBIC

LAN-3311A 1000Base-X Ethernet, GBIC, 2-port, TeraMetrics module GBIC

LAN-3710AS 10GBase-SR Ethernet, 1-port, 2-slot, multi-mode, 850nm module GBIC

LAN-3710AL 10GBase-LR Ethernet, 1-port, 2-slot, single mode, 1310nm module GBIC

LAN-3710AE 10GBase-ER Ethernet, 1-port, 2-slot, single mode, 1550nm module GBIC

POS-3500B POS OC-3c/OC-12c, 1-port, multi-mode, SmartMetrics module SC Fiber

POS-3500Bs POS OC-3c/OC-12c, 1-port, single mode, SmartMetrics module SC Fiber

POS-3502A POS OC-3c, 1-port, multi-mode, SmartMetrics module SC Fiber

POS-3502As POS OC-3c, 1-port, single mode, SmartMetrics module SC Fiber

POS-3504As POS OC-48c, 1-port, single mode, 1310nm, SmartMetrics module SC Fiber
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POS-3504AR POS OC-48c, 1-port, single mode, 1550nm, SmartMetrics module SC Fiber

POS-3505As POS OC-48c, 1-port, single mode, 1310nm, TeraMetrics module SC Fiber

POS-3505AR POS OC-48c, 1-port, single mode, 1550nm, TeraMetrics module SC Fiber

POS-3510A POS OC-3c/OC-12c, 1-port, multi-mode, SmartMetrics module SC Fiber

POS-3510As POS OC-3c/OC-12c, 1-port, single mode, SmartMetrics module SC Fiber

POS-3511A POS OC-3c/OC-12c, 1-port, multi-mode, TeraMetrics module SC Fiber

POS-3511As POS OC-3c/OC-12c, 1-port, single mode, TeraMetrics module SC Fiber

POS-3518As POS OC-192c, 1-port, single mode, 1310nm, SmartMetrics module SC Fiber

POS-3518AR POS OC-192c, 1-port, 2-slot, single mode, 1550nm, SmartMetrics module SC Fiber

POS-3519As POS OC-192c, 1-port, 2-slot, single mode, 1310nm, TeraMetrics module SC Fiber

POS-3519AR POS OC-192c, 1-port, 2-slot, single mode, 1550nm, TeraMetrics module SC Fiber

FBC-3601A Fibre Channel 1G, 2-port, SmartMetrics module GBIC (20-pin)

FBC-3602A Fibre Channel 1G and 2G, 2-port, SmartMetrics module GBIC (20-pin)

Table 1-1. SMB-600/6000B Supported Modules

Module Description Connector
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Specifications and Safety Requirements

Specifications

• Input Power: 100-240 VAC Nominal 115 or 230 VAC, 50-60 Hz.

• Controllable over the Internet or from a PC with Windows 98/2000/NT.

• Maximum number of ports: SMB-600 – 16; SMB-6000B – 96.

• Dimensions: 

– SMB-600: Width: 12 in. (30.5 cm.)

Height: 3.5 in. (8.9 cm.)

Depth: 12.5 in. (31.8 cm.)

Weight: 5.25 lbs. (2.4 kg.) fully loaded. 

Shipping weight, approximately 8.5 lbs. (3.8 kg.)

– SMB-6000B: Width: 19 in. (48.26 cm.)

Height: 8.5 in. (21.59 cm.)

Depth: 16.5 in. (41.91 cm.)

Weight: 45 lbs. (20.4 kg.) fully loaded. 

Shipping weight, approximately 48 lbs. (21.8 kg.)

• Operating Environment: 59-104oF (15-40oC), 20-80% relative humidity. Must have 

unimpeded airflow into the fans at the side of the chassis.

Emissions

• FCC Part 15 Compliant 

• EMI Class A Standard

Safety

•  CSA Listed (CSA 22.2 No. 22)

•  TUV (IEC 950) approved

The SMB-600/6000B chassis are marked in conformity with the following European 

Commission Directives:

• The Low Voltage Directive (72/23/EEC)

• The Electromagnetic Compatibility Directive (89/336/EEC)

• The CE Marking Directive (93/68/EEC)
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FCC PART 15 Statement

This equipment has been tested and found to comply with the limits for a CE Mark class A 

digital devices, pursuant to part 15 of the FCC Rules. These limits are designed to provide 

reasonable protection against harmful interference in a residential installation.

This equipment generates, uses, and can radiate radio frequency energy and if not installed 

and used in accordance with the instructions, may cause harmful interference to radio 

communications. However, there is no guarantee that interference will not occur in a 

particular installation. 

If this equipment does cause harmful interference to radio or television reception, which 

can be determined by turning the equipment off and on, the user is encouraged to try to 

correct the interference by one or more of the following measures:

• Re-orient or re-located the receiving antenna.

• Increase the separation between the equipment and receiver.

• Connect the equipment into an outlet on a circuit different from that to which the 

receiver is connected.

• Consult the dealer or an experienced radio/TV technician for help.

SmartBits Compliance with EC Requirements

All SmartBits products, including chassis, SmartCards/modules, are designed and 

manufactured in compliance with EC directives on EMI and EMC Class A standards, as 

indicated by the CE Mark on the products. The CE Mark and declaration of conformity 

are made by submitting our product to an independent, EU-certified test lab. In this lab, 

each SmartBits card/module is tested individually while installed in the chassis that 

supports it. All certifications (including details of test configuration with photographs) are 

available to any customer who requires a copy.

The CE mark establishes a generic compatibility among different equipment in terms of 

EMI emissions. The EC directive (as with the equivalent FCC Part 15 directives) is an 

established standard in terms of laboratory support, available tools, and resources. It is 

currently the most commonly recognized and accepted engineering practice in designing 

electronic equipment. Spirent Communications designs and produces its products in 

conformance with EC directives in order to quantify performance measurements, with the 

ultimate goal of designing the best possible products in every respect.

To obtain the CE Mark declaration of conformity, each SmartBits product must pass the 

following standard tests: 

• EN 50081-1 Electro-Magnetic Emission Standard

• EN 50082-1 Electro-Magnetic Immunity Standard

• EN-55022 Radiated and Conducted Emissions Standard

• IEC 801-2 Electro-Static Discharge Standard
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• IEC 801-3 Radiated Immunity Standard

• IEC 801-4 Electrical Fast Transients/Burst Standard

• EN 61000 Power Analysis Harmonics and Flicker Standard

Guidelines on Equipment Use

In general, any equipment that is in compliance with the tests listed above will work well 

in a standard industrial environment. Such equipment will present minimum interference 

and similarly will experience minimum interference from other nearby equipment. Having 

passed the above tests, however, does not guarantee that the equipment will work in a 

“strong” EMI environment. Furthermore, it is difficult to specify what constitutes a 

“strong” EMI environment in the absence of any measurement standard.

With respect to SmartBits systems and cards, a typically equipped operating lab should 

cause no interference provided that all other equipment is in minimum compliance with 

CE Mark requirements.

To ensure that SmartBits systems perform well in your environment, observe the 

following guidelines when installing and using SmartBits in your lab:

1 All cables must be terminated, both at the SmartBits and at the DUT. Do not leave an 

unused port with a cable plugged in and dangling.

2 Use only certified cable in any SmartBits Ethernet port (both control port and test 

ports).

3 Use only yellow optical cable with SmartBits ports that support single-mode optics.

4 Use only orange or gray optical cable with SmartBits ports that support multi-mode 

optics.

5 All SmartBits cards and modules should be fully inserted into the chassis, and all 

thumb screws should be tightened.

6 In a crowded engineering prototype lab, be careful of the layout of test cables used to 

connect the SmartBits and devices under test. Avoid passing test cables over or under 

other DUT or live equipment. If test cables are very long, avoid looping cables around 

live equipment.

7 Use the ferrite clamp supplied with each SmartBits chassis on one end of the Ethernet 

cable connecting the SmartBits to the LAN or to the PC. 

8 Use common sense. For example, a test or control cable laid over the AC power sup-

ply of an open DUT will most likely produce faulty measurement results.
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Installation and Setup2

In this chapter . . . 

This chapter contains the following topics:

• Summary of Installation Procedures.....20

• Procedure 1: Check the System Requirements.....21

• Procedure 2: Check the Chassis and Package.....22

• Procedure 3: Install SmartBits Applications & Print.....23

• Procedure 4: Connect SmartBits to PC, Power, & LAN.....25

• Procedure 5: Install the Ferrite Block.....27

• Procedure 6: Start SmartWindow.....29

• Procedure 7: Set the IP Address.....30

• Procedure 8: Confirm the Ethernet Link.....39

• Procedure 9: Update Firmware Version (optional).....43

• Procedure 10: Connect SmartBits to an Application.....51

• Procedure 11: Connect to the DUT and Check Cabling.....53

• Maintenance and Advanced Procedures.....54
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Summary of Installation Procedures

This chapter explains how to install your SMB-600/6000B chassis. A description of the 

following procedures is provided:

Check SmartBits Requirements and Package Contents

1 Check the system requirements (see page 21).

2 Check the SmartBits chassis and package (see page 22).

Install Application and Review Documentation 

3 Install the SmartBits application software onto your PC. Print/review important 

Release Notes for the chassis and module firmware, and for the applications. Print 

user documentation now or later, as needed (see page 23).

Set up SmartBits

4 Connect the SmartBits to a power outlet, to a PC for initial IP address configuration 

and software management, and to your LAN (page 25).

5 Install the ferrite block onto the Ethernet cable (see page 27).

6 Start SmartWindow (see page 29).

7 Set up the SmartBits IP address (see page 30).

8 Confirm the Ethernet link: Ping the Ethernet link between the PC and SmartBits; if 

unsuccessful, check the TCP/IP stack on the PC and add the appropriate IP address 

and gateway if needed (see page 39).

9 Update firmware if needed (optional) (see page 43).

Connect SmartBits to an Application

10 Configure the SmartWindow-to-SmartBits Ethernet connection (see page 51).

Connect SmartBits to the DUT

11 Connect SmartBits to the device(s) under test, check cabling, and ensure that EMI 

guidelines are met. Then use SmartWindow, SmartLibrary, or any other SmartBits test 

software to access and use the capabilities of the SmartBits system (see page 53).

For more detailed explanations of these procedures, refer to the sections that follow.
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Procedure 1: Check the System Requirements 

You must have the following hardware and software in order to use an SMB-600/6000B. 

Review these requirements carefully to ensure successful installation. 

PC Workstation Requirements 

• IBM compatible PC (400 MHz Pentium II recommended) with the following items:

– One 10/100Base-T UTP cable and a 10 Mbps or 10/100 Mbps Ethernet NIC 

card, installed in the PC (optional).

– Minimum of 128 MB RAM (Windows 98/2000 or NT SP4.0); 256 MB RAM 

is recommended.

– Minimum 40 MB space on the hard drive; a 4 GB hard drive is 

recommended.

– A 3.5 in. (8.9 cm.) high density floppy disk drive, a mouse, and a SVGA 

color monitor or equivalent.

– Serial port capable of running at least 38,400 baud.

– RS-232 straight-through cable with DB-25 female connector for attachment 

to the chassis and either a DB-9 or DB-25 female connector for the PC end.

• CD-ROM drive.

• Microsoft Windows 98/2000 or Windows NT.

• Microsoft Terminal or HyperTerminal or another communications application.

• Acrobat Reader 4.0 or later (to print user documentation). 

SmartBits Minimum Requirements

• An SMB-600/6000B chassis (with one or more ordered modules, card panels, and 

firmware installed). 

• Chassis Firmware Version 1.10 or higher. 

• SmartWindow, SmartLib, or SmartApplications (supplied and to be installed on the 

PC that is connected to SmartBits chassis). Use these applications to configure 

SmartBits to test your device.

Note: SmartBits systems can also be controlled using the UNIX version of SmartLib for 

custom application programming. For UNIX workstation requirements, please refer to the 

SmartLib documentation or Release Notes. 
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Procedure 2: Check the Chassis and Package

Review the contents of the SmartBits package and follow these important guidelines if 

you are rearranging any modules in the chassis. 

Checking the SmartBits Package 

The following standard items are shipped with each SmartBits chassis; check your 

package to insure you have received all of the items listed here:

• An SMB-600/6000B chassis (with two or more ordered modules, card panels, and 

firmware installed).

• Four cables, an adapter, and one ferrite block. 

– One power cord.

– White 10 ft. (3.048 m.) crossover Ethernet LAN cable (RJ-45); used to 

connect the SmartBits chassis directly to a PC.

– Blue 10 ft. (3.048 m.) straight-through Ethernet LAN cable (RJ-45); used to 

connect SmartBits chassis to a LAN.

– Purple 3 ft. (.9144 m.) straight-through Ethernet LAN cable (RJ-45); used to 

connect one SmartBits chassis to another SmartBits chassis.

– DB-25-Female to DB-25-Female cable; used to connect the SmartBits 

console serial port to a PC serial port when setting the first-time IP address of 

the SmartBits chassis.

– DB-9-to-DB-25 adapter; used for the serial port cable if needed.

– Ferrite block; connects onto the Ethernet cable that attaches the SmartBits 

chassis to your network or a hub. The ferrite block reduces potential EMI 

interference.

• SmartBits application CDs for bundled and optional software packages. 

• SmartBits 3.5 in. (8.9 cm) firmware disks or a SmartBits firmware CD. 

• SmartBits 3.5 in. (8.9 cm) Key File Disk(s) (for optional applications ordered; not 

required for SmartWindow, SmartLib, or SmartApplications).

• SmartBits Documentation CD (for SmartWindow, SmartLib, and SmartApplications 

manuals).

• SmartBits 600/6000B Installation Guide (this document).
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Adding or Rearranging Modules 

Each SMB-600 can hold up to two modules; each SMB-6000B can accommodate up to 12 

modules. The connector and interface for each module slot on either chassis is configured 

identically. Therefore, any SmartBits module may be installed into any SMB-600 or SMB-

6000B module slot. (Note that some SmartBits modules require two SMB-600/6000B 

slots.)

Warning:  If you are adding or rearranging modules in your SmartBits chassis, you must 

follow these precautions.

• Always turn the power off to the SmartBits chassis before inserting or 

removing modules.

• If fewer than the maximum modules are installed, all unused slots MUST 

BE COVERED with the provided blank face-plates to maximize airflow 

inside the chassis. 

Procedure 3: Install SmartBits Applications & Print

Before proceeding with the chassis setup and installation, it is valuable to:

• Install the SmartBits applications software.

• Print/review the Release Notes, which sometimes have important last-minute 

installation and test setup details not included in this user guide. 

• Print user documentation now or later, as needed.

Installing the SmartBits Applications

To install SmartBits applications, perform the following steps:

1 To install the core applications (SmartWindow, SmartLib, and SmartApplications), 

insert each SmartBits CD into the CD-ROM drive of your PC. If the autoplay on your 

PC does not automatically start the installation, click on the setup.exe file in the Setup 

folder on the CD. The Installation Wizard will prompt you to install the specific appli-

cation.

To install the SmartLib programming library, please follow the instructions in the 

SmartLib documentation or Release Notes. 

Note: Documentation for the SmartBits chassis, as well as for SmartWindow, 

SmartLib, and SmartApplications (user guides and reference manuals), is provided on 

the SmartBits Documentation CD. Documentation for additional software 

applications is provided on the CD for each application.

If you require hard copies of any SmartBits user manuals, please contact your sales 

representative, fax the request form supplied with the SmartBits products, or call us at 

Spirent Communications Technical Support. 
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2 If you have purchased any optional SmartBits software applications, such as 

SmartFlow, you will have an additional CD per application, which will provide both 

the software and the user guide for that application. You may wish to install those 

applications now.

3 If you purchased any optional SmartBits applications, such as SmartFlow, you should 

also have a 3.5 in. (8.9 cm.) disk which contains one or more key files needed to run 

the optional application. Be sure to copy the licensed <application>key.txt file into 

the program directory of each optional application. (Also refer to “Key Files” on page 

85.)

Important:  If you do not install the required key file for an optional application and you 

access the software, you will receive an error message and automatically be placed in 

demo mode. 

Printing/Reviewing your Release Notes

It can be crucial to check the Release Notes for your SmartBits products and highlight key 

items that may affect your installation, test configuration, or test results. We have 

increased our product testing dramatically and want to alert you to important last-minute 

requirements or changes in each product. 

Please locate the appropriate Release Notes (readme.pdf files):

• On the SmartBits firmware CD.

• In the applications directory of each installed application.

• At the Spirent Communications website located at http://www.spirentcom.com/

support/softwareupdates.

Take a few minutes to review the Release Notes for critical information. 

Printing User Guides and Reference Manuals

For each application, programming library, or script option, you may wish to print the 

related documentation either now or later, as needed. 

Core documentation resides on the SmartBits Documentation CD (for SmartWindow, 

SmartLib, and SmartApplications). The user guide for each optional application resides on 

the CD for each application. 

If you require hard copies of any SmartBits user manuals, please contact your sales 

representative, fax the request form supplied with the SmartBits products, or call us at 

Spirent Communications Technical Support. 

Important:  To print the user documentation pdf files, Acrobat Reader 4.0 must be 

installed on your PC. This software is located on the SmartBits Documentation CD and is 

available on the Internet at www.adobe.com. 
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For the best print quality, use a postscript printer. The print driver you use may also affect 

the print quality. For the best results, use one of the Adobe postscript print drivers for your 

printer model. You can download these print drivers from Adobe at www.adobe.com.

Procedure 4: Connect SmartBits to PC, Power, & LAN

This procedure explains how to connect the back panel connectors on your SmartBits 

chassis. We recommend that you complete Procedures 4 through 10 before you connect to 

your device or system under test (Procedure 11).

The back panel connectors of the SMB-600 and SMB-6000B chassis are identical. The 

chassis differ only in the location of the power supply connector and the ON/OFF switch. 

Figure 2-1 shows an SMB-600.

Figure 2-1.    SMB-600/6000B Chassis Back Panel Connectors

Serial Console Port

Ethernet Port

BNC Connectors for External Clock
Connects to a GPS Receiver

Auxiliary DB-9 Connector
Connects to a GPS Receiver

ON/OFF
Switch

Expansion port (optional) is used to 
synchronize timing for up to 8 
connected SmartBits chassis

Power Supply
Connector
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Table 2-1 describes the back-panel connectors, their functions, and the cables to be used 

for each connector.

Table 2-1.    SmartBits Chassis Connections and Cables

Important:  If you are connecting multiple SmartBits chassis for your test environment, 

it is critical to power up the chassis in the correct sequence or the test results may be 

invalid. Refer to Appendix A, “Connecting Multiple Chassis Locally” for details. To 

connect multiple chassis remotely via GPS or a modem, refer to the Using GPS with 

SmartBits manual.

Connect the SmartBits chassis… to … using this cable...

Power supply connector located on 

the back panel

Power outlet Power cord

CONSOLE port (DB-25) – for IP 

address assignment ONLY

PC Serial port (RS-232) DB-25-to-DB-25 cable 

(plus a DB-25-to-DB-9 

adapter if needed)

10/100BASE-T (RJ-45) port – to 

connect a SmartBits chassis to 

applications and to the network 

 Your hub or LAN Blue 10 ft. (3.048 m.) 

straight-through LAN 

cable

10/100BASE-T (RJ-45) port – To 

connect a SmartBits chassis directly 

to a PC using the Default IP Address

PC White 10 ft. (3.048 m.) 

Ethernet crossover 

cable

EXPANSION OUT or IN RJ-45 port 

(optional)

Another SmartBits 

chassis and its RJ-45 

EXPANSION IN port

Purple 3 ft. (.9144 m.) 

straight-through LAN 

cable

EXT CLK INPUT port An external timing 

device

RG58 coaxial cable 

(BNC)

AUX A GPS receiver DB-25 to DB-25 male-

to-male with DB-9 

adapter
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Procedure 5: Install the Ferrite Block

This procedure describes how to attach the ferrite block to the Ethernet cable before 

connecting the cable to your SmartBits chassis. 

The ferrite block is designed to absorb excess electronic magnetic interference (EMI) that 

is transferred through the Ethernet cable to your SmartBits chassis. This prevents potential 

damage to your SmartBits chassis and module and helps ensure that test data is not 

corrupted.

The ferrite block (see Figure 2-2 below) is packaged as part of the Base Unit Cable Kit 

that is sent with your SmartBits chassis.

Figure 2-2.    Ferrite Block

Warning:  Before you begin using your SmartBits chassis, make sure that you have 

attached the ferrite block to the Ethernet cable using the procedure below. 

Installing the Ferrite Block

To install the ferrite block, follow the steps below: 

1 Remove the ferrite block and the Ethernet cable from the Base Unit Cable Kit pack-

age.

2 Release the built-in clip on the side of the ferrite block and open it so that the center of 

the ferrite block faces up. Place the Ethernet cable in the open ferrite block 

(see Figure 2-3, #1).

3 Clamp the ferrite block around the Ethernet cable making sure the built-in clip snaps 

together (see Figure 2-3, #2).

4 Connect the Ethernet cable to the chassis (see Figure 2-3, #3).
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Figure 2-3.    Ferrite Block Installation

1

Place the Ethernet 
cable in the opened 
ferrite block. 

2

Clamp the ferrite 
block around the 
Ethernet cable.

Note: In this example, the ferrite 

block is placed near the end of the 

Ethernet cable that connects to 

the SmartBits chassis. 

The ferrite block is designed to 

slide along the Ethernet cable to 

allow you to move it as needed.

3
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Procedure 6: Start SmartWindow

Once SmartWindow is installed (see “Procedure 3: Install SmartBits Applications & 

Print” on page 23), you can launch the program in two ways:

• Double-click on the SmartWindow icon on your desktop.

• Use the Start button on the task bar. Select Start > Programs > SmartBits Systems 

Applications > SmartWindow.

Note: The information contained in this procedure only describes the basic start-up 

information when using a SmartBits chassis and SmartWindow. For a complete 

description of SmartWindow configuration and other options, refer to the SmartWindow 

User Guide or the SmartWindow online help. 

SmartWindow Launcher

When SmartWindow opens, it displays the SmartWindow Launcher. Use the Launcher to 

select the target SmartBits chassis.

Note: Use a single mouse-click to select any icon from the Launcher.

SmartBits Tab

The Shortcuts tab displays icons for each type of SmartBits chassis: SMB-200, 

SMB-2000, SMB-600,and SMB-6000B (Figure 2-4). When you select one of these, the 

Launcher displays the GUI for that chassis type and it opens a default configuration file.

This tab is useful when you want to set up a configuration offline, before you connect to 

the SmartBits chassis.

Figure 2-4. SmartBits Tab (SmartWindow Launcher)

SmartBits tab shows chassis types
for connection or configuration.
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Connecting to the SmartBits Chassis

When you select an icon on the SmartBits tab, SmartWindow tries to find an accessible 

SmartBits chassis of the selected type and connect to it.

The Launcher informs you of its progress (Figure 2-5). If it cannot find a chassis, you may 

need to check the setup connections shown in “Procedure 4: Connect SmartBits to PC, 

Power, & LAN” on page 25.

Figure 2-5. Connection Status Messages (SmartBits Tab)

Procedure 7: Set the IP Address

All SmartBits chassis are now designed with a default IP address of 192.168.0.100. This 

feature enables quick and easy connection/start up of your chassis without the need of a 

serial cable connection. This procedure is described on page 31.

If you prefer not to use the default IP address and want to set a unique IP address in an 

unconfigured SmartBits chassis, you can use any of the following means to do so:

• HyperTerminal (serial port) (see page 32)

• Telnet (Ethernet) (see page 36)

• SmartWindow (Ethernet) (see page 37)
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Default IP Address Connection

To establish a default IP Address connection, you need to connect the chassis directly to a 

PC using the white, 10-foot long (3.048 m), RJ-45 Ethernet crossover cable (Spirent part 

number 620-0083-001), included in your SmartBits shipment.

To connect the chassis to a PC using the crossover cable:

1 Locate the 10-foot, RJ-45 Ethernet crossover cable included in your SmartBits 

package.

2 Plug the chassis to its power source.

3 Turn the chassis ON.

4 Connect the crossover cable between the SmartBits chassis’ Ethernet Management 

Port (10/100BASE-T) connector and the PC NIC card.

5 Reconfigure the PC to use the same Subnet as the SmartBits chassis (example: 

reconfigure the NIC card to 192.168.0.101 with a Mask of 255.255.0.0).

6 If needed, reset the PC in order for the new IP address to take effect. (For some PC 

operating systems this step is necessary.)

7 Verify that the status light on the front of the chassis is green (see “SMB-600/6000B 

Chassis Front Panel LEDs” on page 56).

8 When the PC is ready, use the DOS prompt and ping the SmartBits chassis (see 

“Pinging the SmartBits IP Address” on page 40). At the DOS prompt type in:

> ping 192.168.0.100.

Important:  If the ping does not work, refer to the following sections of this manual for 

more information:

• Check that your cable connection is in place from “Procedure 4: Connect SmartBits 

to PC, Power, & LAN” on page 25.

• “Checking the TCP/IP Stack/Address/Gateway on Your PC” on page 40.

• “Procedure 8: Confirm the Ethernet Link” on page 39.

• Chapter 4, “Troubleshooting.”

You may now connect a SmartBits application (such as SmartWindow) to the chassis.
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Setting the IP Address via HyperTerminal

These steps illustrate the HyperTerminal application which comes with Microsoft 

Windows. However, you can use any serial port console application.

To set the IP Address via HyperTerminal:

1 Select Start > Programs > Accessories > HyperTerminal. The following window 

opens. 

2 Double-click on Hypertrm.exe to see the Connection Description window.

3 In the Connection Description window, enter a name for the new connection. Select 

the link you are making. In this example we are using smblink. Click OK

The Phone Number dialog box appears as shown in step 4 on page 33.
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4 In the Phone Number window beside the Connect using field, select COM (1, 2, 3, or 

4). The example below shows Direct to COM2 selected. Click OK to access the 

COM port Properties window.

5 Set the port settings (38400, 8, Xon/Xoff) as shown in the Properties window below, 

and then click OK.
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6 In the HyperTerminal Console Command window which then appears, click the 

Properties button as shown below (or choose File > Properties).

7 In the Properties window Settings tab, set the Emulation field to Auto detect or 

VT100. Click OK.
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8 Click the ASCII Setup button. To enable local echo (which allows characters to 

appear in the terminal window), uncheck the Echo typed characters locally box. Click 

OK.

9 Save your settings by using the File menu Save or Save As command in the 

HyperTerminal Console Command window. 

10 Close HyperTerminal and then reopen HyperTerminal with the saved configuration 

(for the settings to take effect).

If you receive garbled characters instead of the message below, see the “Garbled Data 

on HyperTerminal” on page 66.

Important: If the chassis has already completed its startup before HyperTerminal is 

open, simply press Esc for a menu prompt.
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11 To display the current or default IP address, enter ipaddr, and then press Return. The 

terminal window will look similar to the following screen: 

12 Set the IP address after you have checked with your system or network administrator 

for the correct IP address. For example to set the IP address to 192.169.100.19, you 

would enter ipaddr 192.169.100.19.

13 When you have finished, check to be sure the IP address was entered correctly by 

entering ipaddr and then press Return.

14 Power off the SMB-600/6000B chassis and then power it back on. 

Important:  You must reset the SMB-600/6000B chassis before the IP address change is 

implemented.

Setting the IP Address via Telnet

Telnet uses the same commands that are available on the console port (refer to the System 

Reference Manual) and provides a means for the Customer Support group to access a 

customer’s SMB-600/6000B chassis for troubleshooting. In the following example we are 

using an SMB-600.

To set the IP Address via Telnet:

1 Start a telnet session in your PC or workstation using your preferred Telnet Interface 

software.

2 Connect to the SMB-600 chassis by providing the chassis default IP address 

(192.168.0.100) to the Telnet software. You should see the following prompt:

SmartBits SMB-600 Chassis

Copyright @ 2000, Spirent Communications

login:

3 At the prompt, type:

login <enter>

4 Once connected, you should see the same command prompt, “>>”, as if you are 

connected over the console port.

5 Follow steps 10 through 13 on page 36.

6 To disconnect from the chassis, type:

quit <enter>
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Setting the IP Address via SmartWindow

To set the IP Address using SmartWindow, use the Serial CONSOLE port for a point-to-

point connection from your SMB-600/6000B chassis to your PC. This port is used to set 

up the SmartBits IP address for the first time, and can be used to run applications as well.

Note: You must have SmartWindow 6.53 Build 19 or later to use this feature, and you 

must be Offline to access Connection Setup.

Make sure the SMB-600/6000B chassis is connected to the PC with the white Ethernet 

(RJ-45) crossover cable.

Setting or Changing the IP Address via SmartWindow

You can launch the program in two ways:

• Double-click on the SmartWindow icon on your desktop.

• Use the Start button on the task bar. Select Start > Programs > SmartBits Systems 

Applications > SmartWindow.

Note: Before you proceed any further, you must add Allow Admin=1 to the 

Smartbit6k.ini file. To do this, open the SmartBit.ini file C:\WINNT\Smartbit6k.ini 

file, and add Allow Admin=1 as follows:

1 After launching SmartWindow, you will see the following window.

Add Line
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2 Click SmartBits and then select the type chassis you are using. (For this example we 

will use the SMB-600.)

3 Select Options > Connection Setup. You will see the following window.

4 Type in the default IP Address (192.168.0.100) and click OK.

5 Select Actions > Connect or choose the Connect icon.

6 Choose Actions > Connect, then choose Admin > SmartBits IP Configuration. The 

following window appears.

7 Click the box labeled Change the SmartBits IP address. Type in the IP address that 

you want to assign and click OK.

8 Choose Actions > Disconnect.

9 For the changes to take effect, reset the SmartBits chassis.
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Procedure 8: Confirm the Ethernet Link

Note: If you have not already connected the chassis to a PC, hub, or network, do so now. 

Use a Category 5 UTP straight-through cable to connect the SmartBits Ethernet port to the 

local Ethernet network, or Use a Category 5 UTP crossover cable to connect the SmartBits 

chassis to the PC’s NIC.

Checking your Ethernet Cable Connection

To check the Ethernet link to the SmartBits chassis, perform the following steps:

1 Check your Ethernet cable connection (from SmartBits to the PC, hub, or network).

2 Ping the Ethernet link between the PC and SmartBits. 

3 If the ping does not work, check the TCP/IP stack on your PC. Set up the PC IP 

address to be on the same subnet or on a different subnet from the SmartBits chassis, 

as needed. Add a gateway if needed. 

Check that your Ethernet cable connection is in place from “Procedure 4: Connect 

SmartBits to PC, Power, & LAN” on page 25, or connect the cables now, as needed.

PC on Same Subnet as SMB-600/6000B

To connect a PC on the same local subnet as the SMB-600/6000B chassis, you can 

connect the PC to the chassis locally through either of the following connections:

• A direct connection using a crossover Ethernet cable.

• Through a hub or other network device using a straight-through Ethernet cable.

Direct Connection Locally. You can connect the SMB-600/6000B chassis directly to 

the PC Network module using a crossover cable. A crossover (MDI-X) cable is made with 

the transmit and receive wires crossed to allow two PCs with 10 Base-T Ethernet modules 

to make a “back-to-back” connection without using a hub.

1 Connect one end of a crossover cable to the Ethernet module (NIC) in the PC.

2 Connect the other end of the crossover cable to the 10/100BASE-T (RJ-45) connector 

on the back SMB-600/6000B chassis. 

The LINK LED next to the 10/100BASE-T connector on the SMB-600/6000B chassis 

should light. If the LINK LED does not light, refer to Chapter 4, “Troubleshooting.”

Local Connection through a Hub. If you are connecting the controlling PC to an 

SMB-600/6000B chassis through a hub or network device, you must connect the chassis 

to the hub or network using a straight-through Ethernet cable (a blue Ethernet 10 inch 

[25.4 cm.] cable is provided).

The LINK LED will light when a cable is connected from the hub to the SMB-600/6000B 

chassis. If the LINK LED does not light, refer to Chapter 4, “Troubleshooting.”
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Pinging the SmartBits IP Address

To ping the SmartBits chassis IP address to confirm that the Ethernet link is 

working:

1 On your PC, open an MS-DOS prompt by selecting Start > Programs > MS-DOS 

Prompt.

2 Ping the SmartBits IP address on the remote subnet as shown below, with the ping 

command followed by the IP address. A series of four replies indicates that the link is 

working. 

3 If you were unable to ping the address, proceed to the next topic, “Checking the TCP/

IP Stack/Address/Gateway on Your PC.”

Checking the TCP/IP Stack/Address/Gateway on Your PC

The PC must be configured for TCP/IP to be able to connect to the SMB-600/6000B 

chassis via Ethernet. If you are uncertain about how to configure TCP/IP on the 

controlling PC and how to specify the correct IP address, contact your local System 

Administrator.

To check these parameters, you must access the Network window and the related TCP/IP 

adapter for your Ethernet connection, and then define the PC’s IP address and subnet mask 

as needed. If the PC is on a subnet different from that of the SmartBits chassis, you will 

also need to set a gateway address. 
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To check IP address parameters, follow these steps:

1 Select Start > Settings > Control Panel > Network icon. 

2 In the PC Configuration tab window, view the PC’s IP address and netmask, click on 

your TCP/IP adapter card (which will connect to the LAN or directly to the 

SmartBits chassis), and then click on the IP Address tab, shown in the following 

window.

3 Specify a new IP address for the PC if needed. For example, you can set an IP address 

of 192.169.100.19 and a subnet mask of 255.255.255.0. This means that systems on 

this same subnet will all have IP numbers that start with 192.169.100.

4 If your PC is on the same subnet as the subnet of your SmartBits chassis, proceed to 

step 9. 
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5 If your PC is on a different subnet from the subnet of your SmartBits chassis, you also 

need to add a gateway, which is the address of the connecting router. Select the 

Gateway tab in the TCP/IP Properties window. The following window appears.

6 Enter the IP address of the router port for the subnet where the SMB-600/6000B 

chassis is located. In this example, we connect to an chassis with an IP address of 

192.169.100.19. The address of the router port is 192.169.100.1.

7 Click the Add button to add the new gateway address.

8 Click OK to close the TCP/IP Properties window.

9 Click OK to close the Network window.

10 Shut down and restart Windows 98/2000 for the change to take effect.

11 Ping the SmartBits IP address again, as shown on page 40. If you are unable to ping 

the SMB-600/6000B chassis, refer to Chapter 4, “Troubleshooting.” 
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Procedure 9: Update Firmware Version (optional)

Firmware for your new SmartBits has been factory installed and is also supplied on your 

firmware CD. However, when you purchase a new module, or wish to obtain the latest 

upgrade, you need to load new firmware.

You can obtain the firmware from these sources:

• Spirent Communications website at www.spirentcom.com. 

• An E-mail message from Technical Support (no password required).

Checking the Current Firmware Version

To determine the version level of the software you are using, you may look on the CD 

label, or follow the procedures listed below:

Note: You must be connected to a SmartBits chassis to perform the following tasks.

1 Select the Help > About SmartWindow option from the menu bar of the 

SmartWindow main menu.

2 You will see the following window. This window will identify the SmartWindow 

Version number, and the Controller, Serial Number, and Firmware Revision number.

SmartWindow Version

Firmware Revision Number

Displays slot number, card description, and firmware version for each card.
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3 Click Show Card Versions to display version information for the SmartBits chassis 

and installed cards. Below is an example of the window you will see. The window will 

vary depending on the modules you are using:

Note: In the multi-user interface, SmartWindow does not display card information unless 

the chassis is connected and the specified card is reserved. Only the component firmware 

version numbers are displayed in SmartWindow Help About, not the overall firmware 

release number. For information on reserving SmartCards/modules, refer to the 

documentation for the application you are using.

Updating Firmware from the Spirent Website or E-mail

To download firmware updates from the Spirent website or an e-mail message:

Important:  Close all SmartBits applications such as SmartWindow and 

SmartApplications. If you keep an application open, the chassis connection will not be 

available. All other users must be disconnected from the SmartBits chassis in order for 

files to be download to the chassis.

Firmware updates from the website are contained in .exe files that require a password 

obtained from Spirent Communications Technical Support.

1 Contact Spirent Communications for one or more firmware passwords, by phone, fax, 

or email smartbits.support@spirentcom.com

2 Download the desired firmware .exe file(s) from the website Support page at 

http://www.spirentcom.com into the desired directory on your PC. Allow up to 12 MB 

of free space on your local hard drive.

3 Select Start > Run. The Browse window appears.

4 In the Browse window, select the CD-ROM drive, select the Setup.exe file, and click 

Open.
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5 Follow the on-screen prompts to install the firmware onto your hard drive. The 

firmware files are copied to the directory that you specify as shown below.

6 Once the firmware files are copied, locate the directory where the files were copied 

(see preceding screen), and click on fdlmgr.exe. This launches the Download 

Manager application, which you use to download the firmware. You will see the 

Download Firmware screen shown below.

Directory
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7 If you are downloading chassis firmware, make sure that Superuser mode is activated. 

To do this, 

a Choose Action > Preferences. You will see the Download Manager Preferences 

screen shown below.

b Select Superuser mode and enter the Superuser password (default is SMB-

6000). If you only plan to download module firmware, you do not need to activate 

the Superuser mode.

c Click OK. This takes you back to the Download Firmware menu shown in Step 6 

above.

Important: It is important to record your password for easy reference. If you lose the 

password and later need the password to download new chassis firmware, you must 

return the chassis to the factory to reset the firmware. 

8 Double click on the chassis icon. 

Superuser Mode

Password

Chassis Icon
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The Connection Setup window appears.

9 Enter the IP address of your SMB-600/6000B chassis (refer to “Procedure 7: Set the 

IP Address” on page 30). Click on the Ping tab to make sure the connection is 

working properly. You will see the following screen.

Check to see if the system is “pinging”; click on Close and then click OK on the 

Connection Setup window.

10 There are three options for connecting to the chassis:

• Select Action > Connect to connect to the chassis.

• Press the F8 key.

• Click on the connect icon in the tool bar. 
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The Download Firmware window appears, displaying the current firmware versions 

for the chassis and for every module installed in the chassis.

Note: The letter A affixed to the slot number determines a left-hand port; the letter B 

affixed to the slot number determines a right-hand port.

11 Continue the firmware download procedure by following the steps in one of the 

following three sections:

• Download firmware to a non-TeraMetrics module

• Download firmware to an individual TeraMetrics module

• Download firmware to all TeraMetrics modules

Download Firmware to a Non-TeraMetrics Module

To download firmware to the chassis:

1 Maximize the Download Firmware window so that the Status column is displayed (if 

the Download Firmware window is not displayed, then select the Firmware (BFT) 

tab to display it). 
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Note: For non-TeraMetrics modules, an OK in the Status column indicates that a file is 

available for download. TeraMetrics modules will display the message “Only can be used 

by RPM download.”

2 Click the green button next to a chassis or module to reserve it for download (the 

button turns blue to indicate reserved status), or click the Select All Available box to 

reserve all listed non-TeraMetrics modules.

3 Click the Download button to load the firmware to the selected chassis/modules.

Note: To find out if there are other users active in the chassis, select Action > Show 

Active Users.

Download Firmware to an Individual TeraMetrics Module

To download firmware to a TeraMetrics module:

1 Select the Software (RPM) tab. The Download Software (RPM) window appears, 

displaying the current firmware version of every TeraMetrics module installed in the 

chassis.

2 To reserve an individual TeraMetrics module, click the green button next to the 

module to reserve it for download (the button turns blue to indicate reserved status).

3 Select the To Download tab, then click the Files button and select Add.

4 Using the mouse and the Ctrl key or Shift key, select the .rpm file(s) that you want to 

download to the selected module and then select Open. You must select the 

appropriate .rpm file(s) for each TeraMetrics module.
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If the version of the firmware that you are downloading is older or the same as the ver-

sion you already are using, you will see one of the following screens:

5 Click the Download button to download the .rpm file(s).

Note: To find out if there are other users active in the chassis, select Action > Show 

Active Users.

Download Firmware to All TeraMetrics Modules

To download firmware to all TeraMetrics modules:

1 Select the Software (RPM) tab. The Download Software (RPM) window appears, 

displaying the current and new firmware versions for every TeraMetrics module 

installed in the chassis.

2 To reserve all TeraMetrics modules, click the Reserve/Release All Modules box. The 

green button next to each module turns blue to indicate reserved status.

3 Select the To Download tab, then click the Files button and select Add to All 

Reserved Modules.
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4 Using the mouse and the Ctrl key or Shift key, select the .rpm file(s) that you want to 

download to the selected modules and then select Open. You must select the 

appropriate .rpm file(s) for the selected TeraMetrics modules.

If the version of the firmware that you are downloading is older or the same as the ver-

sion you already are using, you will see one of the following screens:

5 Click the Download button to download the .rpm file(s).

Important:  When conducting a Restart, all modules that have been reserved will restart. 

Therefore, be careful which modules you reserve (.e.g., do not reserve a module that is in 

the middle of a test). The chassis and any other modules that are not reserved will not be 

restarted.

Procedure 10: Connect SmartBits to an Application 

After the SmartBits IP address is set up via the serial console port, make sure that the PC 

is connected to the SmartBits chassis using the Ethernet cable (see “Procedure 8: Confirm 

the Ethernet Link” on page 39). Then you may proceed with configuration and testing.

Notes: • The procedure detailed in this section is for installing SmartWindow. The 

installation of other applications may vary slightly. Refer to each 

application’s specific user documentation for details.

• The serial cable cannot be used to connect any of the SmartBits software 

applications on the SMB-600/6000B chassis. This feature is only available in 

the SMB-200/2000 chassis.

To connect a SmartBits application to a specific SmartBits chassis for the first time, 

perform the steps listed below: 

1 Check that you have:

• Installed the application on your PC.

• Connected the PC to SmartBits with the serial cable or Ethernet cable.

• Set the IP address for the SmartBits chassis.

• Powered up the SmartBits chassis.

2 Enter the application by selecting Start > Programs > SmartBits (or Netcom 

Systems) Applications > APPLICATIONname.
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3 The application must be offline (disconnected from any chassis). To disconnect from 

other chassis, choose Actions > Disconnect. 

4 Specify the IP address via the Connection Setup command of an application (located 

under the Options menu). 

For example in SmartWindow, select Options > Connection Setup from the menu 

bar. The Connection Setup window appears (see below).

5 Type in the IP address and select Ping.

6 For the Remote Host address, enter the SmartBits IP address that you loaded into 

SmartBits in Procedure 3, on page 23.

7 Ensure that the TCP port value is set to 16385.

8 Click OK to close the Connection Setup window. 

9 Select Actions > Connect to connect to the specific chassis. If a message box with 

“Unable to reach remote host” is displayed, refer to Chapter 4, “Troubleshooting.”

Note: If you close SmartWindow, and then re-open it, the application will try to 

connect to the IP address last specified in the Connection Setup window.
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Procedure 11: Connect to the DUT and Check Cabling

Connect the SmartBits chassis to the desired device(s) or network to be tested via one of 

the following methods (see Figure 2-6 for an example):

• Connect each module port directly to the device (DUT) or system under test (SUT).

• Connect each module port to the devices/systems over a LAN or WAN, depending on 

the configuration needed. 

Important: You must clip and position the provided ferrite block onto the Ethernet 

cable (at the SmartBits end) that attaches the SmartBits chassis to your network. The 

ferrite block reduces potential EMI interference. Refer to “Procedure 5: Install the 

Ferrite Block” on page 27 for details on connecting the ferrite block.

Figure 2-6.    Example of Connecting a SmartBits Chassis to a Switch.

For cable description and pinouts of each module type, refer to the SmartBits System 

Reference manual.

Most test setups require a minimum of two module connections to the DUT – one module 

to transmit traffic, and one to receive traffic. Many tests are also set up as partial or full 

mesh, uni-directional or bi-directional, full or half duplex, single-to-many ports, or many-

to-many ports. For sample test scenarios, refer to the user guide for each application. 

Important:  Before you begin testing, check your environment and make sure that you 

follow the EMI guidelines as described on page 15 and in Appendix D, “ESD 

Requirements.” Once the testing environment is properly prepared, you are ready to use 

the appropriate software for the tests you want to perform. Failure to comply with these 

guidelines may produce invalid test results.

Note: It is recommended that you 
connect cables from left to right, 
starting with the top row and 
progressing down.
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Maintenance and Advanced Procedures

For maintenance or upgrade information, please refer to the SmartBits System Reference 

manual. 

Procedures include but are not limited to the following topics:

• Changing Chassis Timeout

• Replacing Chassis Fuses

• GPS and Other Remote Access Methods
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Light-Emitting Diodes (LEDs) confirm the status of your installed SmartBits chassis, 

modules, and network link.

For module specifications, refer to the particular module type in the SmartBits System 

Reference manual and in the SmartWindow online help. 

In this chapter . . . 

This chapter contains the following topics:

• SMB-600/6000B Chassis Front Panel LEDs.....56

• SMB-600/6000B Chassis Back Panel LEDs.....57

• Ethernet Module LEDs.....58

• Packet Over SONET (POS) Module LEDs.....59

• Fibre Channel Module LEDs.....60

LED Indicators3
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SMB-600/6000B Chassis Front Panel LEDs

Every SMB-600/6000B chassis has four LEDs located on the front panel of the chassis 

(see Figure 3-1). On the SMB-600 chassis, the LEDs are located on the left side on the 

front panel; on the SMB-6000B chassis, they are located on the lower left side of the front 

panel. 

The functions of the LEDs are the same for both the SMB-600 and the SMB-6000B (see 

Table 3-1).

Figure 3-1. SMB-600/6000B Chassis LED Locations (Front Panel)

Table 3-1 SMB-600/6000B Chassis Front Panel LEDs

LED Color/Status Description

FAN Green

Red

Internal fans are operating properly.

One or more of the fans are not working properly.

LINK Green

Off

One or more users are connected to the SmartBits chassis.

No user or application is connected to the SmartBits chassis.

STATUS1

1 During bootup, the Status LED starts out red, turns to yellow while initializing, then 

turns to green when modules are initialized and Ethernet logins are enabled.

Green

Red

Yellow

Operationally ready to connect.

Not ready to connect.

Blinking – indicates an unrecoverable error. Power cycle the 

chassis to recover.

POWER Green

Off

The chassis is on.

The chassis is off.

LEDs

LEDs
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SMB-600/6000B Chassis Back Panel LEDs

Every SMB-600/6000B chassis has four LEDs located on the back panel of the chassis 

(see Figure 3-2). The LED functions and descriptions are the same for both the SMB-600 

or the SMB-6000B (see Table 3-2).

Figure 3-2. SMB-600/6000B LED Locations (Back Panel)

Table 3-2 SMB-600/6000B Back Panel LEDs

LED Color/Status Description

10/100M

(Transfer Rate)

Green

Yellow

100 Mbps Ethernet rate.

10 Mbps Ethernet rate.

ACT/COL

(Activity/Collision Status)

Green

Yellow

Off

Traffic is being sent or received.

Collisions have occurred.

No traffic activity is occurring.

HDX/FDX

(Communications Protocol)

Green

Yellow

Full duplex.

Half duplex.

LINK/ERR

(Link/Error Status)

Green

Red

Off

Physically connected to the network; 

confirmed with an Ethernet link pulse.

Errors have occurred on the link.

Not connected to the network.

LEDs
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Ethernet Module LEDs

Every SmartBits Ethernet module has its own LEDs, which are located on the left side of 

each module’s front panel (see Figure 3-3). Though the LEDs are similar for all modules, 

some vary according to the features of each module. 

Figure 3-3. Example of LED Locations on an Ethernet Module

Note: Ethernet modules are listed in Table 1-1 on page 13. For complete descriptions of 

the Ethernet modules, refer to the SmartBits System Reference manual.

LEDs

Table 3-3 Ethernet Module LEDs

LED Color/Status Description

TX/INIT Green

Red

Off

Transmitting.

Module not ready. 

Not transmitting.

RX/ERR Green

Red

Off

Receive. Flashes Green once for each frame detected on 

the network.

CRC errors. Flashes Red once for each bad CRC detected 

in receive frames.

Not receiving.

TRIG/

PAUSE

Green

Yellow

Off

Receiving trigger frames.

Receiving PAUSE frames.

No trigger or pause events.

MGMT/

PAUSE

Green

Yellow

Flashes for management frames.

Flashes for pause frames.

TRIG/COL Green

Red

Off

Receiving trigger frames.

Flashes for collisions.

No collision or trigger.

LINK Green

Yellow

Full duplex with valid link.

No link detected.
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Packet Over SONET (POS) Module LEDs

Every SmartBits POS module has its own LEDs, which are located on the left side of each 

module’s front panel (Figure 3-4). Although the LEDs are similar for all modules, some 

vary according to the features of each module.

Figure 3-4. Example of LED Locations on a POS Module

Note: POS modules are listed in Table 1-1 on page 13. For complete descriptions of the 

POS modules, refer to the SmartBits System Reference manual.

LINK 

SPEED

Green

Red

Off

Link up at 1 Gbps.

Link up at 2 Gbps.

No GBIC or loss of signal.

Table 3-3 Ethernet Module LEDs

LED Color/Status Description

LEDs

Table 3-4. POS Module LEDs

LED Color/Status Description

TX/INIT Red

Flashing Green

Link is not ready.

Frame is transmitting.

RX ERR Flashing Red

Flashing Green

Off

Rx frame is received with a CRC error.

Rx frame is received.

Not receiving.

MGMT/LOF Yellow

Flashing Green

Loss of Frame condition exists.

“Management” frame is received.

TRIG/LOS Green

Yellow

Triggered frame is received.

Loss of Signal (optical signal) condition exists.

LOS Yellow Loss of Signal (optical signal) condition exists.
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Fibre Channel Module LEDs

Every SmartBits Fibre Channel module has its own LEDs, which are located on the left 

side of each module’s front panel (Figure 3-4). Although the LEDs are similar for all 

modules, some vary according to the features of each module. 

Figure 3-5. Example of LED Location on a Fibre Channel Module

Note: Fibre Channel modules are listed in Table 1-1 on page 13. For complete 

descriptions of the Fibre Channel modules, refer to the SmartBits System Reference 

manual.

LEDs

Table 3-5 Fibre Channel Module LEDs

LED Color/Status Description

TX/INIT Red

Green

Off

Port not initialized.

Frame is transmitting.

Ready.

RX/CRCERR Red

Green

Off

Receiving CRC errors.

Receiving frame.

Not receiving.

TRIG/OSERR Red

Green

Off

Receiving encoding errors.

Receive trigger.

No OS error or trigger.

LINK/SPEED Red

Green

Off

No GBIC or Loss of Signal.

Link up at 2 Gbps.

Link up at 1 Gbps.

www.valuetronics.com



SmartBits 600/6000B Installation Guide 61

This chapter provides solutions for common serial and Ethernet connection problems, as 

well as HyperTerminal problems.

In this chapter . . . 

This chapter contains the following topics:

• Ethernet Connection Problems.....62

• Serial Connection Problems.....62

• HyperTerminal Problems.....66

Troubleshooting4
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Ethernet Connection Problems

LINK LED on SmartBits chassis does not light

Ensure that the cable is good. If it is a straight-through cable, switch it with a crossover 

cable and connect it directly to the controlling PC.

SmartBits chassis does not respond to ping

Check that you can ping to other nodes on the local network.

If you cannot ping to a SmartBits chassis on another subnet, try pinging the gateway to be 

sure it is alive and at the IP address you have configured. Try pinging other nodes on the 

other subnet.

Unable to reach the remote host

If you receive this message when you start SmartWindow, try pinging the SmartBits 

chassis. Check that the IP address you have entered in SmartWindow is the same IP 

address you set on the SmartBits chassis. Check that cables are connected properly and are 

the correct cable type.

Serial Connection Problems

If SmartWindow cannot establish the communication link automatically, then the link 

must be established manually and some troubleshooting may be required. Most likely, 

another PC COM port should be selected. This can be done through SmartWindow by 

operating with the graphic display in the Offline mode.

To further troubleshoot a communications link problem, check the cables that connect the 

PC and the SmartBits chassis. Review the sections in Chapter 2, “Installation and Setup” 

to confirm that the RS-232 cables connecting the PC serial port to the SmartBits chassis 

(as well as any additional SmartBits chassis) are properly connected and terminated. The 

bottom DB-37 connector of the last SmartBits chassis must be terminated with the 

termination plug provided.

When trying to connect to SmartBits, the following conditions may cause communication 

errors:

• The wrong type of cable is being used. Ensure that the cable is NOT a null modem 

cable.

• The port is configured incorrectly. Ensure that the information in the Connection 

Setup dialog box is consistent with the baud rate indicated on the chassis’ front panel. 

SmartWindow operates successfully at 2400, 4800, 9600, 19,200 and 38,400 bps. 

Generally, baud rates of 9600 and above are preferred for better system performance. 
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• Check that the SmartBits chassis you are using is communicating with SmartWindow 

and not trying to use the RS-232 port to print test results.

• An invalid COM Port was selected from the drop-down Port Setup menu. The COM 

Port may already be in use by another Windows application, or there may not be 

hardware available to support it. In this case, try another COM Port.

No data displayed

This condition can be caused by connecting to the wrong serial port, or a non-functioning 

port, or by using a null modem instead of a straight-through RS-232 cable.

To correct this condition, test your serial connection:

1 Disconnect the cable from the back of the SMB-600/6000B chassis.

2 Connect a paper clip or jumper wire from pin 2 to pin 3 of the cable connector as 

shown below.

3 Type some characters in the HyperTerminal window. If you are connected to the 

correct serial port and the serial port is working correctly, the characters will be 

echoed in the window as shown.

If this does not work, check that you have connected to the correct port, and that the port is 

functioning properly.

4 Ensure that Hardware Flow Control is NOT selected. 

Pin 1
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Using HyperTerminal to Check Serial Link

HyperTerminal can be used when checking a serial link. 

To use HyperTerminal to check the serial communications link:

1 Power off the SmartBits chassis.

2 Open HyperTerminal (choose Start > Programs >Accessories > HyperTerminal).

3 Choose Hypertrm.exe.

4 Enter a name for the new connection. Select Direct to Com in the Connect Using 

combo box. The example below shows Direct to Com2 selected.

5 Set the communications parameters to 38400 8N1 XON/XOFF, as shown below.
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6 Click the OK button to start the session.

7 Power the SmartBits chassis ON. The HyperTerminal window should show data com-

ing back from the SmartBits chassis. If the speed of your HyperTerminal session does 

not match the current setting of the SmartBits chassis, you will run garbled data as 

shown below.

This is not important unless you want to send commands to the SmartBits chassis 

from HyperTerminal. If you do, you will have to set the speeds to match (for details, 

see section on “Garbled Data on HyperTerminal” on page 66.

If the speeds do match, you will receive completion messages.

Another good test of the communication link is to turn the SmartBits RS-232 LED on and 

off from HyperTerminal as follows:

1 To turn the RS-232 LED ON, enter sr at the >> prompt and press the Enter key.

2 To turn the RS-232 LED OFF, enter sm at the >> prompt and press the Enter key.
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HyperTerminal Problems

Garbled Data on HyperTerminal

If your HyperTerminal session showed garbled data when you powered up the SmartBits 

chassis, you have a speed mismatch between the SMB-600/6000B chassis and 

HyperTerminal.

To correct this condition:

1 Choose File > Properties on the HyperTerminal window.

2 Click the Configure button on the Properties window. Check that the speed is set to 

38400 and 8N1.

3 Click OK to close the Properties window. Close HyperTerminal.

4 Start SmartWindow. Select Actions > Disconnect from the SmartWindow menu.

5 When you have disconnected, select Options > Connection Setup from the 

SmartWindow menu.

6 Check the connection speed in the SmartWindow Connection Setup window. Ensure 

that it is set to 38400.

7 Start HyperTerminal with the same settings as before to confirm that the serial 

connection is working correctly. Power the SmartBits chassis off and on again. Wait 

approximately 30 seconds for the “Loaded from device 1” message.

www.valuetronics.com



SmartBits 600/6000B Installation Guide 67

Connecting Multiple Chassis LocallyA

In this appendix . . .

This appendix contains the following topics: 

• Multiple Chassis Connections.....68

• Setting Up and Powering Up Multiple Chassis.....71

• Multi-chassis Extension Unit.....76
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Multiple Chassis Connections

Many SmartBits applications are designed to perform tests with hundreds of SmartBits 

ports by connecting multiple chassis together as defined in this section. Because multiple 

chassis environments may include any mixed combination of SMB-200/2000/600/6000B 

chassis, and SMB-10 units, this section will reference all of these chassis/units.

Important:  For a list of cables to use in your chassis connections, refer to “Procedure 2: 

Check the Chassis and Package” on page 22, and “Procedure 4: Connect 

SmartBits to PC, Power, & LAN” on page 25.

Multiple Chassis Connection Terminology

Use Figure A-1 and the descriptions listed below to help you understand multiple chassis 

connection terminology.

• Controller – A chassis that can be connected via IP (#4, #5, #8, #10). A controller 

can be an SMB-200/2000/600/6000B.

• Primary Controller – The controller that supplies the synchronization in an 

expansion configuration (#4). A primary controller can be an SMB-200/2000/600/

6000B.

• Dependent Controller – Any controller that is connected side-by-side, through the 

RJ-45 expansion connectors, and relies on the primary controller for synchronization 

(#5, #8, #10).

• Master Controller – If a controller is an SMB-2000, it can also be the master 

controller (top) chassis in a stacking configuration (#4, #8, #10).

• Slave Unit – In a stacking configuration, a unit (SMB-2000 or SMB-10) that relies on 

the master controller for its source (#1, #2, #3, #6, #7, #9).

Note: Each controller that is connected via expansion needs a separate IP connection to 

the application.

Figure A-1.    Multiple Chassis Terminology

#1

#2

#3

#4 #5

#6

#7

#8

#9

#10
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Stacking Connections (SMB-2000 only)

A stacking connection involves an SMB-2000 chassis (master controller) and up to three 

units (slave units) connected vertically via DB-37 connectors (see Figure A-2). An SMB-

2000 must serve as the master controller chassis. The three slave units in the stack can be 

any combination of SMB-2000s or SMB-10s.

Refer to Figure A-2 for an example of using the maximum number of units in a single 

stack. 

Figure A-2.    Sample Multiple Chassis Stacking Order

Connect a SmartBits Stack of 80 Ports via DB-37 Connectors 

Note: Refer to “Procedure 4: Connect SmartBits to PC, Power, & LAN” on page 25 

when making any SmartBits chassis connection.

To connect a SmartBits via DB-37 connectors, follow these steps:

1 With the power turned off to all chassis, remove the terminator from the top chassis 

(which must be an SMB-2000). This will be the master controller chassis in the stack. 

2 Remove all cables from the lower (slave) units in the stack.

3 Install the long SmartBits cable from the lower port (where you removed the termina-

tor) of the master controller chassis to the middle port on the lower (slave) unit. Install 

the terminator in the bottom port of the slave unit.

4 The hub of the slave unit will be empty. Note that the SMB-10 has no hub port and 

can only be used as a slave. 

Note: Only the master controller chassis is connected to the PC or LAN, and has a 

cable on the HUB port. Only the last unit in the stack has a terminator on the bottom 

port.

5 Connect third and fourth SmartBits slave units if needed. 

6 When you power up the SmartBits stack (see “Power up the multiple chassis in 

sequential order” on page 73, turn on the slaves first, then turn on the SMB-2000 

(master controller) last. 

Any combination of SMB-2000’s and SMB-10 chassis

SMB-2000Master
Controller

Slave
Units
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Important:  If you fail to follow the power up sequential order, the master controller 

(SMB-2000) will not recognize the slave unit/s.

7 To power off multiple units in a stack, you must turn off the SMB-2000 (master 

controller) chassis first, then turn off the slaves.

Expansion Connections (all chassis)

An expansion connection involves any combination of SMB-200/2000/600/6000B chassis 

connected horizontally, via the RJ-45 expansion connectors. You may connect up to eight 

chassis (one primary controller and seven dependent controller chassis). This allows for 

multiple chassis test synchronization with one clock source (primary controller), which 

supplies the synchronization in the system. Figure A-3 shows an example of an expansion 

connection.

Figure A-3.    Example of Multiple Chassis Expansion Connection

If you are using an SMB-2000 chassis as the primary controller or one of the dependent 

controller chassis, you can also stack and connect up to three additional units below it via 

the DB-37 ports. In this configuration, the chassis would then become a master controller 

chassis.

Primary 
Controller

Any combination of SMB-200/2000s and SMB-600/6000Bs
Dependent Controller Chassis
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Setting Up and Powering Up Multiple Chassis

Important:  Prior to powering up your system, make sure that the following tasks have 

been performed:

• All chassis in the expansion connection are properly connected using the 

RJ-45 expansion cables.

• All chassis in the stacking connection are properly connected using the 

DB-37 cables supplied (see page 69).

• If you are connecting remotely via GPS, make sure that the GPS receiver 

to the primary controller chassis is connected and synchronized using the 

coaxial cables supplied. Refer to the Using GPS with SmartBits manual 

for more information.

• You have read and understand the following safety information:

– “Specifications and Safety Requirements” on page 15

– Appendix D, “ESD Requirements”

– Appendix E, “Fiber Optic Cleaning Guidelines”

Check applications to be used with multiple chassis

To use multiple chassis connections correctly, first check that you have the appropriate 

version of the application to be used with the chassis. If you have an appropriate 

application, please proceed to “Assign an IP Address to each SmartBits chassis” on page 

72.

The SmartBits applications that support multiple chassis connections are:

• SmartWindow 7.00 and higher1

1 Multiple chassis support is provided only through the multi-instance capability of 

SmartWindow. SmartWindow does not recognize Expansion or GPS.

• AST II 1.00 and higher

• SmartLib 3.06 and higher • SmartTCP 1.10 and higher

• SmartApplications 2.22 and higher • SmartxDSL 1.00 and higher

• SmartSignaling 3.00 • SCMT 1.10 and higher

• SmartMulticastIP 1.10 and higher • VAST 2.10 and higher

• SmartFlow 1.00 and higher • ScriptCenter 1.00 and higher

• SmartVoIPQoS 1.00 and higher
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Note: Please confirm with your Spirent Communications sales representative for the 

latest required version levels for all products.

Assign an IP Address to each SmartBits chassis 

Each chassis must have its own IP address and be connected to a LAN or WAN (see 

“Procedure 7: Set the IP Address” on page 30, and Figure A-4 on page 73). 

Connect multiple synchronized chassis

The connected primary controller and dependent controller chassis may be any 

combination of SMB-200/2000 or SMB-600/6000B chassis, totaling up to eight chassis. 

The maximum number of ports to configure is 768 ports (eight chassis x 12 slots x 8-port 

LAN-3100A modules). 

Notes: • A dependent controller may also be a master controller if it is an SMB-2000 

and is also used in a stacking configuration as shown in Figure A-5 on 

page 74.

• The synchronized clock and pulse signals passing through the connected 

chassis require careful sequential powering up to avoid random errors and 

distorted test results (see  Power up the multiple chassis in sequential order 

below).

• To maintain synchronization, the dependent controller you are using must 

always be connected to the primary controller chassis through one or more 

dependent controllers as needed.

To connect multiple synchronized chassis:

1 With power off to all chassis, use a standard Category 5 UTP straight-through cable 

and connect the Expansion Out RJ-45 port of the primary controller chassis to the 

Expansion In RJ-45 port of a dependent controller chassis. Cable should not exceed 

39 inches or 1 meter in length.

Note: The primary controller chassis uses only the RJ-45 Expansion Out port. It does not 

use the RJ-45 Expansion In port. The primary controller chassis is viewed as the first 

chassis (Chassis #1) in the series of connected synchronized chassis. See Figure A-4 on 

page 73.
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Figure A-4.    Example of a Synchronized Multiple Chassis Connection using SMB-6000Bs

2 Connect the remaining chassis in your system, (Category 5 UTP cables) not to exceed 

a total of eight chassis (one primary controller and seven dependent controllers). For 

an example, refer to Figure A-3 on page 70. 

3 After all the chassis have been connected and the IP addresses have been set, proceed 

with Step 4 below for power up instructions.

!
Caution: To prevent false test results, make sure that the Expansion In and 

Expansion Out cables are attached to the proper connectors at each end. Any cables 

left unconnected may cause problems. 

Power up the multiple chassis in sequential order

When powering up your multiple chassis configuration:

• SMB-200/2000 – Allow the LINK LED on the chassis to stop flashing before 

powering up the next chassis in sequence. (Time varies between 30 and 60 seconds.) 

• SMB-600/6000B – Allow the STATUS LED on the chassis to turn green before 

powering up the next chassis in sequence. (Time varies between 30 and 60 seconds.)

• Stacking configuration – Turn on all the slave units (any sequential order). Wait at 

least 30 seconds and then power up the master controller of the stack. If this sequence 

is not followed, the master controller may not recognize the slaves.

Primary Controller
192.168.99.1

Dependent Controller
192.168.99.2

Dependent Controller
192.168.99.8

LAN/WAN
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For an example of powering up multiple chassis in sequential order, we will use the 

example shown in Figure A-5 below.

To power up multiple chassis:

1 Turn on the slave units #1, #2, #3, #6, #7, #9.

2 Allow the LINK LEDs on the chassis’ to stop flashing (at least 30 seconds) and then 

power on the primary controller (chassis #4). 

3 When the LINK LED has stabilized on the primary controller, power on the 

dependent controllers in sequential order, (chassis #5, #8, 10). Wait for LINK LED or 

STATUS LED to stabilize in between powering up each chassis, until you have 

completely powered up all the chassis in a given series.

Important:  If any of the dependent controllers get power-cycled or disconnected, repeat 

the power-up sequence to ensure the system clock connection. 

Figure A-5.    Multiple Chassis Power Up Sequence

#4

#3

#2

#1

#5

#6

#7

#8

#9

#10

Step 1

Step 2
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Note: If powering up too quickly or out of sequence, the PC or workstation may report 

“ethernet connection timeout” and “socket timeout” errors.

While your system is operating, the following connect/disconnect rules apply:

• If you disconnect the primary master controller chassis, you break the 

synchronization of the entire series of connected (RJ-45 Expansion In and Out 

connected) chassis. 

• If you disconnect a dependent chassis within a synchronized series, it breaks the 

connection for itself and for all chassis following it (downstream) in the series.

• If you disconnect a master controller chassis in a stack, you automatically disconnect 

all slave units connected (DB-37) to it.

• If you disconnect a slave unit within a stack, the entire stack is disabled.

Power down and disconnect the chassis

For powering down and disconnecting the chassis, we will use the example shown in 

Figure A-5 on page 74. 

To power down and disconnect the chassis:

1 Power down the expansion chassis in the reverse order of the powering up sequence, 

starting with the last dependent controller chassis (#10) which has an RJ-45 

Expansion In connection only, and no Expansion Out connection. 

2 Power down the dependent controller chassis #8 and #5.

3 Power down the master controller chassis #4. 

4 You may power down the slave units any time after the master controller chassis that 

they are connected to have been powered down.
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Multi-chassis Extension Unit

The Multi-chassis Extension Unit (see Figure A-6 and Figure A-7 below) enables the 

connection of up to 512 synchronized SmartBits chassis. Each extension unit supports up 

to eight chassis; each of these chassis can connect to another extension unit that supports 

up to eight additional chassis, and so on, until reaching the 512 quantity limit. This 

extension unit also provides flexibility in cable length and cable distribution, and supports 

the regeneration of signals and timing at each extension unit.

Figure A-6.    Multi-chassis Extension Unit – Front View

An AC/DC power converter is included with the Multi-chassis Extension Unit. This 

converter connects to the back of the unit and into any 120V outlet (see Figure A-7).

Figure A-7.    Multi-chassis Extension Unit – Back View

Expansion Ports Expansion Ports

Power Converter Receptacle
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Multi-chassis Extension Unit Terminology

The terminology used with Multi-chassis Extension Unit connections is defined as follows 

and is shown in Figure A-8 below:

• Primary Controller – The main chassis which controls the synchronization for all 

the chassis and extension units in the configuration.

• Principle Extension Unit – The extension unit that is connected to the primary 

chassis.

• Dependent Controller – Any chassis that relies on a another chassis or an extension 

unit for its synchronization.

• Subordinate Extension Unit – An extension unit that relies on a dependent chassis 

or another extension unit for its synchronization.

• Flat Connection – An extension unit that is connected to, and relies on, another 

extension unit for its synchronization.

• Hierarchal Connection – A series of connections from extension units to SmartBits 

chassis in multiple layers.

Figure A-8.    Multi-chassis Extension Unit Terminology

Primary Controller

Principle Extension Unit

Subordinate Extension Unit

Dependent

Hierarchal

Flat

Connection

Connection

Controller

Dependent
Controller
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Multi-chassis Extension Unit Cable Connections

Important:  The total accumulative length of the Category 5 UTP cable (RJ-45) used for 

all connections between a layer of SmartBits chassis and another SmartBits 

chassis must not exceed 50 feet in length (15.24 meters).

The primary SmartBits chassis connection that measures from the Primary Controller (or 

#1 chassis) to the Principle Extension Unit (see Figure A-9) determines the maximum 

cable length of subsequent cables used between a SmartBits chassis connected to the 

Multi-chassis Extension Unit. 

To determine the cable length limitation for these connections, subtract the length of the 

Primary Controller/Principle Extension Unit cable from 50 feet (15.24 meters). In the 

example shown in Figure A-9, the cable used to connect the master chassis to the Principle 

Extension Unit is 3 feet in length. Therefore, the maximum accumulative cable length 

from the extension unit to all directly connected chassis (see Figure A-10 on page 79) can 

be any variable under 47 feet (50 - 3 = 47) in length.

Multi-chassis Extension Unit Configurations

The Multi-chassis Extension Unit may be configured in various ways. For this connection 

example, we will discuss using the OUT port of the Extension Unit exclusively.

Note: Refer to Figure A-8 on page 77 for terminology explanations.

Flat connection

To set a flat connection:

1 Connect a cable from the expansion OUT port of the Primary Controller to the IN 

port on the Principle Expansion Unit as shown in Figure A-9. 

Figure A-9.    Initial Connection of a SmartBits Chassis to an Extension Unit

Category 5 UTP Cable

Principle Extension Unit IN Port

Chassis OUT Port

Primary Controller
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2 From each of the Principle Extension Unit’s eight ports, connect up to eight 

dependent controllers IN ports as shown in Figure A-10 below.

Figure A-10.    Connecting SmartBits Chassis to an Extension Unit

Note: In this example, we are using a 3 foot cable to connect the Primary Controller to 

the Principle Extension Unit. Each cable that connects the extension unit to the next 

SmartBits chassis may vary in length and can be any variable under 47 feet in length 

(14.33 meters).

3 You can connect another extension unit to the Principle Extension Unit by connecting 

a cable from the OUT expansion port of the Principle Extension Unit to the IN port of 

the Subordinate Extension Unit as shown in Figure A-11 below. You may continue 

adding extension units and chassis until you reach 512 chassis. 

Figure A-11.    Connecting an Extension Unit to Another Extension Unit

Dependent Controllers

Cables lengths may vary
and can be any
variable under 47 feet.

3 Foot Cable

Principle 
Extension Unit

Subordinate 
Extension Unit
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You can connect up to an additional eight chassis to the Subordinate Extension Unit as 

shown in Figure A-12. 

Important:  To determine the maximum cable length allowed between chassis, we are 

using a 5 foot cable, in the example shown in Figure A-12, which connects 

the principle extension unit to the subordinate extension unit. That means 

that each cable connected from the subordinate extension unit to the next 

chassis can be any variable under 45 feet in length.

Figure A-12.    Connecting Additional SmartBits Chassis to a Second Extension Unit

Continue adding extension units and chassis until you reach the desired number of chassis 

that you want to synchronize (up to 512).

Principle

Subordinate
Extension UnitEach of these cables

may vary and can be 
any variable under

45 feet.

5 foot cable

Extension
Unit
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Hierarchal connection

To set up a hierarchal connection:

Note: Refer to Figure A-8 on page 77 for terminology explanations.

1 Connect the Primary Controller chassis to the Principle Extension Unit.

2 Connect the Principle Extension Unit to eight Dependent Controller chassis.

3 Connect each Dependent Controller chassis to another Multi-chassis Extension Unit.

You may repeat this procedure to obtain the required ports.

Important:  Once the cable connections pass through another SmartBits chassis, the 

cable measuring process starts over again.

Figure A-13.    Example of Hierarchal Connection Configuration 

Each of these cables
can vary and be any
variable under 47 feet.

The cable length 
measuring process
starts over when
exiting the chassis.

3 foot cable
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Beginning with the configuration shown in Figure A-13 on page 81, you can add eight 

more chassis to each extension unit (Figure A-14 below). You may repeat this procedure 

until you reach 512 chassis.

Important:  When measuring cable length from a SmartBits chassis to an extension unit, 

and to another SmartBits chassis, remember that the total cable length can be 

any variable under 50 feet.

Figure A-14.    Connecting Chassis Through an Extension Unit in a Hierarchal Connection Configuration

www.valuetronics.com



SmartBits 600/6000B Installation Guide 83

Downloading and Installing ApplicationsB

In this appendix . . 

This appendix contains the following topics:

• Downloading SmartBits Applications.....84

• Running the Application.....85

• Key Files.....85
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Downloading SmartBits Applications

SmartBits applications are available from the Spirent Communications website at 

http://www.spirentcom.com.

To reach the download area, select the SmartBits option on the Spirent Communications 

home page. This displays the home page for Spirent Communications, SmartBits 

Division. From there, select Support > Software Updates. Both released and beta 

software and firmware versions are listed.

Example Download

To downloaded SmartWindow 7.30. 

1 Call Spirent Communications Technical Support for a password or a set of passwords 

for the applications you are authorized to download via your current Software 

Upgrade Support (SUS) contract. Be ready to give the representative the serial num-

ber of your SmartBits chassis when you call.

2 Go to www.spirentcom.com. Select Support > Software Upgrades menu option. The 

list of current released and beta software and firmware appears.

3 Click the SmartWindow hyperlink. The SmartWindow download area appears. 

A more detailed explanation of the SmartWindow 7.30 release is displayed, listing the 

new features that are included in this update release. Note the hyperlink for the 

Release Notes at the top of the page. The Release Notes indicate the hardware items 

that are supported by the software. 

4 Click the Download button to download the desired file.

Use the download procedures appropriate for the web browser you are using.

You are prompted for the download location on your local system. In this example, we 

will save the SmartWindow file smartwindow730.exe, to the temp directory on our 

local hard drive. The SmartBits software is then placed on your local hard drive.

Note: You did not need any keys or passwords to perform these steps. These are 

required later in the process.

5 After you download a SmartBits application file, run it by double-clicking the .exe file 

on the Windows Explorer window. The file will prompt you for a password. 

When you have entered the password, the downloaded files will start the installation 

and walk you through the installation process. 

6 During the install, you will be prompted for the application directory. It is recom-

mended that you install upgrades in a new directory and that you only install one 

application per directory (do not install all of the SmartBits applications in a single 

directory).

7 To complete the installation of any optional application, copy the <application-

Key.txt> file from the 3.5 in. (8.9 cm.) disk supplied with the application, into the 
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directory where you installed the application. This applies to all applications except 

SmartWindow, SmartLib, and SmartApplications. (See below for more information 

on key files.)

Running the Application

The applications icon will be installed by default in the SmartBits Applications directory. 

You also have the option to install a shortcut on your desktop. To run the application, 

select Start > Programs > SmartBits Applications > DesiredApplication or click twice 

on the applications icon.

Note: Some applications may use the directory: Start > Programs > Netcom Systems 

Applications > DesiredApplication.

Key Files

When you start the application, you may get the No Authorization message. This indicates 

that the application cannot find the key file for the application. 

All SmartBits applications, except the core applications (SmartWindow, SmartApps, and 

SmartLib), require a key file. Look for the 3.5 in. (8.9 cm.) disk supplied with your 

applications; it will contain your key file which you can copy into the directory where 

your application resides.

If the key file is not found, the application will run in demo mode; that is, it will run for a 

limited time and then timeout and close.

If you had a previous installation of the application, copy the <program>KEY.TXT file 

from that directory to the new installation directory.

If you have lost your <program>KEY.TXT file, you will need to call Spirent 

Communications Technical Support to have another file created for you. You will need to 

have the chassis number associated with the key file, as well as an email address to receive 

the key file. When you receive the file, copy it to the directory where the SmartBits 

application is installed. 

Key files are keyed to a specific SmartBits chassis. If you want to move your application 

to another PC, you simply move the key file to the new PC with the application. If you 

want to run the application on a different SmartBits chassis, you will need another key file.

Note: Spirent Communications Technical Support can generate special keys with more 

than one chassis number.
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Debug ConsoleC

In this appendix . . . 

This appendix contains the following topics:

• Enabling the Debug Console.....88

• Using the Debug Console.....88
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Enabling the Debug Console

To enable the Debug console in SmartWindow, you need to add the line 

terminal=terminal.exe to the top or first [Preferences] section of the 

C:\windows\smartbit.ini file, as shown below.

[Preferences]

terminal=terminal.exe

After you add the line, save the smartbit.ini file, and reboot SmartWindow. The Debug 

menu appears in the menu bar beside the Help menu. 

Using the Debug Console

To use the Debug console (example):

1 Choose Debug > SmartCard Debug Console as shown here. 
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The debug console will be displayed. The combo box on the upper left-hand side 

shows the currently selected module. In the following example, the debug console 

shows the GX-1405 Gb Ethernet module in Port 11.

2 To check the Configuration Data register, enter E for Edit Tx. 

The current status of the Link Config Data register is shown as 0020. 

3 Click Esc to return to the main menu. 
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4 Leaving the debug console window open, choose Gigabit Setup from the SmartWin-

dow drop-down menu, shown below. The Gigabit Ethernet Setup menu will be 

displayed. 
 

5 Check the Autonegotiation Enable checkbox and select the Pause Flow Control 

Asymmetric > LocalDevice radio button as shown below.

6 Click the Restart button.

7 Return to the Debug Console (you will have to click in the window to make the 

Window active before it will accept commands). 

8 Select E again to display the Tx setup data. The Link Config Data is now shown as 

01A0. 

Asymmetric -> Local Device Radio Button
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ESD RequirementsD

In this appendix . . . 

This appendix contains the following topics:

• General Equipment Handling.....92

• Workstation Preparation.....93
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Spirent Communications manufactures and sells products that require industry standard 

precautions to protect against damage from electrostatic discharge (ESD). This appendix 

explains the proper process for handling and storing electrostatic discharge sensitive 

(ESDS) devices, assemblies, and equipment.

The requirements presented in this appendix comply with the EIA Standard, ANSI/ESD 

S20.20-1999: Development of an Electrostatic Discharge Control Program, and apply to 

anyone who handles equipment that is sensitive to electrostatic discharge. Such equipment 

includes, but it not limited to:

• All electronic assemblies manufactured by Spirent Communications

• Discrete and integrated circuit semiconductors

• Hybrid microcircuits

• Thin film passive devices

• Memory modules

!
Caution: Failure to comply with the requirements explained in this appendix poses risks 

to the performance of ESDS devices, as well as to your investment in the equipment. 

General Equipment Handling

Whenever you handle a piece of ESDS equipment, you must be properly grounded to 

avoid harming the equipment. Also, when transporting the equipment, it must be packaged 

properly. Follow the requirements below to help ensure equipment protection.

• Wrist straps must be worn by any person handling the equipment to provide normal 

grounding.

• The use of foot straps is encouraged to supplement normal grounding. If foot straps 

are used exclusively, two straps (one on each foot) should be used. Note that foot 

straps are only applicable in environments that use ESD flooring and/or floor mats.

• Hold ESDS equipment by the edges only; do not touch the electronic components or 

gold connectors.

• When transporting equipment between ESD protected work areas, the equipment 

must be contained in ESD protective packaging. Equipment that is received in ESD 

protective packaging must be opened either by a person who is properly grounded or 

at an ESD protected workstation.

• Any racks or carts used for the temporary storage or transport of ESDS equipment 

must be grounded either by drag chains or through direct connection to earth ground. 

Loose parts that are not protected by ESD-safe packaging must not be transported on 

carts.
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Workstation Preparation

The ideal setup for working with ESDS equipment is a workstation designed specifically 

for that purpose. Figure D-1 illustrates an ESD protected workstation. Please follow the 

requirements listed below to prepare a proper ESD protected workstation. 

• The ESD Ground must be the equipment earth ground. Equipment earth ground is the 

electrical ground (green) wire at the receptacles.

• An ESD protected workstation consists of a table or workbench with a static 

dissipative surface or mat that is connected to earth ground. A resistor in the 

grounding wire is optional, providing that surface resistance to ground is

≥ 105 to ≤ 109
���

• The workstation must provide for the connection of a wrist strap. The wrist strap must 

contain a current limiting resistor with a value from ≥ 250K Ω to ≤ 10M Ω.

• ESD protective flooring or floor mats are required when floor-grounding devices (foot 

straps/footwear) are used or when it is necessary to move in between ESD protected 

workstations when handling ESDS equipment.

Figure D-1.    ESD Protected Workstation

Note: The equipment needed for proper grounding is available in ESD service kits, such 

as the ESD Field Service Kit available from Spirent Communications (P/N 170-8505). For 

additional information regarding Spirent Communications ESD standards and procedures, 

please refer to the ESD Control Procedure document (P/N 900-0211-001).
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Fiber Optic Cleaning GuidelinesE

In this appendix . . . 

This appendix contains the following topics:

• Cleaning Guidelines.....96
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Spirent Communications manufactures and sells products that contain fiber optic 

components, including fiber optic transmitters and receivers. These components are 

extremely susceptible to contamination by particles of dirt or dust, which can obstruct the 

optic path and cause performance degradation. To ensure optimum product performance, 

it is important that all optics and connector ferrules be kept clean.

This appendix presents guidelines for maintaining clean fiber optic components. Spirent 

Communications recommends that these guidelines be followed very closely.

!
Caution: • Failure to comply with the guidelines explained in this appendix poses 

risks to the performance of fiber optic-based devices, as well as to your 

investment in the equipment. 

• Whenever you handle a piece of equipment that contains fiber optic 

components, you must be properly grounded to avoid harming the 

equipment. Refer to Appendix D, “ESD Requirements” for more details on 

ESD. 

Cleaning Guidelines

To ensure the cleanliness of fiber optic components, follow the guidelines below:

• Use fiber patch cords (or connectors if you terminate your own fiber) only from a 

reputable supplier. Low-quality components can cause many hard-to-diagnose 

problems during an installation. 

• Dust caps are typically installed on fiber optic components to ensure factory-clean 

optical devices. These protective caps should not be removed until the moment of 

connecting the fiber cable to the device. Ensure that the fiber is properly terminated, 

polished, and free of any dust or dirt. Also make sure that the location of installation is 

as free of dust and dirt as possible.

• Should it be necessary to disconnect the fiber device, reinstall the protective dust caps.

• If you suspect that the optics have been contaminated, alternate between blasting with 

clean, dry, compressed air and flushing with methanol to remove particles of dirt.
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