VXG Signal Generator
and X-Series Signal Analyzers

M9484C VXG Vector Signal Generator
N9042B, N9041B, N9040B, N9032B, N9030B,
and N9021B Signal Analyzers

This manual provides documentation for the M9484C and X-Series Signal Analyzers running the Microsoft Windows 10 operating system.

'W KEYSIGHT MEASUREMENT GUIDE



Notices

© Keysight Technologies, Inc.
2021- 2023

No part of this manual may be
reproduced in any form or by any
means (including electronic
storage and retrieval or translation
into a foreign language) without
prior agreement and written
consent from Keysight
Technologies, Inc. as governed by
United States and international
copyright laws.

Trademark Acknowledgments

Bluetooth and the Bluetooth logos
are trademarks owned by
Bluetooth SIG, Inc., U.S.A. and
licensed to Keysight Technologies,
Inc.

Manual Part Number
M9484-90002
Edition

Edition 1, October 2023
Supersedes: April 2023

Published by:

Keysight Technologies

1400 Fountaingrove Parkway
Santa Rosa, CA 95403

Warranty

THE MATERIAL CONTAINED IN THIS
DOCUMENT IS PROVIDED “AS IS,”
AND IS SUBJECT TO BEING
CHANGED, WITHOUT NOTICE, IN
FUTURE EDITIONS. FURTHER, TO
THE MAXIMUM EXTENT PERMITTED
BY APPLICABLE LAW, KEYSIGHT
DISCLAIMS ALL WARRANTIES,
EITHER EXPRESS OR IMPLIED WITH
REGARD TO THIS MANUAL AND
ANY INFORMATION CONTAINED
HEREIN, INCLUDING BUT NOT
LIMITED TO THE IMPLIED
WARRANTIES OF
MERCHANTABILITY AND FITNESS
FOR A PARTICULAR PURPOSE.
KEYSIGHT SHALL NOT BE LIABLE
FOR ERRORS OR FOR INCIDENTAL
OR CONSEQUENTIAL DAMAGES IN
CONNECTION WITH THE
FURNISHING, USE, OR
PERFORMANCE OF THIS

DOCUMENT OR ANY INFORMATION
CONTAINED HEREIN. SHOULD
KEYSIGHT AND THE USER HAVE A
SEPARATE WRITTEN AGREEMENT
WITH WARRANTY TERMS
COVERING THE MATERIAL IN THIS
DOCUMENT THAT CONFLICT WITH
THESE TERMS, THE WARRANTY
TERMS IN THE SEPARATE
AGREEMENT WILL CONTROL.

Technology Licenses

The hardware and/or software
described in this document are
furnished under a license and may
be used or copied only in
accordance with the terms of such
license.

U.S. Government Rights

The Software is “commercial
computer software,” as defined by
Federal Acquisition Regulation
(“FAR”) 2.101. Pursuant to FAR
12.212 and 27.405-3 and
Department of Defense FAR
Supplement (“DFARS”) 227.7202,
the U.S. government acquires
commercial computer software
under the same terms by which the
software is customarily provided to
the public. Accordingly, Keysight
provides the Software to U.S.
government customers under its
standard commercial license,
which is embodied in its End User
License Agreement (EULA), a copy
of which can be found at
http://www.keysight.com/find/swe
ula. The license set forth in the
EULA represents the exclusive
authority by which the U.S.
government may use, modify,
distribute, or disclose the
Software. The EULA and the
license set forth therein, does not
require or permit, among other
things, that Keysight: (1) Furnish
technical information related to
commercial computer software or
commercial computer software
documentation that is not
customarily provided to the public;
or (2) Relinquish to, or otherwise
provide, the government rights in
excess of these rights customarily
provided to the public to use,
modify, reproduce, release,
perform, display, or disclose

commercial computer software or
commercial computer software
documentation. No additional
government requirements beyond
those set forth in the EULA shall
apply, except to the extent that
those terms, rights, or licenses are
explicitly required from all
providers of commercial computer
software pursuant to the FAR and
the DFARS and are set forth
specifically in writing elsewhere in
the EULA. Keysight shall be under
no obligation to update, revise or
otherwise modify the Software.
With respect to any technical data
as defined by FAR 2.101, pursuant
to FAR 12.211 and 27.404.2 and
DFARS 227.7102, the U.S.
government acquires no greater
than Limited Rights as defined in
FAR 27.401 or DFAR 227.7103-5
(c), as applicable in any technical
data.

Safety Notices

A CAUTION notice denotes a
hazard. It calls attention to an
operating procedure, practice, or
the like that, if not correctly
performed or adhered to, could
result in damage to the product
or loss of important data. Do not
proceed beyond a CAUTION
notice until the indicated
conditions are fully understood
and met.

A WARNING notice denotes a
hazard. It calls attention to an
operating procedure, practice, or
the like that, if not correctly
performed or adhered to, could
result in personal injury or death.
Do not proceed beyond a
WARNING notice until the
indicated conditions are fully
understood and met.


http://www.keysight.com/find/sweula
http://www.keysight.com/find/sweula

Where to Find the Latest Information

Documentation is updated periodically. For the latest information about this product, including instrument
software upgrades, application information, and product information, browse to the following URL:
https://www.keysight.com/us/en/product/M9484C/m9484c.html

Information on preventing instrument damage can be found at:

http://keysight.com/find/PreventinglnstrumentRepair
ls your product software up-to-date?

Periodically, Keysight releases software updates to fix known defects and incorporate product enhancements.
To search for software updates for your product, go to the Keysight Technical Support website at:

http://www.keysight.com/find/techsupport


http://www.keysight.com/find/PreventingInstrumentRepair
http://keysight.com/find/PreventingInstrumentRepair
http://keysight.com/find/PreventingInstrumentRepair
http://www.keysight.com/find/techsupport




1. M9484C VXG Basic Measurements

OVBIVIBW o o 10
Equipment Setup . ... 11
Required Software . ... ... 12
Setting Up Triggers on the X-Series Signal Analyzer .. ............ .. ... ... ... ..... 13
Basic Measurements. . . . ... 14
Generating a Continuous Waveform (CW) . ... .. ... . . . . .. 14
Generating Amplitude Modulation ... ... . . 19
Generating Frequency Modulation . ... .. ... 24
Generating Phase Modulation . . ... . 28
Generating Synchronized Pulse (IQ + Analog) Modulation. .. ..................... 33
Generating a Multitone Signal. . ... . 37
Setting Up Waveform File Vector Modulation. . ... .. ... . . . . 42

2. Corrections

Corrections/De-embedding Using PathWave N7653APPC Software. . ................. 52
Adding Fixture Blocks using s2p Files . .. ... .. 52
Using a Spectrum Analyzer to Make the Corrections Measurement . ............... 58
Using a Power Meter to Make the Corrections Measurement . .................... 65
Using the equivalent SCPIcommands. .. ... .. 69

Instrument Nonlinear Correction . . . ... . 71
Setting Up an INC 1CC 4 GHz, 10 dBm EVM Measurement. . ..................... 71
Setting Up an INC 8CC 28 GHz, 10 dBm EVM Measurement. . .................... 82

3. Advanced Measurements

Channel Bonding .. ... 92
Generating a Multi-Carrier DVB-S2X Signal for Satellite TV . .. ... ... ... ... 93
Generating a Wide Band QPSK . . . ... 107
Generatinga bG NRWaveform .. ... ... 116

Setting Up 8 Virtual Signal Generators . .. ... ... 126
ONthe VXG: o 127
Onthe Signal Analyzer: . . ... 134

Using the VSA Flex Frame to Create a DVB-S2X Signal ............ ... ... .. .. .... 136
DVB-S2X PHY Layer Framing . .. ... o 137
Part 1: Generating a DVB-S2X Waveform Using N7623C Signal Studio for Digital
Modulation . ... 138
Part 2: Generating a DVB-52X Waveform Using the N7608APPC Signal Studio for Custom
Modulation . ... 155

Creating & Analyzing a 5G NR DL 2x2 MIMO Measurement Using Two UXAs. . ......... 174
ONthe VXG . o 175
Demodulate the 5G NR 2x2 MIMO in X-ApPS. . . .. oot 185

M9484C VXG and X-Series SA Measurement Guide 5



Demodulate the 5G NR 2x2 MIMO Using VSA: .. ... . . 189

Creating and Analyzing a 4x4 MIMO using a UXR Running VSA Software . ............. 196
EqQuipment Setup. . . .. o 196

Other X-Series Signal Analyzer Measurements

Setting Up a Group Delay Measurement . ... . . 212
Setting Up Millimeter-Wave Measurements. .. ... ... . i 222
Setting up a 5G NR Millimeter-Wave Measurement .. ............ .. ... ......... 222
Setting-up a Millimeter-Wave DVB-S2X 64APSK Measurement. . ................. 231
Setting-up a Millimeter-Wave 5G NR, 2 GHz BW FR2 Measurement. . ............. 253
Using the X-Series Analyzer’s SCPI Recorder Function . .......... ... ... .. ... ..... 277
Using the graphical userinterface . ....... ... . .. . 277
On the X-Series Signal Analyzer: .. ... ... .. . 279
Using the X-Series Analyzer’s Preload/Unload Function. . ............ ... ... .. ..... 290

5G New Radio (NR) Measurements using X-Apps

5G Waveform, EVM, and ACP Analysis Using X-Applications . ....................... 292
Setting Up Triggers on the Signal Analyzer using 5G NRMode ................ ... 292
SettingUp a1 CC 28 GHz EVM Measurement . .......... ... .. .. .. ... .. .. ..... 294
Settingup an 8 CC 28 GHz EVM Measurement. ............ ... .. ... .. .. .. ..... 301
SettingUp a1 CC 3.5 GHz ACP Measurement . .......... ... .. .. .. ... . ... .. 311
Using PathWave N7631APPC to Create a Waveform File then Automatically Configure the
Analyzer to View the Results. .. .. .. ... 316

5G NR Measurements Using the VSA Software

5G Waveform and EVM Analysis Using VSA Software . .. ............. ... .. ... ..... 326
SettingUp a1 CC 28 GHz EVM Measurement. . . ... .. .. . ... 326
Setting Up an 8 CC 28 GHz EVM Measurement. .. ... ... ... 339
Creating a Basic 5G NR Signal Using PathWave N7631APPC Embedded Software .. .349
Creating a DL MIMO Signal Using PathWave N7631APPC Signal Generation. . ... ... 369

M9484C VXG and X-Series SA Measurement Guide



M9484C and X-Series Analyzer Measurement Guide

1 M9484C VXG Basic Measurements

KEYSIGHT

TECHNOLOGIES

“Overview” on page 10

“Equipment Setup” on page 11

“Required Software” on page 12

“Setting Up Triggers on the X-Series Signal Analyzer” on page 13

“Basic Measurements” on page 14

“Generating a Continuous Waveform (CW)” on page 14
“Generating Amplitude Modulation” on page 19
“Generating Frequency Modulation” on page 24
“Generating Phase Modulation” on page 28

“Generating Synchronized Pulse (IQ + Analog) Modulation” on
page 33

“Generating a Multitone Signal” on page 37
“Setting Up Waveform File Vector Modulation” on page 42



Overview

10

M9484C VXG Basic Measurements
Overview

The M9484C VXG Vector Signal Generator provides frequency coverage from
9 kHz to 54 GHz, with up to 2.5 GHz RF modulation bandwidth per channel
using an internal baseband generator, and up to 5 GHz RF modulation
bandwidth with channel bonding.

The measurement examples use an X-Series Signal Analyzer to view the
results. A few measurement examples require an N9042B signal analyzer and is
called out in those specific measurement examples. For information on using
the X-Series Signal Analyzer multi-touch user interface, refer to the Online
Help.

Please refer to the VXG data sheet and X-Series Signal Analyzer data sheet to
ensure your measurement setup has adequate power.

https://www.keysight.com/us/en/product/M9484C/m9484c.html

The software versions used in this measurement guide are:

— VXG: A.12.02
— X-Series Spectrum Analyzers/N9085EMOE: A.34.xx or later
— 89601 VSA: Version 2023 or later

M9484C VXG and X-Series SA Measurement Guide
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Equipment Setup

Equipment Setup

— M9484C front panel RF T Out to X-Series Signal Analyzer front panel RF In
— M9484C front panel Event 2 to X-Series Signal Analyzer rear panel Trig 1 In

Trig 3 In is used for an N9040B with Option H1G (1 GHz Bandwidth). For
N9O040B with Bandwidth 510 MHz or less, use Trig 1 In.

— M9484C rear panel 10 MHz Ref Out to X-Series Signal Analyzer rear panel
Ext Ref In

M9484C
(front panel)

X-Series Signal Analyzer
(front panel)
MNI042B, N904TB, N9040B,

N9032B, N90308, ar NO021B
(minimum frequency 28 GHz)

M9484C
(rear panel)

For N9040B with Bandwidth of

Trig 3 In is for an NSO40B with
Option H1G {1 GHz Bandwidth).
less than 510 MHz use Trig 1 In.

Trigger 3 In

X-Series Signal Analyzer
(rear panel)
N3042B, N3041B, N9040B,

N90328, NS0O30B, or N9D21B
{minimum frequancy 28 GHz)

Trigger 1 In

m34B84c2x series.png

M9484C VXG and X-Series SA Measurement Guide 11



M9484C VXG Basic Measurements
Required Software

Required Software

— M9484C
— N7631APPC - 5GNR
— N7608APPC - Custom Modulation
— N7605APOC - 3GPP Real Time/Fading

— PathWave Automatic Channel Response Correction and S-parameter
De-embedding (N7653APPC)

12 M9484C VXG and X-Series SA Measurement Guide
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Setting Up Triggers on the X-Series Signal Analyzer

Setting Up Triggers on the X-Series Signal Analyzer

1. From the X-Series Signal Analyzer Menu Panel (on the top right of the
display), select Mode/Meas > Spectrum Analyzer mode.

If accessing the instrument via a Remote Desktop connection, select the
NOTE Screen tab (at the top of the display) to open the

Mode/Measurement/View Selector window.

2. Select Mode Preset to set Spectrum Analyzer mode to a known state.

3. From the dropdown on the top right, select Trigger and set Trigger Source
to Free Run.

g Trigger

;E;-Sere«:l Trig Source

Free Run

Gate
| Source

; Gate
Video Setlings

Line

External 1 i '.D|=-Tnff
External 2

RF Burst

Periodic

™

M9484C VXG and X-Series SA Measurement Guide 13



M9484C VXG Basic Measurements
Basic Measurements

Basic Measurements

Generating a Continuous Waveform (CW)

This procedure will demonstrate the amplitude and frequency accuracy of the
VXG at RF and pW frequencies.

Ensure the equipment and triggers are properly configured. Refer to
“Equipment Setup” on page 11 and “Setting Up Triggers on the X-Series
Signal Analyzer” on page 13.

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.
2. In the Output area, set Frequency to 1 GHz and Power to 0 dBm.

These values are coupled to CW Frequency and Total Power (RMS) in the
corresponding RF Output Block.

1.00000000000 GHz

0.00 dBm

3. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

4. For multi-channel instruments only: In the top right corner of the display,
set RF Out (All) to On by selecting the switch.

RF Out (All)

In order to turn on RF for any channel, both the RF Out for the specific
channel (for example, Channel 1 or Channel 2), and RF Out All must be
turned on.

On the X-Series Signal Analyzer:

1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

2. From the Menu Panel, select Frequency and set Center Frequency to
1 GHz and Span to 1 MHz.

14 M9484C VXG and X-Series SA Measurement Guide
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Basic Measurements

3. Select Peak Search.

Observe the accuracy of the amplitude and frequency of the signal.

KEYSIGHT |nput [input Z- 50 0 Atler: 101 aB PNG- Balanced lAvg Type: Log-Pawer
Coupling: DC (Comections: Off Praamp: Off Gale. Of Trig. Free Run
\Freq Ref. Int {5) W Path: Standand IF Gain: Low |
NFE: Adaptive Source: Off Sig Track: OF

G

|
| Scale/Div 10 dB Ref Level 0.00 dBm
Loa — 4 - - b 4 —

(Res BW 9.1 kHz Sweep 1.00 ms {1001 pts)

On the VXG:
1. Set Output 1 Power to -90 dBm.
2. Ensure that RF Out is On.

On the X-Series Signal Analyzer:

1. Select Amplitude and set Ref Level to =70 dBm and Scale/Div 5 dB.
2. Select BW and set Video BW to 300 Hz.

3. Select Peak Search.

M9484C VXG and X-Series SA Measurement Guide 15
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Basic Measurements

Observe the frequency and amplitude accuracy of the VXG at low power
levels.

On the VXG:

1.

Set Frequency to 44 GHz and Power to 0 dBm.

On the X-Series Signal Analyzer:

1.
2.

Select Frequency and set Center Frequency to 44 GHz.

Select Amplitude and set Ref Level to 0 dBm and Scale/Div to
10 dB.

3. Select BW > Video BW and set to Auto.

Select Peak Search.

M9484C VXG and X-Series SA Measurement Guide
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Basic Measurements

KEYSIGHT Wsr

s i

Observe the frequency and amplitude accuracy at high frequency levels.
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Basic Measurements

Using the equivalent SCPI commands
Creating a CW signal on Channel 1.

On the VXG:

SYSTem: PRESet

RF1:FREQuency:CW 1GHZ

RF1:POWer:AMPLitude 0dBm
RF1:0UTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFAL1 :OUTPut ON

On the X-Series Signal Analyzer:
FREQuency:CENTer 1GHZ
FREQuency: SPAN 1MHZ

CALCulate:MARKerl :MAXimum

On the VXG:
RF1:FREQuency:CW 1GHZ

RF1:POWer:AMPLitude -90dBm

RF1:0UTPut:STATe ON

On the X-Series Signal Analyzer:
DISPlay:WINDowl:TRACe:Y:RLEVel -70

DISPlay:WINDowl:TRACe:Y:PDIVision 5
BWIDth:VIDeo 300Hz
CALCulate:MARKerl :MAXimum

On the VXG:

RF1:FREQuency:CW 44GHZ
RF1:POWer:AMPLitude 0dBm

On the X-Series Signal Analyzer:
FREQuency:CENTer 44GHZ
DISPlay:WINDowl:TRACe:Y:RLEVel O
DISPlay:WINDowl:TRACe:Y:PDIVision 10
BANDwidth:VIDeo:AUTO ON

CALCulate:MARKerl :MAXimum

M9484C VXG and X-Series SA Measurement Guide
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Basic Measurements

Generating Amplitude Modulation

The VXG must have the N7642APPC PathWave Signal Generation for 1Q
Based AM, FM, Phase license installed.

Ensure the equipment and triggers are properly configured. Refer to
“Equipment Setup” on page 11 and “Setting Up Triggers on the X-Series
Signal Analyzer” on page 13.

Follow the steps below for AM analog modulation using the internal or an
external I/Q modulation source.

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.
2. Set Frequency to 20 GHz and Amplitude to 0 dBm.

3. Select the Signal block.

| Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.

M9484C VXG and X-Series SA Measurement Guide 19
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Basic Measurements

Group 1: Signal Summary

[l 2

Ennbled  Signal Mode Frequency Offset Attenuation

5. In the Mode dropdown, select Analog Modulation and then select the
Analog Modulation tab in the left pane.

— (1 1] — s
=0 L 1l o (] > Group1:Signal Summary > Signal 1: Setup

General Made Signal Attenuation
Enable

i g 0dB
Analog Modulation A Ninoraen

Trigger Frequ 3 Pawer
0Hz 0dB

Sample Rate
1.280 000 000 000 MHz

Reset Phase Accumulator

6. In the Analog Modulation Signal Setup:
a. Set Modulation Type to AM.
b. Set Waveform to Sine.
c. Set Rate to 100 kHz.

. Set Depth to 50%.

o

[|‘1| > Group 1: Signal Setup

General Modulation Type Rate

AM N 100.000 0 kHz

Analog Modulation

2 Waveform Depth
Trigger ol L Ll

Sine 50.0 %
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Basic Measurements

7. Select the General tab > Enable.

— EEE [E_—I LI‘L| > Group 1: Signal Summary » Signal 1: Setup

General Mode

| . Enable

Signal Attenuation

. i 0dB
Analog Modkilation Analog Modulation

Mute .
- Frequency Offset Power
Trigger

OHz 0dB

1.280 000 000 000 MHz

Reset Phase Accumulator

Selecting Enable automatically turns on both Output Modulation and
Internal I/Q Modulation as displayed in the Output Modulation block.

[ Output Mod 01 |

8. Close the Vector Modulation Signal Setup by selecting the Home icon at
the top of the display.

[“J » Group 1: Signal Summary » Signal 1: Setup

9. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

On the X-Series Signal Analyzer:

1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

2. Select Frequency and set Center Frequency to 20 GHz and Span to
500 kHz.

M9484C VXG and X-Series SA Measurement Guide 21
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Basic Measurements

3. Select BW and set Res BW to 100 Hz.

i

4, Select Peak Search.

5. Use markers to measure sideband power relative to the center frequency
by selecting Marker Delta. Select Next Pk Right until the second marker is
at the next highest peak.

The Delta Marker should be approximately -12 dB for 50% AM.

KEYSIGHT leout iF
1 ‘.ll--:l I
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Using the equivalent SCPI commands

On The VXG:

SYSTem: PRESet
RF1:FREQuency:CW 20GHZ
RF1:POWer:AMPLitude 0dBm
SIGNal:MODE AMODulation
SIGNall:AMODulation:TYPE AM
SIGNall:AM:SHAPe SINE
SIGNall:AM:FREQuency 100KHZ
SIGNall:AM 50

SIGNall ON

RF1:0UTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALL :OUTPut ON

On the X-Series Signal Analyzer:
FREQuency:CENTer 20GHZ
FREQuency:SPAN 500KHZ
BANDwidth 100 Hz
CALCulate:MARKerl:MODE DELTa

CALCulate:MARKerl :MAXimum:RIGHt

Repeat the above command until the marker is at the next highest peak.

To retrieve the delta marker:

CALCulate:MARKerl:Y?

M9484C VXG and X-Series SA Measurement Guide
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Generating Frequency Modulation

The VXG must have the N7642APPC PathWave Signal Generation for 1Q
Based AM, FM, Phase license installed.

Ensure the equipment and triggers are properly configured. Refer to
“Equipment Setup” on page 11 and “Setting Up Triggers on the X-Series
Signal Analyzer” on page 13.

Follow the steps below for FM analog modulation using the internal or an
external I/Q modulation source.

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.
2. Set Frequency to 20 GHz and Amplitude to 0 dBm.

3. Select the Signal block.

| Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.

Enabled  Signal Mode Frequency Offset Attenuation

>
?
?
?
?
?
>
>
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Basic Measurements

5. In the Mode dropdown, select Analog Modulation and then the Analog
Modulation tab.

Lf"l_] > Group 1: Signal Summary » Signal 1: Setup

General Made Signal Attenuation
Enable

i g 0dB
Analog Modulation e Sttt
Trigger Power
0dB

Sample Rate
1.280 000 000 000 MHz

Reset Phase Accumulator

a. Set Modulation Type to FM.
b. Set Waveform to Sine.

c. Set Rate to 400 Hz.

d. Set Deviation to 10 MHz.

LJ:I_] > Group 1: Signal Summary » Signal 1: Setup

General Modulation Type Rate

Analog Modulation 7 = s 000 He

Trigger Waveform :DE\-’IBYIOI'I

Sine 10.000 000 0 MHz

6. Select the General tab > Enable.

= (11} — sy L . .
— maa EI (nl > Group 1: Signal Summary » Signal 1: Setup

General p— Made Signal Attenuation
| . Enable

. i 0dB
Analog Modkilation Analog Modulation

Mute .
Frequency Offset Power

Trigger

OHz 0dB

Sample Rate
1.280 000 000 000 MHz

Reset Phase Accumulator
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Basic Measurements

7. Close the Vector Modulation Signal Setup by selecting the Home icon at
the top of the display.

|_|_|_| » Group 1: Signal Summary > Signal 1: Setup

8. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

On the X-Series Signal Analyzer:
1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

2. Select Frequency and set Center Frequency to 20 GHz and Span to
50 MHz.

3. Select BW and set Res BW to 240 Hz.

KEYSIGHT L A pulE 800 iAter 19 0 PO Dest Witk ey Type Lug-Fowe i 2
e Cen 1] 3 Trgr Frea fim ™

Ref Level 0.00 dBm

L

Video BW 240 Hz

Cener 0000 GHE 2
iRes B 200 1z
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Basic Measurements

Using the equivalent SCPI commands

On the VXG:

SYSTem: PRESet
RF1:FREQuency:CW 20GHZ
RF1:POWer:AMPLitude 0dBm
SIGNal:MODE AMODulation
SIGNall:AMODulation:TYPE FM
SIGNall:FM:SHAPe SINE
SIGNall:FM:FREQuency 400HZ
SIGNall:FM 10MHZ

SIGNall ON

RF1:0UTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALL :OUTPut ON

On the X-Series Signal Analyzer:
FREQuency:CENTer 20GHZ
FREQuency:SPAN 50MHZ

ACPower :BANDwidth 240 Hz

M9484C VXG and X-Series SA Measurement Guide
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Basic Measurements

Generating Phase Modulation

The VXG must have the N7642APPC PathWave Signal Generation for 1Q
Based AM, FM, Phase license installed. The X-Series Analyzer must have
N9063EMOE Analog Demodulation Measurement license installed.

Ensure the equipment and triggers are properly configured. Refer to
“Equipment Setup” on page 11 and “Setting Up Triggers on the X-Series
Signal Analyzer” on page 13.

Follow the steps below for PM analog modulation using the internal or an
external I/Q modulation source.

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.
2. Set Frequency to 20 GHz and Amplitude to 0 dBm.
3. Select the Signal block to open.

| Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.

M9484C VXG and X-Series SA Measurement Guide
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Basic Measurements

Frequency Offset

>
?
>
>
>
?
>
>

5. In the Mode dropdown, select Analog Modulation and then the Analog
Modulation tab.

e L] — P
= N S (] > Group1:Signal Summary > Signal 1: Setup

General Made Signal Attenuation
Enable

i g 0dB
Analog Modulation A Ninoraen

Trigger Power

Sample Rate
1.280 000 000 000 MHz

Reset Phase Accumulator

6. In the Analog Modulation Signal Setup:
a. Set Modulation Type to PM.
b. Set Waveform to Sine.
c. Set Rate to 10 kHz.

M9484C VXG and X-Series SA Measurement Guide 29
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General

Analog Modulation

Trigger

M9484C VXG Basic Measurements

Basic Measurements

d. Set Deviation to

1 rad.

LJ:lJ > Group 1:Signal Summary » Signal 1: Setup

General Modulation Type Rate

Analog Modulation

Trigger
Sine

AM FM ® PM 10.000 0 kHz

Waveform Deviation

1.00 rad

7. Select the General tab > Enable.

(11} — A~ - . -
Bza [E__I. (] > Group 1: Signal Summary » Signal 1: Setup

: Enable Made

Mute

Signal Attenuation

Analog Modulation 0dB

Frequency Offset Power

OHz

0dB

Sample Rate
1.280 000 000 000 MHz

Reset Phase Accumulator

8. Close the Vector Modulation Signal Setup by selecting the Home icon at

the top of the display.

> Group 1: Signal Summary > Signal 1: Setup

9. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.
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On the X-Series Signal Analyzer:

1. From the Menu Panel (on the top right of the display), select Mode/Meas >
Analog Demod mode.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

2. Select Mode Preset to set Spectrum Analyzer mode to a known state.

3. From the Menu Panel (on the top right of the display), select Mode/Meas >
Analog Demod mode > PM Measurement > Quad View.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

4. Select Frequency and set Center Frequency to 20 GHz.

| +
KEYSIGHT __Inptrt:'RF Input Z: 50 O \Atten: 10 dB LPF: Off Center Freq: 20.000000000 GHz
Coupling: DC RCal Preamp: Off HPF: 20 Hz Avg|Hold:=>10/10
@ |Align: Off Freq Ref: Ext (S) W Path: Standard BPF: Off Trig: Free Run
| Chan BW: 25 000 kHz  |Meas TmerTZU ms

1 RF Spectrum 2 Demod Waveform ¥
Scale/Div 10.0 dB Ref Value 0.00 dBm | Scale/Div 1.000 rad Ref Value 0.000 rad

|
|-t00raa
|
|

—[ 1 1 L i 1 L 1 2 % ]
Center 20.00000000 GHz Span 75 kHz| | | | | | |
Res BW 680 Hz Start 0.000 = Points 1001 Stop 2.000 ms

3 AF Spectrum 4 Metrics

_Scale."Div 10.0 dB Ref Value 6.280 rad PM Deviation Fommrs Max Hold
| Peak+ 845.9 mrad 902.7 mra
| Peak- -850.4 mrad 907 3 mra
- (Pk-Pk)2 850.1 mrad 905.0 mra

| RMS 646.3 mrad 6465 mra

- Carrier Fower -8.331 dBm SINAD 30.486 dB
| | Carner Freq Emr 2068 mHz  SNR 30.486 dB
] l'u' . | | | | | Mod Rate 10.0000 kHz DistTotal Vrms 3.110 %

AF Start Freq 0 Hz " AF Stop Freq 20.000 kHz
AF Rez B 80 Hz THD — %
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Using the equivalent SCPI commands

On the VXG:

SYSTem: PRESet

RF1:FREQuency:CW 20GHZ
RF1:POWer:AMPLitude 0dBm
SIGNal:MODE AMODulation
SIGNall:AMODulation:TYPE PM
SIGNall:PM:SHAPe SINE
SIGNall:PM:FREQuency 10KHZ
SIGNall:PM 1

SIGNall ON

RF1:0UTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.
RFALL :0OUTPut ON

On the X-Series Signal Analyzer:
INSTrument : CONFigure: ADEMOD: PM
SYSTem: PRESet
DISPlay:VIEW:ADVanced:SELect "QUAD"

FREQuency:CENTer 20GHZ
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Generating Synchronized Pulse (IQ + Analog) Modulation

Ensure the equipment and triggers are properly configured. Refer to
NOTE “Equipment Setup” on page 11 and “Setting Up Triggers on the X-Series

Signal Analyzer” on page 13.

You will need to create your own ASCII text marker file and a binary file with
the exact same name. Both files must be stored in the same file folder. For this
example, we will use example files that have been stored on the VXG.

(D) » Users » Instrument * Documents » Keysight » PathWave » SignalGenerator » Examples v
A [ HNeme - v Date modified Type
|=] SGNR_1CC_FR1_30kHz_SCS_100MHz_256QAM_DC ...
| 5GNR_1CC_FR1_30kHz_SCS_100MHz_256QAM_DC ..,
[7] 5GMR_1CC_FR1_30kHz_5CS_100MHz_256QAM_DC ..,
[Z] 5GMR_1CC_FR2_120kHz SC5_100MHz 256QAM DC ... 2/20
| SGMR_1CC_FR2_120kHz_SCS_100MHz_2560AM._DC .. 22
|| SGNR_1CC_FR2_120kHz_SCS_T00MHz_256QAM_DC ... 7/1
[Z] SGNR_2x2_MIMO_VXG_Scope_Updated.scp
| S3GNR_2x2_MIMO_VXG_Scope Updated.setx
|=] 5GNR_8CC_FR2_120kHz_SCS_100MHz_256QAM_Cor...
[ ] 5GNR_8CC_FR2_120kHz_SCS_100MHz_256QAM _Cor... 7/1
[] 5GMR_8CC_FR2_120kHz_SCS5_100MHz_256QAM DC .., 2/20
|| 5GNR_UXR_Recording 28 _GHz.csv
] 19GHzInDB.s2p
|| 4000_SamplelGPulseOnOff 30% wim.csv
_| 4000_SamplelQPulseOnOff_50% wfm.wmk
| GSM_1C_BURST_SECUREWAVE.wfm
| simpleAt10GHzInDB.s2p

ocument

18
/2972018
19

acument

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.
2. Set the Frequency to 1 GHz and Power to 0.0 dBm.
3. Select the Signal block to open.

Group 1: Signals

File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
NOTE generators) is installed. For all other option configurations, continue to the
next step.
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Enabled  Signal Mode Frequency Offset Attenuation

>
?
>
>
>
?
>
>

5. Select the Mode dropdown and select Waveform File.
|_J_|_| > Group 1: Signal Summary » Signal 1: Setup

General Mode Signal Attenuation

Waveform Eile Waveform File 0dB

Mute ' TR -
Trigger Freguency Offset Power
0 Hz 0dB

Markers

Sample Rate
3.000 000 000 000 000 GHzZ

Reset Phase Accumulator

6. Select the Waveform File tab (left pane), and then in the Waveform Setup
area, use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

and choose
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Way
Trigger

Markers

General
Waveform File
Trigger

Markers
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4000_SampleQPulseOnOff 50% wfm.csv

then Select.

Sample Raie

3.000 00O 000 000 000 GHz

| Ru

1.412 667 100.00 % OHz

LI‘I_| > Group 1: Signal Summary » Signal 1: Setup

General pr— Mode Signal Attenuation
. Enable

. i 0dB

Anslog Niodtation Analog Modulation

Mute Crin T ires Dt B
Trigger requency Offse ower
0 Hz 0dB

Sample Rate
1.280 000 000 000 MHz

Reset Phase Accumulator

9. Close the Vector Modulation Signal Setup by selecting the Home icon at
the top of the display.

> Group 1: Summary » al 1: Setup

10. Set RF Out to On by selecting the numbered channel indicator switch.
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This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

On the X-Series Signal Analyzer:

1. From the Menu Panel (on the top right of the display), select Mode/Meas >
Spectrum Analyzer mode > Swept SA Measurement > Normal View.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

2. Select Mode Preset to set Spectrum Analyzer mode to a known state.

3. Select Frequency and set Center Frequency to 1.0 GHz and Span to 0 Hz.

4. Select BW and set the Video BW to 300 Hz.

5. Select Sweep and set the Sweep Time to 4.0 s.

: Input: nput £ en 1 | - Fast A : Log-Powar
Input: RF Input 7: 60 0 At 0dB PNO: F: |Avg Type: Log-P
L Coupling. PC |Corr CCorr RCal Pre. Int off, LNA off |Gate. OFf |Trlg: Free Run
@ Align: Gff Freq Ref: Ext (8) pW Path- Standard IIF Gain: Low

1 Spactrum v

Scale/Div 10 dB
Log

enter 1.000000000 GHz
Res BW 3.0 MHz

36

NFE: Adaplive 13ig Track: Off

Ref Level 0.00 dBm

" #Video BW 300 Hz
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Generating a Multitone Signal

This example shows you how to create a multitone signal, which allows you to
separate the usable frequency band into multiple channels. This can make a
signal that is difficult to characterize in the time domain more readable.

The VXG must have the N7621APPC PathWave Signal Generation for
Multitone license installed.

Ensure the equipment and triggers are properly configured. Refer to
“Equipment Setup” on page 11 and “Setting Up Triggers on the X-Series
Signal Analyzer” on page 13.

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.
2. Set Frequency to 20 GHz and Amplitude to -10 dBm.
3. Select the Signal block to open.

| Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.
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Attenuation

>
?
b
bs
b
>
>
>

LHJ > Group 1: Signal Summary » Signal 1: Setup

General Mode Signal Attenuation

' ' d
Multitone Multitone 0dB

Mute
: Power
Trigger

0dB

Sample Rate
60.000 000 000 kHz

Reset Phase Accumulator

6. Select the Multitone tab and set:
a. Set Vector Modulation Signal Mode to Multitone.
b. Set Tones to 15.
c. Set Tone Spacing to 500 kHz.

|_J:L] » Group 1: Signal Summary » Signal 1: Setup

General

Multitone 2

Trigger .TCII"iE wacmg

500.000 000 00 kHz

# of Points
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7. Select the General tab > Enable.

E [ > LI_IJ > Group 1: Signal Setup

General

S Mode Signal Attenuation
i .' Enable B

i : 0dB
Multitone Multitone

Trigger Frequency Offset
0 Hz

Reset Phase Accumulator

8. Close the Vector Modulation Signal Setup by selecting the Home icon at
the top of the display.

[HJ S Group 1: Signal Summary » Signal 1: Setup

9. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

On the X-Series Signal Analyzer:

1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

2. Select Frequency and set Center Frequency to 20 GHz and Span to
10 MHz.

3. Select BW and set Res BW to 300 Hz.

Observe the 15 tones.
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet
RF1:FREQuency:CW 20GHZ
RF1:POWer:AMPLitude -10dBm
SIGNall:MODE MTONes
SIGNall:MTONe:ARB:NTON 15
SIGNall:MTONe:ARB:FSP 500KHZ
SIGNall ON

RF1:0UTPut:STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFAL1 :OUTPut ON

On the X-Series Signal Analyzer:

Change to Spectrum Analyzer mode, Swept SA measurement.

INSTrument : CONFigure: SA: SAN
DISPlay:VIEW:ADVanced:SELect “NORMAL”
FREQuency:CENTer 20GHZ

FREQuency:SPAN 10MHZ

M9484C VXG and X-Series SA Measurement Guide
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Setting Up Waveform File Vector Modulation

In this section, we will load a GSM and a LTE waveform into the VXG to
demonstrate the accuracy of the VXG’s vector modulation using error vector
magnitude (EVM) measurement applications available on the X-Series Signal
Analyzer.

The VXG supports all ARB waveforms that are provided on the X-Series
sources. This section will use a few of the ARB files that come with the X-Series
sources.

Ensure the equipment and triggers are properly configured. Refer to
“Equipment Setup” on page 11 and “Setting Up Triggers on the X-Series
Signal Analyzer” on page 13.

On the VXG:

1. Select Preset > Preset to set the instrument to a known state.
2. Set Frequency to 20 GHz and Amplitude to 0 dBm.

3. Select the Group 1: Signals block to open.

| Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.

M9484C VXG and X-Series SA Measurement Guide



M9484C VXG Basic Measurements
Basic Measurements

Frequency Offset

>
?
>
>
>
?
>
>

5. In the Vector Modulation Signal Setup:

a. Select the Mode dropdown and set to Waveform File.

|_J_|| > Group 1: Signal' Summary » Signal 1: Setup

General Mode Signal Attenuation

Waveform File Waveform File 0dB

Trigger Frequency Offset Power
0Hz 0dB
Markers

Sample Rate
3.000 000 000 000 000 GHz

Reset Phase Accumulator

b. In the left pane, select the Waveform File tab.

c. Use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples
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d. Highlight GSM 1C BURST SECUREWAVE.wfm, then Select.

r % Examples

Date Modified

D This Computer

Aug 23, 2027, 31252 AM

Clear Arb Memory

Cancel

() » Group 1: Signal Summary » Signal 1: Setup

General —_— Mode Signal Altenuation
@ cnable

Waveform File Waveform File 0dB

Mute i
Trigger i
0dB

Markers

Reset Phase Accumulator

6. Close the Vector Modulation Signal Setup by selecting the Home icon at
the top of the display.

s Group 1: Signal Summary Signal 1: Setup
(nd Poece - 1 ;

7. Set RF Out to On by selecting the numbered channel indicator switch.
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This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

On the X-Series Signal Analyzer:
1. Select Mode Preset to set Spectrum Analyzer mode to a known state.

2. Select Frequency and set Center Frequency to 20 GHz and Span to
900 kHz.

3. Select BW and set Res BW to 470 Hz.
4. Select Trace and set Trace Type to Max Hold.
5. Observe the GSM signal.

On the VXG:
1. Select the Group 1: Signals block to open.

| Group 1: Signals
File None selected
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2. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.

Enabled  Signal Mode Frequency Offset Attenuation

WOW WV WV WV WV VWV

3. Select the Mode drop down menu and select Waveform File and then
select the Waveform File tab on the left side.

E nes
= H &=
General
Waveform File

Trigger

Markers

Reset Phase Acoumulator
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4, Use File Select to navigate to:
D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

Genesal

Select »

Waveform File
Trigger A Launch f configure »

Markera

5. Set the file extension to All Files (*.*), highlight
WDCMA TM1 64DPCH 4C.wfm, then Select.

rator » Examples
Date Modified

D This Computer
— Delete

[ Rename

Clear Arb Memory

All Supported Formats (*.wim, *.wig, *.bin, *.csv, *.ba, *.seq, *.mat, *hdf, *h5, *inc) ~ Cancel
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6. Select the General tab > Enable.

LI"I] > Group 1: Signal Summary » Signal 1: Setup

General Mode Signal Attenuation

P Enable

. i 0dB
Anaboq ModUlation Analog Modulation

¢ Offs i
Trigger Frequency Offset Power

0 Hz 0dB

Sample Rate
1.280 000 000 000 MHz

Reset Phase Accumulator

7. Ensure that RF Out is on.

On the X-Series Signal Analyzer:

1. Select BW and set Res BW to 620 Hz.

2. Select Frequency and set Span to 30 MHz.
3. Observe the WCDMA signal.

KEYSICIH

Ref Lovel 0.00 dBm

Ly g T

sl
S RN T T 51.d.

Video BW 5.2 ke
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet
RF1:FREQuency:CW 20GHZ
RF1:POWer:AMPLitude 0dBm
SIGNall:MODE WAVeform

SIGN1:WAV " D:\Users\Instrument\Documents\Demo
Waveforms\GSM 1C Burst.wfm"

SIGNall ON
RF1:0UTPut:STATe ON
For multi-channel instruments, set RF Out (all) to On.

RFAL1 :OUTPut ON

On the X-Series Signal Analyzer:
FREQuency:CENTer 20GHZ
FREQuency: SPAN 900KHZ
ACPower:BANDwidth 470 Hz

DISPlay:TXPower:WINDowl: TRACe :MAXHold ON

On the VXG:

SIGN1:WAV " D:\Users\Instrument\Documents\Demo
Waveforms\WDCMA TM1 64DPCH 4C.wfm"

SIGNall ON

RF1:0UTPut:STATe ON

On the X-Series Signal Analyzer:
ACPower:BANDwidth 620 Hz

FREQuency:SPAN 30MHZ

M9484C VXG and X-Series SA Measurement Guide
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M9484C and X-Series Analyzer Measurement Guide

2  Corrections

— “Corrections/De-embedding Using PathWave N7653APPC Software” on
page 52

— “Using a Spectrum Analyzer to Make the Corrections Measurement”
on page 58

— “Using a Power Meter to Make the Corrections Measurement” on
page 65

— “Adding Fixture Blocks using s2p Files” on page 52

— “Instrument Nonlinear Correction” on page 71

— “Setting Up an INC 1CC 4 GHz, 10 dBm EVM Measurement” on
page 71

— “Setting Up an INC 8CC 28 GHz, 10 dBm EVM Measurement” on
page 82

KEYSIGHT

TECHNOLOGIES
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Corrections/De-embedding Using PathWave N/653APPC Software

De-embedding is used to remove the effects of the test fixtures and cabling
from the measurement results. De-embedding uses a model of the test fixture
and mathematically removes the fixture characteristics (cables, connectors
and other passive components) between the source and the device under test
(DUT). Once the desired topology has been characterized, its effects can be
removed from the output signal, moving the effective reference plane to the
point at which the power sensor was connected.

Blocks can be added from supported file formats (.s2p, .csv, .uflat) or by direct
measurement, using one of the supported power sensors (power meter,
spectrum analyzer, or a network analyzer).

The VXG must have the N7653APPC PathWave Automatic Channel
Response Correction and S-parameter De-embedding license installed.

Adding Fixture Blocks using s2p Files

Amplitude and phase can be corrected by adding multiple s2p files as Fixture
Blocks.

An s2p file (also known as a Touchstone file) is an ASCII text file used for
documenting the n-port network parameter data and noise data of linear
active devices, passive filters, passive devices, or interconnect networks. Each
record contains 1 stimulus value and 4 S-parameters (total of 9 values)

The first line in the figure below (# GHz DB R 50) designates:
— (GHz) designates the frequency in Hz, kHz, MHz, or GHz
S) the measurements are in S parameters (rather than Y or Z)

- (

— (DB) the values are given in decibel/angle. Instead of DB, you can have Rl
(real/imaginary) or MA (magnitude/angle)

—

50) the characteristic impedance is 50 ohms

152P File: Measurements: s11,521,512,522:
# GHz S DB R 50
9.0 -100 -106 10.0 -160 10.0 -100 -100 -100

9.5 -100 -100 .0 -100 5.0 -100 -100 -100

10.0 -100 -1060 0.0 -108 P.0
10.5 -100 -100 .0 -100 -5.0 :
11.8 -100 -100 8 -1ee 8 -180 -108 -108

If there is not a first line header, the default format is GHz, S-parameters,
and magnitude/angle.

1. Create s2p files in Notepad in the format shown above.
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An s2p example file is included on the VXG. Go to

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples\simpleAt10GHzInDB.s2p

2. Select Preset » Preset to set the instrument to a known state.

3. In the VXG Output area, set the Frequency to 10 GHz and Power to
-10 dBm.

10.000 000 000 000 00 GHz

-10.00 dBm

4. Select the Group 1: Signals block to open.

| Group 1: Signals
File None selected

5. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.
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Enabled  Signal Mode Fre fif s Attenuation

>
?
b
bs
b
>
>
>

6. Select the Mode dropdown and select Multitone.

[.Fl:] > Group 1: Signal Setup

General Mode Signal Attenuation
Enable

' i d
Multitone Multitone 0de
Trigger Frequency Offset

0 Hz

Reset Phase Accumulator

7. From the left pane, select Multitone and set:
— Vector Modulation Signal Mode to Multitone
— Tones to 21
— Tone Spacing to 100 MHz

[.I'U » Group 1: Signal Summary » Signal 1: Setup

General

Multitone

Tone Spacing

Trigger

100.000 000 000 00 MHz
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8. Select the General tab > Enable.

— ) ,ﬁ et > Group 1: Signal Setu
— - 3, P g P

General ™ Mode Signal Attenuation
) Enable

i ‘ 0dB
Multitone Multitone
Trigger Frequency Offset

0O Hz

Reset Phase Accumulator

9. Close the Signal block by selecting the Home icon, and then select RF Out
to turn on.

10. On the X-Series Signal Analyzer spectrum analyzer in Spectrum Analyzer
Mode:

— Select Mode Preset to set Spectrum Analyzer mode to a known
state.

— Set the Center to 10 GHz
— Set Span to 3 GHz

o B 10 MHT
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11. On the VXG, select the RF Output block > Corrections/De-embedding.

Freq and Amp Adjusiment

Carrections/De-embedding 1 00 O

Optimizationa Phasa Transition Mode

12. In the Corrections Setup dialog, select Add from File.

ssm L"d > Output 1: RF Output

General
Corrections On Absolute Power Corrections Only

Freq and Amp Adjustment

Corrections/De-embedding

A
Optimizations ‘ @ T |T }—
Embed

Add from File

13. Navigate and select the s2p file and then Select.
D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples\simpleAt10GHzInDB.s2p

Notice that Block B is added in the Correction Setup diagram.

56 M9484C VXG and X-Series SA Measurement Guide



Corrections
Corrections/De-embedding Using PathWave N7653APPC Software

= : (] > Output 1: RF Cutput

General

« Enable
isimpleAt&GHzINDB.s2p >
Optimizations =

Desmbed

Add from File Delete Block

14. Turn Corrections On.

View the results on the signal analyzer. Observe how the .s2p file has
impacted the signal.

KEYSIGHT |nput RF Input Z 50 0 #Atten 0 dB PNO: Fast |Avg Type. Log-Power |1
T {Coupling. DG Corrections: Off Preamp: Off Gate: Off [Trig: Free Run
@ ‘Align: Auto Freq Ref: Int (S)  pW Path: Standard IF Gain: High
NFE: Adaptive Source: Off Sig Track: Off

I

I 1 Spectrum

]

| Scale/Div 10 dB Ref Level -20.00 dEBm

|
|
|

|Center 10.000 GHz Video BW 3.0 MHz Span 3.000 GHz|
|Res BW 3.0 MHz Sweep 5.00 ms (1001 pts)|
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15. Add a third block using the same file name as shown in the steps above.
Under Block C Properties, set to Embed.

Block C Properties

File

~.amples\simpleAt10GHzInDB.s2p

Embed

Reverse Poris

View the results on the X-Series spectrum analyzer. Notice that the
corrections are no longer shown. This is because the de-embedded

corrections applied in Block B cancel the embedded corrections applied in
Block C.

o B 10 MHT

Using a Spectrum Analyzer to Make the Corrections Measurement

When using a spectrum analyzer, it must be locked to the VXG Frequency
Reference. This is important because the power measurement can be
inaccurate due to a narrow resolution bandwidth (RBW) used in the spectrum
analyzer. Supported Keysight X-Series signal analyzers are:

— N9Y000A/B CXA

M9484C VXG and X-Series SA Measurement Guide



Corrections
Corrections/De-embedding Using PathWave N7653APPC Software

— NO90T0A/B EXA
— N9Y020A/B MXA
— NO9030A/B PXA
— N9040B and N9041B UXA

On the VXG:

1. Connect the VXG 10 MHz Out to the N90x0A/B Ext Reference In.

2. Connect cable or DUT between the VXG RF Out and the signal analyzer
RF in.

Select Preset > Preset to set the instrument to a known state.
Set the Frequency to 12 GHz and Amplitude to -10 dBm.
Select the Signal block to open.

o g w0

Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.

Enabled Frequency Offset Attenuation

>
?
>
>
>
?
>
>

7. Select the Mode dropdown and select Multitone.
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8. Select the Multitone tab from the left pane and then, configure the signal

to have 501 Tones with 4 MHz Tone Spacing, then select the General tab
> Enable.

Ll|:|_| » Croup 1: Signal Summary » Signal 1: Setup

General
Multitone

Trigger .
00 000 000 00 MHz

9. Select the Home icon and set RF Out to On by selecting the numbered
channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.
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On the Signal Analyzer:

1. From the Menu Panel (on the top right of the display), select Mode/Meas >
Spectrum Analyzer mode > Occupied BW Measurement > OBW Results
View.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

2. Set the Center Frequency to 12 GHz and the Span to 3 GHz.

Observe how the fixturing is impacting this signal, including the flatness
and the total power.

Input Z- 50 0 Atten: 10 dB Tiig: Free Run Center Freq: 12.000000000 GHz
Comeclions: OFF  Preamp OF Gate. Off AvglHold >10/10

Freq Ref Exi(S) W Path: Standard #IF Gain: Low Radio Std: None

NFE: Adaplive

1 Graph
| Scale/Div 10.0 dB Ref Value -30.00 dBm

Video BW 50.000 MHZ* Span 3 GHz
Sweep 5.00 ms (1001 pts)

Occupied Bandwidth
1.9700 GHz Total Power -17.3 dBm

Transmit Freq Error -213.66 kHz % of OBW Power 93.00 %
¥ dB Bandwidth 2010 GHz xdB -26.00 dB

f) ~ M ? e J:E
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On the VXG:

1. Select the RF Output block > Corrections/De-embedding tab to open the
Correction Setup.

2. Select Block A to highlight > Add from Measurement to open the Measure
Corrections Block Wizard.

er > Dutput 1: RF Output

Freq and Amp Adjustment
Corrections/ mbedding

Optimizations

Add from Measurement

Add from File

3. Connect the power sensor (in this case, the X-Series signal analyzer) as
shown in the diagram below. After reading the overview, select Next to
move to the Configure Sensor setup.

|'i'-,| > Dutput 1 RF Qutput »

4. In the Configure Sensor setup, select the Power Measurement Device
dropdown and select Spectrum Analyzer.

» Output 1: RF Output 3 asure Comections

Configure Sensor
Overview

U List
Configure Sensor P fely e g Hoslname or [P

e Test Connection
ey Powes

Measure Correcticns 1.000 000 D00 000 00 GHz -10.00 dBm Protocol Address

stn ncy Mumber HisSLIP b hislip0

2.000 000 D00 000 00 GHz 1]

Cance! { Back Next >
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5. Set the Start and Stop Freq, Amplitude, and the Num Steps. For this
example Start Freq 11 GHz, Stop Freq 13 GHz, Amplitude to the highest
power used in your measurement (For this example, -10 dBm, which we
already set in the main window. If you change the value here, it will update
the value in the main measurement window.) and Number of Steps to 101.

> oulput LRFOuUIput > N

[l

Configure Sensor
" Powe T o
Spectrum Analyzer pE Hostname or IP
Configure Sensor
B Test Connection
Start Frequency
11.000 000 000 D00 00 GHZ .00 dBi g Address

HISLIP w hislipo

13.000 000 000 D00 00 GHz

cancel ¢ Back Next

6. Set Connection Type to LAN, enter the LAN Address and set the Protocol
parameters to HiSLIP, and then select Test Connection.

Configure Sensor
Power Measurement Device
Spectrum Analyzer
Start Frequency Power Test Connection
11.000 D00 000 00 MHz -10.00 dBm Address
HISLIP - hislipd

000 00 GHz

Cancel £ Back

tion Test to Remate instrument TCPIP: e 00 hslip0iNg

7. Once you are successfully connected, select Next to move to the Measure
Corrections step.

8. Select Measure Correction Data.
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During the measurement, the VXG outputs a CW between the Start and
Stop Frequencies for the specified number of steps and output power. It
will take some time to measure all 101 points, and the progress is
indicated by the blue bar. You can watch the signal analyzer as it steps
through this process.

= Corection Data

The measurement results are saved to a csv file using an automatically
generated file name.

9. When the measurement is complete, select Finish, then select Corrections
On.

The output csv file is set to Block A.

Add from Measurement Add from File

A

UserCom-2021-08-17_001

MAI3B4E

@ i i >

Oultput 1
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Block A is dedicated for User Correction. The image below shows how
blocks are assigned in the User Correction and Fixture block.

[ Fixture |

. [ ] .
m mFixture Block

10. On the signal analyzer, Restart (on the left corner of the user interface)
the measurement (because it is applying averaging). Observe how the
measured corrections impacted the signal. You can easily toggle
Corrections on and off on the VXG to see the difference.

Using a Power Meter to Make the Corrections Measurement
The following USB power sensors can be used for the power measurement.
— UB8487A-CFG0O07
— UB485A-CFG0O06
— U2000A
— U2001A
— U2002A
— U2004A
— U2000B
— U2001B
— U2000H
— U2001H
— U2002H
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On the VXG:
1. Connect the VXG 10 MHz Out to the N90x0OA/B Ext Reference In.

2. Select the RF Output block > Corrections/De-embedding block to open
the Correction Setup.

3. Select the A Block (to highlight) then Add from Measurement to open the
Measure Corrections Block Wizard.

General

Freq and Amp Adjustment

Add from Measurement

Add from File

4. Connect the power sensor as shown in the diagram below then select
Next.

= == & © (R > Dutputl:RF Ouiput > Meas

Overview
Overview

Canfigure Sensor

Measuire Corrections

5. Select Next to go to Configure Sensor dialog and select the Power
Measurement Device dropdown > Power Meter.

: Power Measurement Device Power Meter
Overview : s

Start Frequency 11.00000000000 GHz Stop Frequency 30.00000000000 GHz

Number of Steps 20 Power 5.00 dBm

Measure Corrections

6. Set the Start and Stop Freq, Amplitude, and the Num Steps. For this
example Start Freq 26 GHz, Stop Freq 30 GHz, Amplitude to the highest
power used in your measurement 5 dBm, and Num Steps to 20.
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7. Select the Connection Type to USB, and then specify the Device and VISA
Address.

8. Select Test Connection to verify connectivity, and then select OK then
Next to continue.

You can also calibrate and zero out the power sensor before measuring
corrections.

9. Select Next to go to the Measure Corrections dialog and select Measure
Correction Data.

During the measurement, the VXG outputs a CW between the Start and
Stop Frequencies for the specified number of steps and output power. The
measurement results are saved to a csv file using an automatically
generated file name.

10. Select Finish. The output csv file is set to Block A.

Add from Measurement Add from File

A

UserCom-2021-08-17_001

MG384B

@ i i >

Oultput 1
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Block A is dedicated for User Correction. The image below shows how
blocks are assigned in the User Correction and Fixture block.

[ Fixture |

. [ |
m mFixture Block

11. Select Corrections On to apply.
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Using the equivalent SCPI commands

Using a spectrum analyzer to make the corrections measurement

On the VXG:

SYSTem:PRESet

Set the power level to the highest level used in your measurement.
RF1:POWer:AMPLitude 5dBm

CORRection:PMDevice SANalyzer
CORRection:FLATness:STEP:STARt 26GHZ
CORRection:FLATness:STEP: STOP 30GHZ
CORRection:FLATness:STEP: POINts 20

CORRection:SANalyzer:COMMunicate:TYPE SOCKets

Set the LAN address and protocol parameters for your spectrum analyzer.

CORRection:SANalyzer:COMMunicate:LAN:IP "192.168.1.5"
CORRection:SANalyzer:COMMunicate:LAN:PORT 5025
CORRection:FLATness:CALibrate

CORRection ON

Using a power meter to make the corrections measurement.

On the VXG:
SYSTem: PRESet
RF1:POWer:AMPLitude 5dBm
CORRection:PMDevice PMETer
CORRection:FLATness:STEP:STARt 26GHZ
CORRection:FLATness:STEP: STOP 30GHZ
CORRection:FLATness:STEP:POINts 20
CORRection:SANalyzer:COMMunicate:TYPE USB
Use query CORRection:PMETer: COMMunicate:USB:LIST? foralist of all
connected USB devices.
CORRection:PMETer:COMMunicate:USB:DEVice “instr0”
[Optional] CORRection:PMETer:CALibrate
[Optional] CORRection:PMETer : ZERO

CORRection:FLATness:CALibrate
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CORRection ON

Adding fixture blocks using s2P files

On the VXG:

SYSTem: PRESet

RF1:FREQuency:CW 10GHZ
RF1:POWer:AMPLitude -20dBm

SIGNall:MODE MTONe
SIGNall:MTONe:ARB:NTON 21
SIGNall:MTONe:ARB:FSP 100MHZ

SIGNall ON

RF1:0UTPut : STATe ON

For multi-channel instruments, set RF Out (all) to On.

RFALL :OUTPut ON

On the X-Series Signal Analyzer:
SYSTem: PRESet
FREQuency:CENTer 10GHZ

FREQuency:SPAN 3GHZ

On the VXG:

Set the path to the s2p data as block 2 (you can use 1 through 4).
CORRection:BLOCk2:FILE "FixtureChannel2"
CORRection:BLOCk2 ON

Add block C with the same file.

CORRection:BLOCk3:FILE "FixtureChannel2"

Change Block C to Embed.

CORRection:BLOCk3:APPLy EMBedding

CORRection:BLOCk3 ON
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Instrument Nonlinear Correction

Limited by SNR

EVM (%)

Instrument Nonlinear Correction (INC) is a digital pre-distortion (DPD) based
correction using a Keysight signal analyzer (N9042B, N9040B, or N9030B) to
compensate for nonlinearities in the VXG. INC is useful in reducing EVM (and
other metrics impacted distortion) at high power levels and extending the
range of the power with linear output of the VXG. INC is a point correction valid
for a given frequency/power/waveform combination and can be used for EVM
and ACP measurements at high power levels (>5 dB). The VXG must have the
N7653APPC PathWave automatic channel response correction and
S-parameter de-embedding license installed.

Instrument nonlinear corrections compensate for nonlinearities in the VXG.
Improvement to EVM will only be seen at power levels where distortion is the
limiting factor. INC will not improve EVM in the area where signal to noise ratio
(SNR) is the limiting factor.

—— Limited by distortion

-16 -14 -12 -10 -8 -6 -4 -2 O ) 4 6 8 10 12 14 16 18

Spt F rar (AR
et Power (dBm)

Setting Up an INC 1CC 4 GHz, 10 dBm EVM Measurement

On the VXG:

In order to compare before and after correction results, we will start by making
an EVM measurement without applying corrections.

1. Select Preset > Preset to set the instrument to a know state.

2. In the Output area, set Frequency to 4 GHz and Power to
10 dBm.

4.000 000 000 000 00 GHz

10.00 dBm

ALC ON

M9484C VXG and X-Series SA Measurement Guide 71



Corrections
Instrument Nonlinear Correction

3. Select the Signal block to open the Vector Modulation Signal Setup panel.

| Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

Enabled  Signal Mode fise Attenuation

WOW WV VWV VWV

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.

5. Set Mode to Waveform File, then select the Waveform File tab in the left
pane.

General
Waveform File

Trigger

Markers

Reset Phase Acoumulator
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6. In the Waveform Playback Setup area, use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

and choose
5G 100MHz 1CC FRI1.wfm

then Select.

ator % Examples

Date Modified

is Co el
D This Computer 00 esy 31946 AM

Aug 22,2027, 74356 AM
SG_T D0 R2.wim Au
SGNR_TCC OMHz AM_D wim AL

AL

Ak

A

Clear Arb Memory

All Supported Formats (*.wim, *.wig, *.bin, *.csv, *.ba, *.seq, *.mat, *hdf, *h5, *inc) ~ Cancel

() » Group 1: Signal Summary » Signal 1: Setup

General —_— Mode Signal Altenuation
@ cnable

Waveform File Waveform File 0dB

Mute i
Trigger i
0dB

Markers
000 000 000 MHz

Reset Phase Accumulator

8. Select the Home icon and set RF Out to On.
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On the UXA:

1. From the X-Series Signal Analyzer Menu Panel (on the top right of the
display), select Mode/Meas > 5G NR & V2X Mode > OK.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

2. Select Mode Preset to set Spectrum Analyzer 5G NR & V2X mode to a
known state.

3. From the X-Series Signal Analyzer Menu Panel (on the top right of the
display), select Mode/Meas > 5GNR & V2X Mode > Modulation Analysis
Measurement > OK.

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or
the PC running the VSA application.

4. Select Recall (If accessing the X-Series Signal Analyzer remotely, select

the Folder icon at the bottom of the display) Demod Info > Data Type set
to CC Setup > Recall From >
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Signal Studio 5G 100 MHz 1CC FRI1.scp

Recall

Recall fom File

% Ugers 3 Instrumerd. 3 Documents,  NREGEwn ) CarmerSolup

atiing + St

cerccive |

Signal_Snudin_56_10MH_160_FRT s

Fietype  AFFIES ("7} Recsl

5. The Signal Stuidio_5G_100 MHz_1CC_FR1.scp file automatically sets the
Carrier Frequency to 4 GHz.

6. From the Main menu, select Meas Setup > Advanced tab > Advanced

Demod Setup and set DC Punctured to On, then Close the Advanced
Demod Setup window.

General

L Component Camier | GCO
EVM
UL Flatnece £1BE Sync Mode CP Auto Comrelation SO it
Magnitude & Phase (L
Emor Off
On
I | 10 Imbalancs
e — e —
Lockrange [T |
L
| DC Punctured o
| (O ) = .
DC Offsed from G |y i i
Canter | AU Symbol Clock Errar 0N

Conpersaon [ S

Crass Carrier

Channel Power
Threshold

-30.00 dB

el
:

7. In the Meas Setup window, select the Settings tab > Optimize EVM.
Record the results. For this example EVM is 0.32% and EVM Peak is 1.79%
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KEYSIGHT InpuiRF [Input Z50 0 Atten32 dB TrigFree Run Carmier Ref Freq4.000000000 GHz
L CouplingDC |Corr CCorr RCal Preint off, LNA off #iF Gain: -4 dB CC InfoDL, 1 CC, SISO
@ AlignOff Freq RefExt (S) uW PathBypass
#PNOBest Wide
| 1 cco-BwPi 2 CCO-BWP1
i 1Q Meas Time Detected Allocations
| Scale/Div 328 subcarrlers

,Start' 0.00 symbols Stop: 279.00 symbols
4 CCO
Spec Raw Man Time
ScaleiDiv 10.00 dB Ref Value 0.00 dEm Scale/Div 10.00 dB Ref Value 10.00 dBm

Ctr: 4000000000 GHz ' ' '  Width: 110.6 MHz — j N N N
Res BW: 100 Hz Info BW: 98.30 MHz Start: 0.00 nz Stop: 22.00 ms

5 CCO Frame Summary ¥ 6 Ermor Summary

Power perRE = NumRB
-26.49 dBm 22 =hanne , A
-26.49 dBm 22 EVM (RMS / P 032%/1.79%
: -26.49 dBm 42 FIEqUEicy SO RS TWOIST -1 Tz T aras
PBCH DMR: 5 Block 1) 2T % -26.49dBm 7} Symbal Clock Emror 0.000 ppm
32 % 26 45 dBm 546 1Q Offset (SISO) -84.81dB
26.45 dBm 3 Time Offeet 3.314 ms
Freq Error Sync E:orrelation ~ ?9.6 %
Caihfraran.d 09 8 bl Sync Source 55 Block

76 M9484C VXG and X-Series SA Measurement Guide



Corrections
Instrument Nonlinear Correction

To Measure ACP:

a. Select Mode/Meas > 5GNR & V2X Mode > ACP > OK.

b. Select Amplitude > Signal Path tab > and set uyW Path Control to
Low Noise Path Enable (if Option LNP is available on your analyzer).

Record the results for the Lower and Upper ACP results. For this
example -50.9 dBc (lower) and -50.9(upper).

v -+ | Arpliude
e
KEYS|G|-|‘|’ Input RF Inpul Z 50 0 Aben: § dB Trlg: Free Run Carrier Ref Frag: 4 000000000 GHz = -
Coupling 0T Corr CCorr RCal \Pmeamp- Of Gata: Off AugiHekd>10M18
Align: Auto Fraq Ref Ext [S) uW Path: LNF, On IF Galn: Low Moisa Correciion: OF
PNC: Bast Wide CCinto: DL, 1 CC

(1 Graph

| Scale/Div 10.0 dB

[W Path Contrar
LNP Enable

Auto
Man

| Center 4.0000 GHz Video BW 1.0000 MHZ" Span 500 MHz|
:‘Hﬂas BW 100 kHz Sweap 17.7 ms (5001 pts::
2 Malrics

Total Gar Pwr 7.925 dB Measure Trace
Total PSD Trace Type Trace Averag

Lower Upper
ACF Reference G Refer

c. Select Mode/Meas > 5GNR & V2X > Modulation Analysis > OK.
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On the VXG:

1. Open the Signal block and select the Waveform File tab > Configure to
open the Nonlinear Correction Setup.

Waveform File

Trigger 4 Launch Configure >

Markers

2. In the Instrument Nonlinear Correction area, select Measure Correction to
open the Instrument Nonlinear Calibration screen.

> Signal 1:Setup » Nonlinear Correction

Measure Correction Load Cormection

[ DUT No

Enable

Mode: Lookup Table

‘Waveform

3. Under the Receiver tab (opened by default), enter your connection
information and test the connection. For this example, select LAN as the
Connection Type > Enter the IP address for you signal analyzer (for this
example, 141.121.149.32) as the Hostname > Test Connection.
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The Connection status will be displayed in the Notifications area at the
bottom of the main window.

g Nonlinear Cor 1 » Instrument Nonlinesr Calibration

Advanced

141.121.149.32 Test Conneclion

Start Calibration

& REFINT

4. Select the Calibrations tab and select EVM and ACP for the Calibration
types, then Start Calibration.

— ‘I] ¥ Group 1:° Summary » Signal T:Setup » N

Receiver Calibrations: Advanced

Calibrations

Power 98.280 000 MHz
’( EVM 98280 000 MHz -50.00 dB

98,280 000 MHz 98.280 000 MHz 3 -50.00 dB

Start Calibration

98.280 000 MHz

M9484C VXG and X-Series SA Measurement Guide 79



Corrections
Instrument Nonlinear Correction

The calibration will take a few minutes to complete. Once done, the INC
file will be created and it will automatically be used in place of the .wfm
file originally loaded. An "I" will be displayed in the Signal block indicating
this status.

. Stonal 1 —=
Type 5G_100MHz_1CC_FRlinc [T

[POWer U0Uan
Status - Playing

On the UXA:
1. Select Optimize EVM.

Note the changes to EVM RMS and EVM Peak values. For this example
EVM RMS is 0.24% (before 0.32%) and EVM Peak is 1.47% (before 1.79%).

[input Z: 50 0 [Atten: 30 dB [Trig: Free Run [Carrier Ref Freq: 4.000000000 GHz
Coupling: DC \Comr CComr RCal Pre: Int off, LNA off #F Gain: 2 dB CC Info: DL, 1 CC, SIS0
Align: Off |Freq Ref: Ext (S) pW Path: Bypass
[ #PNO: Bast Wide
| i"c;::u-me | 2 CCO-BWP1
| 10 Meas Time i Detected Allocations
| Scale/Div 328 subcarriers

|-5.948 _B=1:30kHz 5.948 | Start: 0.00 symbols Stop: 279.00 symbols
3cco 4CCO
Spectrum Raw Main Time
ScalelDiv 10.00 dB Ref Value 0.00 dBm ScalelDiv 10.00 dB Ref Value 10.00 dBm

—_—

v

Width: 110.6 MHz

|Ctr: 4.000000000 GHz = | I — I—
Res BW: 100 Hz Info BW:- 98.30 MHz |Start: 0.00 ns Stop: 22.00 ms|

5 CCO Frame Summary ¥ 6 Emor Summary

Power par RE cco
2673 dBm 7 Channal Bower. (Active [ Total), 847 48m [0 27 dlim
EVM (RMS / Peak) _ 3
28 % “Frequency Error (i WSL) a1 Z 5082 mHz
0.20 % -26.73 dBm Symbol Clock Error -0.001 ppm
0.24 % -26 77 dBm 5460 10 Offset (SISO) -87 11 dB
0.24 % -26.77 dBm 3¢ Time Offset 1.262 ms
Freq Error 'c_‘f'ync C:ulrr:latiun ] ?9_5 %
o T Sync Source SS Block

To Measure ACP:
a. Select Mode/Meas > 5GNR & V2X Mode > ACP > OK.

b. Select Amplitude > Signal Path tab > and set uyW Path Control to
Low Noise Path Enable.
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1 Graph v
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Total PSD
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Note the changes to the Lower and Upper ACP values. For this
example Lower -58.67 dBc (before -50.9 dBc) and Upper
-57.85 dBc (before -50.9).

Aten: § dB
Praamp: Off

uW Path: LNP, On
PHNC: Best Wida

inpul 250 0
\Com CCorr RCal
Froq Raf Ext (S)
MNFE: Off

Gate: Off

Ref Value 0.00 dBm

Video BW 1.0000 MHz"

Reference
dBm Car#
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Trig: Free Run

IF Gain- Low

Cartler Rel Freq. 4 100000000 GHz
AvgHold:>10/10

Naoise Comaction: Of

CC infa; DL, 1 t_:c |Presel Adiust
{0kHz

;I"nil:m'ai Preamp
E Full Range
|_on

Off
i =
| WW Fath Contral

[ |

t LNF Enable
| Aulo
|

{ Man

Span 500 MHz

Measure Trace
Trace Type

ACP
dBm

i i
Fresel Center | Y Scale

| Aftenuation
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Setting Up an INC 8CC 28 GHz, 10 dBm EVM Measurement
On the VXG:

In order to compare before and after correction results, we will start by making
an EVM measurement without applying corrections.

1. Select Preset > Preset to set the instrument to a know state.

2. In the Output area, set Frequency to 28 GHz and Power to
10 dBm.

28.000 D00 000 000 00 GHz

10.00 dBm

ALC ON

3. Select the Group 1: Signals block to open.

| Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.

Enabled Frequency Offset Attenuation

>
>
>
bs
>
>
>
>
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5. Set Mode to Waveform File and then select the Waveform File tab in the
left pane.

6. In the Waveform Playback Setup area, use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

5G 100MHz 8cc FR2Z.wfm

then Select.

< Back
@ Racent A A es Instrument

@ Wavelonms Name - Date Modified

[ is computer 4000.5a

Alg 22, 2021, 7:44:04 AM

7. Select the General tab > Enable.

I~

— = - P - . -
— z [:I- (nl > Group 1: Signal Summary » Signal 1: Setup

General . Mode Signal Attenuation
. Enable
. i 0dB
Analog Niodlation Analog Modulation

Mute _
. Frequency Offset Power
Trigger

0Hz 0dB

Sample Rate
1.280 000 000 000 MHz

Reset Phase Accumulator

8. Select the Home icon and set RF Out to On.
On the UXA:

1. From the X-Series Signal Analyzer Menu Panel (on the top right of the
display), select Mode/Meas > 5GNR & V2X Mode > OK.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

2. Select Mode Preset to set Spectrum Analyzer 5GNR mode to a known
state.
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3. From the X-Series Signal Analyzer Menu Panel (on the top right of the
display), select Mode/Meas > 5GNR & V2X Mode > Modulation Analysis
Measurement > OK.

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or
the PC running the VSA application.

4. Select Recall (If accessing the X-Series Signal Analyzer remotely, select
the Folder icon at the bottom of the display) Demod Info > Set Data Type
to CC Setup > Recall From >

5G 100 MHz 8CC _FR2.scp

Recall

Rocall from File

5. The .scp file automatically sets the Carrier Frequency to 28 GHz.

6. Select Meas Setup > Advanced tab > Advanced Demod Setup and set DC
Punctured to On, then Close the Advanced Demod Setup window.

7. Select the Sweep > Single Sweep.
8. Select Meas Setup > Settings tab > Optimize EVM.
It will take a few minutes for the UXA to measure all 8 carriers.

Record the results.
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For this example CCO EVM RMS is 6.21%, EVM Peak is 27.33% and for CC7
EVM RMS is 4.51% and EVM Peak is 15.75%

Amplitude v

KEYSIGHT it RF pulZ 500 Atler: 28 dB Trig: i Flun Cartier Rief Fiag: 28000000000 GHz
: Coupling’ BFC Carr CCarrACal Praamp: OF #IF Gain' 5 dB £C info: DL, & €Cs, SISO
G aign Aumo Freq Ref- Ext [} WVl Path: Bypass
FENO: Best Wide
1 CCO-BWP = CUL S

12 Meas Time % 12 Meas Time

p =2 60 kHz NCP 5.948 -5.945 M = 2: 60 kHz NCP
4CCT
Spectrum
Scale/Div 10.00 dB Ref Value 0.00 dBm Scale/Div 10.00 dB Ref Value 0.00 dBm

(Ctr: 27 650000000 GHz Width: 110.6 MHz Ctr: 28.350100000 GHz
Res : 3771 Hz _ iz _|Res BW: 377.1 Hz Info BW: 98.30 MHz :

I sel
Time Offset
5 elation

To Measure ACP:
a. Select Mode/Meas > 5GNR & V2X Mode > ACP > OK.

b. Select Amplitude > Signal Path tab > and set uW Path Control to
LNP (Low Noise Path) Enable (if your analyzer has Option LNP).

c. Select Sweep > Restart to take a new sweep.
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Note the values of the Lower and Upper ACP. For this example
Lower, at 100 MHz offset is -26.7 dBc and Upper
-27.06 dBc.

EYSIGHT nput RF nput £250 0 Aren: 28 db Trig: Frea Run Carrier Ref Freg: 28 000000000 GHz
Coupling: DC Corr CComr RCal Preamp. OF Gale. OF Avgitold: 1010
s Align: Aute Freq Ref: Ext [S) W Path: LNP, On IF Gain: Low Moieo Comection: O
PASS NFE: OF |PNO: Best Wige | CC info DL, 8 CCs

1 Graph v
Scale/Div 10.0 dB Ref Value 0.00 d8m

Center 28.0000 GHz Video EW 1.0000 MHz" Span 1.198 GHz
£Res BW 100 kHz Sweep 42.4 ms (12001 pts) |

v

6.400 dBm/7 1 MHz Measure Trace
Total P50 Trace Type

Lower
ACP Reference
Offs Fraq £ dBe dBm
1000 MHz ] 2882
0 MiHz 0

23 O 5 A n
d. Select Mode/Meas > 5GNR & V2X > Modulation Analysis > OK.
On the VXG:

1. In the Signal block, select Waveform File Mode > Waveform File tab >
Configure to open the Nonlinear Correction Setup.

ary » Signal 1: Setup

General
Isers\jacquipa\Docul ts! Keys=ight\PathWavelSign: Select »

Waveform File
n 1o cre

Trigger Digital Video 2020 Update 1.0 : Launch Configure >
Markers

0 000 000 000 MHz 983.040 000 MHz

2. In the Instrument Nonlinear Correction area, select Measure Correction to
open the Instrument Nonlinear Calibration screen.

3. Under the Receiver tab (opened by default), enter your connection
information and test the connection. For this example, select LAN as the
Connection Type > Enter the IP address for you signal analyzer (for this
example, 141.121.149.32) as the Hostname > Test Connection.
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The Connection status will be displayed in the Notifications area at the
bottom of the main window.

> Sigr Setup > Nonlinear Corection > Instrurment Nonlinear Calibration

Calibrations Advancad

Test Conneclion

Start Calibration

CPIP:141.121.149

4. Select the Calibrations tab and select EVM and ACP for the Calibrations,
then Start Calibration.

Calibrations Advanced

ations Tolerance
Ol = == 10MHz Rel In

9A4.040 000 MHz : a10de LAM [of— LAN

B83.040 000 MHT 3 -50.00 dB
3k will 1L an oulpul

758.480 000 MHz 870.760 000 MHz 3 -50.00 dB

983.040 000 MHZ Start Calibration

On the UXA:
1. Select the Sweep > Restart.
2. Select Optimize EVM.
Note the changes to EVM RMS and EVM Peak values.
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For this example CCO EVM RMS went from 6.21% to 3.13%, EVM Peak
went from 27.33% to 11.68% and for CC7 EVM RMS went from 4.51% to
2.87% and EVM Peak went from 15.75% to 10.55%.

Input Z 50 0 Anen. 28 4B Tiig. Fiez Run Carler Rel Freq. 28.000000000 GHz
Car CCorr RCal Preamp: OF #IF Gain & d2 CC Info: DL, B CCs, SISO
Fraq RHat Ext (S) :

p=2: 60 kHz NCP

Scale/Div 10.00 dB Ref Value 0.00 dBm Scale/Div 10.00 dB Ref Value 0.00 dBm

fom
| Mech Alten Step
| 2dB

10d8

| iy o L ik s L0 Lis rem Ll o 1 Lk L '
Width: 110.6 MHz/Ctr: 28.350100000 GHz Width: 110.6 MHz, |
Info BW: 98.30 MHz ]

yolad ]
Cir: 27650000000 GHz
| Res BW: 377.1 Hz Info BW: 98.30 MHz Res BW: 377.1 Hz

I
5 CCO Error Summary ¥ |6 CCT Eror Summary ¥ |
Channel Power (Actve / Total) .11 dBm /4.1 Channel Fo Achive { Total) —4.26 f- St
| EVM (RM ) / )
IJI

¢ Ertor (RMS / Worst) IWorst) 140
K

To Measure ACP:
a. Select Mode/Meas > 5GNR & V2X Mode > ACP > OK.

b. Select Amplitude > Signal Path tab > and set uyW Path Control to
LNP (Low Noise Path) Enable.

c. Select Sweep > Restart to take a new sweep.
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Note the changes to the Lower and Upper ACP values. For this
example Lower, at 100 MHz offset is -32.27 (before -26.7 dBc) and
Upper -31.15 (before -27.06 dBc).

+

KEYSIGHT Input RF Input 2:50 0 Atten. 25 dB [Trig. Free Run Cantier Rel Frag 26000000000 GHz
Coupling: DC Com CCorr RCal Freamp: Off Gate: OFf AvglHold 1010
IFraq Raf: Exi (S) W Path- LNP, On IIF Gain- Low Moiza Comaction: Of
NFE: Off PNO: Best Wide CC Info: DL 8 CCs

1 Graph l
Scale/Div 10.0 dB Ref Value 0.00 dBm Sweep | Measure

Single

Span 1.198 GHz |

Center 20.0000 GHz Video BV 1.0000 MHz"
Sweep 424 ms (12001 pts) §

ARes BW 100 kHz

;
2
|

Measwe Trace
Trace Type
Upper
AGP Refer
dBm dBm
4.775
4775

Total Car Pwr
Total PST
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M9484C and X-Series Analyzer Measurement Guide

3 Advanced Measurements

— “Channel Bonding” on page 92

— “Generating a Multi-Carrier DVB-S2X Signal for Satellite TV” on
page 93

— “Generating a Wide Band QPSK” on page 107
— “Generating a 5G NR Waveform” on page 116
— “Setting Up 8 Virtual Signal Generators” on page 126
— “Using the VSA Flex Frame to Create a DVB-S2X Signal” on page 136

— “Creating & Analyzing a 5G NR DL 2x2 MIMO Measurement Using Two
UXAs” on page 174

— “Creating and Analyzing a 4x4 MIMO using a UXR Running VSA Software”
on page 196

KEYSIGHT

TECHNOLOGIES
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Channel Bonding

Data requirements are pushing bandwidths and modulation complexity across
many global industries.

— Global data consumption is growing
— |oT drives new data consumption
— Autonomous vehicles require data links

— Satellite networks need to provide 5G backbone in 5G Non-Terrestrial
Networks (NTN)

— New applications generate new sources of data intelligence
The following three examples are showing
— “Generating a Multi-Carrier DVB-S2X Signal for Satellite TV” on page 93
— “Generating a Wide Band QPSK” on page 107
— “Generating a 5G NR Waveform” on page 116
For this measurement example, we are using the following equipment:
— MB9484C with options
— Two channels (M9484C-001 and 002)
— RF bandwidth of 2.5 GHz per channel (M9484C-R25)
— Channel bonding, 5 GHz (M9484C-CB5 and M9484C-PCH)
— PathWave Signal Generation for Custom Modulation (N7608APPC)

— PathWave Automatic Channel Response Correction and S-parameter
De-embedding (N7653APPC)

— Accessories

— Channel Bonding Combiner kit (Y1166A or Y1167A, frequency
dependent)

— N9042B UXA
— Analysis bandwidth of 4 GHz (N9042B-R40)
— 89600 PathWave Vector Signal Analysis software, VSA
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Figure 3-1 Channel Bonding Setup

Y1166A or
Y1167A

RF out 2> RF In

Generating a Multi-Carrier DVB-S2X Signal for Satellite TV

DVB-S2X is a digital satellite television broadcast standard. Channel bonding
can be used for UHDTV services where statistical multiplexing is used to allow
many television channels can use the same bandwidth. Other applications
include Direct to Home (DTH), Digital Satellite News Gathering (DSNG) and
professional VSAT.

On the VXG:
1. Connect the equipment as shown above.

2. Select Preset » Preset to set the VXG to a known state.
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If a Synchronization Alignment is required, indicated by in the
bottom left corner, tap or click the warning message and choose Perform

Alignment before proceeding.

Instrument Information  Global Trigger Synchronization Status

ale 'and chatnels ytili
ot als and channels utilizing
/0 Configuration -hronization On

Alignment

. Immediate
clobal Trigger/Sync
Fower On/Presel
Reference
1iq Waveform Synchronizetion Alignment

Service

Preforences

Perform Alignment Clear Alignment

3. Select the System menu (triple bar icon at the top left of the window), and
then select Configure Channels > 2 Channel Bonded > Add (for 4 channel
instruments only) > Apply > Apply.

Independent.

1 CHANNEL 2 CHANNELE 4 CHANNELS
Indepandent : rent 4 Tx Coherant

2 Channel Bonded (Beta)

4. Set the Center Frequency to 12 GHz and Power to 0 dBm.
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5. Select the Apps block to open, then select Custom Modulation.

Keysight PathWave Signal Generation

. LTE FDD (Beta) LTE DD (Beta)
lation (Beta)

6. In the Custom Modulation setup, select the Carrier tab > Quick Setups >
DVB-S2X > 32APSK > 4+8+4+16APSK 140/180.

om Modulation
Carrier

Export 89600 VA Setup

Custom AS

Filter
TETRA
NXDN
dPMR
DECT

DMR

7. From the bottom pane, select Remove Segment to remove the Header.
This will simplify the demonstration.

+ Add Segment -~ Remaove Segment » Move Down

Name Type  Number of Symbols Payload Constellation Phase Rotation  Shift  Bits Per Symbol  Differentiel  Offset
PIHEATER Data ag 180 bits hinary data [0007..] OPsK 1} 2

DataSeg Deta 2000 PN15 DVB-52X 4+8+4+16APSK 140/180 1] 5

@« 1090 Sym

8. From the left pane, select Custom ASK & PSK & QAM Settings and set the
Symbol Rate to 500 Msps per channel.

Custom IQ Selection ymbol Rat 500 Msps
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9. Select Filter > Alpha to 0.2.

Custom IQ Selection Filter Root Nyquist v

Custorn ASK & PSK & QAM Settings Alpha 0.2

Length(symbol) 32

10. Select the Waveform tab > Basic > Oversampling Ratio to 7 x multiplier
which provides a span of 3.5 GHz.

Each channel is 2.56 GHz for a combined sample rate of 5.12 GHz. This
could be set by entering 5.12 GHz as the User Defined Sample Rate
however; for Multi-carrier it is best to set the Oversampling Ratio.

(] > Apps

Custom Modulation (Beta) *

", Generate Carrier ~ Waveform

Custom Modulation
Marker

Oversampling Ratio
Crest Factor Reduction AEiE a0

11. From the left pane, select Multi Carrier and select Multicarrier Enabled.

12. Open the Frequency Offsets setup screen. For Carrier Index O, set the
Frequency Offset to -1200 MHz, then select Add Rows.

+ Add - Add Rows

Carrier Index Frequency Offsel (MHz) Power Offsel (dB)

0 -1200

Cancel
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13. Enter the 1st Frequency Offset of -600 MHz, # of Carriers 4, and Carrier
Spacing 600 MHz. Select Add.

+ Add Add Rows

1st Frequency Offset -600 MHz

# of Carmers

Carrier Spacing 600 MHZ

Add

Carrier Index Frequency Offset (MHz) Power Offset (dB)

-1200

All five carriers will be setup. Select OK to close the Frequency Offsets
dialog.

- Add — Remove Clear -} Add Rows

Carrier Index Frequency Offset (MHZ) Power Offset (dB)

-1200 0

-600 0

0 0

600
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14. Generate the waveform and select the Spectrum tab from the bottom
pane to ensure the resulting waveform is correct.

=

Custom Modulation (Beta)

Random ~

(]

-1.2GHZ -600MHz, 0Hz,600MHz,

0,0.0,0.0

15. Select the Home icon to return to the main window and then select the
Signal Block to open.

16. In the Signal Setup dialog box, notice that new custom modulation file is
already selected (CustomMod G1S1.wfm). Set the Occupied Bandwidth
to 3 GHz.

Tnggerning & Markars

| Trigger

Configure Channel Bonding )

Group 1: Signal

25,000 000 000 00 GHz
Type  Cuslomiod_G151.wim
Power [.328 825952
Status Disabled
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17. Select Configure Channel Bonding and configure the Hostname or IP
address for the UXA, then Test Connection. Ensure that you have
successfully connected to the UXA, a message will be displayed in the
Status area at the bottom of the display.

sbup

Advanced

us90420008 Test Connection

Protoco Address

HISLIP e hislipa
i will turn on oulput

Start Calibration

‘Group 1: Signal
od_G157.wim
612

12.000 000 000 00 GHZ

0.00 dBm

£ REFINT Locked SYNC 0ct 10, 2022, #F Connection Test o Remole Instrument TCPIP uKa-us90420008: hislipd: INSTR

18. Select the Calibrations tab and clear the ACP calibration.

In some cases it is not possible (or necessary) to improve the ACP of the
bonded waveform. In these cases, it is best to disable it.

— If the ACP cannot be improved, in some cases, the highest fidelity
bonded waveform will result from Bonding with ACP disabled.

— ACP increases the time it takes to perform Bonding, and if the
receiver does not have sufficient analysis bandwidth to cover the
ACP regions + modulated bandwidth of the waveform, then
frequency-stitching will be performed and this will further increase
the Bonding time.

— With ACP enabled, the resulting signal will typically have
significantly increased bandwidth, sample rate, and number of
samples (as compared to a Bonded signal with ACP disabled).
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— Note that the available ACP region bandwidth is limited by the
bandwidth of the source, so if the available source
bonded-bandwidth is 5 GHz, and the bonded waveform is 5 GHz,
then there is no available BW for performing an ACP calibration.

5 l| » Group 7: Signal Setup > Channel Bonding Setup

Receiver Calibrations Advanced

Calibrationg Span Dffael Max [terationa

5,000 000 000 GHz 0.10 dB

5,000 DDD DOD GHZ 3 -50.00 dB
ion will turn on outpun

-50.00 dB

4.000 D00 00D GHz Start Calibration

19. Select the Advanced tab and set Compaction Off, then Start Calibration.

When the waveform length is short enough, compaction is not needed.
However, for 5G signals (which tend to be relatively long and have a lot of
IQ samples), the calibration time can be long (without compaction). So for
signals with lots of IQ samples, the suggestion is to use compaction as this
will reduce the calibration time. The calibration takes a few minutes to
complete. However, the highest fidelity bonded waveform may result
without compaction. How much compaction to use can be optimized
(none, automatic, or a specified compaction level) by experimenting with
the different settings.

— EEE ‘ ] f- |".:'!"| » Group 1: Channel Bor Setup » Chann
Recaiver Calibrations Advanced

Rece Source

10 DC Alignment

Calibration will turn on output power.

nonda

Start Calioration

The calibration takes a few minutes to complete.
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Notice that the CustomMod_G1S1.bnd waveform is now playing.

| Group 1: Signal

Type CustomMod_G1S1.bnd

Power 0.347 909 875
Status [ Playing

On the Signal Analyzer:

1. Select Frequency > Auto Tune to observe the spectrum.

Ensure that signal analyzer is set to Spectrum Analyzer mode > Swept SA
Measurement > View Normal.

; u Franasy [
KEYSIGHT ! Impust £ 50 0 Atten: & dB PNCY Fast (Awg Type: Log-Pawer 2 4

L C Con CCom RCal Fre: mtoff, LNA off Gate: Off

Fraq Ref. Ext (3} W Path: Standard IF Gain: Low

NFE- Adaptive Source: Off Sig Track: OF

Trig: Free Run Center Frequency !
25000701073 GHz .
1 Spectum

pan
Scale/Div 10 dB

L 27526300 GHz
Swept Span

Mkr1
Ref Level -7.00 dBm

—
[ AUTO TUNE

GF Step
B27.526300 MHz

Center 25.001 GHz ' Video BW 3.0 MHz ) ) ‘Span 8.275 GHz|
Res BW 3.0 MHz Sweep ~15.5 ms (1001 pis}|

2. Open the VSA software by selecting Mode Meas > Launch VSA.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top left of the display) to open the
Mode/Measurement/View Selector window.
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Mode / Measurement/ View Selector

Sequencer

1Q Analyzer (Basic)

When Sequencing is On and

there are multiple Screens, all Vector Modulation Analyzer
Screens updale in sequence.

When Sequencing is Off, only 5

the selected Screen updates. 56 NR

Power Amplifier

LTEFDD & NB/eMTC & VX
LTETDD & LTE-ATDD
Phase Noise

W-CDMA with HSPA+
Analog Demod

Biuetooth

To launch 89600 VSA press the button below.
EMI Receiver

Launch VSA
Remote Language Compatibility

YO Software Version
2022 ¥ SCFI Language Compatibility

3. In the Spectrum window, select Center frequency and set to 12 GHz, then
select Auto-range.

Input  Mes 3 Trace  Markers

I .l’{' Uil A B EvalusteRspend

Mesiurement running I Bieta Features in Use, 1 I EXT REF I “CAL OK
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4. From the menu bars, select MeasSetup > Measurement Type: Vector >
General Purpose > Custom I1Q.

File Edit Control Source Input MeasSetup Trace Markers Window Utilities

; e W, - 1
“ ( i e B - o £ A B8
ResBW...

Time...
Average...
dBrm Frequency vs. Time...

Time vs. Time...

Loghlag = New Measurement

| Duplicate Measurement
Measurements...
Measurement Type: Vector » | v | Vector
Power Spectrum Analysis

Anzlog Demod General Purpose
Digital Demod Cellular
Custom 1Q Wireless Connectivity
Custom OFDM Radar Analysis
Channel Quality Other standard formats
Channel Sounding

Flex Frame

LogMag

5. Select MeasSetup > Custom IQ Demod Properties.

a. In the Format tab, select Constellation Edit.
o= Measl1 - Custom IQ Demod Properties ? X
Format Filter
Sawve As Quick Setup... Quick Setups...
Constellation ~ DVB-S2X 4+8+4= 16APSK 140-180 | -Editi. | |- Recall..

Symbol Rate 500 MHz

Result Length

Search Length 5 ms

Pulse

b. Select Preset to Standard Constellation > DVB S2X APSK > 32APSK
(4+8+4+16) > 32APSK 7/9. This is equivalent to the 4+8+4+16APSK
140/180 setting we chose in the Custom Modulation setup.
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c. Select OK to close the Constellation Edit dialog.

% | GO CustomiQ Err Vect Time =

User-defined Symbals =

 Preset To Standard Constellation. ..

d. Turn off Pulse Search Enable (checkbox cleared).
e. Set the Result Length to 2000 Symbols.

f. Set the Symbol Rate to 500 MHz. The Result Length and Symbol
Rate will adjust the resolution bandwidth to better define the
waveform.

E Meas01 - Custom IQ Demod Properties ? *
Format Filter Advanced

\s Quick Setup... Quick Setups...

Search Length 5

Pulse Search Enzble

Pattern Search Enable

104 M9484C VXG and X-Series SA Measurement Guide



Advanced Measurements
Channel Bonding

g. Select the Filter tab and set Alpha/BT to 0.2, Filter Length to 33,
and Equalizer Type to Minimize EVM. Close the Custom IQ Demod
Properties window and notice the center carrier is now being
demodulated.

B Meas01 - Custorn 1Q Demo.., T *
Format Filter Advanced
Measuremnent Filter | Root Raised Cosine =

Reference Filter Raised Cosine

Alpha/ET 0.2

Equalizer
Equalizer Type  Minimize Error Vector =
| Filter Length 33
Convergence 1E-06
Adaptive Operations
Equalizer Mode
e Run

Held

6. In the CustomIQMeas Time window, click on I-Q and change to
Constellation, if desired.

A:Chi Cuctomil] Meas Ti EChl Time

7. Change the window layout to Grid 2x2.

om 8 WEE- .l
Previous Layout
Single
Slack 2
Stack 3

Stack 4

Stack b
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8. Note the measured EVM value in the CustomIQSyms/Errs window. For this
example, 1.2%rms.

s e Wude key o

[fre R il A

CiCh Vet Time

syt

% [ Chl Costomi0 Syms/Errs
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Generating a Wide Band QPSK

On the VXG:
1. Connect the equipment as shown in Figure 3-1 on page 93.
2. Select Preset > Preset to set the VXG to a known state.

3. Select the System menu (triple bar tab at the top left of the window), and
then select Configure Channels > Group 1:2 Channel Bonded > Add (for 4
channel instruments only) > Apply.

Independent

! CHAMNEL 4 CHANNELS

Indepandent 27 herent 4 Tx Coherant

Nxd MIMO (Bata)

4. Set the Center Frequency to 12 GHz and Power to 0 dBm.
5. Select the Apps block to open, then select Custom Modulation.

D Apps

Keysight PathWave Signal Generation

# Applications

5G NR

Custom Modulation (Beta)
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6. In the Custom Modulation setup, select the Carrier tab > Quick Setups >
DVB-S2 > QPSK.

(] > Apps

*  Custom Modulation (Beta) *

Carrier

[+ Export 89600 VSA Setup

DVB-S2X
APCOZ5
TETRA

NXDN

7. From the bottom pane, select Remove Segment to remove the Header.
This will simplify the demonstration.

8. From the left pane, select Custom ASK & PSK & QAM Settings and set the
Symbol Rate to 3 Gsps per channel.

Custom 1Q Selection

9. Select Filter > Alpha to 0.2.

Custom IQ Selection Filter Root Nyquist v

Custorn ASK & PSK & QAM Settings 0.2

32

10. Select the Waveform tab > Basic > Select User Defined Sample Rate and
set Sample Rate to 5.12 GSa/s.

Each channel is 2.56 GHz for a combined sample rate of 5.12 GHz.

Custom Modulation (Beta)

, Generate Carrier Waveform

Marker Ld

5.12 GSa/s

Crest Factor Reduction
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11. Generate the waveform and select the Spectrum tab from the bottom
pane.

Carrier Waveform Setup » Export Skignal Setup

5.12GSafs

Correction

Rowting

12. Select the Home icon to return to the main window and then select the
Signal Block to open.

13. In the Signal Setup dialog box, notice that new custom modulation file is
already selected (CustomMod G1S1.wfm).

14. Set the Occupied Bandwidth to 3.6 GHz (or 1.2 x 3 GHz) and the Sample
Rate to 5.12 GHz Samples per second.

15. Select Configure Channel Bonding and configure the Hostname or IP
address for the UXA, then Test Connection. Ensure that you have
successfully connected to the UXA.
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16. Select the Calibrations tab and clear the ACP calibration.

Calibrations

4.915200 000 GHz 0.10de

4.915 200000 GHz 50,00 dB

42,400 000 MHz 2,478 300 000 GHz

-50.00 dB

4.915 200 000 GHz

Start Calibration

| |
Group 1: Signal
Gr 15y 12.000 000 000 00 GHz

Status Disabled

17. Select Start Calibration.

The calibration takes a few minutes to complete. Note that the VXG
displays an Invalid file selection message. This is because the VXG

no longer sees the .wfm waveform instead the newly calibrated waveform
has a .bnd file extension.

Notice that the CustomMod_G1S1.bnd waveform is now playing.

| Group 1: Signal

Type CustomMod_G1S1.bnd
Power 0.347 909 875

Status [ Playing
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On the Signal Analyzer:

1. Select Frequency > Auto Tune to observe the spectrum.

|Inpust Z: 50 (3 |Atten: & df FNO: Fast Avg Type: Log-Power
|Pre: Int off, LNA off Gate: OF Trig: Free Hun
‘uWY Path: Standard IF Gain: Loy

1 Spectrum 876656601 GHz

Swepl Span

| Scale/Div 10 dB Ref Level -6.00 dBm
o : = ¥ Zero Span

§ 16.374612817 GHz |

AUTO TUNE ‘
1 m

" Video BW 3.0 MHz ] ] Span B.767 GHzii
Sweap ~16.1 ms (1001 pts)| |

2. Open the VSA software by selecting Mode Meas > Launch VSA.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top left of the display) to open the
Mode/Measurement/View Selector window.
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3. In the Spectrum window, set the Center Frequency to 12 GHz and
Auto-range.

up Trace Markers

B EvalusteRspend

Messurement running | eetareawresinuses | samer | cavox

4. From the menu bar, select MeasSetup > Measurement Type > General
Purpose > Custom 1Q.

5. From the menu bar, select MeasSetup > Custom IQ Demod Properties.
a. Select the Format tab and select Constellation Edit.
b. Select Preset to Standard Constellation > PSK > QPSK.
c. Select OK to close the Constellation Edit dialog.

| Consteliation Editor ? »
MName Constellation Graph
Symmetry
Magnitude RMS 1 Nommalize RMS
Symbol Mapping State Indeves
Constellation States
Insert  Delete  Copy Freset To Standard Consteflation...

Magnituds

2 04 06 0B 1

Show Syrnbols
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d. Turn off Pulse Search Enable (checkbox cleared).

e. Set the Symbol Rate to 3 GHz.

Format Filter Advanced

Save As CQuick Setup... Quick Setups...

stellation Edit... Recall...

Symbol Rate || 3 GHz

Result Length |20

Pulse écurnh Enabile

Pattern Search Enable

f. Select the Filter tab and set Alpha/BT to 0.2, Filter Length to 33,
Equalizer Type to Minimize Error Vector, and Reset the Filter.

B Meas01 - Custorn 1Q Demo.., T *

Format Filter Advanced
Measuremnent Filter | Root Raised Cosine =
Reference Filter Raised Cosine
Alpha/ET 0.2
Equalizer
Equalizer Type  Minimize Error Vector =

Filter Length

Convergence 1E-06

Adaptive Operations
Equalizer Mode
e Run

Held
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6. View the results.

7. In the menu bar, select the Trace Layout icon and select the Grid 2 x 2
format.

Previous Layout
Single

Slack 2

Stack 3

Stack 4

Stack b

Custom...

Tile Visible

This allows you to view more measurement details like the EVM results,
which for this example is ~1.6 %rms.
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Utilies  Help

& Ui A

ime
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Generating a 5G NR Waveform

On the VXG:

1. Connect the equipment as shown in Figure 3-1 on page 93.

2. Select Preset » Preset to set the VXG to a known state.

If a Synchronization Alignment is required, indicated by in the
bottom left corner, tap or click the warning message and choose Perform

Alignment before proceeding.

2 Instrurment S

/O configuration
Alignment

; Immediate
Global Trigger/Sync
Power On/Presel
Reference
1/ Waveform Synchronization Alignment

Service

Preforences

Perform Alignment Clear Alignment
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3. Select the System menu (triple bar tab at the top left of the window), and
then select Configure Channels > Group 1:2 Channel Bonded > Add (for 4
channel instruments only) > Apply > Apply.

|||| > Configure Channels

Independent ~ Remaining RF Channels: 4

1 CHANNEL 2 CHANNELS 4 CHANNELS
Independent 2 erent
2 Channel Bonded (Beta)

Nx2

4. Set the Center Frequency to 12 GHz and Power to 0 dBm.
5. Select the Apps block to open, then select 5G NR.

|_rL| > Apps

tom LTE FDD (Beta) LTE TDD (Beta)
dulation (Beta)

6. Select the Carrier tab.
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7. Select Full-Filled Config and set Bandwidth to FR2 400 MHz, and then
select OK.

Fulifilled

Bandwidth FR2 400MHz

Numerology p=3:120 kHz

“~ Duplex Type

Maodulation

Cancel

Full Filled Configurations is a great place to start creating your waveform.
You can select FR, bandwidth, and modulation format with a fully
allocated PDSCH data channel. This would represent a spectrally correct
signal that is typically used in power amplifier measurements. You can
modify the RB allocations and Slot allocations if fully allocated data
channels are not desired.

8. Select DL Test Model to open. set Bandwidth to FR2 400 MHz and set
Phase Compensation to Off, and then select OK.

NR-FR2-TM1.1
Bandwidth FR2 400MHz

Numerology p=3:120kHz
Duplex Type andwidth
and unwanted

Test Model NR-FRZ-TM1.1 o
spurious

missions

Number of Layers

DCI/DLSCH Payload Data

Cancel
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9. Select the Waveform Tab, and set the Time Scale Factor to 10.

Carrier Waveform

Capability Waveform Playback ~~

Total Number of Antennas 1

Required License Version Date

User-Defined Sample Rate
Sample Rate

Time Scale Factor

Subframe Offset

CDF

10. Generate the waveform and select the Spectrum tab from the bottom
pane. The waveform will take a moment to finish generating.

Waveform

otor Reduction

Routing
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11. Select the folder icon in the right corner of the display, and select Export
Signal Setup (*.scp) file. In the File Name field, create a name for the
setup file, then select Enter. Note the location where you saved this file as
you will need to copy it to the UXA.

7~ Open

Y Save As

+ Export Waveform

[+ Import Signal Setup (*.scp)

Export Signal Setup (*.scp) .

12. Select Export 89600 VSA Setup. In the File Name field, create a name for
the setup file, then select Enter. Note the location where you saved this
file as you will need to copy it to the UXA.

¢ Generate Carrier Waveform

Tatal Number of Antennas

To copy the two setup files to the UXA:
a. Select the System menu icon (triple bar), then Switch to Windows.

b. Select the Windows icon (bottom left corner), open File Explorer
and navigate to the setup files and Copy both files.

c. Onthe UXA, select the Windows icon, open File Explorer and Save
the two setup files.

d. On the VXG, select the PathWave SG icon in the Desktop to restore
the PathWave application.

13. Select the Home icon to return to the main window and then select the
Signal Block to open.

14. In the Signal Setup dialog box, notice that new custom modulation file is
already selected (NR5G G1S1.wfm).

15. Select Configure Channel Bonding and configure the Hostname or IP
address for the UXA, then Test Connection. Ensure that you have
successfully connected to the UXA.
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16. Select the Calibrations tab and clear the ACP calibration, then select
Start Calibration.

4.915200 000 GHz 0.10dB
4.915 200000 GHz 3 -50.00 dB
42,400 000 MHz 2,478 300 000 GHz 2 -50.00 dB

4.915 200 000 GHz

Start Calibration

I 5P
Group 1: Signal
e 12.000 000 000 00 GHz

Status Disabled 0 dBm

1
m
2

On the Signal Analyzer:

Below are two methods for viewing the results of the 5G NR wideband
waveform.

— Using X-Apps 5G NR & V2X Modulation mode Modulation Analysis
measurement

— Using 89600 VSA
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Using X-Apps 5G NR & V2X 1 Mode
1. Select Frequency > Auto Tune to observe the channel bonded signal.

KEYSIGHT |mput RF Input Z- 50 0} Atten: & dB PNO: Fast Avg Type: Log-Powsr ; E 234
Coupling: DC Cor CCorr RCal Pre: Int off. LNA off Gate: Off Trig: Free Run -
oo Align: Auto Freq Ref: Ext (S) W Path: Standard IF Gain: Low w
NFE: Adaptive Sig Track: Off MNNRNN
1 Spectrum Mkr1 13.759 GHz|
Scale/Div 10 dB Ref Lavel -9.00 dBm -32.48 dBm

Center 12.000 GHz Video BW 3.0 MHz Span 10.86 GHz|
Res BW 3.0 MHz Sweep ~20.2 ms {1001 pts)

2. From the N9042B select Mode/Meas > 5G NR &V2X Mode > OK.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top left of the display) to open the
Mode/Measurement/View Selector window.

3. Select Mode Preset to set Spectrum Analyzer 5G NR mode to a known
state.

4. From the N9042B Menu Panel (or the Screen tab), select Mode/Meas > 5G
NR & V2X Mode > Modulation Analysis Measurement > OK.

5. Select Recall (If accessing the N9042B remotely, select the Folder icon at

the bottom of the display) Demod Info > Data Type set to CC Setup >
Recall From.
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6. Navigate to the .scp file you created in step 11 above and select Recall.

Recall mod Info g from File q {""Jl ? x

e ) [ Computer ) . ) Users ) Administrator ) Documents. ) Keysight Made B N Y

Sereen Config + State & Date Size Content
Correction = \ 2419 AM
Complex Correction ument 2022 12:26 PM

Recording BGNR Channel Banding scp Q72022 554 AM 106 KB Scp file

SCPI Recorder

rding + State

FeiE |

File name. | S5GNR Channel Bonding.scp File type: | All Supported Files (*.scp;* sgen;*.nrce,” pwsg*.seb) Recall

7. From the Menu Panel, select Meas Setup > Settings tab > Optimize EVM.
For this example, the EVM RMS is ~1.9%.

s UM Anay7er 1
Swepil 54 : & -Q
KEYSIGHT Joput RF Trigy Frow R oy Raf Frae. 12 000000008 Géx
L /) o = o 1 Poe I off, LNA o 2IF Gain. Low CEC o 0L 1 € S0

L W Path: Bypass GCo
#PND Besl Wide

Meas Selup 7
rempnoed Caarriar
WPt

1
0 Mesn Time
Ref Value 0 subcarriers

=3 170 kMz

Raw Main Time

Ref Value 0.00 dBm Scala/Div 10.00 dB Ref Value 10.00 dBm

Widih: 3.832 GHa. For best EVM, set

Info BW: 3.93 GHz |Start: 0.00 ns "Rl Fuill Py
I Auito”™ to Cndin
the Ampltuc
men

Fowerper AE  Num RE
41.08 24

Magnitude Frror
Phasa Em
alance
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Using 89600 VSA
1. Open the VSA software by selecting Mode Meas > Launch VSA.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top left of the display) to open the
Mode/Measurement/View Selector window.

2. In the Spectrum window, set the Center Frequency to 12 GHz and
Auto-range.

woe  Input  MeasSetup  Trace  Markens w  Utifties  Help

Sl 7 W
ange To Pesk Power (Default]) = N 25 .1 By ¢ | A % l;-r',a\-alumNP:-.med

Megiurement running l Eita Features in Use 1 I EXT REF l AL OK

3. From the menu bar, select File > Recall Setup > Recall and select the .setx
file you copied over from the VXG.

4. From the menu bar, select MeasSetup > 5G NR Demod Properties > Time
tab and set Time Scale Factor to 10. Close the Demod Properties windows
and observe the results.
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5. In the Spectrum window, set the Span to 4 GHz, then select the
Auto-range icon at the top of the display.

File  Edit  Control rce Input

L&  Range To Peak Power |

In this example, the EVM is ~2%
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Setting Up 8 Virtual Signal Generators

126

The M9484C Option 8SG provides eight virtual signal generators (multiple 1Q
paths to RF) allowing you to emulate up to 8 signals simultaneously with one
channel. This feature is most beneficial in receiver design and test applications
in which the current implementation often involves RF combining of multiple
signal generators due to dynamic range limitations. 8SG can simplify device
characterization where multi-carrier or multi-radio access technology signals
are required.

The VXG must have Option M9484C-8SG (8 virtual signal generators)
installed.

10 MHz out = Ext RefIn

-
P

Event 1 out=> Trig1In_

RF out = RF In

For this example we will use the following equipment:

— M9484C VXG
— RF bandwidth of 2.5 GHz per channel (M9484C-R25)
— 8 Virtual Signal Generators (M9484C-8SG)

— N7631TAPPC PathWave Signal Generation for 5G NR measurement
application

— X-Series Signal Analyzer
— N9085EMOE 5G NR Measurement application
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On the VXG:

1. Select Preset > Preset to set the instrument to a known state.

2. In the Output area for Channel 1, set Frequency to 2 GHz and Power to
-5 dBm.

2.00000000000000 GHz

-5.00 dBm

3. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.

Enabled  Signal Mode Frequency Offsat Attenuation

WOW WV WV WV WV VWV

4. Select Group 1 Signal block to open.

| Group 1: Signals
File None selected
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5. Select the Mode drop down menu and select Waveform File and then
select the Waveform File tab on the left side.

= © [ >

General Mode
Wavaform Fila Waveform File
Trigger

Markers

00 GHZ

Reset Phase Acoumulator

6. In the Waveform Playback Setup area, use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

and choose
01 _GSM_Framed_slots 1 3 5 off_EDGE Framed_slots © 2 4 6 off_2MHz
separation_WFM1.wfm

then Select.

Date Modified
Delete
D This Computer

[ Rename

Clear Arb Memaory

All Supported Formats (*.wfm, *.wiq, *.bin, *. waveform, *.csv, *.bx, *.seq, *.mat, *.hdf, #.h5, *inc) w o Cancel
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Whenever you enable a particular waveform file that is not currently
enabled in another I1Q path, it uploads prior to playback. If the file is
already enabled in one or more other 1Q paths, an upload does not occur
and the waveform plays directly.

If you update the |Q data for a particular waveform file, you must first
disable the 1Q paths where the old version of the same file is being used so
that it uploads, replacing the old data.

7. Set the Frequency Offset to the desired value. For this example -1.2 GHz.

The Frequency Offset is the distance from the channel’s RF center
frequency (set in step 2) to the center frequency of the signal. You can
adjust the signal attenuation for each signal to allow scaling the signal
down without disrupting the output.

8. Select the General tab > Enable

LI‘L| > Group 1: Signal Summary » Signal 1: Setup

General pr— Mode Signal Attenuation
f . Enable

. i 0dB
ndon MadUlation Analog Modulation v

e Frequency Offset Po
Trigger requency Offse ower

0Hz odB

Sample Rate
1.280 000 000 000 MHz

Reset Phase Accumulator

9. From the Menu/Tool & Navigation bar, select Group 1: Signal Summary.

Notice the Remaining Sample Rate has decreased from 3.0 GHz to
2.9956 GHz now that Signal 1 is consuming 4.333 MHz.

1 !Group 1: Signal Summary

Enebled Signal Mode Frequency Dffset Attenuation

v File: 0

>
>
>
>
>
>
>
>

10. Repeat step step 5 through step 9 for Signal 2, Signal 3, and Signal 4 with
the following changes.
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— Signal 2

— Waveform:
D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples\02 W-CDMA TM1 1 DPCH.wfm

— Frequency Offset: -1.0 GHz
— Signal 3
— Waveform:
D:\Users\Instrument\Documents\Keysight\PathWave

\SignalGenerator\Examples\03 LTE full
filled 160AM.wfm

— Frequency Offset: -900 MHz
— Signal 4

— Waveform:
D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples\04 802.1lac 160 MHzO.wfm

— Frequency Offset: 1.0 GHz

Enabled Signal Mode Frequency Offset Attenualion Stalus

v

v e 0 | o 0.00dB

0.o0odB P Paying

11. Signals 5 -7 will be configured using the embedded PathWave Signal
Generation for 5G NR (N7631APPC). Select the Radio Apps icon in the top
left of the window, and then select 5G NR.

@ >

Keysight PathWave Signal Generation

LTE FDD (Beta)

12. To create signal 5, select the Carrier tab > Full-filled Config and set
— Bandwidth to FR1 100 MHz
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— Duplex Type to FDD
— Modulation to 64QAM, then select OK

Camier  Wav

ww Fultfilled Corfig || T+ DLTest Modal [ DL FRC Config & Auto Frequency Offset [+ Export 83600 VSA Setup

General

ectrum Control

FR1 100MHz

p=1:30kHz

Dowriink

Channel Allocation Sum|

Modulation

13. Select the Waveform tab and scroll down to turn Phase Compensation
Off. This will allow the waveform to be offset in frequency without needing
to be re-generated.

*, Generate Carrier ~ Waveform

[» Export 89600 VSA Setup

Subframe Offset
Marker Number of Subframes

Crest Factor Reduction Slot Offset in Subframe

AWGN Number of Slots in Subframe

Total Sample Points

Routing

Naveform Length

Mirror Spectrum
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14. From the left pane, select the Routing tab, set the signal number to 5, and
then Generate.

s ;
(©; Generate Carrier Waveform

[+ Export 89600 VSA Setup

Basic GILIU[J
Marker
Crest Factor Reduction

AWGN

15. To create signal 6, select the Carrier tab > Full-filled Config and set
Bandwidth to FR2 200 MHz.

16. Select the Waveform tab, then from the left pane, select the Routing tab,
set the signal number to 6, and then Generate.

17. To create signal 7, select the Carrier tab > Full-filled Config and set
Bandwidth to FR2 400 MHz.

18. Select the Waveform tab, then from the left pane, select the Routing tab,
set the signal number to 7, and then Generate.

19. Return to Group 1: Signal Summary by selecting the Home icon > Group1:
Signals and set the Frequency Offset for each of the newly generated 5G
NR signals as follows:

— Signal 5 to -700 MHz
— Signal 6 to -300 MHz
— Signal 7 to 300 MHz

(A1 > Group 1 Signal Summary

Enabled Signal Mode Frequency Offset Altenuation
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20. Select the arrow for Signal 8.

21. Select the Mode drop down and select AWGN. Select the AWGN tab and
set Channel Bandwidth to 1.5 GHz.

-:IJ » Group 1: Signal Summary » Signal & Selup

General

Channel Bandwidth

f Ch idth I A 3
1.50 DOD GHZ o |
I Char Nolge Power
1.500 000 000 GHz Channel Noise

AWGN

[€&——— Flat Bandwidth ——| Freq

22. Select the General tab and set Frequency Offset to -200 MHz and Enable
the AWGN signal.

’JL » Group 15

General Mode
(B robie
AWGN

-200.000 000 MHz

le Rate

Reset Phase Accumulator

23. Select the Home icon and set RF Out to On by selecting the numbered
channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

| output Mod
(Fl] On

2.00000000000000 GHZ

2,00 dem

ALCOFF

M9484C VXG and X-Series SA Measurement Guide 133



134

Advanced Measurements
Setting Up 8 Virtual Signal Generators

24. For multi-channel instruments only: In the top right corner of the display,
set RF Out (All) to On by selecting the switch.

RF Qut (All)

In order to turn on RF for any channel, both the RF Out for the specific
channel (for example, Channel 1 or Channel 2), and RF Out All must be
turned on.

On the Signal Analyzer:
1. Select Mode/Meas > Spectrum Analyzer Mode > Swept SA Measurement.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

2. Select Mode Preset to set the spectrum analyzer to a known state.
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3. Adjust the center frequency and span to view all of the signals around the
RF center frequency. For this example, set the Center Frequency to 2 GHz
and Span to 2.5 GHz.

KEYSIGHT Input £ 50 Aten 10 db PNOD: Fast Avg Type: Log-Power [1]2 FET———
' c oo Co Goom RGal Pre: ntoff, LNAO  Gate: OF Trig: Frea Fun Center Frequency =

L:] Align Partal Freq Rat. Ext(S) uW Fath: Standard IF Gain: Low ! | 2000000000 GHz
NFE: Adaptive '3ig Track: Off

Span
1 Epectrum ¥ ! ESUUM GHZ 2

Scale/Div 10 dB Ref Level 0.00 dBm

Center 2.000 GHz ' Video BW 3.0 MHz ]
Res BW 3.0 MHz Sweep 167 ms (1001 pts! §

4. Adjust the Resolution Bandwidth and Video Bandwidth as needed.

5. Now that 8 waveforms are playing, try some of the following experiments
to see how different settings impact the signals.

— Toggle the Enable checkbox for various signals.

— Adjust the Frequency Offset of various signals. Note that signals can
overlap.

— Set up a Channel Power measurement on the Signal Analyzer.
Observe how changing different signal settings (relative power,
attenuation, mute, enable, etc.) either impact or do not impact Total
Channel Power.

— Use the Auto Configure Analyzer feature to demodulate one of the
5G NR signals. Note, the center frequency will need to be manually
adjusted on the Signal Analyzer to match the Frequency Offset of
the signal set on the VXG.

— Change Trigger and/or Marker settings.
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Using the VSA Flex Frame to Create a DVB-S2X Signal

136

The Flex Frame extension (89601AYAC) for the 89600 VSA software provides a
means of creating complex frames to demodulate and analyze advanced
custom 1Q signals.

A frame can contain a combination of flexible elements, or allocations. Each
allocation can be a Preamble, Pilot, Data or an Idle period. Allocations have
configurable payload PN sequence and modulation type.

As you build the flexible frame in the Frame Definition tab, an Allocation
Summary panel displays the order of each assembled frame part and
allocation, and shows how the total number of symbols are distributed across
the frame.

There are two parts to this example.

The first example uses N7623C Signal Studio for Digital Video. The N7623C
generates a fully coded, full-standard compliant DVB-S2X waveform. Then, we
will use VSA Flex Frame to demod the signal.

The second example uses PathWave N7608C Custom Modulation. Since the
N7623C cannot provide an uncoded signal, we will use the N7608C to
uncoded the signal to perform a Bit Error Rate (BER) measurement.

For this example, we will use the following equipment:

— N7623C Signal Studio for Digital Video (Software release 2020 Update 1.0
or higher

— N7608C Signal Studio for Custom Modulation (Software release 2021 or
higher)

— 89600 VSA Digital Demodulation Analysis, Flex Frame Measurement
(Software release VSA 2022 or higher)
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DVB-S2X PHY Layer Framing

+———— PLFRAME before PL Scrambling: Total Length = 90(S+1)+P int{(S-1)/16}, (P=36 pilots) —

|Length:1-slot (90 symbols)  Length:1-slot (90 symbols) Length:36 symbols
Modul 1 BPSK . Mad l iS to APK} | odlle

¢ ~ For modes
; ~ TEQUITInG piots

i SOF | PLSCODE ]

PLHEADER (90 symbols) includes: + Payload length is multiple slots of 90 symbols each

+ Pilots are grouped in blocks of 36 symbols and

= SOF (Start of Frame): 26 symbols (y1y2...y26): inserted every 16 payload slots

01 1000 1101 0010 1110 1000 0010

« PLS (PHY Layer Signaling) Code: 64 symbols

256 APSK modulation is used in this demo guide. The coding rate is
represented differently between Signal Studio for Digital Video (N7623C),
Signal Studio for Custom modulation (N7608C), and VSA Flex Frame
(89601AYAC). N7608C and 89601AYAC use “Implementation MODCOD” name
and N7623C uses “Canonical MODCOD” name.

In this example, we will use a coding rate of 32/45 in the N7623C which
corresponds to 128/180 in the N7608C and VSA.

N7623C Signal Studio for Digital N7608C Signal Studio for Custom 89601AYAC Flex Frame

Modulation Modulation
256APSK 29/45 256APSK 116/180 256APSK 116/180
256APSK 2/3 256APSK 20/30 Not supported
256APSK 31/45 256APSK 124/180 256APSK 124/180
256APSK 32/45 256APSK 128/180 256APSK 128/180
256APSK 11/15 256APSK 22/30 Not supported
256APSK 3/4 256APSK 135/180 256APSK 135/180
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Part 1: Generating a DVB-52X Waveform Using N/623C Signal
Studio for Digital Modulation

DVB-S2 and DVB-S2X operate in Ku band (10-14 GHz) and Ka band
(18-30 GHz). This example uses a sub-6GHz hardware thus using a center
frequency of 4.5 GHz. Modify the frequency based on the hardware you are
using.

Setting Up the Waveform in Signal Studio for Digital Video
1. From the main menu, select Format > DVB-S2/S2X.

= Keysight Signal Studio for Digital Video - RF Output - O kst

File Control System ToolsHeIp
D& 1 DVB-T/H
~Quick Setups DVB-T2
El-Hardware _
LInstrument DU GHER S
E--m DVB-5 | Frequency Cffset Power
~Carrier 0 I « DVB-§2/S2X 52X 0.00 Hz 0.00dB
ISDB-T
ISDB-Tmm
ATSC
ATSC-M/H DTV
J.83 B, DOCSIS DS 12514032
DOCSIS 2.1 Downstream Off
DOCSIS 3.1 Upstream
DTME (CTTB) 2 j
CMMB
B Gaussan B8 Reference (e Acquirs

>

[~ Hint

-

10% —dB
1% —dB
0.1% —dB
0.01% —dB
0.001% |—dB
0.0007% —dB

20.00 dB&

2. From the left panel, select Quick Setups > Hardware > Instrument.
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3. Set the Frequency to 4.5 GHz and the Amplitude to -10 dBm.

= Keysight Signal Studio for Digital Video - RF Output* - O X

File Control System Tools Format Help
1
Genarator
Updatetcrlnstru‘ Updatefromlnstru| Loca||- DC Ca| Power S¢

[ Hint

* 1. Confiauration o
Instrument Model Number N5162/MN5172/N5182 EXG/MXG

™
Freausncy 4.500 000 000 000 GHz
Amplitude -10.00 dBm
utout ol

v 3. 1Q
1/Q Adiustments
| Offset
Q Offset
1/Q Gain Balance
Quadrature Anale Adiustment
|/Q Timina Skew Path

L Carrier 0

Q Cg I
/Q Skew
1/Q Delav
Internal Channel Correction
v 4 ALC

ALC On
ALC Bandwidth Auto
Power Search Reference Fixed
RF Durina Power Search Normal j

4. Under Waveform Setup, select Carrier and configure the DVB-S2/S52X
signal to the following parameters.

Roll of Factor to 0.25

Symbol Rate to 20 MHz
Support DVB-S2X to True
Modulation Type to 256 APSK
Code Rate to 32/45
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This is equivalent to MODCOD 256APSK 128/180 in the VSA.

= Keysight Signal Studio for Digital Video - RF Output* - O X

File Control System Tools Format Help

W= = | 1

- Quick Setups

-Hardware
-Waveform Setup State Format Frequency Offset Power
""" Carrier 0 On DVB-52/52X% 0.00 Hz 0.00dB
| Hint
State On T
Format DVB-52/52X
Freauencv Offset 0.000000 Hz
Initial Phase 0.00 deg
Powar 000de
W 2. DVB-52/52X Settinas

Filter Tvoe Root MNyquist
Roll-off Factar 0.25
Svmbol Rate 20.0000000 MHz
Support DVB-$2X True
VL-SNR Header False
FEC Frame Normal
Modulation Tvoe 256 APSK
Code Rate 32/45
Insert Pilot False
CRC-8 Encoder True
Number of LDPC Blocks 188
Multi-oath Channel OFF

5. In the Waveform Setup window, set the Oversampling Ratio to 2.

This results in a Waveform Length of 3147120. We will use this length
when configuring the signal in VSA Flex Frame.

File Control System Tools Format Help

(= = 1
s~ Quick Setups |Wavef0rm Setup

-Hardware

i eInstrument

E-Waveform Setup Camier | State Format Frequency Offset Power

i Carrier 0 Carier 0 On DVB-52/52X 0.00 Hz 0.00dB
< >
Waveform Setup | Hint
Waveform Lenath 3147120 | j
ast Download e
» 2. Spectrum Control
LY H o " {"HF
2 J
* 3. Impairments in Waveform
Quadrature Anale Adiustment 0.000 deg J
1/Q) Gain Balance 0.000 dB h

CCDF ]Wa\re{orrn ]
B Gaussian B Reference i8] Acquire Ref.

—dB
—dB

T 20.00 dB
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6. From the Control menu, select Generate.

Depending on the signal generator you are using, the steps for
downloading the waveform may be different. If this is the case, go to File >
Export Waveform Data and Save the file. Then load it onto the your signal
generator.

7. Select Control menu > Download to download it to your Signal Generator.

Setting up and Analyzing the Signal Using VSA Flex Frame

Changing settings on the VSA can take longer to take affect than
expected. Wait to change the next setting until the previous setting has
been updated.

1. From the VSA menu bar, select MeasSetup > Measurement Type >
General Purpose > Flex Frame.
2. Set the correct frequency, span, and input range. For this example, set:
— Change the Trace Layout Grid to 2 x 3.

— Change Trace B to Ch1 Spectrum, and set Center Frequency to
4.5 GHz

— Span to 40 MHz
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— Autorange

2= Flex Frarme - Eeysight PathiWave Viector Signal Analyss (30600 VS4)
File Edt C Input  MeasSetup  Trace Markers Wi Utilities__ Help

1 Range To Pesk Powes (Default) - mem  BEELE (RO Rl A

Auto-Range

exFrame Summany

= EvM :
ramer; All o Sy M ¢
sfiat Allocslion ey tdBm) %ol Sy SNG HOT FouND

Freq=4.5 GHz

Span = 40 MHz NOTE: The low-resolution spectrum
will get adjusted automatically when
the correct Symbol rate is set in the
next step
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3. Select MeasSetup > Flex Frame Properties > Carrier Aggregation tab, then
set CCO Absolute Center frequency to 4.5 GHz.

E MeasO1 - Flex Frame Properties

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation

Preset Measurement Quick Setups  » Save Ag Quick Setup..

Selects for Trace Display: | €CO
Component Carriers

R nce Frequency: 0O Hz

lute Center

+ Add CC

Acquisition Configuration

20 Overall Status:

Errar: unassigned component carmers: [CCO]

The Symbol Rate error will be resolved once the Symbol Rate gets
adjusted in step 5.
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4. At the bottom right portion of the display, select Edit, then select the
Assigned Carriers drop down and select CCO.

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation

Preset Measurermnent Quick Setups * Save As Quick Setup..

x

+ Add €C

4475 GHz

omelated EVM

Configure...

5. In the Flex Frame Properties window, select the Frame Definition tab and
set:

— Frame Type to Periodic
— Symbol Rate to 20 MHz
— Length to 3147120 Symbols

To match the waveform length in Signal Studio.
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For a bursted signal, Frame Type is set to Burst, and the frame
length can be automatically set based on the detected burst length.

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation

-

Component Carrier: |CCO

All .

195.3125 kHz

Component Carrier Configuration Allocation Summary
Frame Configuration Modulation Index Enabled Frame Part Allocat
0 ] FramePart0 Alloch
Frame Type: Periodic -
Symbol Rate:| 20 MHz

Length: 3079440 Symbols

Frame Parts

4 FramePart0

Allocd

6. In the Component Carrier Configuration area, select the Modulation tab
and set Preferred Bit to Symbol Mapping to Default.

When testing a DUT, if the bit mapping into constellation point is as
defined by DVB-S2X, DVB-RCS2 or 802.11ad/ay standard, selecting the
correct standard under "Bit To Symbol Mapping" is required for accurate
Tx BER measurement. When using Signal Studio, leave it as Default.

Constellation mapping definition between VSA Flex Frame and N7608C
Signal Studio is not aligned. VSA comes with a set of bit mappings (.txt
file) to recall into the N7608C and this is required for successful
demodulation. You can find it under: C:\Program Files\Keysight\
<version>\89600 VSA Software\Help\Signals\FlexFrame.

7. Set the Sequence Type to DVB-S2/S2X PLFRAME.

This selects the scrambling method as described in section 5.5.4 of
EN 302.301-1.
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8. Set both Sequence Index and Reset Symbol to 0.

Component Carrier Configuration

Frame Configuration Modulation

Preferred Bit To Symbol Mapping: {pefaurt

Scrambler: . aF

Scrambler Configuration
Sequence Type: DVB-52/S2X PLFRAME
Sequence Index: 0

Reset Symbol Index: 0

Configure the Preamble (PLHEADER)

Length:1-slot {90 symbols) Length:1-slot (30 symbols) Length:36 symbols
od on: 2/PLEP Mo ion (QPSK to APSK)

i ation o

PLHEADER

” i For modes
’ ~ requiring pliots

PLHEADER

SOF PLSCODE

PLHEADER (90 symbols) includes:

« SOF (Start of Frame): 26 symbols (y1y2...y26):
01 1000 1101 0010 1110 1000 0010

9. Select the Frame Configuration tab and configure the Start of Frame Index
(SOF), 26 symbols long:

— In the Frame Parts area, select AllocO.
— In the Configuration area, set
— Name to SOF
— Type to Preamble
— Sequence to Custom
— Modulation to DVB-S2/S2X n/2BPSK

— Enter the 26 symbols
01100011010010111010000010

(011 000 110 100 101 110 100 000 10)

— In the Location area,

— Clear the End of Frame checkbox
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— Start Symbol to 0
— Total Length to 26
Note that Scrambling is not applied to Preamble.

Frame Parts
Configuration Location
4 FramePart0 9

Alloc Enabled: v Start Symbol: 0

MName: AllocO Last Symbol

— Symbol Index: 25

Type: Preamble - e
-or-

Power Boost: | 0 dB

Total Length: 26 Symbols

Payload
End of Frame

Seguence: Custom

Repeat Pattern

Custom Sequence Type: | Bit Sequence -

Modulation: DVB-52/52X /2 BPSK  +

Include in BER Calculations

01100011010010111010000010

Scrambling

Enabled
Add Frame Part

Add Allocation

Configure the PLS (PHY Layer Signaling) Code 64 symbols long
10. In the Frame Parts area:

— Select Add Allocation
11. In the Configuration area, set:

— Name to PLSCODE

— Type to Preamble

— Sequence to Unknown

— Modulation to DVB-S2/S2Xn/2 BPSK

Notice that Scrambling is not applied to Preamble.

12. In the Location area, set:

— Clear the End of Frame checkbox

— Start Symbol to 26

M9484C VXG and X-Series SA Measurement Guide

147



Advanced Measurements
Using the VSA Flex Frame to Create a DVB-S2X Signal

— Total Length to 64 Symbols

Frame Parts

4 FramePartd Configuration Location

SOF Enabled: v Start Symbaol:

PLSCODE Mame: PLSCODE Last Symbaol

s Symbol Index
Type: Preamble i

==

Power Boost: | 0 dB
o 0 0 dB Total Length:

Payload
End of Frame

Sequence: Unknewn

Repeat Pattern
Modulation: | pyB-52/52X m/2 BPSK
Scrambling

Enabled

Add Frame Part

Add Allocation | Remove Allocation

Configure the Payload
Length:1-slot (30 symbols) Length:1-slot (90 symbols) Length:36 symbols
Modulation: 2/P] BPSK Modulation (QPSK to APSK) Unmodulated

PLHEADER

For modes
requiring pilols

Payload length is multiple slots of 90 symbols each

+ Pilots are grouped in blocks of 36 symbols and
inserted every 16 payload slots

13. In the Frame Part area, select Add Allocation.
14. In the Configuration area:
— Name to Data
— Type to Data
— Sequence to Unknown
— Modulation to DVB-S2/S2X APSK
Notice that Scrambling is not applied to Preamble.
— MODCOD to 256APSK Normal 128/180
— Scrambling to Enabled
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15. In the Location area, set:
— Start Symbol to 90
— Last Symbol to End of Frame
— Select Repeat Pattern
— Set Active Symbols to 0:1439

Before the Pilot block, there are 16 payload slots, each 90 symbols
long resulting in 1440 active symbols.

— Repeat every to 1476 Symbols

The 1440 payload symbols are followed by a 36-symbols Pilot block
resulting in a total of 1476 symbols. This will repeat until the end of
the frame length.

Frame Farts

4 FramePart0
Enabled: L

Name: Data

Typs: Data
4 FramePartl ; 7
‘ower Boost: | 0 dR
Data
Favioad
V| End of Frame
Unknown
+ Repeat Pattemn

Modulation: | DYB-S2/S2X APSK

MODCOD: | 256APSK Normal 1267180 ~

Repeat every 1476 Symbals

Add Frame Part

Add Allocation

Configure the Pilot
16. In the Frame Part area, select Add Allocation.
17. In the Configuration area:
— Name to Pilot
— Type to Pilot
— Sequence to Unknown
— Modulation to QPSK
Pilots are unmodulated, but they are identified by
1=Q=1/v2
— Scrambling to Enabled
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18. In the Location area, set:
— Start Symbol to 90
— Last Symbol, select End of Frame
— Select Repeat Pattern
— Set Active Symbols to 1440:1475
Pilot is 36 symbols long following a 1440 symbols long payload.
— Repeat every to 1476 Symbols

The 1440 payload symbols are followed by a 36-symbols Pilot block
resulting in a total of 1476 symbols. This will repeat until the end of
the frame length.

Frame Parts

Configuration Location
4 FramePart0 9

AllocO Enabled: V! Start Symbol: 90

PLSCODE Name: Pilot Last Symbol

ilot Type: Pilot

4 FramePart1
Power Boost. |0 dB
Data
Payload
¥ End of Frame
Sequence: Unknown

+| Repeat Pattern
Modulation: | gpsk
Repetition Parameters
Scrambling Active Symbols: | 1440:1475
B Repeatevery | 1476 Symbols
Scrambler ID: | g
Add Frame Part

Add Allocation | Remove Allocation
Configure Synchronization and Equalization
19. Select the Measurement Control tab, and set:
— Synchronization Source to Auto

By default, SOF is used for synchronization. This can be changed to
"Customized" to add additional frame parts for synchronization.

— Channel Estimation Source to Preamble and Pilots
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Equalization is off by default. You can choose the different frame
parts for channel estimation and equalization.

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation
—

Component Carrier; CCO

All

195.3125 kHz

Overall Allocation Control

Frequency Estimation & Equalization & Synchronization

Synchronization Source: Auto

Frequency Estimation Mode: Normal
Equalization Mode: Zero-forcing
Channel Estimation Source: Preamble and Pilots

Normalized Channel Delay Spread: | 10 Symbols

EQ Tracking:

Configure the Analysis Region
20. Select the Time tab, set the Result Length to 8000 Symbols.

Setting the result length to < the waveform length when oversampling
ratio of 1, provides the best performance. In Signal Studio, when
oversampling ratio is set to 1, the waveform length is 8370. Using a result
length of <8370 symbols provides the best EVM performance.

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Medulation
-

Component Carrier: | CCO

All

Result Length: | 8000 Symbols
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Configure the RRC filter
21. In the Filter tab, set Alpha/BT: to 0.25.

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation

Component Carrier: | CCO ~

All

Measurement Filter: | poot-raised Cosine Length: | 5, Symbols

Reference Filter:

Raised Cosine

Alpha/BT:

Save the Configuration as a Quick Setup
22. In the Carrier Aggregation tab, select Save As Quick Setup.

This saves the measurement settings for future use. Select Share with all
users if you want to share with other users on the PC running the VSA
software.

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation

Preset Measurement Quick Setups  » Save As Quick Setup...

Selected CC for Trace Display: = €CO PR e Quick Setup P %
= !

Component Carriers Name DVB-52X setup|

Reference Freguency: |0 Hz Share with all users

MName ute Center Offse Symbol Rate (014 Cancel

Copy CCO to... *
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23. Close the Properties window and change Trace A to a Constellation
Diagram, then view the results.

BB Flex Frame - Keysi A Software - Press the Made key ta switch applicotions a 5
ities  Help

- RISV o I & i A
Frame Syme/frs

FlesFrama Summary

FramePart  Allocation oy 2= First SymbolNum of Symbols M

FramezParl

You should see a successful demodulation with very low EVM. Multiple
traces and tables are available including Error Vector Spectrum, Error
Vector Time, demod, and BER Bits.

The FlexFrame Summary table is a type of Matrix Table that provides
sortable rows by column, selectable column visibility, and copy/paste and
export functionality to share rows of content or complete tables to
applications like email, text editing or spreadsheet programs.

Right click the column header to display the menu.

F: {CCO) FlexFrame Summary *

it CAllocotion oxdulation t BER Coburnn Visibiy
i

artd
Expand Al

Pdot | 5281  -11.05
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FlexFrame Summary always displays the EVM of each active segment.
Flex Frame Syms/Errs table shows composite EVM of segment(s) selected
under Measurement Control -> Include EVM. By default, it shows all
segments.

0z (CO0) FeexFrame Summalry

EVM P
FramePant  Alocetion e {d"g":; Num. of Symbols Modulation Format BER

FrameParnd 3 094 B000 el
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Part 2: Generating a DVB-52X Waveform Using the N7608APPC
Signal Studio for Custom Modulation
For this example, we will use the embedded N7608APPC application on the
M9484C VXG.

The VXG must have the N7608APPC Signal Generation for Custom
Modulation license installed. You can also use N7608C Signal Studio for
Custom Modulation

Setting Up the Waveform in PathWave Custom Modulation

1. Onthe VXG, select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 4.5 GHz and Power to
-10 dBm.

4.500 000 000 000 00 GHz

-10.00 dBm

ALC ON

3. Select the Radio Apps block to open the Vector Modulation Signal Setup
panel.

Loy

stom WR-V2X LTE FDI (Beta) LTE TDD (Beta)
dulation (Beta)
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5. In the Custom Modulation setup, select the Carrier tab > Quick Setups >
DVB-S2X > 256APSK > 256APSK 128/180.

Carrier

+ Export 89600 VSA Selup

DvB-s2

DVB-S2% - BAPSK

APCO25 > 16APSK

TETRA 32APSK

NXDN » BAAPSK

dPMR 128APSK >

DECT FSEAPSK > 256APSK 1167180
DMR 256APSK 124/180
ARIB > 2SEAPSK 128/180

Nar  of Symbols “Hoad Constellation Phase Rotation shift Bits Per Symbol Differential  Offset
ZigBea » 256APSK 13580
DataSec 1 9 160AM o 4
Wi-SUN(B0Z.15.4g) > 256APSK 20/30

ITU-T G.9950 ¥ 256AP

1000 Sym

6. From the left pane, select Custom ASK & PSK & QAM Settings and set the
Symbol Rate to 20 Msps per channel.

(", Generate Carrier Wavefarm
i(y Preset  [| Quick Setups [+ Export 80600 VSA Setup

Customn 1Q Selection

7. Select Filter > Alpha to 0.25.
Filter length is 32 symbols, which we will set this value in the VSA.

¥ Generate Carrier

"y Preset [] QuickSetups [+ Fxport 80600 VSA Setup

Custom IQ Selection Filter Root Nyquist «

Custom AS SK & QAM Seltings | 0.25

Length(symbof) 32
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Configure the PLHEADER (Preamble)

In Part 1, the PLHEADER using n/2-BPSK modulation is split into two: SOF
(Start of Frame) of 26 symbols and PLS (PHY Layer Signaling) of 64 symbols for
a total of 90 symbols. The N7608C by default uses a single segment for
PLHEADER with 90 symbols using QPSK modulation and provides a payload of
180 symbols. For the purpose of this example, we will merge the two. You can
split the PLHEADER into two by adding a segment and provide a payload of
52 symbols for the SOF. Since N7608C doesn't support 1/2-BPSK modulation,
it uses QPSK so it would require a payload of 52 symbols for the SOF, instead
of the 26-symbols used in Part 1.

Default constellation symbol mappings of VSA Flex Frame and N7608C/APPC do not
NOTE match. VSA provides .txt files to load into the N7608C/APPC to match the mapping.

These .txt files are in the VSA installer under:
C:\Program Files\Keysight\<version>\89600 VSA Software\Help\Signals\FlexFrame.

I ¥ 7 | FlexFrame - O B
Home Share View
&« v A « Help » Signals » FlexFrame w @ Search FlexFrame £
* [J Name Date modified Type Size
7 Quick access | | DVB_RCS2 Reference Waveform_ID2.f...  10/15/2021 .48 PM SETX File 189 KB
[ Desktop » a Hw_generated_DVB_52X_64_APSK 8 1.  10/13/2021 1:48 PM HTML Docurment KB
& Downloads # [ 7] Hw_generated_DVB_S2X 64 APSK 8. 1... 12/2/2021 1:41PM  SDFFile 65,541 KB
B Documents # [7] Hw_generated_DVB 52X 64 APSK 8_1.. 11/11/202112:35..  SETXFile 125 KB
= pict ¢ 2] Ideal DVB_S2¥_16_APSK 4 12_rate 26_... 10/15/20211:42PM  HTML Document 3KB
&= FICIUres —
|_1 ldeal_DVB_52X_16_APSK 412 rate 26_... | 11:41PM SDFFile 36,869 KB
= [7] \deal DVB_52%_16_APSK_4 12_rate 26_.. 10/15/20211:48PM  SETXFile 132 KB
U 2] Ideal DVB_52%_32_APSK_4 12_16_rate_... 10/15/20211:48PM  HTML Document 1KB
M9424C Demo v [7] \deal DVB_52%_32_APSK 4 12_16_rate .. 12, SDF File 10,006 KB
Users [7] \deal DVB_52%_32_APSK 4 12_16 rate_.. 11/11/ :33.. SETXFile 112 KB
a MixedModulation 0 HTML Document KB
3 This PC - _ . A
- u MixedModulation.sdf SDF File 5,002 KB
- 30 Objects [} MixedModulation.setx SETX File 108 KB
I Desktop [ psks_DVBRCS2 2021 1:43PM  Text Document 1KE
@] Documents |j PSKE_DVBS2 /2021 1:48 PM - Text Document 1KB
‘ Downloads |:] PSKB_WLAN1Tad 5/2021 1:45 PM  Text Document 1KB
J’ Music I:] QAM16_DVBRCS2 2021 1:48 PM - Text Document 1KB
. |j QAM16_ WLANT1ad Text Document 1KB
| Pictures -
Text Document 2KB
B Videos S —
|_1 QPSK_Default /2021 1:44PM Text Document 1KB
AR R e 0/15/2021 1:43PM  Text Document ke
= UserData (D), E apsk_pvas2 0/15/2021 1:43PM  Text Document 1KB
NOTE For the convenience of this demonstration, the QPSK text file has already
been copied onto the VXG.

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples\QPSK_Default_for FlexFrame Example
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8. From the bottom pane, select the PLHEADER row > QPSK constellation to
open the Constellation Edit window.

-+ Add Segmenl  — Remowve Segment + Move Down

Name Type Number of Symbols  Ramp Samples
PLHEADER Data 90 0

Payload Constellation Phase Rolation  Shift 8its Per Symbol  Differential Offset

T80 bits binary data [0001..] QPsK 0 2
DatasSeq Dala 2000 a PN1S DVE-52X 256APSK 128/180

2000 Sym

Insert Delete | Recall | Save Normalize

Name | QPSK Default show Rotation B show Symbol

Q Magnitude Phase  Symbol
0.707 1 45 0000
0.707 1 135 000
0707 1 -45 noo2

0707 1 -135 0003

10. Navigate to the text file and choose Select. Select OK to Close the
Constellation Edit dialog.

{ Back

i er : | ) 3 : » Instrument 3 Documents » Keysight > PathWave 3 SignalGenerator > Exz
j s Comput; ysig g

Date Modified

QPSK_Default_for FlexFrame Example txt

De
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11. In the PLHEADER row, under Payload, select 180 bits binary data [0001...]
to open the Segment Payload Edit dialog. Select and copy the 180
symbols. These will be pasted in to the VSA for synchronization. Select OK
to close the dialog box.

Pattern f&l Load from File [¥) Save to File Clear

000111100010110100010010111011011110111000100010111000100001111000101101001011100010001000011110111011100
001001071010070001011101110007000011110110100011101000100700001000111070010

Current: 0 Total: 180(Max: 128K hits)

Cancel

12. To configure the Payload, from the DataSeq row, set the Number of
Symbols to 1440.

Name Type Number of Symbols  Ramp Samples Payload Constellation Phase Rotation  Shift Bits Per Symbaol Differential Offset
PLHEADER Data | 90 (1] 180 bits binary data [0001...] OPSK_Default_for FlexFrame Example 0

Dataseg | Data | 1440 4] PN1S DVE-S2X 256APSK 128/180 0

PLMEADE Ri

a o0 1530 Sym

Use 16 payload slots (90 symbols/slot) for the radio frame. These are the
slots prior to Pilot. Pilots are optional and not generated (See part 1 of this
demo guide for a frame with pilot segment).

13. In the DataSeg row, under the Constellation area, select
DVB-S2X256APSK 128/180 to open the Constellation editor, and then
select Normalize.
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It is a good idea to normalize the power. Difference power levels between
data and preamble can result in high EVM.

Quick Setups | Insert Delete Recall Save | Nomalize Name DVE-52X 2560 Show Rotation Show Symbol

| Q  Magnitude Phase  Symbol

0.028 0.785 5635 nooon
-0.028 0.285 -5.625 0010
0.028 A 17435 | 0008
0.028 L -174.3 0018
0.083 . 16.87% 0o
-0.083 -16.87 oo1
0.083 . 163.12 | 0009
-0.0683 L2835 -163.1 o019

39.37¢ | DOO2

-39.37 0012

Taner nana

14. Close the Constellation editor and select Generate to generate the
waveform. To view the Generated waveform, select the Waveform tab and
select Spectrum.

s

Custom Modulation (Beta)

carrier Waveform

>tion
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15. Select Home to exit the setup panel.

g (2

Custom Modulation (Beta)

+ Import Signal Satup

16. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

Setting up and Analyzing the Signal Using VSA Flex Frame

Changing settings on the VSA can take longer to take affect than
expected. Wait to change the next setting until the previous setting has
been updated.

1. From the VSA menu bar, select MeasSetup > General Purpose > Flex
Frame.

=
A (CCOL

B: Ch Spectrum

2. Set the correct frequency, span, and input range. For this example, set:
— Change the Trace Layout Grid to 2 x 3.

— Change Trace B to Ch1 Spectrum, and set Center Frequency to
4.5 GHz

— Span to 40 MHz
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— Autorange

W Utifties_Help

8 E5- .la

o Frame Summasy

E 5 _ EVM  Powsr 1
FramePan .ﬂJllIaﬂunl.‘ﬁ:] {dBm) Murn, of Syrmbols Modul ST oD

Freq=4.5 GHz

Span = 40 MHz NOTE: The low-resolution spectrum
will get adjusted automatically when
the correct Symbol rate is set in the
next step
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3. Select MeasSetup > Flex Frame Properties > Carrier Aggregation tab, then
set CCO Absolute Center frequency to 4.5 GHz.

Carrier Aggregation Frame Definitio Measurement Control Time Filter Custom Modulation

Preset Measurement Quick Setups * Save As Quick Setup

Add CC

Configure..

40

5. Error: CCO bandwidth (S ot entirely captured within Ch1 bandwidth

M9484C VXG and X-Series SA Measurement Guide 163



Advanced Measurements
Using the VSA Flex Frame to Create a DVB-S2X Signal

4. At the bottom right portion of the display, select Edit, then select the
Assigned Carriers drop down and select CCO.

Frame Definition Measurement Control Time Filter Custom Modulation

Preset Measurermnent Quick Setups * Save As Quick Setup..

E Acquisition Configuration

=+ Add CC Fregues

Chi Lo

4475 GHz

& Overall Status: Mo Error
. . -

rrelated EVM

Configure...

@ Overall Status:  No Error

5. In the Flex Frame Properties window, select the Frame Definition tab and
set:

— Frame Type to Periodic
— Symbol Rate to 20 MHz
— Length to 1530 Symbols
This is 90 symbols of PLHEADER plus 1430 symbols of data.
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For a bursted signal, Frame Type is set to Burst, and the frame
length can be automatically set based on the detected burst length.

Frame Defmition Measurement Control lime Filter Customn Modulation

odulation

Configure the Preamble (PLHEADER)
6. Configure the Start of Frame Index (Preamble), 90 symbols long:
— In the Frame Parts area, select AllocO.
— In the Configuration area, set
— Name to PLHEADER
— Type to Preamble
— Sequence to Custom
— Modulation to QPSK

— Enter the 180 symbols you copied over from the Custom
Modulation PLHEADER Payload setup in step 11.

— In the Location area,
— Clear the End of Frame checkbox
— Start Symbol to 0
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— Total Length to 90

Frame Parts

) onfiguration
4 FramePart0 2

“PLHEADER
PLHEADER

Preamble

Custom
Repeat Pattern

PE Bit Sequence

0110111
10

Add Frame Part

. . Enabled
Add Aliocation  Remove Allocation il

7. Configure the Payload 1440 symbols long:

— In the Frame Parts area:

— Select Add Allocation

8. In the Configuration area, set:

— Name to Data

— Type to Data

— Sequence to PN15

— Modulation to DVB-S2/S2X APSK

— MODCOD to 256APSK Normal 128/180

— Select Include in BER Calculations

— Select Autodetect Bit Sequence Offset
9. Inthe Location area, set:

— Start Symbol to 90
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— Last Symbol to End of Frame

Carrier Aggregation Frame Definition Measurement Control Tirme Filter Custom Modulation

¥! End of Frame

‘attern

Add Frame Part

Add Allncation || Remowe Allocation

TIP Include in BER Calculations: BER is supported if the allocation's payload
sequence is either a PN type or a Custom bit sequence.

Autodetect Bit Sequence Offset: Supported when the segment(s) is not used
for synchronization.

If not selected (unchecked), demodulator assumes the bit sequence starts at
the beginning of the allocation.

If selected, demodulator finds the best match to the bit sequence.

Configure Synchronization and Equalization
10. Select the Measurement Control tab, and set:
— Synchronization Source to Auto

By default, PLHEADER is used for synchronization. This can be
changed to "Customized" to also include the Data segment for
synchronization. Calculated BER must be cleared (unchecked) from
Data before selecting if for Synchronization.

— Channel Estimation Source to Preamble Only
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Equalization is off by default. You can choose the different frame
parts for channel estimation and equalization.

Carrier # gation Frame Definition Measurement Control Time Filter Custom Modulation

Overall Allocation Control

Frequency Estimation & Equalization & Synchronization

Synchronization Source: Aute

Mormal

Zera-forcing

. Channel Estimati - Preamble Only Initial Equatzation B
Normalized Channal 1

EQ Tracking:

Configure the Analysis Region
11. Select the Time tab, set the Result Length to 1530 Symbols.
90 for the preamble plus 1440 for the data.

Frame Definition Measure

Result Length
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Configure the RRC filter
12. In the Filter tab, set Alpha/BT: to 0.25 and Length to 32 Symbols.

Carrier £ gatior Frame Definition Measurement Control Time Filter [ m Modulation

ment Filter: | pootraised Cosine ength:

Reference Filter:

Raised Cosine

Alpha/BT: 025

Save the Configuration as a Quick Setup
13. In the Carrier Aggregation tab, select Save As Quick Setup.

This saves the measurement settings for future use. Select Share with all
users if you want to share with other users on the PC running the VSA
software.

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation

Preset Measurement Quick Setups  » Save As Quick Setup...

Selected CC for Trace Display: = €CO PR e Quick Setup P %
= !

Component Carriers Name DVB-S etup|

Reference Freguency: |0 Hz Share with all users

ute Center Offse Symb (014 Cancel
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14. Close the Properties window and change Trace A to a Constellation
Diagram, then view the results.

O 1. & i A

axFrame Syme/Errs

Rng -& dBm

dBm

i h'#(-’t’!W"‘W”ﬁ'{""\*"*m

10

ds

J |
-ﬂI;rf Hﬂl‘*'i' hl ”

Cen Stap 1,529 kaym

Wi

Rag BW 49, - TimeLen 7642438

You should see a successful demodulation with very low EVM. Multiple
traces and tables are available including Error Vector Spectrum, Error
Vector Time, demod, and BER Bits.
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The FlexFrame Summary table always displays EVM of each active
segment. However, "Flex Frame Syms/Errs" Table shows composite EVM
of segment(s) selected under Measurement Control -> Include EVM. By
default, it is all segments.

Flexframe Syms/Ems

Cartior Aggregation Frarne Doflisition]  Measusement Control | Time  Fillr

4475 GHE

Component Carrier: 00

di
dB

mideg

Equalization & Synchronizetion

Charnel Estimation Souroe;

FramePart  Allocation

FrameParD Mormalired Channol Delay Spreed

Dhspilay

4 Use Multi-corries Tiller

TxBER/RawBER is returned for the Data segment. NOTE: BER is supported
if the allocation's payload sequence is either a PN type or a Custom bit
sequence. Reference and measured bits are returned.

— BER is expressed as a ratio and calculated as Bit Errors/Bit Count.
— Turn On averaging to accumulate bit count.

— Recording with 0% overlap gives gap free BER data (limited by
memory).
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file LAt G

rama Ret BER Bi

LogMag

1]
dit

FlexFrame Summary always displays the EVM of each active segment.
Flex Frame Syms/Errs table shows composite EVM of segment(s) selected
under Measurement Control -> Include EVM. By default, it shows all
segments.

0z (CO0) FeexFrame Summalry

FramePart  ABocation e

e ::m Num. of Symbols Modubation Format BER

FramePam )9 & M
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FlexFrame Summary table is a type of Matrix Table that provides sortable
rows by column, selectable column visibility, and copy/paste and export
functionality to share rows of content or complete tables to applications
like email, text editing or spreadsheet programs. Right click the column
header to display the menu.

F: (CCO) FlexFrame Summary ~

EVM Power | pm - - -
FramePart  Allocation (dR) (dBm) Num. of Symbols Modulstion Format BER = Column Visibiity
-52

-10.99 2000
SOF -10.88
PLSCODE 11.03 A 2 4 o Collapse All
Dala 52 | 10.99
Pilot | 5291 ' -11.05

FramaPartl
Expand All

4 W/ Metrics

v EVM (dB)

v Power (dBm)

¥ Num, of Symbols

+! Modulation Format
4 W BitErrors

¥ BER

Bit Errors (bit)

Bit Count {bit)

OK
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Creating & Analyzing a bG NR DL 2x2 MIMO Measurement Using

Two UXAs

We will create a 5G NR MIMO signal using a VXG with PathWave Signal
Generation, and then analyze it with using both the X-Series 5G NR
measurement application and the 89600 VSA software.

The hardware setup includes a 2-channel VXG and two N9042B UXAs.

3| ]
o
> . m
> 3 o~
: 4 &
S 3 -
Chl Event 1 A
10MHZ ref
M9484C VXG N9042B UXA
Required Options Required Options
— RF bandwidth of 160 MHz or above — UXAT
B B - - NS042MMOB Multi-box Synchronization for
Two-channel configuration MIMO, Analysis Bandwidth of 160 MHz or
above
— UXA?2
Analysis Bandwidth of 160 MHz or above
Required Software Recommended Software
— MO9484C Firmware version A.11.01 or higher — NO9042B UXA Firmware version 2023 (XA34)
— 7631APPC PathWave Signal Generation for 5G NR ~ ©F Nigher
— NO9085EMOE 5G NR Measurement application
— 89600 VSA

89601200C for VSA Base Core
89601BHNC for VSA 5G NR
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On the VXG
1. Connect the equipment as shown above.
2. Select Preset » Preset to set the VXG to a known state.

3. Select the System menu (triple bar icon at the top left of the window), and
then select Configure Channels > Nx2 <MIMO > Add > Apply > Apply.

figuration

Independent Remaining RF Channels: 4

1 CHANMNEL 2 CHANNELS 4 CHANNELS
Independent 2 Tx Coherent 4T rent

Micd MIMO (Beta)

4. Set the Frequency to 20 GHz and Power to 0 dBm.

20,000 000 000 D00 00 GHz!

|_|'L| > Apps

Keysight PathWave Signal Generation

LTE FDD (Beta) y  LTE TDD {Beta)

Custom
Modulation (Beta)
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6. Select the Waveform tab and set the Total Number of Antennas 2. This
means that two antenna port signals will be generated.

Wavefarm

Markar

ctor Reduction

7. Select the Carriers tab > Cell Specific node, and set Bandwidth to FR2
100 MHz. Keep the rest of the default settings.

sustom Modulation (Beta)
* Generate Carrier V rm
wm FulHfilled Config T+ DLTestModel g™ DL FRC Config « Auto Frequency Offset [+ Export B9600 VSA Selup
seneral Carrier Typa Downlink s
Spectrum Control CelliD 0

FR2 100MHz ~

Numerology Mode
Downlink

Max RB

k0

Configured

8. Select the Downlink node > SS/PBCH > RB Offset by 60 kHz SCS and set
to 0.
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This automatically changes the Delta Frequency to Carrier Center to
-33.12 MHz. Using 0 RB Offset puts the SSB at the lower edge of the
carrier.

“  Custom Modulation (Beta) ™

(", Generate Carrier Waveform

mm Fultfilled Config T+ DLTestModel g~ DL FRC Config - Aulb Frequency Offset -+ Export 89600 VSA Selup

General BWP

NR-PECH Ive Inc 03
W oo e 0,0,0,0,0,0,0,0,0,0,0,6,0,0,0,0,0,0,0,0,0,C
3C| MiB
1}
DL-5CH
0

B csi-rs

33,12 MHZ

0

0ds

9. Select the Downlink node > DL-SCH> Transmission Settings and confirm
DMRS ports is set to 0,1. Set Number of DMRS CDM groups without data
to 2.

Number of DMRS CDM groups without data is used to determine how
many resource elements are reserved for DMRS. When this parameter is
changed, the DMRS power boosting is automatically coupled based on
table 4.1-1 of 38.214.

You will see the layer number is updated to 2 and each layer is assigned
with a particular DMRS port. You'll also see that Antenna Ports Generated
is automatically set to PO,P1, which will map the multiple antenna port
signals to different antennas (instruments).

“  Custom Moduiation (Bzta)

le Carrier

mn Fulbfilled Config T+ DLTestModel §° DL FRC Config & Aulo Frequenc

Cellspecific oo

DMRS Setlings

PTRS Settings

HARQ Settings

10. Select the Resource Allocation node and set:
— Allocated Slots to 2:79
— RB Offset to 20
— RB Number to 20
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DL-SCHO will occupy the RBs 20-40 and DL-SCH1 will occupy the rest of
the resources.

", Generate Camer Wavelorm

mn FulHilled config T+ DL TestModel | DLFRC Config - Auto Frequency Offset [+ Export 89600 VSA Setup

General BwWP ue General Settings
First Symbol
L ast Symbal

Bandwidth Part
Modulation and Coding

DMRS Settings

PTRS Settings

HARQ Setlings

11. Select the Modulation and Coding node and set:
— MCS to 20
— MCS Table to 5.1.3.1-2 (256 QAM)
Notice that modulation is updated to 256 QAM.

Generate Carrier Waveform
mm Fullilled config T+ DLTestModel g~ DL FRC Conflig <« Auto Frequency Offsel [+ Export 80600 VSA Setup
General BWP . General Setlings
spectrum Control [l SS/PBCH Transmis

Regource Allocation

DMRS Settings

PTRS Settings

HARQ Sellings

12. Select the DMRS Settings node and set DMRS Power Boosting to 3 dB.
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When CDM Group Number is 2, DMRS power boosting becomes 3 dB per
3GPP.

, Generate Carrier Waveform
#m FulHfilled Corfig T+ DL TestModel g™ DL FRC Config & Auto Frequency set [+ Export 80600 VSA Setup

BWP 4 was General Settings

Spectrum Control . PBCH Transmission Settings

M oci Resource Allocation

Modulation and Coding

PTRS Settings

HARQ Setlings N ID.O Cell ID

13. Under the DL-SCH 0 node, select the + icon to add a new +DL-SCH
(DL-SCH1).

& oenemte Camier  Waveforr [+ Import Signal Setup

wei Ful-filled Config T+ DL Tes! Model < Aulo Frequency

PTRS Settings
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This will create a conflict between DL-SCHO and DL-SCH1. This will be
resolved in a later step.

mH Full-filled Config  T* DLTestModel K" DL FRC Config & Auto Frequency Offset
General BWP | wan General Settings
Spectrum Control |l SS/PBCH H Transmission Setiings
Call-Specific | [ile] DL-SCH 1 Resource Allocation
Modulation and Coding

Il csi-Rs

B LTE-Coexistence PTRS Settings

H Prs HARQ Settings

Channel Allocation Summary

14. From the Channels node, select DL-SCH > DL-SCH1 > Transmission
Settings and set DMRS port(s) to 0,1. Change the Number of DMRS CDM
groups without data to 2.

180 M9484C VXG and X-Series SA Measurement Guide



Advanced Measurements
Creating & Analyzing a 5G NR DL 2x2 MIMO Measurement Using Two UXAs

Notice that Number of Layers is updated to 2 and each layer is assigned
with a particular DMRS port. Antenna Ports Generated is automatically
assigned PO,P1, which will map generated multiple antenna port signals
to different antennas (instruments).

Custom Modulation (Beta)

Carrier Waveform
mn FullilledConfig T+ DLTesiModel g° DLFRC Config < Aulo Frequency Offsel [+ Export B9600 VA Selup

General | sun General Settings Antenna P

Spectrum Control S5/PBC DL-SCHO DMRS pe

: Number of
Cell-Specific S Resource Allocation

Number of Antenna ports
Mnodulation and Coding

B Csi-RS DMRS Settings

. LTE-Coexislence PTRS Settings

LS HARQ Settings
15. Select the Resource Allocation node and set:
— Allocated Slots to 2:79
— RB Offset to 45
— RB Number to 18

Notice that this resolves the conflict between DL-SCH channels. (The pink
shading is removed from the Channel Allocation graph. To clear the
conflict error message at the bottom of the display, select the Message
icon (bottom, right corner) and select Clear.

(%, Generate Carriet Waveform
mm Fullfilled Config T+ DL Test Model  g° DLFRC figy & Auto Freguency Offset + Expaorl 8¢
General BwP - General Soitings

Tranamis

Channel Allocation Summary

EF INT |ocked
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16. Select the Modulation and Coding node, and set MCS to 20.

Use the default MCS Table to Table 5.1.3.1-1 (64QAM). You will see the
modulation is updated to 64QAM.

ed Conflg T+ DL TestModel g DL FRC Config

Channel Allocation Summary Framed ~  p=3 ~ gn Display Detail

17. Select the Waveform tab > Select Generate.

View the waveform by selecting Spectrum on the bottom display.

18. Select the File icon on the top right and select Export Signal Setup (*.scp),
and save the file.
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You will need to copy this setup file to the UXA to speed up demodulation
on the UXA using X-Apps.

7 Open

Save As

Export Waveform

Import Signal Setup (*.scp)

ExportSne Sup (:5)

19. Select the Carrier tab and select Export 89600 VSA Setup and save the
file.

You will need to copy this setup file to the UXA to speed up demodulation
on the UXA using the 89600 VSA software.

& Generate Carrier Waveform
m Fullfilled Config 7" DL Test Model @° DL FRC Config < Auto Frequency Offset " Export 83600 VSA Setup
General Carrier Type Downlink
Spectrum Control Cell ID 0
Bandwidth FR1 100MHz ~
Single Numerology
Downlink
Numerology p=1:30kHz v
Max RB

ko

Intra-Cell Guard Band (u = 1)
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20. Select the Home icon and set RF Out to On by selecting the numbered
channel indicator switches, and then select RF Out (All) master control
switch to turn the RF output On for both channels or off for both channels.

20:000 000 000 000 00 GHz

0 dBrm

| Adjustrnents I
20,000 000 000 000 00 GHZ

0 dBm i

21. Select the Signal block to open.

| Group 1: Signals
File None selected

22. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.

Frequency Offset

WOW WV VWV VWV
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23. Select the Trigger tab and set Trigger Source to Global Trigger.

”| » Group 1: Signal Summary » Signal 1: Setup

General Trigger Mode Trigger Source Global Trigger

Waveform File Sl 2 Global Trigger

Trigger Corintots Moce Synchronization State
Trigger & Run On
Markers
Trigger Delay Edit Global Trigger >

Os

Enable Playback Synchronization

| Group 1: Signals .; ._,f\:d‘u_s_t_rpems .
Na fife sefected off i

Off

1/Q Out ‘

Demodulate the 5G NR 2x2 MIMO in X-Apps

Changing settings on the VSA can take longer to take affect than
expected. Wait to change the next setting until the previous setting has
been updated.

On the Primary UXA:
1. From the N9042B select Mode/Meas > 5G NR &V2X Mode > OK.
If accessing the instrument via a Remote Desktop connection, select the

Screen tab (at the top left of the display) to open the
Mode/Measurement/View Selector window.

2. Select Mode Preset to set Spectrum Analyzer 5G NR mode to a known
state.

3. From the N9042B Menu Panel (or the Screen tab), select Mode/Meas > 5G
NR & V2X Mode > Modulation Analysis Measurement > OK.
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4. From the Menu Panel, select Meas Setup > Radio and turn MIMO On.

Meas Setup

Component
Camers

S | Meas Time
Muilti Channel

Config Channel

: Profile

Interfening Signal Advanced
Present N

Decode

Power
| Meas

5. Select Multi Channel Config to open the Configuration dialog box.
— Set Channel 1 IP Address to Local
— Enter the IP address for Channel 2
— Select Locked for both Channel 1 and Channel 2

Conhguraton

Channed 1
Channel 2

Unused local

Unused  local
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Once MIMO mode is ON and both channels are locked, the
secondary N9042B display changes as shown below.

Remote 89600 VSA

A remote computer (o instrument) with hosiname "UXA-US90420226 s currenly controling the local hardware
To resume the local signal analysis aclivibies, pléase release the hardware from the remole computer (of instrument)

instruchons o release the local hardware

it the local har

if the local hardware s controlied by the XSA MIMO measurement

Locate the remole wter (or instrument) with hosiname UXA-USS0420226
Bring up the active measuremnent o Single mode
of swilch 10 another measurement, of close the application

6. Select Recall (If accessing the signal analyzer remotely, select the Folder
icon at the bottom of the display) > Demod Info > set Data Type to CC
Setup > Recall From > and Recall the setup file.

You must be in the correct analysis mode to recall the .scp file.

7. Select Trigger > Trigger tab and set Select Trigger Source to External 1
and Trigger Level to 1 V.

Q Trigger

Select Trig Source
External 1

" Penodic

Trigger Level Sync Src
100V
Auto/

I Trigger Delay | Holdoff
1

1.000 ps

On
Off

Trigger Siope
] Positive
Negative
Trigger Settings
Diagram

8. Select Meas Setup > Settings tab> Optimize EVM.
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Optimize EVM is an immediate action to adjust the hardware settings to
minimize EVM.

&

Normal method will capture input signal, measure its peak power
then the algorithm will find proper setting combination for
attenuation, preamp and IF Gain.

Iterative method will capture input signal multiple times in a
iteration process, demodulate the signal and calculate EVM for each
iteration and find setting combination for attenuation, preamp and
IF Gain with minimum EVM.

For 5G NR signals, this method is much slower, than normal, but
with achieve better EVM results. You can also manually adjust IF
Gain, Frequency Extender Attenuation (use when measurement
setup includes a V3050A frequency extender).

Meas Setup ¥

Component Carmier

CCo

Avg|Hold Number

10

Averaging
On
on

Radwo

Average Mode Meas Time

Exponential

Channel

Acquesition Mode Profile
Sequental ¥ | Advanced

Decode

Power
Meas

Optimize EVM

EVM Optimization

Method
Normal
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View the results.

Demodulate the 5G NR 2x2 MIMO Using VSA:

1. Open the VSA software by selecting Mode Meas > Launch VSA.

If accessing the instrument via a Remote Desktop connection, select the Screen tab (at the top
left of the display) to open the Mode/Measurement/View Selector window.
2. To configure the hardware, go to Utilities > Hardware > Configurations.

3. Open the Discovered Instruments tab and verify that the two UXAs are
listed, if not, select the Rediscover Instruments icon.

2= Hardware ? X

Configurations Discovered Instruments

4 TCPIPO
Keysight N9042B Signal Analyzer (TCPIP0:141.121.151.206:inst0:INSTR)
Keysight/Agilent PXA Signal Analyzer (TCPIP0:K-N9030B-42898:inst0:

Keysight/Agilent UXA Signal Analyzer (TCPIPO:k-n9040b-122
Keysight N9042B Signal Analyzer (TCPIPO:uxa-us9042010:
Keysight/Agilent PXA RF Tuner (TCPIPO:K-N9030B-428!
Keysight/Agilent UXA RF Tuner (TCPIPO:k-n9040b-12206:i

b SIM

P USR
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4. In the Configuration tab, select the + icon.

= Hardware 7 x

gurations Miscovered Instruments

Current Analyzer Configuration: Ap

Channels: Baseband: 2 C

+ &

4 Analyrer Configurations

5. Scroll down the Possible Logical Instruments and select Keysight/Agilent
X-Series Signal Analyzer twice.

a. Select the first Keysight/Agilent X-Series Signal Analyzer and then
press the right arrow to move it under the Configuration area.

b. From the middle of the dialog box, select the down arrow next to the
Analyzer and select the IP address of the Primary UXA.

c. Repeat the two steps above for the second signal analyzer but
select the IP address of the Secondary UXA.

ﬁ Mew Hardware Configuration 7 =

Select the logical instrument(s) to use. Sources and Analyzers cannot be combined within the same configuration.

Simulate Hardware

Possible Logical Instruments e Configuration
4 Analyzer -
Keysight VSA Stream
Keysight/Agilent X-Series Signal Analyzer
CXA EXA MXA, MXE PXA
LA, CXA-m, UXM Series.
Frequency range depends :
upon model and options. Hints:
Baseband or RF inputs -
depending upon options. The primary instrument that has trigger out wired
to trigger in on the other instruments must be
placed first in the configuration,

ht/Agilent X-5Series Signal Analyzer

Keysight/Agilent X-Series Signal Analyzer

2. Select the instrument(s) to use for each logical instrument in the configuration,

ADC Keysight N9042B Signal Analyzer TCPIP:141,121.150.79inst0:INSTR. =

6. Select OK to create the new configuration.

M9484C VXG and X-Series SA Measurement Guide



Advanced Measurements
Creating & Analyzing a 5G NR DL 2x2 MIMO Measurement Using Two UXAs

7. In the Configurations tab, set the Current Analyzer Configuration, select
the Analyzer number for the new configuration. In this example Analyzer 3.
= Hardware ? x

ions Discovered Instruments

Current Analyzer Configuration: Analyzerd

4 Analyzer Configurations

[mL] NI042EB (TCPIPD: 141.121.1

4 Analyzerd

8. From the menu bar, select Input > Channels > RF > 2 Channel.

E Vector - Keysight PathWave Vector Signal Analysis (89600 VSA)

File Edit Control Source | Input | MeasSetup Trace Markers Window  Utilities Help

Channels > ﬂ Baseband: 2 Channel » 1 Channel
Analog... 1+jQ » |¥ | 2Channel
Custom... 3 Channel

Digital...
o 4 Channel
Trigger.

Playback Trigger...

External Mixer...

Extensions...

User Correction...

Playback User Correction... Ti

|
in

H"n Al
i I
Data From vV " | 'ﬁl

I'."thl o [
Vi ‘l‘ \| l“

Recording...
Select Switch: None

Switch...
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9. From the menu bar, select File > Recall > Recall Setup and navigate to the
.setx file you save during the VXG waveform generation.

E Vector - Keysight PathWave Vector Signal Analysis (89600 VSA)

File | Edit Control Source Input MeasSetup Trace Markers Wi
Fa Recall Recall Setup...

Preset

D Save

Export
Copy Trace...
— -
() Print.. Ctrl+P

Exit Alt+F4 Recall Demo...

You can also set the frequency and span of both channels under Meas
Setup > Frequency.

If you are using a UXR, Select Autorange.

Auto Range samples the current input signal and then sets the full scale
input range to the minimum range that includes the peak voltage sample
of the input signal.

B Victer - Kevsiaht S9500VSS Sabtwase == - -

% Meas01 - MeasSetup 7 X

Frequency ResBW Time WETAGE

Measurement Channek m n ﬂ

LCenter Span:

100 MHz

¥ Auto Frequency Step

Time Data:

Zoom v Mirror Frequency

i

Meatment paaied

2 O m € & L

10. From the menu bar, select Input > Trigger and set:

— Style to External
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— Levelto1V

11. From the menu bar, select MeasSetup > 5G NR Demod Properties>
Advanced tab and select the DC Punctured check box.

As part of conformance test, 3GPP has defined different equalizer training
and tracking for EVM measurements. 3GPP Conformance Test is enabled
by default where Tracking, Equalizer Training and EVM Window, and
Symbol Timing is applied per 3GPP conformance test requirement. For
FR1, no tracking is applied. For FR2, Phase Tracking using PTRS is applied.
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5G NR counts the DC subcarrier as a valid subcarrier for rate-matching
purposes. The network decides if the DC subcarrier is modulated or not.
High LO feedthrough will impact demodulation and EVM performance of
the input signal. This is OFF by default.

Configuration Input & Antenna Time Decode Advanced

¥ 3GPP Conformance Test

Tracking: Equalizer Training

Symbol Timing Transient Period
Length:
Power Change Threshold: . o
1Q Impairments
10 Imb. Estimation Mode:  Off

Compensate 1Q Offset V| DC Punctured

UL Spectrum Flatne

ronment Condition:  Mormal * Test Tolerance: 14 dB

~ | Freq Domain: | Per Subcarrier =

12. Close the 5G NR Properties dialog.

13. From the toolbar, select the Auto-Range dropdown and select EVM-Table
or Algorithm Based.

— EVM - Table or Algorithm Based performs EVM optimization based
on prescribed table/algorithm instead of using EVM in the feedback
loop. This method of EVM auto-range is normally faster than Meas
Based Iteration, but may not achieve the most optimal setup for
minimized EVM).

— EVM - Meas Based Iteration has a feedback loop around the entire
measurement, uses the measured EVM in the feedback loop, and
tries to adjust hardware parameters to minimize the EVM. It is the
slowest EVM auto-range method, but it should achieve the most
optimal setup for good EVM.

HEe Rl A
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Creating and Analyzing a 4x4 MIMO using a UXR Running VSA
Software

Equipment Setup

M9484C front panel Channel 1 Event 2 to UXR rear panel Aux Trig In

M8484C rear panel 10 MHz Out A
to UXR rear panel 10 MHz Ref In

' .—'_-o 4 + ; ol L R
A 4 s
CH1 RF1 Out  UXR

CH2 RF2 Out UXR
CH3 RF3 Out UXR
CH4 RF4 Out UXR

— M9484C

— Four channels (M9484C-004)

— N763TAPPC PathWave Signal Generation for 5G NR
— UXR0334

— UXRO00-602: DDC option with 2 GHz BW

— 89600 PathWave Vector Signal Analysis (VSA)

On the VXG:
1. Connect the equipment as shown above.

2. Select Preset » Preset to set the VXG to a known state.
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Instrument Information
/o configuration
Alignment

clobal Trigger/Sync
Power On/Presel
Reference

1/Q Waveferm

Service

Preforences

Advanced Measurements
Creating and Analyzing a 4x4 MIMO using a UXR Running VSA Software

If a Synchronization Alignment is required, indicated by in the
bottom left corner, tap or click the warning message and choose Perform

Alignment before proceeding.

2 Instiu

Glohal Trigger Synchronization Status

hronization On

Immediate

Synchronization Aignment

Perform Alignment Clear Alignment

3. In the Output area for all four channels, set the Frequency to 5 GHz and
Power to -10 dBm.

5.000 000 D00 000 00 GHz

5.000 000 00O 000 00 GHz

-10.00 dBm

ALC DM

5.000 000 DOO 000 00 GHe

-10.00 dBm

ALC ON

5.000 000 DOO 000 00 GHz

10.00 dBm

ALC ON
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4. Select the Apps block to open, then select 5G NR.

[nl ?

Keysight PathWave Signal Generation

Custom Y23 LTE FOD (Beta) LTE TDD (Beta)
Modulation (Beta) .

5. Select the Carrier tab > DL Test Model and set the Test Model to
NR-FR1-TM3.1. Leave other settings as default and select OK.

. NR-FR1-TM3.1
Bandwidth FR1 100MHz

p=1:30 kHz
> Duplex Type

NR-FR1-TM3.1

DCDLSCH Payload Data

6. Select the Waveform tab and set the Total Number of Antennas to 4. This
indicates that two antenna port signals will be generated.
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7. Select Generate to apply the signals to each channel. The expected
spectrum can be observed in the bottom window.

= B~

(, Generate Carrier Waveform

|-+ Exporl 89600 VSA Setup

Marker
Crest Reduction
AWGHN

Routing

8. To simplify analysis, select Export 89600 VSA Setup and save the file.

.JIJ % Apps:5GNR

Carrier Waveform

|-+ Export 839600 VSA Setup

Capability Waveform Playback

4

Required Lic
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9. Select the Home icon to return to the main block diagram, and then
select the gray 1, 2, 3, and 4 to turn on each channel.

Output Mod | RF output
5.000 000 000 000 00 GHz

-10.00 dBm

ALC OFF

5.000 000 000 000 00 GHE

-10.00 dBm iﬂ?m

ALC OF

5.000 000 000 000 00 GHE

10.00 dBm

ALC OFF

5.000 000 000 000 00 GHE

-10.00 dBm

ALC OFF

On the UXR
1. Open the VSA software.

To access the VSA software, go to the Windows Start menu and find
Keysight 89600 Software (latest installed version) folder and run the
software.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

2. From the VSA menu bar, select File > Preset > All to set the VSA to a
known state.
3. To configure the hardware, go to Utilities > Hardware > Configurations.

If it is already configured, go to step 10.
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4. Open the Discovered Instruments tab and verify that the UXR is listed, if
not, select the Rediscover Instruments icon.

2= Hardware ? X

Configurations Discovered Instruments

4 TCPIPO
Keysight N9042B Signal Analy CPIP0:141.121.151.206::i
Keysight/Agilent PXA Signal Ana (TCPIPO:K-N9030B 9
t/Agilent UXA Si E (TCPIPO:k-n3040b-12201
ght N9042B Signal Anal ( = 90420108:inst0:
ght/Agilent PXA RF Tuner ( K-N9030B-428 INSTR)
Keysight/Agilent UXA RF Tuner (TCPIP0:k-n9040b-12206:inst0:INSTR)
b SIM
P USR

5. In the Configuration tab, select the + icon.

2= Hardware ? b4

figurations Dhscovered Instruments

Current Analyzer Configuration:  Anahzer?

+

4 Anzlyrer Configurations

Samulated

3 Stream
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6. Scroll down the Possible Logical Instruments and select Keysight/Agilent

Infiniium Series Oscilloscope, and then select the right arrow to move it
under Configuration.

= New Hardware Configuration

? X
1. Select the logical instrument(s) to use. Ces

ces and Analyzers cannot be combined within the same configuration
it Simulate Hardware
Possible Logical Instruments

4 Analyzer

Keysight/Agilent Infiniium Series Oscilloscope
Keysight VSA Stream

. Configuration

Keysight/Agilent Infiniium Series Oscilloscopd

ndwidth from
z depending
upon model. 4 Inputs.

Hints

ect the instrument(s) to use for each lo trument in the configuratio

ADC Keysight/Agilent Technologies Infiniium Series Scope TCPIPO:locathost=inst0=INSTR -

me the configuration

Cancel

7. From the middle of the dialog box, select the UXR to be used.

2. Select the instrume o use for each logical instrument in the configuration

ADC Keysight/Agilent Technologies Infiniium Senies Scope

TCPiPO:localhost:instO=:INSTR -

8. Select OK to create the UXR configuration.
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9. In the Configurations tab, set the Current Analyzer Configuration by

selecting the Analyzer number for the new
Analyzer 3.

Disc

Configurations ered Instruments

Current Analyzer Configuration: Analyzerd

4 Analyzer Configurations

4 Ana

Infimiium (SIM:Infinitum)
Analyzer3
4 Keysight/Agilent Infiniium Series Oscilloscope
Infiniium (SIMzInfin
es Oz

t/Agilent Infiniium S cilloscope

[mE] Infipiium (SIM:Infin

configuration. In this example

Baseband: 1 Channel

Analyzer

Group Type:

Analyzer

10. From the menu bar, select Input > Channels > Baseband > 4 Channels.

Input || MeasSetup Trace Markers Window  Utilities

» Baseband: 4 Channel
1+jQ

Channels

Analog...
Digital.. Custom...
Capture...

Trigger...

Playback Trig

External M

Extensions...

Us orrection...

Playback User Correction...

Data From

cording...
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3 Channel
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11. From the menu bar, select MeasSetup > Frequency and set the Center
Frequency to 5 GHz and Span to 100 MHz on all four channels.

Utilities  Hel,

MeasSetup | Trace Markers Window

E Meas01 - MeasSetup
Frequency ResBW Time Average

Measurement Channel:
Center: Span:
5 GHz 100 MHz

v Show Center/Span Full Span

| Auto Frequency Step

Time Data:

Zoom Mirror Frequency

12. If External Trigger is available, it is recommended to use it to speed up the
demodulation of the measurement. From the menu bar, select Input >

Trigger and set:
— Style to External
— Levelto1V

Trigaer Pl
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13. Select File > Recall > Recall Setup and navigate to the setup file you
saved during the VXG 5G NR setup.

You will need to copy over the setup files to the X-Series Signal Analyzer or
the PC running the VSA application, or continue with the settings below to
setup the VSA manually.

14. From the menu bar, select MeasSetup > Measurement Type > Cellular >
5G NR > 5G NR Modulation Analysis.

15. To configure the Analysis region, select MeasSetup > 5G NR Demod
Properties > Configuration tab and select Open Test Model > TM3.1 >
Apply > Close.

. e

Configuration | Input & Antenna  Time 28 Test Mode!

Save As Quick Setup...  Quick Setups. @ Settings changed but not applicd.

3GPP Version: Latest (2022-03)
Carriers Link Direction: ‘e Downlink

Carrier Indexes:

Configure... + Add Carrie
Bandwidth: FR1 100 MHz ~

4 Channel Reference: €CCO - Displa Duplex Type: DD

Numerology: p=1:30kHz ~

BELCH / Test Model M3

PDSCH
Maodulzation Format:

CSl-RS
Cro

Results & Filters T
Confic

Manually apply settings
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16. Select the PDSCH tab, scroll down, open the Antenna Port tab and set
Antenna Ports Used to 0:3. Repeat for the remaining PDSCH channels by
selecting the corresponding number at the top.

Configuration Input & Antenna Time Decode Advanced
Quick
Add Re I5CH Clear All Enabie Channels...

POSCH: u T2

Modulation

Resulting Format: DoDDDDDDDDDDDD

Transport Blc RE R SET ID: -1 - RA Type:

3RB RE Number

nip Source Cell ID

nip

Antenna Port

Wideband

17. To reduce measurement time, select MeasSetup > 5G NR Demod
Properties >Time and set:

— Result Length to 5 Subframes
— Meas Interval to 2 Subframes

— Enable Frame Trigger is present.

206 M9484C VXG and X-Series SA Measurement Guide



Advanced Measurements

Creating and Analyzing a 4x4 MIMO using a UXR Running VSA Software

We are using an external trigger for this example so selecting Frame
Trigger is Present will use the external trigger and will speed up the

measurement significantly. If not using an external trigger, set to

Normal.

Configuration Input & Antenna Time Decode Advanced

Analysis Region
Result Length: 5 Subframes 0 Slots
Meas Offset: 2 Subframes 0 Symbaols
Meas Interval: 3 Subframes 0 Symbaols

Time Scale Factor: 1

Analysis Start Boundary Acquisition Mode

MNormal
® Frame
- Reduced acquisition length
Half-frame
) Frame trigger is present
Subframe
Slot trigger
Slot

First Slot Index

Timing Diagram

Result Length 5 Subf. ———

Meas. Interval 3:0
* Meas. Offset 2:0

Frame Boundary

18. At the top of the display, select Autorange.
File Edit Control rce  Input  Me tup Trace Markers Window Utilities

| | |$- n'l.ux All = Range To Peak Power (Default) -

A: OFDM Meas: All Layers
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l I Z
I i !
I l | |
i I : | ‘
i l i i i
| l | 1
T :
I | 1 |

Nnn af

19. Observe the demodulation results.

File Edit Coni fry y Marcers Window  Uhilities  Help

o

cmia W5

RANTI  BWPID

Madulztio My

G MRS MIMD Info

— Trace A: Composite constellation diagram showing different
modulation formats for the different channels/signals present in the
transmitted signal. See Trace F (Frame Summary) for the list of
channels and modulation formats.

— Trace C: Summary trace showing composite error metrics.

— Trace D: Error Vector Spectrum showing EVM versus subcarrier and
symbol.

— Trace E: Detected Allocations Time showing the detected
allocations of all channels/signals within the measurement interval.

— Trace F: Frame Summary. EVM, per Layer EVM, Power per RE, Mod
Format, Number of RB, RNTI, and BWP ID of the individual
channels/signals.

— Trace G: MIMO Info table shows EVM, power, and time, frequency
and phase offset for each antenna port.
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MIMO Info is a type of Matrix Table that provides sortable rows by
column, selectable column visibility, and copy/paste and export
functionality to share rows of content or complete tables to
applications like email, text editing or spreadsheet programs.
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4 QOther X-Series Signal Analyzer Measurements

KEYSIGHT

TECHNOLOGIES

“Setting Up a Group Delay Measurement” on page 212
“Setting Up Millimeter-Wave Measurements” on page 222
— “Setting up a 5G NR Millimeter-Wave Measurement” on page 222

— “Setting-up a Millimeter-Wave DVB-S2X 64APSK Measurement” on
page 231

— “Setting-up a Millimeter-Wave 5G NR, 2 GHz BW FR2
Measurement” on page 253

“Using the X-Series Analyzer’s SCPI Recorder Function” on page 277
“Using the X-Series Analyzer’s Preload/Unload Function” on page 290
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Setting Up a Group Delay Measurement

Group delay is a measure of phase distortion. Group delay is the actual transit
time of a signal through a device under test as a function of frequency. When
specifying group delay, it is important to specify the aperture used for the
measurement.

In a group delay measurement:

— The linear phase shift component is converted to a constant value
(representing the average delay).

— The higher order phase shift component is transformed into deviations from
constant group delay (or group delay ripple).

— The deviations in group delay cause signal distortion, just as deviations from
linear phase cause distortion.

— The measurement trace depicts the amount of time it takes for each
frequency to travel through the device under test.

In this measurement example, we will use the M9484C VXG to generate a
wideband modulated signal, drive this through a filter and the N9042B UXA
will analyze the output signal and display the filter characteristics (gain, phase,
and group-delay). Also, all settings to the VXG will be made via the Connection
Management setup in the N9042B/N9056EMOE application.

We will start by running a calibration to remove the fixture characteristics
(cables, connectors, and other passive components) between the source and
the device under test (DUT), in this case the filter. The filter in this example is a
500 MHz bandpass filter, centered at 10.27 GHz. Settings my need to be
adjusted for your filter.

For this example we are using the follow equipment:
— M9484C

— Frequency range to 13.5 GHz (M9484C-514, M9484C-520,
M9484C-532, or M9484C-544, or M9484C-554)

— N9042B (you can also use a N9040B, N9033B, N9030B, N9020B, or
N9021B)

— N9056EMOE Channel Quality/Group Delay Measurement application

— Accessories
— Two 3 dB attenuators

— Baseband filter
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1. Connect the two 3 dB attenuators, cables and adapters between the VXG
and UXA (omitting the filter).

Altenualc Bandpass filter

After running a calibration to remove the effects of the fixturing, we will
insert the filter between the two attenuators.

2. From the N9042B, select Mode/Meas > Channel Quality/Group Delay
Mode > Group Delay Measurement > Quad display View.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

The Quad display shows the Spectrum, Gain Phase, Gain Magnitude, and
Group Delay measurements.

3. In the Frequency menu panel, set the Center Frequency to 10.27 GHz and
Span to 1 GHz.

4. In the Meas Setup menu panel, select the Signal Generator tab and
confirm the Center Frequency is set to 10.27 GHz (the frequency of the
filter) and set the Amplitude to +10 dBm.

The power is set to +10 dBm to compensate for the affects of the
attenuators on the edges of the trace.This is because the SNR has been
reduced by the attenuators and without increasing the power you would
be essentially measuring the "noise" at the edges.

5. Select Connection Management.

6. In the New Signal Generator area, specify the Hostname or IP address of
the VXG, then select Add to Generator List > Connect.
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This allows us to setup the VXG directly from the UXA.

Connection Management

nerator List
Name {OpBional)

Information

New Signal Generator
Hostna Add To Generator
Address List

Delete Setected
Generator

7. Select Apply Settings to Signal Generator to send these settings directly
to the VXG, then Close the Connection Management window.

8. In the Meas Setup menu panel select the Tone tab and set the Number of
Tones to 501 with a Tone Spacing of 1 MHz to provide a 500 MHz
wideband signal.

| Threshold Level
| -50.00 dB

On

Off

| Measurement Rz

i 49599 MHz
Auto

| onesto ||
enerator ||

Notice that the span has automatically changed to 626.3 MHz to
accommodate the Tone settings.

9. Select Configure Tone Table. There are lots of settings to choose from, but
we will use these default settings.
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— Fill Type to Random Phase
— Random Seed Type to Fixed
— Random Seed to 0

10. Select Apply Fill and all of the phase points get filled in for the 501 points.
(Originally there were 64.)

11. Select Apply Tones to Signal Generator to setup the multitone signal.

You will notice there is some ripple in the traces.

If there is an Input Overload in the UXA, go to Amplitude > Attenuation tab > and increase
the Mech Atten 2 dB at a time until the overload condition is resolved.

12. Close the Configure Tone table.
13. Select the Calibration tab > Calibrate Tones.

The calibration will calculate the difference between tone definition and
average input trace (magnitude and phase).

14. Once the calibration is complete, connect the filter between the two 3 dB
attenuators to see the response of the filter.

15. For this example, set the Gain Magnitude Scale/Div to 5 dB and the
Group Delay Scale/Div to 1 ns. For your specific measurement adjust the
screen settings to a value that allows you to get the best signal resolution
on your measurement displays.

Input Z 50 0 Atten; 12 dB [Trig: Free Run Center Froq. 10.270000000 GHz
Com CComr RCal Pre: int off, LNA off AvqgiHold > 2525
Freq Ref Ext (5 BW Paih: Bypass
Bus Out: Of
5 (aln Phase

Scale/Div 10.00 dB Ref Value 0.00 dBm Scale/Div 20.00 * Ref Value 0.0

Ll o LAl | i 1L | I [Tl I 1 1 i 1 1 1
f Center 10.2700 GHz Span626.3 MHz Center10.27006Hz ~~ Spanb263 Mhz
1 Gain Magnitude v i f Group Delay v
Scale/Div 5.00 dB Ref Value 0.00 dB i Scale/Div 1.000 ns Ref Value 0.000 s
on T ] [ T
|

Center 10.2700 GHz ] Span 626.3 MHz|Center 10.2700 GHz Span 626.3 MHz|

M9484C VXG and X-Series SA Measurement Guide 215



Other X-Series Signal Analyzer Measurements
Setting Up a Group Delay Measurement

16. From the menu panel, select Marker > Settings > Marker Settings
Diagram.

17. Activate Marker 1 by setting Marker Mode to Normal and set Marker
Trace to Gain Phase. Click and drag Marker 1 to the Reference Marker 2
position. Activate Marker 2 by setting Marker Mode to Delta, then set
Marker Trace to Gain Phase to put the marker on the Gain Phase
measurement, then Close the window.

The Gain Phase is really input versus output instead of absolute phase.

Marker Settings Diagram

Touch a Marker fo select it.

Norm

1A

v

Reference 2
Marker

Drag a Marker to another Marker's reference position to make it
the reference Marker for that Marker

St Marker Mode Marker Trace
SSIEERNE Detta (8) Gain Phase

Marker 2

18. Move Marker 1 to the Peak of the Signal within the bandwidth range of
the signal and Marker 2 to the minimum.
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This provides the peak-to-peak deviation across this portion of the
bandwidth of the filter. For this example, Peak to Peak Deviation is
54.69 °.

KEYSIGHT IlnpuL RF Input Z: 50 O Atten_ 12 dB Trig. Free Run Canter Freq. 10270000000 GHz
| G Comr CCom RCal Pre: imt off, LNA off MovglHald > 2525
0 T i nal W Path: Bypass

| 5 Gain Phase

Scale/Div 20.00 *

1 Spectum
Scale/Div 10.00 dB Ref Value 0.00 dBm

|
|
1
|
|
1
|
_i_
|
|
|

f Center 10.2700 GHz ' I Span 626.3 MHz|
4 Gain Magnitude & Group Delay
Scale/Div 5.00 dB Ref Value 0.00 dB Scale/Div 1.000 ns Ref Value 0.000 =

| Center 10.2700 GHz ] Span 626.3 MHz/Center 10.2700 GHz

19. Go back into the Marker Menu and turn on Marker 3 and set Marker Mode
to Normal and Marker Trace to Avg Group Delay. Drag Marker 3 to Marker
4’s Reference Position. Turn on Marker 4 and set Marker Mode to Delta
and Marker Trace to Avg Group Delay. Close the Marker Settings Diagram.

Marker Settings Diagram

Delta Delia

Marker | ) i 2 .’ i

l

Reference 2 1 & 3 AlG
Marker <,-’

Drag a Marker fo another Marker's reference position to make it
the reference Marker for that Marker

Marker Mode Marker Trace
Delta (A) | Avg Group Delay v

Marker 4
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20. Move Marker 3 to the peak of the trace and Marker 4 to the minimum.

For this example, peak to peak Average Group Delay is 4.42 ns.

KEYSIGHT nmutRF InputZ. 50 0 Atter: 12 dB Tilg. Free Run Center Freq: 10270000000 GHz
= G GG Pre: int off LNA off Avg|Hold:>25/25
Ly A R rnat pW Path- Bypass

1 Spectrum 5 Gain Phase
ScalefDiv 10.00 dB Ref Value 0.00 dBm

Center 102700 GHz 2 Span 626.3 MH:__
4 Gain Magnide ip D
ScalefDiv 5.00 dB Ref Value 0.00 dB Scale/Div 1.000 ns

Center 10.2700 GHz Span 626.3 MHz|Center 10.2700 GHz _ B ‘Span 626.3 MHz|

21. From the menu panel, select Trace > Averaged Trace Off. With Averaged
Trace Off, you can capture smalls spurs that might occur on the trace.

Atten- 12 dB Trig: Free Run Center Freq: 10. 270000008 GHz
Com CCom RCal Pre. Int off, LNA off Avg{Hold >25/25
Freq Refl Ext (S) W Path: Bypass
Bus Out OFf

5 Gain Phase

Scale/Div 10.00 dB Ref Value 0.00 dEm Scale/Div 20,00 *

Center 10.2700 GHz
4 Gain Magnitude
Scale/Div 5.00 dB

Center 10.2700 GHz

218

Span 6263 MHz Eentér 102700 GHz - —

Ref Value 0.00 dB

Span 626.3 MHz|Center 10.2700 GHz

M9484C VXG and X-Series SA Measurement Guide



Other X-Series Signal Analyzer Measurements
Setting Up a Group Delay Measurement

22. Turn Instantaneous Trace Off and Averaged Trace On then set the

Aperture to 10% to get a smoother result, but lose a little bit more at the
beginning and the end of the 500 MHz band.

The Group Delay Aperture is the span over which the math of the delta
phase over delta frequency is calculated.

Cemer Freq: 10 270000000 GHz In'-'ian;an_ec_u:Tr;ce
Com CCorr RCal Pre- Int off, LNA off FoglHold 2125 B =
Freq Ref Ext (S) uW Path: Bypass 1 On
Bus Out OF o

Input 7- 50 0 Anen 12 dB Trig- Free Run

1 Spectrum 5 Gain Phase ’ foecr E Eailies
H On
Scale/Div 20.00 * off

Scale/Div 10.00 dB Ref Value 0.00 dBm

Center 10.2700 GHz

_Span626.3 MHz|Center 10.2700 GHz
4 Gain Magnitude & Group Delay
Scale/Div §.00 dB Ref Value 0.00 dB Scale/Div 1.000 ns
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23. Now set Aperture to a very narrow aperture of 1%. Any deviation or noise
in the phase trace will show up a lot more. However as it averages down,
the noise will average away.

KEYSIG H'i‘ Input- RF 2 Afien-12'dB Trig: Free Run Center Freq: 10 270000000 GHz
) Coupling C C C Pre. Inf off, LNA off Avg|Hold. 18725
: gn- oq UW Path. Bypass
Bus Out OF

1 Spedum 5 Gain Phase

Scale/Div 10.00 dB Ref Value 0.00 dBm Scale/Div 20.00 *
; erence Trace
On
Off

Center 102700 GHz

4 Gain Magnitude
Scale/Div 5.00 dB Ref Value 0.00 dB

24, From the N9042B, select Mode/Meas > Channel Quality/Group Delay
Mode > Group Delay Measurement > 3x2 View.

The 3x2 View will add the RF Envelope (Instantaneous Envelope) and
Metrics. Other interesting Views to look are the 1Q Waveform that is similar
to the RF Envelope, or add the Phase View. Phase only is the absolute
phase of the tone.
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KEYSIGHT |nput RE Atten: 12 dB Center Freq: 10 270000000 GHz
Corr RC Pre. Int off, LNA off 5125
Freq Ref. Ext ! W Path: Bypac
Bus Cur OF

Spectrum 5 Gain Phase

Scale/Div 10.00 dB Ref Value 0.00 dBm Scale/Div 20.00 °

Center 10.2700 GHz E ]  Span 626.3 MHz Center 10.2700 GHz
4 Gain Magnitude nup Delay
Scale/Div 5.00 dB Ref Value 0.00 dB Scale/Div 1.000 ns

Hz Center 10.2700 GHz Span 626.3 MHz

| 9 Metrics

Sample
417

30.166 us|
Meas Time 30,166 ps (23615 pts)im
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Setting Up Millimeter-Wave Measurements

The V3080A Vector Signal Generator Frequency Extenders are designed to
extend the frequency range of Keysight's M9484C for millimeter-wave
applications up to 110 GHz.

The V3050A Signal Analyzer Frequency Extenders are unbanded, preselected
devices designed to extend the frequency range of Keysight's N9042B UXA for
millimeter-wave applications up to 110 GHz.

We will connect the output of the M9848C VXG to the V3080A, then connect
the output of the V3080A to the input of the V3050A, and finally connect the
VV3050A to the UXA to measure frequencies at 60 GHz and above. For complete
setup instructions, refer to the V3080A Startup Guide.

Trigger 1

In N9042B
p——————— "\ 10 MHz

_— M9484C out

RS = 2 [ L

o = 828 - | Lo

"”th IF yss-c ||B88 ;F-L 2 @Kﬁr
N\ e uss-c-T ] gsel 1 RFou
[0 = 00 9% %E5 G oo \\ 585 @-H‘; !
-High - RF Input = =
ot LO Out
LO In
SB-C
V3050A
Pass Thru
TmmFtoF
Cable
Setting up a 5G NR Millimeter-Wave Measurement
The VXG must have the N7631APPC Signal Generation for 5G NR license
NOTE installed.
On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 60 GHz and Power to
-10 dBm.

3. Select the Radio Apps block to open the mode selection panel.
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4. Select 5G NR to enter the 5G NR signal mode.

m >

LTE FDD (Beta) E TDD (Beta)

5. In the 5G NR setup, select the Waveform tab and observe the Phase
Compensation and Radio Frequency settings.
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Phase Compensation is applied by default at baseband for RF
up-conversion. This means it depends on the carrier frequency, and the
waveform should only be played at the carrier frequency it was generated
for, unlike conventional Signal Studio waveforms, which are independent
from carrier frequency. Phase Compensation is set to Auto by default. The
frequency is coupled with the VXG frequency setting. You can select
Manual to specify a different frequency, or turn it off.

&=

» Export 89600 VSA Setup

Number of Slots in Subframe
Waveform

Total Sample Points

Waveform Length

Mirror Spectrum

Phase Corr ation

TIP Some applications, like power amplifier measurements use the same
waveform at different frequencies and can be time consuming to generate a
separate waveform for each frequency. In this case, you would turn Phase
Compensation Off, so the waveform becomes independent from the carrier
frequency. You need to do the same on the analysis side, or the demodulation
will fail.

6. Select the Carrier tab.

7. Select DL Test Model and set Bandwidth to
FR2 400 MHz and Test Model to NR-FR2-TM3.1a.
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Notice that the description of the currently selected test model appears to
the right. These test models are defined in the section 3GPP TS 4.9.2 of
38.141.

Downlink Test Mode onTx T on 38.141 v17.5.0)

Bandwidth FR2 400MHz NENANE. 1a

* Qutput power dynamics
Total power dynamic
Numerology u=3:120kHz range (upper OFDM

symbol power limit at
Duplex Type
NR-FR2-TM3.1a
modulation (at max

Phase Compensation Auto power)

DCI/DLSCH Payload Data PN23

8. Select OK to exit the Downlink Test Model setup.

9. Select Generate to generate the Waveform, and then select Home to exit
the setup panel.

|| ] » Apps

Carrier Waveform

10. Set RF Out to On by selecting the numbered channel indicator switch.
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This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

11. Select the System menu (triple bar tab at the top left of the window) to
open the System Menu and then select Configure Analyzer.

226

12. In the System Configuration setup, click on the Remote Signal Analyzer
block (on far right) to setup the communication channel to the Keysight
X-Series Signal Analyzer.

Click to change connection

13. Set Connection Type to LAN.

14. In the Connect Remote X-Series Signal Analyzer setup, enter the
Hostname or IP Address for the signal analyzer.

15. Under Set Protocol, select HiSLIP and use the Remote name hislipO.
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16. Select Test Connection to verify, then Back.

nstrurment

Test Connection

Protocol

Type

17. Select Auto Configure Analyzer to send the VXG settings to the analyzer.

ﬁ Meas Setup ¥ |-

Component Carrier

| Acquistion Mode Profile
| Sequential ") Advanced

Decode

Oplimize EVM

Optimization
od

lterative

Optimize EVM is an immediate action to adjust the hardware settings to
minimize EVM.

— Normal method will capture input signal, measure its peak power
then the algorithm will find proper setting combination for
attenuation, preamp and IF Gain.
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— lterative method will capture input signal multiple times in a
iteration process, demodulate the signal and calculate EVM for each
iteration and find setting combination for attenuation, preamp and
IF Gain with minimum EVM.

For 5G NR signals, this method is much slower, than normal, but
with achieve better EVM results. You can also manually adjust IF
Gain, Frequency Extender Attenuation (use when measurement
setup includes a V3050A frequency extender).

19. View the results on the signal analyzer.

Amplitude N

KEYS|GHT - E3 Input 2: 50 0 Atten: 14 dB Trig: Free Run Carrier Hef Fraq: 60 000000000 GHz [ = _'I
= Cerr CCom RCal Fra Inl off, LNA off WIF Gain: -10 di CC Info; DL, 1 €C, 5150 : |Y Scale
' |Align; Light Freq Rel: Ext (5) W Path: Fiiyp, On |
H#PNO; Bast Wide
1 CCO-BWFP1 v
I3 Meas Time

Scale/Div 3"8 enbcame rs | | Signal Path

TTLLTLE

-5.943 1 =3: 120 kHz 5.948 |Start: 0. 00 aymbnl.-. Stop: 1119.00 symbols
3cco 4CCO

Spectrum Raw Maln Tima
Scale/Div 10.00 dB Ref Value 0.00 dBm Scale/Div 10.00 dB Ref Value 10.00 dBm

[ . T i T T Lon Adjust Atien
Ctr: 60.000000000 GHz Width: 383.2 MHz | . i B IR BN = B e B! | ¥ On
Res BW: 100 Hz Info BW: 393.22 MHz |Start: 0.00 ns p: 22.00 _-: Oft
1

| 6 Error Summary

5 CCO Frame Summary ¥ |

Channel Power (Active [ Total)

Mech Alten ‘\lep
2dB
10 d8

20. Change the frequency and power level of the M9484C and frequency of
the N9042A to view other results. Remember to Optimize EVM after each
change.
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This measurement was done at 70 GHz, - 10 dBm.

Inptit - 50 (1
Corr CCorr RCal
Freg Ref. Ext (S)

10 M=as Time

P=3:120 kHz

Scale/Div 10.00 dB Ref Value 0.00 dBm

Ctr: 70.000000000 GHz

Res BW: 100 Hz Info BW: 383.22 MHz

Frame Summary ¥

Power per RE
45 dBm
-45 51 dBm
45 51 dBm

dBm

Input - 50 £
Corr CCorr RCal
Freq Ref Ext (S}

=3 120 kHz

eCium

| =P
| Scale/Div 10.00 dB Ref Value 0.00 dBm

Ctr; BD.000000000 GHz

{Res BW: 100 Hz Info BW: 393.22 MHz

5 CCO Frame Summary ¥

Subframe 1
LSIPLY AR 2.

|Aften; 12 dis

{Pre: Int off, LNA off

uW Path. FByp, On

(BPNO-. Bect Wide
2 CCO-BWP1
Detected Allocal

Trig: Free Run
#IF Gain, -15 dB.

Carmier Ref Freq: 70000000000 GHz
CC info: DL, 1 €T, SISO

Scale/Div 328 subcarriers

5.948 |Start: 0. s
———

Raw Main Timo
| Scale/Div 10.00 dB

Ref Value 10.00 dBm

Stop: 22.00 ms

Power (Active / Total)

Peak)
af (R

Aften: 16 dBl

Pew: Int off, LNA off
W Fath: FByp, On
#PNO: Best Spurs

Start: 0.00 symbols
4
E w Main Time
| Scale/Div 10.00

1'
|

Width: 393.2 MHz|

| Start: 0.00 ns

Frequency i
Symbaol Clock Ermor
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S | Worst)

Carier Ret Freq: 80 000000000 GHz
CC ok DL, 1 CC, SIS0

Ref Value 10.00 dBm

Stop: 1119.00 symbols

Stop: 22.00 ms

Meas Setup ¥

ke

Componenl Carier

Av;agmg
On
Off

Average Mode

Exponential

Component
Carriers

Meas Time

Channe|

| | Acquisition Mode
Sequential "

Decode

Powes
Meas

For best EVM, sel
"Allow Full Bypass
inAuto” to Onfin

the Amphtude menu)

o]

mponent Carrier
Co

Meas Selup ¥

heas
Standard

Componenl
Carriers

hdeas Time

Channel
Frofile

Advanced

Decode

Fower
heas

Oplimize EVM

EVIM Optimization

inAute” ta Onfin
the Amphtude menu)
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This measurement was done at 85 GHz, - 10 dBm.

Meas Selup
Input £ 50 0 Atten: 4 db Carrier Ref Fraq: 85 000000000 GHz = =
Coupling. DX Corr €Cotr RCal Pro It off LNAoff  #IF Gain. -5 dB [CC Info: DL, 1 ©C, S150 fEaneoneny Car0e
Align. Light Freq Ref: Ext [5) WW Path. FEyp, On

#PNC: Bast Spurs

Scale/Div 328 subcarriers

s

5.948 |Start: 0.00 symbols Stop: 1119.00 symbols| |Average Mode

i

| Exponential
taw Main Ti
calefDiv 10.00 dB Ref Value 10.00 dBm

o | 5
Scale/Div 10.00 dB Ref Value 0.00 dBm | Arcquisition Mode
1 1 1 | | Sequenbal

Ctr: 85.000000000 GHz

Width: 353.2 MHz|
Res BW: 100 Hz Info BW: 393.22 MHz

|start: 0.00 ns Stop: 22.00 ms| |
|
§ CCO Frame Summary ¥ 6 Etror Summary |I‘ Optimize EVM |
Method
‘ HNomal
|-
| For best EVM, set
"Allow Full Bypass
i Auto™ to Oniin
|. the Amplitude me
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Setting-up a Millimeter-Wave DVB-5S2X 64APSK Measurement

The VXG must have the N7608C Signal Studio for Custom Modulation
license installed.

Setting up the VXG

1. Select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 81 GHz and Power to
-10 dBm.

3. Select the Radio Apps block to open the mode selection panel.

Loy

LTE FDD (Beta) LTE TDO (Beta)

5. Select the Carrier tab.
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6. In the Custom Modulation setup, select the Carrier tab > Quick Setups >
DVB-S2X > 64APSK > 4+12+20+28APSK 132/180.

|

Custom Modulation (Beta)

Carrier Wavefarm + Import Signal Setup

{4 Preset | Quick Sstups | [+ Expori B9600 VSA Selup

ove-52

DVB-52X 4 BAPSK

APCO25 + T6APSK

TETRA FZAPSK

NXDN > BAAPSK > 16416416+ 16APSK 128/180

dPMR 128APSK » B416420472 {79

DECT 2Z56APSK B+16+20+20APSK 4/5

- Add Seg
DMR B+16+20+20APSK 5/6

Name 5 Hamp Samples

- g Constedlation Phase Rotation  Shift Bits Per Symbol Differential Offset
ARIB 4+12420+28APSK 132/180

PLHEADER QPsK 0
ZigBee >
DataSeq PN15 DVB-S2X 4+12+20+2BAPSK 132/180

WESUN(BOZ.15.4g) *

ITU-T G.9959

7. From the left pane, select Custom ASK & PSK & QAM Settings and set the
Symbol Rate to 400 Msps per channel.

Carrier Waveform + Import Sig

i Preset [ Quick Setups |-+ Exporl 89600 VSA Selup

lection 1 t 400 Msps

8. Select Filter > Alpha to 0.1.
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We will match these settings in the UXA setup.

GE Waveform Setup [+ Export Signal Setup
iy Preset [ Quick IS * Export BO600 VE

Cuslo ztion Filter Root Nyguist s

custom ASK & PSK & QAM £ 1 0.1

32

-+ Add Ssegment — Remove Segment + Move Down
Name Type Number of Symbols  Ramp Samples Payload Canstellation Phase Rotation  Shift Bits Per Symbol Differential Offse!
PLHEADER Data | 90 Q 180 bits binary data [0001..) QpPsK 1]

DataSeq FatE C DVB-SZX 44124 20+2BAPSK 132/180 (i]

9. Select the Waveform tab, then Generate to generate the Waveform, and
then select Home to exit the setup panel.

Custom Modulation (Beta)

Carrier ‘Waveform + Import Signal Setup

tor Reduction

Number of Frames
i Carrier

ength

10. Set RF Out to On by selecting the numbered channel indicator switch.

M9484C VXG and X-Series SA Measurement Guide 233



Other X-Series Signal Analyzer Measurements
Setting Up Millimeter-Wave Measurements

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

Setting Up the UXA Using X-Apps

1. Using Spectrum Analyzer Swept SA mode, set Frequency to 81 GHz and
Span to 500 MHz.

2. Select Marker > Marker Function tab > Band Function and select to Band
Power.

3. Set Marker Frequency to 81 GHz.
4. Set Band Span to 400 MHz.

T .y
n Marker B~

Input Z° 50 & IAtten: 0 dB PND: Fast Avg Type: Power (RMS) (1] 2 " Select Marker
Corr CCorr RCal Pra: Int ofl, LNA off Gate, Off Trig. Free Run |. =
Freq Ref. Ext (S) WW Path. Standard  IF Gal: Low w Marker 1

Il o
NFE: Adaplive Isig Track: Off L :
- et S Frequerh:\! @,
i Settings
Mkr1 8 21000000000 GHz

Scale/Div 10 dB Ref Level -12.00 dBm Band Power -1 m Peak
Log . . . - - T T T Search

Pk Search

. = - ) 5 a1 o | ‘ - . ;::ﬂn::m MHz |
PR T AT P, [Eiaee

o

Measure at
Marker
-

Measure at

Meas al Mkr Window
On
Off

Z'I;:enur_ 81.0000 GHz/ Video BW 3ﬁu kHz" | Span 500.0 MHz
Res BW 3.0 MHz Sweep (SW Pre) ~2.38 ms (1001 pts)

5. Select Mode/Meas > Vector Modulation Analyzer Mode > Digital Demod
Measurement > Dual Segment View.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.
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Mode / Measurement / View Selector Sereen Narme Srecium Alvam 1

Digital Demod

EMI Receiver
Custom OFDM
When Sequencing s On and Channel Guality / Group Delay
t are multiple Scr z Manitor Demod Error
Soreens update in sequence &S|
When Sequencing is Off, only 7 N ~
the selected Screen updates 12 Waveform Results Summary
LTE FDD & NB/eMTC & V23
el Power Eye Diagram
LTETDD & LTE-ATDD
Cccupied BW

Noise Figure
MR & V2X
Power Amplifier
Fulse
rous Enmssons
Remote Language Compatibility
SCPI Language Compatitulity

To launch BIE00 VSA press the button below. i\fedor Modulation Analyzer

Launch VSA v IMA with HSPA+

89600 Software Version
2024 BETA1 A\

WLAN

6. Select Frequency and set to 81 GHz.

n Frequency

:‘(_Jimler Frequency
81.000000000 GHz
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7. Select Meas Setup >Meas Standard tab > Presel to Std, and then select
Digital Video > DVB-S2X > 64-APSK Code Rate 132/180 (11/15), then OK
to close the window.

Q Meas Selup ¥

Radio Standard Presets

Category Standard | Frofiles ! | Settings

Gellular ATSC odle Rate 100/180 (5/9) I{ PresetTo Std

Wireless Networking DvB-C
Frame

Digital Video DVB-S2

Ieas Time

Demod

Advanced
BER
Lirmits

| Global

Info BW
440.00 MHz
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9. Select Meas Setup > Demod tab and set the Symbol Rate to 400 MHz and
Filter Alpha to 0.1 for both Segment 1 and Segment 2 to match the
settings in the Custom Modulation Setup.

T

Inpu;Z: 50 0 Atten: 10 db g Custorn 10/ Custom 10 CF: 81000000000 GHz

Selected Segment
L ) ing DC Con CCorr RCal Pro; 0. 400 MHz /400 MHz  Trig: Free Run g ah il

Freq Ref Ext (S) |W Path: Bypasa vk 997 1000 symbols Segment 2
Info BYV- 440 MHz Equalizer: Off I O

| 1 Spectrum | 2 Raw Main Time L

| Scale/Div 10.00 dB Ref Value 0.00 dBm | ScalefDiv 10.00 dB Ref Value 10.00 dBm ¢ Modulation

Format ot

- ~ Standard
Symbol Rate

400 D000D00 MHz Frame
| Points  Symbol | 5
| Meas Time
| Ctr: 81.000000000 GHz Width: 440 MHz: | | | [ |
| __Actual Info BW: 440 MHz |Start: -143.64 ns Stop: 3.36 ms
egl_ |0 12 Meas Tima eas Filter
(Const) ' Roat Raised Gosine ¥ | Advanced
- !
— o
gReI_Fﬂter .  oen
Raised Cosine A |
i | Limits.
(R |
( Advanced Setup
-3.718 3.718 |-3.718 o

- - - T Constellation |
5 Segl_Mefrics X Powe n 6 Seg2_Metrics X Settings

Quad Error
Gain Imb Gain Imb

10. Select the Meas Time tab and note that Meas Interval for Segment 1 is set
to 90 symbols, the same as the Header setting in the Custom Modulation
setup. Select Segment 2 and set Meas Interval to 2000 symbols to match
the Data Segment in the Custom Modulation setup.

Q Meas Setup ¥

selected Segment
Segment 2
i
| Sellings
Meas Interval il
| 2000 symbols | Meas

= Standard

I
|
| Rel To Sync Pattern TJI
E ¢ Demad
il
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11. Select the Frame tab > Segment Config Diagram and set Equalizer to turn
on for both Segment 1 and Segment 2, then Close the window.

Segment Config Diagram

Setiings
Seqg Name | Modulation Format Symbol Rate h Offset Meas Interval Meas Offset Ref Equalizer [Sym

1 Segi Cuslom 1Q 400.0000000 MHz 90 symbuls - Segment Number

2 Seg2 Custom 10 400 0000000 MHz  B0.00 symbaols 2000 symbols || Rel To Sync Pattern < Se“"mﬁ 'Cunﬁg'l 1
i Dizgram
sas Time:

Demod

|
Ad

BER
Limits

| Global

( Syne Pattern

12. Select Amplitude > Signal Path tab > select Allow Full Bypass in Auto to
turn On.

Notice that is recommended in the Meas Setup > Settings tab to turn this
on for best EVM results.

Q Amplitude v

Y Scale

Q Meas Setup ¥

Attenuation | Avg|Hold Number
: 10

Meas
Standard

.I nternal Preamp
Low Band
On
Of
LNA

On
Off

_'Averaghgi
On
Off

Average Mode
Exponential | Meas Time

Frame

Optimize EVM

! Demod
\UW Path Gontrol !

PW Fresel Bypass ¥

Auto
Man

EVM 6pﬁmizétion
Method Advanced
Normal
| BER

For best EVM, se

"Allow Full By

in Auto” to On( Limits

| the Amplitude menu)

Allow Full Bypass
in Auto

On

Off

N Global
Auta Gouple

Meas Preset
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13. At the top of the display, select Equalizer On/Off. From the dropdown,
select Equalizer Reset.

| Spectrum Analyzer 1
| Swept SA !
KEYS'GHT Inj Input Z: 50 [} \Atten; 10 dB Eanw[' Custom IQ  Gustom 10 :CF' 81.000000000 GHz
Coupling: DG Corr CCaorr RCal |Prec Int off, LNA off (Sym Rate: 400 MHz / 400 MHz Trig: Frea Run
[:] Align: Auto Freq Ref: Ext (S) yW Path: FByp, On Ihdaas Intel G0 7 2000 symbaols
Info BW: 440 MHz ‘Equalizer; On/ On
1 Spectum v

ScaleiDiv 10dB Ref Level 0.00 dBm

|
\]":ﬂ [1;' ﬂ'nIU] lf“f [ .rl i "'iJrIPhr'r‘l

Illl,l

H Emualizer Reset ..

fulp Al

Center 81.0000 GHz Video BW 360 kHz" Sp:m 500.0 MHz
Res BW 3.0 MHz Sweep (SW Pre) ~2.38 ms (1001 pts)
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14. In the Seg2_IQ Meas Time display, notice that the constellation diagram
goes off the display. To adjust the scaling, select the left side of the
window and set the Scale/Div to .3 (300.00 m per division) > Enter.

Spectrum Analyzer 1
Swepl SA
KEYSIGHT fnput [Atian 1088
C f Pre: Int off, LNA oft
W Path: FByp, On
Info BW: 440 MHz

Format: Custom I/ Custom IG CF: 81 000000000 GHz
Sym Rate: 400 MHz / 400 MHz Trig: Free Run

Meas Intvl; 90 / 2000 symbols

Equalizer: On [ On

Freq Ref. Ext (S)

2 Raw Main Time L]
Scale/Div 10.00 dB

1 Spectrum v
| Scale/Div 10.00 dB Ref Value 0.00 dBm

Ref Value 10.00 dBm

Ctr: 81.000000000 GHz
Res BW: 1.122 kHz
3 Segl_IQ Meas Time
{Consl)

Actual Info BW: 440 MHz
v

3.718/-3.718

TX Pawer 11.62 dBm 6 Segd Mebics ¥ | TX Power 11 62 dBm

Freq Emor
Clock Emor
I Offset

5NR (MER)
d Error
Gain Imb

Spectrum Analyzer 1
Swept SA

KEYSIGHT |input EaRF

g D0

LT-J .-;ign Aulo

Scale/Div 10.00 dB Ref Value 0.00 dBm

Scale/Div

Ctr: 81.000000000 GHz

| Res BW: 1.122 kHz Actual Info B |
3 Segl_ICQ Meas Time
{Const)

Freq Emor
G Emor
fiset
SNR (MER}
Quad Error
Gain Imb.

SNR (MER)
Quad Error
Gain Imb

Atten: 10 di
Pri: Int off, LNA off
W Path: FElyp, On
nfo BW: 440 MHz

[Format Custam 10/ Custom [0
Sym Hata: 400 MHx | 400 MHz
|Meas Intvl. 50 [ 2000 symbols
|Equalizer On/On

2 Raw Main Tima v

Scale/Div 10.00 dB

Clock Error
L 5
SNR (MER)
Quad Emor
Gain Imb

CF: 81 000000000 GHz
Trig' Free Run

Ref Value 10.00 dBm
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You must set this value to 300 instead of .3, the scaling gets changed to
250 k per division instead of 250 m per division.

[2 Seg2 1Q Meas Time ¥
(Const)

15. Select Meas Setup > Settings tab > Optimize EVM.

The default setting uses the Normal method for Optimize EVM. This is a
quick way to improve your measurement results. The EVM will continue to
reduce as the UXA continues to sweep. This is because the Equalizer is
correcting for linear distortions in the measurement setup.

pectrum Analyzer 1
it SA

pt U o ﬁ MeasSetup ¥ |-, -
| KEYSIGHT Input Ext RF Input Z: 50 O (Aften: 10 d8 |Format: Custom I/ Custom 1Q |CF: 81000000000 GHz
Ci o] Corr CGarr RCal |Pre: Int off, LA off (Sym Rate: 200 Mtz / 400 MHz Trig: Frea Run
@ Align. Auto Fraq Raf. Ext ($) W Path: FByp, On (Meas Intvl: 90 f 2000 symbols
Info BW: 440 MHz |Equalizer. On / On
1 Spectrum ¥

{ RvglHold Number
2 Raw Main Time v
Scale/Div 10.00 dB Ref Value 0.00 dBm

Scale/Div 10.00 dB Ref Value 10.00 dBm

{Ctr: 81.000000000 GHz Width: 440 MHz! [ [
Res BWY: 1.122 kHz Actual Info BW: 440 MHz Start: -143.64 ns
3 Segl 10 Meas Time

5to_p'. :!.‘35 ms
= Q) Meas Time
(Const)

= | EVM Oplimization
Method

Naormal

For best EVM, set
"Allow Full Bypass
in Auto” to Onfin

the Amplitude menu)

N | Global
Auto Couple =
-3.718 3.718 |-4.461 461 | d
5 Seq1_Metrics 2 Melrics B8 '|

R dB SNR (MER)
Quad Emor 9° Quad Emor
Gain Imb 0.01 Gain Imb

.00 db
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You can also set EVM Optimization Method Iterative mode, then select
either segment for optimization. This method takes a few minutes to
complete. For the example below, we set the Optimization Target to
Segment 2. Notice how the EVM went from .89% to .74%.

Spectrum Analyzer 1
Swept SA
IAtten: 10 dB Format: Custom [Q ( Costom IQ  CF: £1.000000000 GHz
|Comr CCorr RCal |Pre: Int off, LNA off Sym Rate: 400 MHz / 400 MHz Trig: Free Run
Freq Ref Ext (5) W Path: FByp, On Meas Intvl 90 f 2000 symbols
linfo BV 440 MHz Equalizer. On [ On

1 Specirum 2 Raw Main Time L]
Scale/Div 10.00 dB Ref Value 0.00 dBm Scale/Div 10.00 dB Ref Value 10.00 dBm

[} | Exponential

Ctr: 81.000000000 GHz Width: 440 MHz| 1 [ [ [ [ 1 [ | l|T Dptimize EVM
: 1.122 kHz Actual Info BW: 440 MHz | Start: -143.64 ns Stop: 3.36ms|

as Time 2 10 Meas Time {EVM Oplimization

- Optimization Target
Segment 2 v Limits

| |
For best EVM, sel Global
“Allow Full Bypass. 2
-3.718 4.461 || inAuto” lo Onfin

5 Seg1_Marics TX Power 11.58 dBm
EVM
Mag Error
Phase Emor

Gain Imb 0.01dB | Gain Imb

TIP You can also manually adjust to optimize EVM.

— Select Amplitude menu > Attenuation > Frequency Extender Atten.
Use the step keys to increase and decrease the attenuation by 2 dB
per step. After each increment, wait for the update to determine
where the lowest EVM point is achieved.

— Select Meas Setup > Advanced > IF Gain Other. Use the step keys to
increase and decrease the attenuation by 1 dB per step. After each
increment, wait for the display to updated to determine where the
lowest EVM point is achieved.

In this example, we found the optimum settings were 10 dB of Mechanical
Attenuation and -8 dB of IF Gain. We will use these settings in the 89600 VSA
setup.
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Setting Up the UXA Using 89600 VSA

Changing settings on the VSA can take longer to take affect than
expected. Pausing the measurement until all settings have been made will
help speed up the time. Wait to change the next setting until the previous
setting has been updated.

1. Open the VSA software.

To access the VSA software, go to the Windows Start menu and find
Keysight 89600 Software (latest installed version) folder and run the
software.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

2. From the VSA menu bar, select File > Preset > All to set the VSA to a
known state.

3. From the menu bar, select Input > Channels > External Mixer > 1 Channel.

E Vector - Keysight 89600 W5A Software - Press the Mode key to switch applicatic

File Edit Control  Source Input MeasSetup  Trace Markers Wi
| _Cha j bR v
. j X4 1 Channel | \o‘}i:.E:Xtt.‘rn!|.h¢'1i:(.!r: 1 Channel b
Digital... Custam.,,

Capture...
Trigger...
Playback Trigger...

Switch..,

4. In the Spectrum window, select Center and set the Center Frequency to
81 GHz. and Span to 1 GHz.

A:Chl Spectrum = I
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5. From the menu bar, select Input > Extensions and set:
— Microwave Path Control to Full Bypass
— Phase Noise Optimization to Best Wide Offset

File Edit Contiol Source || Input | MeasSetup  Trace  Markers  Window  Utilities  Help

OBE 5= hieas0) - Analyzer

Aq [CCO) FlesFram  Analog Digital Capture Trigger Playback Tngger External Mixer Estensions

Legical Instrument:

Off
Path Contral Full Bypass
Mixer Mode
Phase » mization Best Wide Offset
off
Wideband |F Output Off
4 Parameters Influenced by the Measurement Type
4 Range
Control Methad Attenuation
IF Gain -8
| Mechanical Attenuation 10
Breamplfier / LNA Off

Mechanical Attenuation

. Selects the mechanical attenuation in dB of the analyzsr.
Loghdag &

— IF Gainto -8 dB
— Select the External Mixer tab and set Input Attenuation to 10 dB

These are the optimized settings we used in the X-Apps
measurement.

Arnalog Dhgital Capture Trigger Playback Tnigger External Mixer Extensions

Measurement/Logical Channel: .

Signal Analyzer Frequen: tender
nic Table:
Min Freg Max Freq
Input Attenuztion:
10 dB
Cable IF Loss:

0.26dB

Mixer Paths:

Mormal
USEB Micer
/ USB Mizer detected

$62160117
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6. From the menu bar, select MeasSetup > General Purpose > Flex Frame.

2= Flex Frams - Keysight BSE00 VS2 Softiare - Press the Mode key b suntch applications - u] b4

File  Edit  Control

=
ktccnn

Fregquer

tupl| Trace Markers  Window  Ufities  Help
o (3 W BR- W38

e SymsEis | D [CC0) FlexFrame Summoany ] FlexFrame Eir Vect Time Fi [CCO) FlexFrame Phase Err | G: (CCO) FlesFrame Mag Error - | H: Ch CCDF

¥ | FlexFrame

7. Change the Trace Layout Grid to 2 x 3.

E Flex Frame - Keysight 83600 V5A Software - Press the Mode key to switch applications

File Edit Control Source Input MeasSetup Trace Markers Window  Utilities Help

L] [l - Cm E W BR-[.3%

G: (CCO) FlexFrame Mag Error Previous Layout arne Syms/Errs

Single

Custorn...

Tile Visible

8. Select MeasSetup > Flex Frame Properties > Carrier Aggregation tab, and
set:

— CCO Absolute Center frequency to 81 GHz
— Symbol Rate to 400 MHz.
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— Edit dropdown and set Assigned Carriers to CCO.

MeasSetup | Trace [ . 3 R - : z = :
Larrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation

CCO) FlexF = Preset Measurement Quick Setups ¥ Save As Quick Setup...
L exFrame Syrr

Selected CC for Trace Display: = CCO
Component Carriers

Reference Frequency

E Acquisition Configuration

Frequency Span: |2 GHz

c
- . - 4 CC
% Overall Status:  Error: unassigned compo o

Cancel

Cross-Correlated EVM

Configure...

Acquisition Configuration

verall Status:  Error: unassigned component carriers: [CC0]

9. In the Flex Frame Properties window, select the Frame Definition tab.
Under Component Carrier Configuration, select the Modulation tab, and
then set Preferred Bit to Symbol Mapping to DVB-S2X.

% MeasD1 - Flex Frame Properties
Carrier Aggregation Frame Definition Measurement Control Tirme Filter Custorm Madulation

Component Carrier; | CCO

All
82 GHz

81GHz

Component Cammer Conf guration
Frame Config on Medulation
FrameFartd

Preferred Eit To & ol Mapping: | gy

Default

Scrambler: . +

Scrambler C

Sequence
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10. In the Frame Definition tab, under Component Carrier Configuration,
select the Frame Configuration tab and set Symbol Rate to 400 MHz and
Length to 2090 Symbols.

Carrier Aggregation Frame Definition Measurement Contiol Time Filter Custom Modulation

Component Cerrier: | CC0

B0.46 GHz | 81.54 GHz

81 GHz

ent Carier Configuration

Configuration Modulation
Frame Type Bt

Symbol Rate: 400 MHz

Length:

11. To configure the Pilot:
— In the Frame Parts area, select AllocO
— In the Configuration area, set

— Name to PLHEADER

Type to Pilot

Sequence to Custom
Modulation to QPSK

Select Include BER Calculations
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— Go back into the VXG Custom Modulation setup Carrier

tab and select PLHEADER Payload to open and copy the
symbols.

Custom Modulation
Carrier

s Preset  [] Quick Setups [+ Export 89600\

Patlern w
%L OAM Settings
& Load fram File [ save ta Fie

0007171100010110100070010771017071110111000700
01011100010000711100010170100701 1100010007000
011110111011100001001011010010001011101110001
00001T1T0T10700011101000700100001000111010010

~~ Add Segment — Remove Segment = Move Down

Name Type Mumber of Symbols.  Ramp Samples Payload
PLHEADER Dala 90 1] 180 bits bhﬁif.‘)_l data ﬁ}ﬂﬂl..:!
DataSeg Dala 2000 Q

Cur 80 Tolak 180
PN15 VE-S

View updates

— Paste the symbols you copied over from the Custom
Modulation PLHEADER Payload setup.

— In the Location area,

— Clear the End of Frame checkbox
— Start Symbol to 0
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— Total Length to 90

E Meas01 - Flex Frame Properties ?
Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation

Component Car “onfiguration Allocation Summary
Frame Configuration Modulation Index  Enabled Frarme Part C
0 J FramePart0 PLHeader
Burst
Symbol Rate: | 400 MHz
Length: 2080 Symbols

Frame Parts

4 FramePartD | + Add Allocation Configuration

fEorT £ ] ed: Start Symbol: 0
IPLH.W*:!I:' | Enabled: v tart Symbol 0

Name: PLHeader Last Symbol
Type: Pilot Symbol Index: | g9
- af
Power Boost: | 0 dB
Total Length: 90 Syr

Payload

] End of Frame
Sequence: Custom

Repeat Pattern
Custom Sequence Type: | Bit Sequence =
Modulation: QPSK
V| Include in BER Calculations

Autodetect Bit Sequence Offset

Serambling

12. In the Frame Parts area, select Add Allocation and set:
— Name to Data
— Type to Data
— Sequence to PN15
— Modulation to DVB S2/52X APSK
— MODCOD to 4+12+20+ 28APSK Normal 132/180

— Select Include in BER Calculations
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— In the Location area, set Start Symbol to 90.

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation

Component Carrier Configuration n Summary
Frame Configuration Modulation « | Enabled

7 FramePart0
Frame Type:

il J FramePart0
Symbol Rate: | 400 MHz

Length: Auto

Frame Parts

4 FramePart) |+ Add Allocation SoNiG e

Location
PLHeader Enabled: [

Data

Start Symbol: a0

Mame: Data Last Symbol

Type: Data
Power Boost: | 0 dB
P d
#! End of Frame

Sequence: PM15

Repeat Pattern
Modulation:

DVB-52/52X APSK

MoDCoD: 4+12+20+28APSK Normal 132/180 ~

¢! Include in BER Calculati
Autodetect Bit Sequence Offset
Scrambling

Enabled
Add Frame Part

Add Allecation | Rernove Allocation

13. In the Measurement Control tab, and set:

— Channel Estimation Source to Allocations with Known Sequences
— Select Initial Equalization

— Normalized Channel Delay Spread to 20 Symbols
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— Clear the Show EVM in dB checkbox

Carrier Aggregation Frame Definition Measurernent Control Time Filter Custom Modulation

Overall Aliocation Control

art

FramePart0 PLHEADER Pilot

FramePartd Data Data

Frequency Estimation & Equalization & Synchronizat

Synchronization Source: Auto
Frequency Estimation Mode: Mot
Equalization Mode: Zero-forcing
Channel Estimation Source: Allocations with Known Sequences = ¥ Initial Equalization

Nermalized Channel Delay Spread:

EQ Tracking:

Display
show EVM in dB

Points per Symbaol:

14. In the Time tab, set Result Length to 2090 Symbols.

Carrier Aggregation Frame Definition Measurement Contral Time Filter Custom Modulation

Component Carrier: | CCO

ymbols
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15. In the Filter tab, set Alpha BT to 0.1 and Length to 32 Symbols and then
close the Flex Frame Properties window.

Carrier Aggregation Frame Definition Measurement Control Time Filter Custom Modulation

Component Carrier. | CCO

| 81.5 GHz

Measurement Filter: | poot raiced Cosine = Length: | 55 Symbals

Reference Filter: Raised Cosine =

Alpha/ET: 0.1

16. View the results of the measurement. Try to improve EVM by adjusting
the IF Gain and Mechanical Attenuation settings in the Input >Extensions
and the Input > External Mixer windows.

Source gl MessSetup  Trace  Markers  Window  ilibes  Help
Ot W ER- W2

G (CC0) FlexFrame Mag Emar - ¥ CCO) Flerame Sym

[8°cht Spectrum | vt ccoF - | « % | D [CC0) FleFrame Summary
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Setting-up a Millimeter-Wave 5G NR, 2 GHz BW FR2 Measurement

This measurement example will show you how to configure and analyze a
2000 MHz 5G NR, FR2, signal. 3GPP Rel-17 introduced a new frequency band
52.6 - 71 GHz, with new numerology (480 kHz, 960 kHz) and new bandwidth
(800 MHz, 1600 MHz, 2000 MHz). Support for these new
numerologies/bandwidths was added in VSA2023 Update 2.0 release and will
be part of PWSG 2023 Update 1.0.

Software Requirements

PathWave Signal Generation for 5G NR N7631APPC 2023U1 or later
89600 VSA software 8960T1BHNC VSA2023U2 or later

Using the graphical user interface
On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 70 GHz and Power to
-10 dBm.

Waveform generation and analysis speed will be very slow since we are
generating and analyzing a 2 GHz wide NR signal. (That is, 5 times more
data compared to a 400 MHz 5G NR signal.) To improve some
demodulation speed, use VSA2024, which has some speed improvement
and also use an external trigger for demodulation. (N9042B rear panel
Trigger 1 In to M9484C rear panel 10 MHz Ref Out.) Furthermore, to
improve VSA setup speed Stop the measurement until all parameters are
correctly configured, then run the measurement (Control menu > Stop).

3. Select the Radio Apps block to open the mode selection panel.

[ FI._l > Hpps

Keysight PathWave Signal Generation

stom 2 LTE FDD (Beta)
sdulation (Beta)

5. Select the Waveform tab and turn off Phase Compensation so the same
waveform can be used at different frequencies.
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Phase compensation is applied by default at baseband for RF
up-conversion. This means, it depends on carrier frequency, so a
waveform needs to be generated per carrier frequency unlike conventional
waveforms which are independent from carrier frequency. Phase
Compensation default is set to AUTO. The frequency is coupled with VXG
frequency setting. You can select Manual to specify different frequency or
turn it OFF so it is not frequency dependent.

PATH [ Filev 5 System -
(A Home 5G NR

’f Generate + Generate & Download Carrier Waveform Hardware

[ Export 89600 VSA Setup

e Oudic racuun
Number of Radio Frames

Subframe Offset

MNumber of Slots in Subframe
Total Sample Points
Waveform Length

Mirror Spectrum

= 5 Off ~

Marker
Marker 1 Source Waveform Start v

Marker 2 Source Frame Start v
Marker 3 Source
Marker 4 Source

~ Crest Factor Reduction

6. To configure the Downlink carrier, select the Carrier tab > Full-filled
Config and set:

— Bandwidth to FR2 2000 MHz

— Duplex Type to TDD

— Number of Downlink slots to 59
— Number of Uplink Slots to 18

— Modulation to 256 QAM
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— Select OK to close the window.

PATH
[0 Home 5G NR

+ Genera Bandwidth

8 Full-filled Config | T* DL Test Numerology

-

“ Duplex Type

~ Carrier 0 (DL)

BWP Setup Duplex Type
Channel Setup

Transmission Periodicity

Number of Downlink Slots

Number of Downlink
Symbols

Number of Uplink Slots

FR2 2000MHz

W= 6:960 kHz

TDD

1.25 ms

59

Number of Uplink Symbols

Channel Allocation [ Number of Special Slots

CRBu=1
TDD Slot Allocation

2560AM

These parameters are based on 3GPP endorsed Test Model for

2000 MHz bandwidth.

59 Downlink Slots UL Slots

58 Downlink Slots

UL Slats

& sym.

A
v

1.25 ms

10 ms (1 Frame)
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7. Under the Carrier (DL) side tab, scroll down and set Cell ID to 201.

¢ Generate

k# Full-filled Config

~ Carrier 0 (DL)
BWP Setup

Channel Setup

~ Carrier 0 (DL)
BWP Setup

Channe! Setup

Channel Allocation

u==6

256

Generate & Download

T* DL Test Model

Carrier Waveform

@~ DL FRC Config

~ General
Enabled
Frequency
Timing O
Power Boosting
Initial Phase
Spectrum Control
DC Punctured
Window Beta
indowing Method
Baseband Filter
v Cell-Specific
_ Carrier Type

«# Auto Freguency Offset

Hardware

[ Export 89600 VSA Setup

'
0 Hz
Os
0dB
0 deg

0.01
Centered at Symbol Boundary
4

Downlink ~
| 201

8. Select Channel Setup > SS/PBCH and set Active Indices to 0:63.

Dcl DL-SCH CSI-RS PRS

* SS/PBCH Block
Name
Enabled
Antenna Port Weight

Summary

RIM-RS LTE-Coexistence

SS/PBCHO
L4
1
p=6:960 kHz

101
0

B4 ~

| 0:63

0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0.0
1024
0dB

With RB Offset by 60 kHz SCS set to 1024 and kSSB by
subcarrierSpacingCommon set to 0, the SSB is set to the center of the
carrier. This is shown in the Channel Allocation graph at the bottom of the
window. If you set it to 0, the SSB will be set in the lower band of the

carrier.
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Unlike LTE, there is no fixed frequency location for SS/PBCH in NR. By
default, PWSG transmits SS/PBCH (20 RB or 240 subcarriers wide)
centered at the carrier bandwidth (2000 MHz channel BW in this
example). This is a very important parameter since it shows were the
SS/PBCH is located within the channel bandwidth in the frequency
domain and it is relative to common resource block 0 (CRBO).

9. Select DL-SCH > DL-SCHO_D.

You should see DL-SCHO_D and DL-SCHO-S. These are configured from
the Full-filled Config settings above. We will make a couple edits to the
Reference Signal configurations.

. Generate + Generate & Download Carrier Waveform Hardware

M Fullfilled Config T* DL TestModel g™ DL FRC Config < Auto Frequency Offset [~ Export 89600 VSA Setup

SS/PBCH pci DL-SCH CSI-RS PRS RIM-RS LTE-Coexistence

WET Enabled Slot Symbol BWP PRB Allocation RNTI Coding
DL-SCHO_D v 0:58,80:138,160:218,240:298,320:378 4... 0:13 BWP1 RATypel, 0:147 1 On

Ehannel Setup DL-SCHO.S B 59,13 379,459,539,619 0:5  BWP1 RATypel, 0:147 1 On

— Confirm Allocated Slots is set to
0:58,80:138,160:218,240:298,320:378,400:458,480:538,560:618

These values will be used in the VSA/X-App. You can copy these
values for easier setup later.

“ Resource Allocation
Alloc lots 0:58,80:138,160:218,240:298,320:378
]

Last Symbol 13

— Confirm that MCS Table is set to 256QAM and MCS to 20. MCS
table, MCS value, scaling factor, etc. must match with the VSA (or
X-App) for successful decoding (CRC pass/fail).

— Set DMRS-add-pos to 1. Additional DMRS is transmitted on a
symbol before the last symbol.

— Select PTRS Enabled. For FR2, PTRS is used for phase tracking.
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— Set Time Density to 4.

SS/PBCH DCl H CSI-RS PRS RIM-RS LTE-Coexistence

Name Enabled Slot Symbol BWP PRB Allocation
DL-SCHO_D ' 0:58,80:138,160:218,240:298,320:378 4. 0:13 BWP1 RATypel, 0:147

59,139,219 379,459,539, 0:5 BWP1 RATypel, 0:147

E4
Table 5.1.3 QAM)
20
1.0

0w

Payload Dz

DMRS Settings

0
N_ID_O Cell 1D
N_ID_1 CellID
DMRS

mbol

pping
* PTRS Settings

PTRS PowerBoosting
PTRS pc
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10. Select DL-SCHO_S. Set PTRS Enabled and Time Density to 4. Confirm that
Allocated Slots is set to 59,139,219,299,379,459,539,619.

SS/PBCH DCI PRS RIM-RS LTE-Coexistence -+
Name Enabled Symbol BWP PRB Allocation

DL-SCHO_D 4 198, 8,160 A 34... 013 BWF1 RATypel, 0:147

DLSCHIS M 05 RATypel, 0:147

" DMRS Settings
S-Downlink-r16
[1]
Cell ID
Cell ID
0dB

apping Reference
PTRS Settings

11. Select the Waveform tab, then Generate to generate the Waveform, and
then select Home to exit the setup panel.
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TIP When using 89600 VSA software for demodulation, you can export the VSA
setup file from PathWave to demodulate the waveform quickly and easily or
export the setup file into X-Apps.

Waveform

12. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.
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Setting Up the UXA Using 89600 VSA

Changing settings on the VSA can take longer to take affect than
expected. Stopping the measurement (Control menu > Stop) until all
settings have been made will help speed up the setup time.

1. Open the VSA software.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window, then select Launch VSA.

2. From the VSA menu bar, select File > Preset > All to set the VSA to a
known state.

3. From the menu bar, select Input > Channels > External Mixer > 1 Channel.

E Vector - Keysight 89600 VSA Software - Press the Mode key to switch applicatic

File Edit Control Source '_In_gy__t MeasSetup  Trace Markers Wi
r RF »

‘[ 1 Channel | ”i._. External Mixer: 1 Channel 4

Digital... Custom.,,
Capture...
Trigger...
Playback Trigger...

4. In the Spectrum window, select Center and set the Center Frequency to
70 GHz.

Notice there is an OV1 error indicator. The OVx indicator appears when
the trace was created from data that contained an ADC overload. We will
resolve this in step 7.

ource  Input  MeasSetup  Trace Markers  Window  Uilities Help

catm WES-uZ (R[OOI R A e e

M9484C VXG and X-Series SA Measurement Guide 261



Other X-Series Signal Analyzer Measurements
Setting Up Millimeter-Wave Measurements

5. From the menu bar, select Input > Trigger and set Style to External and
Level to 500 mV.

Using the External Trigger will help to improve the demod speed.

e || Input | MeasSetup Trace Markers Window Utilities Help

E Meas01 - Analyzer 7 4
Analog Digital Capture Trigger Playback Trigger External Mixer Extensions

Input Trigger Channel: | 1
Entry Channel: s 1

Style Delay:
External 0s
Slope: L
Positive

Holdoff Style: Holdoff:
Conventional Os
Time Criteria: Timel: Time:
Trigger Out

De Actual:

Trigger Out 1 " | Trigger Out 1

6. Select the Extensions tab and set:
— |IF Path to 2 GHz
— Microwave Path Control to Full Bypass
— Phase Noise Optimization to Best Wide Offset

Analog Digital Capture Trigger Playback Trigger External Mixer Extensions

Logical Instrument: Preset All

' Show All

4 Misc
Adc Dither Off
Capture Bit Packing Auto
Ext Reference Lock Bandwidth 15 Hz
External Trigger Location Trigger 1In
IF Path 2 GHz
IF Path Auto .Mﬂnllil
Instrument User Corrections Off
LQ Dither Off

vave Path Control Full Bypass

Phase Noise Optimization Best Wide Offset
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7. Select the External Mixer tab and set Input Attenuation to approximately
20 dB, or a level where the overload flag disappears. This is to bring the
waveform up on the spectrum display.

Trace Markers

[ )

Floybock Trigger | Ex

sl Anhyrer Frequen

A IF Frequency:
Mlormal
USE Mixes
Abcer detected

8. In the Spectrum window, right click on the Spectrum display and select
Auto Scale.

T vector - Keysight 29500 V5A Software he Made key to switch applicatians a 4

QL A

Marker1 ~| +

A n Al f
| ||,u1|..|||rII i l.|||||||“I ".1 ilI f""-'ll'lll'|"n'l
\.
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9. From the menu bar, select MeasSetup > Cellular > 5G NR > 5G NR
Modulation Analysis.

File Edit Control Source Input e_!:ug;: Trace Markers Window  Utilities

Frequency... v mi] 2 € 85~

New Measurement
Duplicate Measurement

Measurements...

Measurement Type: finalog Demod Vector

Analog Demod Properties... Power Spectrum Analysi

General Purpose: Analog Demod

Other standard formats
1 Do
MB-laT
LTE
LTE Advanced
Loghdag e e — =
5G NR | 5G NR Modulation An
Pre-5G Pow ipecfrum

Adjacent Channel Power

10. Change the Trace Layout Grid to 2 x 3. Right click on the Spectrum
window and select Auto Scale to bring the waveform back up on the
display.

E Flex Frame - Keysight 89600 VSA Software - Press the Mode key to switch applications

Fite Edit Control Source Input MeasSetup Trace Markers Window  Utilities Help

L] ||| . om0 W BR:|L

A: (CCO) FlexFrame Meas Time | G: (CCO) FlexFrame Mag Error Previous Layout ame Syms/Errs
Single
Stack 2

Stack 3

Custorm...

Tile Visible
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11. Select the Control menu > Stop to stop the measurement until all
parameters have configured. This will greatly improve setup speed.

File Edit! Control

-_.,. Restart

Pause/Single
Stop

] Disconnect
Switch Mode

Record

12. Select MeasSetup > 5G NR Demod Properties > Configuration tab >
Carriers panel and set:

— Cell ID to 201 (or select the box to the right to Auto Detect the cell
ID)

— Bandwidth to FR2 2000 MHz

— Frequency for Phase Compensation to Disabled.

Cell ID is carried on PSS and SSS so the SS/PBCH must be transmitted
and enabled for Auto Cell ID to work and must be a Downlink since
SS/PBCH is only transmitted in the DL.

= Meas01 - 5G NR Demod Properties ? X
Configuration Input & Antenna Time Decode Advanced

Save As Quick Setup... Quick Setups...

Carriers Link Direction: '@ Downlink Uplink

Bandwidth ow Multiole Carrier Definitions

Configure.. + Add Carrier Allow Multiple Carrier Definitions

BWP
4 Channel Referencer | CCO = Display: | CCO ~
SS/PBCH
Cell ID Bandwidth
PDCCH
201 FRZ2000MHz = 7

PDSCH

C5l-R5 Open Test Model...

RIM-RS Cross-Correlated EVIM

Configure...
Results & Filters

Manually apply settings

13. Select MeasSetup > 5G NR Demod Properties > Configuration tab >
Bandwidth panel. This section of the Ul is to configure Resource Grid for
each Numerology. Numerology is set to p = 6:960 kHz.
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For FR2 2000 MHz, only the 960 kHz subcarrier spacing is available. This is
why the other numerologies are not shown. The Max RB is 148 RB. We will
use this value when we configure BWP, SS/PBCH, and PDSCH parameters.

P Meas01 - 56 NR Demod Properties ? X
Configuration Input & Antenna ~ Ti Decode  Advanced

Save As Quick Setup...  Quick Setups...

Carriers
o Bandwidth: | FRZ2000 MHz -

Baridwidth

Resource Grid
BWP
Grid Start Grid Size Grid Enabled
4 Channel

O RB 148 RB

RIM-RS

Results & Filters

Manually apply s

14. Select MeasSetup > 5G NR Demod Properties > Configuration tab > BWP
panel. We will use the default settings for DL-BWP 1.

This section of the Ul is to configure the DL BWP allocation within the
component carrier and the control resource set (CORESET). CORESET is
used for PDCCH configuration and there is no PDCCH in this measurement
example, so we don't need to make changes.

A CC with 2000 MHz at FR2 has a max RB of 148 for 960 kHz numerology.
In this example, the DL-BWP uses the full carrier bandwidth of 148 RBs
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When using multiple BWPs within a single component carrier, you will
spread the total 148 RBs across the multiple BWPs.

= MezsD1- 56 NR Demad Properties
Configuration Input & Antenna Time Decode

Save As Quick Setup... | Quick Sstups...

Carriers ) jumerology B Offset RE Murnber
Initial-DL-BWP 0

Bandwidth
[ « | DL-BWP
. DL-BWP
4 Channel

DL-BWP

RB Mumber

e o Initial-UL-BWP O =6:90kHz - |ORB 148 RB
PDSCH E

CSI-RS

CORESETs
RIM-R5

Add CORESET
Results &L Filters

CORESET ID: | 1 EWP1 ~

| Mumber: 1 = DMRS Scrambling D -1

Configured CCE To REG Mapping Type | Mon-interleaved

Precoder Granularty: Same as REG bundle ~

Manuzlly apply settings

15. Select MeasSetup > 5G NR Demod Properties > Configuration tab >
Channel > SS/PBCH.

Configuration Input & Antenna Time Decode Advanced

Save As Quick Setup... | Quick Setups...

Carriers
PDCCH
Bandwidth

Copy Auto to Manual

BWP 2

« |Ehanner Refi e Bits

PDSCH IQ Ref: Demod

55/PBCH
Synchronization Config

PDCCH

Sync Source: | Auto Source |D:

PDSCH

Sync Mode: | CP Autocorrelation = Ignore MIB Data

CSI-RS

Surmmary

SS/PBCH PDCCH PDSCH CSI-RS
Results & Filters ~ On

RIM-R5

Manually apply settings

The auto detected parameters are returned in the Summary table trace.
Once you see what has been auto detected and are happy with what you

see, you can do "Copy Auto to Manual" to copy the detected parameters
into the SS/PBCH settings. See image below.
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The auto detected SSB parameters are returned in the Summary table.
"Copy Auto to Manual" will copy these detected parameters into the
SS/PBCH settings.

16. Select MeasSetup > 5G NR Demod Properties > Configuration tab >
Channel > SS/PBCH.

PSS and PBCH Power boosting cannot be auto detected, you must enter
power boosting values under SS/PBCH. We will use the default values.
Notice that the remaining values are grayed out as we are in Auto
Detection mode.

Note that the frequency location of a SSBlock is not fixed. In our software,
the default value of 1024RB and kSSB of 0 subcarriers places it in the
center of the carrier bandwidth. If you set RB Offset to 0 dB, it places the
SSB on the lower edge of the carrier bandwidth

Configuration Input & Antenna Time Decode Advanced

Save As Quick Setup... | Quick Setups...

Carriers
Bandwidth
BWP

Channel

X PSS power boosting BCH pow posting | 0dB
Results & Filters

Manually apply settings

268 M9484C VXG and X-Series SA Measurement Guide



Other X-Series Signal Analyzer Measurements
Setting Up Millimeter-Wave Measurements

17. Select MeasSetup > 5G NR Demod Properties > Configuration tab >
Channel > PDSCH and set:

— MCS Table to Table 256QAM
— MCSto 20

Transport Block Size value must match the PathWave 5G NR
settings for successful decoding (CRC result).

— Allocated Slots to
0:58,80:138,160:218,240:298,320:378,400:458,480:538,560:618

TIP You can copy/paste these values from PathWave 5G NR Signal Generation.

Configuration Input & Anterna Time Decode Advanced

Save As Quick Setup... | Quick Setups...
Carriers Add PD5CH : Enable Channels..

PDSCH ‘

#| Enabled BWPID BWPT = RNTIE: | 1 3GPF Version:  R17 Latest (2022-09) ~

pWp
Channel
Modulation and Coding | Time/Freq Allocation

Modulation and Coding Time/

POSCH g L 0 Frame Perio 1 Frames

C5I-R5

Allocate

RIM-RS Slot Format

Results & Filters

Transport Block Size: it

o Source
™D
VRE-To-PRE Mapping: Mon-Interleaved =
CORESET ID
Rate Match Patterns: Mone
Custom ModFormat:
RE: 148 -

Unused RBs Allocated REs
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PATH £ File v System v
(Al Home  5GNR
erate & Download Carrier Waveform
HH Fullfilled Config T* DL Test Model g" DL FRC Config « Auto Frequency Offset [*» Export 89600 VSA Setup

[ SS/PBCH DCi DL CSI-RS PRS RIM-RS LTE-Coexistence

ier 0 (DL) Name Enabled Slot Symbol BWP PRB Allocation

BWP Setup DL-SCHOD # 0:58,80:138,160:218,240:298,320:378,4 .. 0:13 BWP1 RATypel, 0:147

Channel Setup DL-SCHO.S ®@ 59,139,2 ),379,459,539,619 0:5 BWP1 RATypel, 0:147

Scrambling

RNTI

n_ID

Transmission Settings

DMRS port(s) 0

PRB Bundle Size Wideband
User Defined Pre

Number o

Antenna Port(

Number of Codewords
“ Resource Allocation

18. Scroll Down to RS Sequence and set:
— DMRS AddPos to Pos1
— Select Enable PTRS
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Save As Quick Setup...

Carriers

Bandwidth

BWP

RIM-RS

Results & Filters

Other X-Series Signal Analyzer Measurements
Setting Up Millimeter-Wave Measurements

— LPTRS to 4

Input & Antenna Time Decode Advanced

Quick Setups...

Add PDSCH Enable Channels...

PDSCH: '
e

Transport Blo HE Ket CORESED 1Lk - - RA lype:

RE Of RE Nurmber:

Cell ID

VRE-To-PRE Mapping: | Non-Interleaved =
CORESET ID: -1

Rate Match Patterns: RELE
Custorn ModFormat: | Off

Unused RBs Allocated RBs

Antenna Port

RS Sequence
DV onfig Typel \d 5-Downlink-r16 #!| Enable PTRS
ax Length 1 - N = Source Cell ID - KPTRS
DMRS Length Single-Symbol = Mscid: [i] LPTRS
DMRS AddPos Posl v Nip PTRS RE Offset
DMRS Map Ref v i ) AdditionalDMRS-DL-Alt

DMRS Init Option: NR Standard = DMRS Init:

19. Select Add PDSCH and then select PDSCH 1. Set:
— MCS Table to Table 256 QAM
— MCSto20

Transport Block Size value must match the PathWave 5G NR
settings for successful decoding (CRC result). The Value depends
on parameters in this section and the RNTI value of the PDSCH
much also match. This will not affect EVM.

— Allocated Slots to 59:80:619
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— Last Symbol to 5

figuration Input & Antenna Time

As Quick Setup... | Quick Setups...

Carriers Clear All Enable Channe
Bandwidth
EW

4 Channel

Modulation and Coding | Time/Freg Allocation

Modulation and Coding Tirme/Freq Allocation

RV In 0 Frame Peri
Table 2560AM ~ Allocated Slots:
S.Icnt Format:
RIM-RS TB Scaling Factor 5
verhead: 0 v Mapping Type
Target Cod : 0.6 062 First Symbol:
Modulation: QAM2E ulting Format:
Transport Block Size: ESET ID:

RB Nurnber

To-PRE Mapping: | Non-Interleaved
RESET ID:
Rate Match Patterns: MNone
om ModFormat:

Jlocated RBs

20. Scroll Down to RS Sequence and set:
— DMRS AddPos to Pos1
— Select Enable PTRS
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— LPTRS to 4

Configuration Input & Antenna Time Decode Advanced

Save As Quick Setup... | Quick Setups...

Carriers Add PDSCH  Remove PDSCH  Clear All Enable Channels...

Bandwidth 45 2 '
PDSCH: |0

BWP
Transport Bloc

Channel . - B Offset: RE Nurmnber:

i nip Source Celf 1D
PDCCH
SCl VRB-To-PRB Mapping: = Non-Interleaved ~
—— SETID:
Rate Match Patterns: MNone Edit...

CSI-RS

Custormn ModFormat:

RIM-R5 -BWP M

Unused RBs Allocated RBs

Results & Filters

Antenna Port

RS Sequence
DMRS Config Typel Iy ownlink-r16 | Enable PTRS
DMRS Max Length 1 ” r \ Source Cell ID ¥ KPTRS
DMRS Length Single-Symbol ~ Nscid: 0 LPTRS
DMRS AddPos Posl N .[:,'5 0 PTRS RE Offset
DMRS Map Ref : v T a AdditionalDMRS-DL-Alt

DMRS Init Option: MR Standard  ~ DMRS Init:

21. In the Time tab set:
— Result Length to 4 Subframes
— Meas Interval to 1 Subframes

We are reducing the analysis region since a 2000 MHz carrier has a
large amount of data resulting in very slow demod speed. (That is,
5x more data than 400 MHz carrier.)

— Acquisition Mode to Frame Trigger is Present
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We are using an external trigger for this example, so selecting
"Frame Trigger is Present" will use the external trigger and will
speed up the measurement significantly.

Meas01 - 5G NR Demod Properties ? b

Configuration Input & Antenna Time Decode Advanced

|Result Length: 4 Subframes 0 Slots at pb -

Meas Offset: 0 Subframes ymbols at ub
Meas Interval: 1 Subframes 0 nbols at pb

Time Scale Factor: 1

Analysis Start Boundary Acquisition Mode
MNormal
® Frame
* Reduced acquisition length
Half-frame i
®: Frame trigger i
Subframe
Slot trigger is p
Stot

First Slot Index: ¢ Use Periodic Trigger

Time/Spectrum/CCDF Data Source
e All
Enabled Channels

EVM Included Channels

Timing Diagram

- Result Length 4 Subf. =

Frame Boundary

22. Select the Advanced tab:
— Clear the 3GPP Conformance checkbox

— In the Tracking area, set Tracking Source to RS + Data and select
Phase

— In the Equalizer Training area, set Signal Source to RS + Data and
clear the Freq Moving Avg. Filter checkbox.

— Turn on DC Punctured.

274 M9484C VXG and X-Series SA Measurement Guide



Other X-Series Signal Analyzer Measurements
Setting Up Millimeter-Wave Measurements

5G NR counts the DC subcarrier as a valid subcarrier for
rate-matching purposes. High LO feedthrough will impact
demodulation and EVM performance of the input.

Configuration Input & Antenna Time Decode Advanced

3GPP Conformance Test Low SMNR Mede
Tracking: Equalizer Training
Amplitude Signal Source: | RS+Data
4| Phase

Tirni Time Per Frame
iming

Tracking Source: | RS+Data - Freq Moving Avg. Filter 19 85

EVM Window and Symbol Timing Transient Period
EVM Window Length Mode:
/M Window Length in Samples:
EVM Window Length in Sample Lengti
Symbol Time Adjustment Mode: f Window Start/End ~

. Power Change Threshold:
FT Duration:

Signal Repetition Pattern

Repetition Pattern: | Standard = | FirstSlot: | O
IC Impairments

1Q Imb. Estimation Mode: | Off

Compensate [0 Offset | DC Punctured

UL Spectrum Flatness

| Spectrum Flatness Enabled

Test Environment Condition: | Normal = Test Tolerance: | 1.4 dB
Error Vector Unit

Time Domain: | PerSymbol = FreqDomain: | PerSubcarrier =

23. Close the 5G NR Demod Properties window and select Control > Restart
to restart the measurement.

24, View the results of the measurement. Try to improve EVM by adjusting
the Mechanical Attenuation setting until the OV1 indicator goes away in
the IF Gain and Mechanical Attenuation settings in the Input >Extensions
and the Input > External Mixer windows.

For this example, the optimum settings were Input Attenuation set to
8 dB and IF gain set to -12 dB.
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Fle  Edt Conbrol  Source  Input MeasSetup Trace  Markers  Window  Ubibbes  Help
|| - o [ D RR- W

- 3 |G Summany

D: OFDM Err Vet Spectrum: All Layers + . -x

SINR PowerperRE,, . . Num. ol
3 [} {dEim} Modulation oo

RN
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Using the X-Series Analyzer’s SCPI Recorder Function

The SCPI Recorder feature allows you to view active recording content, and
edit the content. Right-click or touch and hold on any Ul control to display a
menu allowing you to record the SCPI associated with the control. You can also
record a series of commands. These commands can be viewed and edited
directly, or you can also play, save/recall for future use.

For this example, we will generate a simple 5G NR 100 MHz signal.

Using the graphical user interface
On the VXG:
1. Select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 3.5 GHz and Power to
0 dBm.

3. Select the Radio Apps block to open the mode selection panel.

Custom VT LTE FOD (Beta)
odulation (Beta)
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5. Select the Carrier tab > DL Test Model and set Test Model to
NR-FR1-TM3.1b, leave the remain settings at their default values, and
select OK.

. NRFR1-TM3.1b
Bandwidth FR1 100MHzZ

Nurmerclogy p="T1:30kHz
> Duplex Type
NR-FR1-TM3.1b

Auto

DCUDLSCH Payload Data PN23
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6. Select the Waveform tab, then Generate to generate the Waveform, and
then select Home to exit the setup panel.

Waveform

[ Export 89600 VSA Setup

~ Basic

Spectrum

7. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

On the X-Series Signal Analyzer:
1. Select Mode/Meas > 5G NR &V2X Mode > OK.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top left of the display) to open the
Mode/Measurement/View Selector window.

2. Select Mode Preset to set Spectrum Analyzer 5G NR mode to a known
state.
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3. From the N9042B Menu Panel (or the Screen tab), select Mode/Meas > 5G
NR & V2X Mode > Modulation Analysis Measurement > OK.

4. Select Frequency and set Carrier Reference Frequency to 3.5 GHz.

— Touch and hold the Carrier Reference Frequency function for at
least one second on the touch screen or if using a mouse pointer
and right click to open the menu.

Q Frequency

"-Garrier Reference
Freguency
} 3.500000000 GHz

Add to User Menu
Help on this setting
Show SCPI Command
Add to SCPI Recorder

Start SCPI Recorder

— Select Show SCPI Command.
The SCPI command for this function is displayed in the dialog box.

Carrier Reference Frequency x

:SENSe:CCARrier:REFerence 3500000000

oK Copy

Select Copy to copy the current SCPI command string for further
use.

If you use Windows Remote Desktop or a VNC viewer with clipboard
synchronization enabled, you can copy the SCPI command into the
clipboard. This makes SCPI commands available on the fly via a
simple copy/paste operation.

— Select Help on this setting to open the SCPI syntax document page.
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You will see the background information for that setting including
allowed values, SCPI command and examples, and other useful
information.

K1 [ [PN K2 RES

Carrier Reference Frequency

The parameter sets the reference frequency of all the carriers. The center frequencies of carriers are defined as
offset frequency from this value.

Remote [ :SENSe]:CCARrier:REFerence <freqg>

Command [:SENSe]:CCARrier:REFerence?

Example :CCAR:REF 2GHz
:CCAR:REF?
Preset 1 GHz
State Saved in instrument state
Saved
Min Depends on instrument minimum center frequency. Same as Center Frequency
Max Depends on instrument maximum center frequency. Same as Center Frequency

To Start Continuous SCPI Recording:

The SCPI Recorder supports an automatic mode of operation. In this mode, a
series of manual operations can be added to the list automatically without any
further user activity. You can start the recording process by enabling the
Continuous SCPI Recording, then disable it to stop recording after completing
all configuration steps. This is normally the best choice for fast and convenient
SCPI list recording.

There are two ways to start continuous SCPI recording:
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— From the System Settings > SCPI Recorder.

System Settings SCPI Recorder . — ? x

| Continuous SCPI
System Function Label SCPI | Recording
On
/0 Config oft
Recording Limit
Preload / Unload 250
Modes

User Interface

Power On

Restore Defaults

Alignments

Licensing

Security

Diagnostics

Service

— From the context sensitive menu of the function key.

Meas Setup

il |
‘K SlGHT lInput: Ext RF Input £ 50 00 Atten: 10 dB Trig: Free Run Carrier Ref Fraq: 3500000000 GHz
Coupling: DC Corr CCorr RCal Pre. Int off, LNA off (EIF Gain Low (CC Info; DL, 1 CC, 5150
Freg Ref: Int (S) 'WW Path: Bypass |

| Detscted Allocations T andwidth
| Scale/Div 328 subcarriers 100 MHz

262 | | | NO DATA | Erequenr.yﬁﬁ@
‘ : | i i FR1

Start: 0.00 symbols Stop: 1.00 symbols
1cco
Main Time Channel
Scale/Div 10.00 dB Ref Value 0.00 dBm Scale/Div 10.00 dB Ref Value 10.00 dBm Profile
§
| | 1 | | | | i
G ] Adh
Fillfiled QFSK T

Ctr: 3.500000000 GHz ) ) ) Width: 110.6 MHz| . Help on this setting
Res BW: 100 Hz Info BW: 98.30 MHz Start: 0.00 ns Stop: 22.00 ms/

5 CCO Frame Summary ¥ & Emror Summary Show SCP| Command

EVM Power per RE ~ Num RB
Add to SCPI Recorder

Start SCPI Recorder
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1. Select Mode Preset to set 5G NR V2X mode to a known state.

2. For this example, select the System Settings icon (Gear wheel on top right
of the display) > SCPI Recorder > Continuous SCPI Recording On. Close
the System Settings window by selecting the "X" at the top of the window.

System Settings SCPI Recorder Lo lle 2?2 X

Continuous SCPI
Syt Function Labe! SCPI ol
On
1/0 Config off
Recording Limit
Preload / Unload 250
Modes

User Interface
Power On
Restore Defaults
Alignments
Licensing
Security
Diagnostics

Service

3. Select Mode/Meas > 5G NR &V2X Mode > Modulation Analysis
Measurement > Normal View > OK.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top left of the display) to open the
Mode/Measurement/View Selector window.

4. Select Frequency > Carrier Reference Frequency and set to 3.5 GHz.
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5. Select Meas Setup > Meas Standard > RB Alloc Preset > DL NR-TM3.1 >
DL NR-TM3.1b (1024QAM) > OK.

=+ ﬁ Meas Setup
Input Z: 50 O iAtten 14 dB (ed) Carrier Ref Freq- 3 500000000 GHz
Corr CComrRCal  Preamp. Off CC Info: DL, 1 CC, SISO
Freq Rel” Exi (S) pW Palh Slandard
#PND: Best Wide

|2cco

| Raw Main Time

| Scale/Div 10.00 dB

Trig: Free Run
H#F Gain’ Low

KEYSIGHT Input RF
Coupling: AC
i

Configuration

! LI_PI;MD_de— i Campﬁl‘len
TDD X Iiers

Fulfilled DL NR-TM3.1 (B84 QAM)

| =
‘ d=1:30 kHz

Auto
Man

DL NR-TM1.1

. | Meas Time

3
Channel

DL NR-TM1.2
624 _ 624 | Profile

Jcco

Spectrum

Scale/Div 10.00 dB Ref Value 0.00 dBm

DL NR-TM2
If.'lL NR-TM3.1

DL NR-TM3.2

DL NR-TM3.1a (256 QAM) ra AlloiEFre
Fulfilled QPSK

IDL NR-TM3.1b (1024 QAM)

Y Advanced

|

Advanced Preset Tl Decode
Parameters  ©

| Power

'—.iMeas

(oAICCs) ||
DL NR-TM3.3 Al CC g

tr: 3.500000000 GHz. Width: 110.6 MH

Res BW: 100 Hz

6. Select Apply Preset (to All CCs).

0 Meas Setup | v
Inpul Z: 50 0 3 500000000 GHz
Corr CCorr RCal
Freq Ref: Ext (5)

Alten 14 dB (a4)
Preamp: Off
pW Path: Standard
#PNO: Bost Wide ; —
e | : " Setiings
| Raw Main Time Bandwidth |

| Scale/Div 10.00 dB

Carmer Ref Freq
CC Info: DL, 1 ©

Tng. Frea Run
MIF Gain: Low

KEYSIGHT It &
L @ Couphng: AG

Algn: Gif

| 100 MHz v
i m— { Radio
Frequency Range

Component

' | Carriers

Meas Time

A |

e [ [ . [ | ¢ | Channel
tart: 0.00 ns Stop: 22.00 m Profile

4 Error Summary

CCco | Y
Channel Power (Active / Total) -10.29 dBm/-10.29 dBm e T ST e

EVM (RMS / Peak) /
Frequency Error (RMS / Worst) -1
Symbaol Clock Error

1Q Offset (SISO)

Time Offset

Sync Gorrelation

Sync Source

Magnitude Error

Phase Error

Ctr; 3.500000000 GHz Width; 110.6 MHz.

Res BW: 100 Hz
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7. Select the Settings side tab and select Optimize EVM.

Meas Setup v || -

+ o

Atten 12 dB

Preamp: Off
W Path: Bypass
#PNO. Best Wide
G0

Raw Main Time
| Scale/Div 10.00 dB

Input 2 50 0
AC Corr CCorr RCal
Freq Ret: Exi (S)

Tng: Free Run

| KEYSIGHT [t RF g _
Leuping, #F Gain 3d8

L @ - ling

U=1:30 kHz 3.624 [Start: 0.00 ns

S Y 4 Emmor St ry
Scale/Div 10.00 dB Ref Value 0,00 dBm

Channel Power (Active / Total)
| EVM (RMS / Peak]
| Freguency Error (RMS / Worst)
Symbol Clock Emor
| 10 Offset (SIS0)
Time Offset
| Sync Correlation
T 1 Sync Source
Width: 110.6 MHz Magnitude Error
Phase Error

P S S Sy pp—"

| Ctr: 3.500000000 GHz
Res BW: 100 Hz

3 500000000 GHz
|5

CcCo
-0.58 dBm / -0.58 dBm
0.20%/71.27 %
33.4 mHz / 370.0 mHz
0.000 ppm
-38.08 dB
7.732ms
100.0 %
PDSCH DMR3
0.14 %
0.00 rad

8. Select Sweep > Sweep/Meas to Single > Restart.

Atten: 12 dB

Preamp: Off

W Path: Bypass

#PNO: Best Wide
CCo
w Main Time

Input £ 50
Corr CCorr RCal
Freqg Ref: Ext(5)

Trig: Free Run
H#IF Gain: 3 db

4 Error Sumimary

Scale/Div 10.00 dB Ref Value 0.00 dBm

Channel Power (Active / Total)
EVM (RMS / Peak)
Frequency Error (RMS ! Worst)
| Symbol Clock Error
| 10 Offset (SISO)
| Time Offset
| Sync Cormrelation
Sync Source
Magnitude Error
Phase Error

Ctr: 3.500000000 GHz
Res BW: 100 Hz

Width: 110.6 MHz
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[Carmier Ref Freq: 3.500000000 GHz
CC Info: DL, 1 CC, SISO

-0.56 dBm / -0.56 dBm
.2 11.39%

77.7 mHz / -466.7 mHz
0.000 ppm

-85.41 dB

6.636 ms

PDSC

Component Carrier
cCco

| Acquisition Mode
| Sequential

&

Sweep I Measure
Continuous
Single

Sweep

Radio

Meas
Standard

Component
Carriers

Meas Time:

Channel
Profile

Advanced

Decode

Power
Meas
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Other X-Series Signal Analyzer Measurements
Using the X-Series Analyzer's SCPI Recorder Function

9. Select the System Settings icon (Gear wheel on top right of the display) >
SCPI Recorder > Continuous SCPI Recording Off. Close the System
Settings window by selecting the "X".

System Settings SCPI Recorder 'j (& ? x

Function Label ' SCPI ' Sontinuous SCPI
System | | 1 Recording
| Active Mode & Measurement [INST:CONF:NR5G:EVM On
VO Config _ | | o
8 i " APC |Recording Limit
Preload / Unload Query Operation Complete OPC? 250
Modes E
Measurement Swilch :CONF:EVM:NDEF Play
User Interface
Query Operation Complete "OPC?
Power On

Carrier Reference Frequency :SENSe:CCARrier.REFerence 3500000000
Restore Defaults

RB Alloc Preset ‘SENSe;RADio; STANdard:PRESet:RBALIoc DLTM3DOT1B |

Alignments |
Apply Preset (to All CCs) :SENSe:RADIo:STANdard:PRESet: IMMediate HoyEBoin

SR ' Delete Row
Optimize EVM :SENSe:EVM:OPTimize

S Delete All

| S\ :INITiate:CONTinuous 0

Diagnostics |
ANITiate:RESTart

Service )

Manual Recording, Edit, Save and Play Functions

The SCPI Recorder supports manual recording of a list consisting of SCP!I
commands comprising any number of parameter variations when Continuous
SCPI Recording is off. In this mode, the user can decide which SCPI commands
should be added to the SCPI list. This mode of recording is helpful if a certain
configuration must be figured out, and you only want to record the final,
correct settings and not every variation or keystroke.
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Other X-Series Signal Analyzer Measurements
Using the X-Series Analyzer's SCPI Recorder Function

1. Touch and hold the any function for at least one second on the touch
screen or if using a mouse pointer and right click to open the menu and
select Add to SCPI Recorder. For this is example we will change EVM
Optimization Method to Iterative.

+

linput Z: 50 Q
Corr CCorr RCal
Freq Ref: Ext (S)

[Atten: 14 dB (e4)
FPreamp: Off

KEYSIGHT Input RF

Coupling: AC
Go) fign: o

Trig: Free Run
#IF Gain: Low

[ 1 CC
1 Meas Tima

aw Main Time
| Scale/Div 10.00 dB

_u=1:30kHz

4 Error Summary

Channel Power (Active / Total)

EVM (RMS / Peak)

Frequency Error (RMS / Worst)

Symbol Clock Error
1Q Offset (SISO)
| Time Offset
Sync Caorrelation
Sync Source
Magnitude Error
Phase Ermor

PP o Ly Sy Py

Ctr; 3.500000000 GHz
Res BW: 100 Hz

Width: 110.6 MHz]

CC infoz DL, 1 CC, SI50

~ Stop: 2200 ms

cco
-0.58 dBm /-0.58 dBm
034%/171%
347.2 mHz / 748.5 mHz
0.000 ppm
-83.40 dB
4 985 ms

PDSCH DM
0.
0.01 rad

Meas Setup

3

\Component Carrier

Help on this sefting
Show SCPI Command
Add to SCPI Recorder
Start SCP| Recorder
|EvM Optimization

| Method
Iterative

v ='e

Compaonent

2. To view the newly added command, go to System Settings icon (Gear
wheel on top right of the display) > SCPI Recorder.
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Other X-Series Signal Analyzer Measurements
Using the X-Series Analyzer's SCPI Recorder Function

From the SCPI Recorder provides several operations to edit the SCPI list
you created. You can Play, Copy, Move Up or Down the selected SCPI
command, Delete the command, or Delete All the commands.

. .

System Settings SCPI Recorder ' | ? x

j g Continuous SCPI
System Function Label SCPI . | Bt

Active Mode & Measurement AINST:CONF:NRSG:EVM g;
1/O Config !
s ot e - Recording Limit
Preload / Unioad Query Operation Completes OPC? 260
Modes -

EVM Optimization Method :SENSe:EVM:OPTMethod ITERative . Play

User Interface

Copy
Power On

Restore Defauits

Alignmenis
Move Down

bioneng Delete Row

Security Delete Al

Diagnostics

The recorded SCPI list can be exported as a script file in .TXT format via
the Save/Recall function at the bottom of the main window.

Cir: 3.500000000 GHz ~ Width: 110.6 MHz adnitude Error
Res BW: 100 Hz Phase Error

@l e Mar 22, 2023
1] ( - ? 11:26:20 AM

SCPI Recorder
Slate :
Save To File )
Screen Config + State

Measurement Data

Correction

Screen Image

Recording

Recording + State

Compaonent Carrier
Setup
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Other X-Series Signal Analyzer Measurements
Using the X-Series Analyzer's SCPI Recorder Function

There are two ways to playback SCPI commands. One is recalling from a
script file. And another one is pressing the 'Play' button in 'SCPI Recorder'
tab view.

Recalling SCPI script file allows you to play back a series of operations in
the same or another instrument, which helps you setup complex
measurement scenarios quickly and easily.

To recall the SCPI recording, go to Save/Recall and navigate to the saved
file.

‘( SCPI Recorder Recall from File

State ( '4 ] | Computer Users , Instmmentj) Documents ‘.:) ScpiRecordlng."':::-

Screen Config + State Name A Date Size Content

o [ 5GNR 100 MHz waveform b 3/22/2023 11:41 AM 60 B Txifie
Compiex Correction

Recording

Recording + State

Demod Info
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Other X-Series Signal Analyzer Measurements
Using the X-Series Analyzer’s Preload/Unload Function

Using the X-Series Analyzer’s Preload/Unload Function

The Preload/Unload function allows you to flexibly configure which
applications should be preloaded when the software starts up, or also unload
any previously loaded applications. This can help to save startup time or
system memory as needed.

1. Select the System Settings icon (Gear wheel on top right of the display) >
Preload/Unload.

System Settings Preload / Unload Modes

System To reduce the analyzer startup time, check only the Modes you want to preload. Selected (checked) Modes will be preload at the next
startup.

T on If you encounter out of memory emor, unload unused Modes. It helps you keep using the analyzer program without having to restart it.
g

|Power On Mode Spectrum Analyzer v
Pr&load. Loaded Unload Mode . :fNST:SEL. Preload: Select All
User Interface

v Spectrum Analyzer SA
¥ : Preload: Deselect Al

Power On Real-Time SA RTSA

Move Up

Restore Defaults EMI Receiver EMI Move Down

Alignments ‘ IQ Analyzer BASIC Unload
Licensing v WCDMA WCDMA

Security GSMEDGE EDGEGSM

Diagnostics Phase Noise PNOISE

Service Noise Figure NFIG

SCPI Recorder Analog Demod ADEMOD

Bluetooth BT

— Power On Mode displays a list of licensed Applications. Use this
control to change the factory default Power-On Mode. The
instrument will execute the selected Application after power up.
Selecting the Power-On Mode here automatically enables that
Mode for preloading

— Select All, Deselect All toggles the Preload checkbox state for all
applications listed, except for the Power-On application.

— Move Up, Move Down allows you to reorder the listed applications
in the table. This is the order in which they are displayed in the
Mode/Measurement/View Selector dialog.

— Unload Mode unloads the specified mode.

— Loaded Modes returns a list of loaded modes.
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M9484C and X-Series Analyzer Measurement Guide

5 5G New Radio (NR) Measurements using X-Apps

This section includes the following topics:

— “5G Waveform, EVM, and ACP Analysis Using X-Applications” on page 292

KEYSIGHT

TECHNOLOGIES

— “Setting Up Triggers on the Signal Analyzer using 5G NR Mode” on

page 292

“Setting Up a 1 CC 28 GHz EVM Measurement” on page 294
“Setting up an 8 CC 28 GHz EVM Measurement” on page 301
“Setting Up a1 CC 3.5 GHz ACP Measurement” on page 311

“Using PathWave N7631APPC to Create a Waveform File then
Automatically Configure the Analyzer to View the Results” on
page 316
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5G New Radio (NR) Measurements using X-Apps
5G Waveform, EVM, and ACP Analysis Using X-Applications

5G Waveform, EVM, and ACP Analysis Using X-Applications

The VXG enables 5G testing with a low error vector magnitude (EVM) at high
frequencies. The VXG has extremely good EVM at high power levels. However,
not all signal analyzers can capture this low value. We will use the X-Series
signal analyzer with the 5G NR X-Series application to observe EVM and
adjacent channel power (ACP).

Setting Up Triggers on the Signal Analyzer using 5G NR Mode

292

Refer to “Equipment Setup” on page 11 for connecting the instruments and
accessing the VXG SFP.

Setting Up Triggers on the X-Series Signal Analyzer
Using the graphical user interface
1. On the signal analyzer, select Mode/Meas > 5G NR & V2X mode.
If accessing the instrument via a Remote Desktop connection, select the

Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

2. Select Mode Preset to set 5G NR mode to a known state.

3. Select Mode/Meas > 5G NR V2X Mode > Modulation Analysis
Measurement.

4. From the Menu Panel (on the top right of the display), select Trigger and
set Select Trigger Source to External 1 and Trigger Levelto 1 V.

ﬁ Trigger

Select Tng Source
External 1
Triager Level
100V |
| At
| Tngger Delay | Holdoft
1.0ps
On
Off
| Trigger Slape
Pasitive
Negative

< fr'tg.ger Seﬂjm_]'s .
Diagram
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5G New Radio (NR) Measurements using X-Apps
5G Waveform, EVM, and ACP Analysis Using X-Applications

Using the equivalent SCPI commands

On the X-Series Signal Analyzer:

INSTrument : CONFigure:NR5G

SYSTem:PRESet

Change the current window to 5G NR Modulation Analysis Measurement Mode
INSTrument : CONFigure:NR5G:EVM

TRIGger:EVM:SOURce EXTernall

TRIGger:EXTernall:LEVel 1V
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5G New Radio (NR) Measurements using X-Apps
5G Waveform, EVM, and ACP Analysis Using X-Applications

Setting Up a 1 CC 28 GHz EVM Measurement

Ensure the equipment and triggers are properly configured. Refer to
“Equipment Setup” on page 11 and “Setting Up Triggers on the Signal
Analyzer using 5G NR Mode” on page 292.

On the VXG:
1. Select Preset > Preset to set the instrument to a known state.

2. In the Output 1 area, set Frequency to 28 GHz and Power to
5 dBm.

28.00000000000 GHz

5.00 dBm

ALC ON

3. Select Group 1: Signals block to open.

| Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.
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5G New Radio (NR) Measurements using X-Apps
5G Waveform, EVM, and ACP Analysis Using X-Applications

Enabled  Signal Mode Frequency Offsat Attenuation

>
?
b
bs
b
>
>
>

5. In the Vector Modulation Signal Setup:

a. Select the Mode dropdown and set to Waveform File.
|_J_|| > Group 1: Signal Summary » Signal 1: Setup

General Mode Signal Attenuation

Waveform File Waveform File 0dB

Mute :
Trigger Frequency Offset Power
0 Hz 0dB

Markers

Sample Rate
3.000 000 000 000 000 GHz

Reset Phase Accumulator

b. In the left pane, select the Waveform File tab.

c. Use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples
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5G New Radio (NR) Measurements using X-Apps
5G Waveform, EVM, and ACP Analysis Using X-Applications

and choose
5GNR 1CC FR2 120kHz SCS 100MHz 256QAM DCPunctured
_28GHz.wfm > Select.

V) e
O Recent Name ~ Date Modified

Delete
Waveforms = - "
401 In0ff_s50%_wim.csv Mar AM

D This Computer s : pres AR [ Rename

Clear Arb
Memory

Jul 10,

All Formats v

Select

U:LJ » Group 1: Signal Summary » Signal 1: Setup

General —_— Mode Signal Altenuation
@ Enable

Waveform File Waveform File v 0dB

Tigkjor MuE Frequency Offset Power
0dB
Markers
Rate
000 000 000 MHz

Reset Phase Accumulator

6. Close the Vector Modulation Signal Setup by selecting the Home icon at
the top of the display.

[“J % Group 1: Signal Summary > Signal 1: Setup

7. Select the Adjustments block and select Optimize Dynamic Range with
OBW and Enable System RF Flatness Correction.

Optimize Dynamic Range with OBW This setting filters the system
RF flatness correction coefficients over the instantaneous bandwidth
indicated in the waveform header (or in the “Occupied Bandwidth”
settings area under the Signal block > Occupied Bandwidth setting).
This has the potential to improve EVM performance by not having to
correct for flatness errors outside the requested bandwidth. For
example, if RF flatness correction was done at 2 GHz, but you are
only interested in an 800 MHz section, then applying the correction
flatness to that portion only can improve signal to noise ratio, and
therefore EVM when there is a lot of hardware roll off.
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5G New Radio (NR) Measurements using X-Apps
5G Waveform, EVM, and ACP Analysis Using X-Applications

Enable System RF Flatness Correction - Disabling this function
disables the factory calibrated RF channel flatness equalizer.
Depending on the hardware channel response, this may hurt or
improve the EVM. This is due to the dynamic range implications as it
relates to signal to noise ratio. The greater the RF hardware
variations in flatness, the greater the amount of correction is
required, the greater the correction effectively reduces the number of
resolution DAC bits that can be used, which degrades the signal to
noise ratio and therefore potentially EVM. The trade-off is to balance
between flatness and signal to noise ratio.

L’H] » Output 1: Adjustments

General 1/Q Common Delay Optimizations

! Os =
1/Q Adjustments & Optimize Dynamic Range with OBW

AWGN Swap | &Q _
™ Enable System RF Flatness Correction

8. Close the Adjustments Setup by either selecting the Back or the Home
icon at the top of the display.

[’}D > Signal 1: Setup

9. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

10. For two channel instruments only: In the top right corner of the display,
set RF Out (All) to On by selecting the switch.

RF Out (All)

In order to turn on RF for any channel, both the RF Out for the specific
channel (for example, Channel 1 or Channel 2), and RF Out All must be
turned on.
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5G New Radio (NR) Measurements using X-Apps
5G Waveform, EVM, and ACP Analysis Using X-Applications

On the X-Series Signal Analyzer:

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or
the PC running the VSA application.

1. Select Recall (If accessing the signal analyzer remotely, select the Folder
icon at the bottom of the display) Demod Info > Set Data Type to CC Setup
> Recall From >

5GNR_1CC FR2 120kHz SCS 100MHz 256QAM DC punctured
28GHz 34.scp

Recall

< Demaod info Recall from File

State ~ N AR R e e e P LT S AR T T O
@’} Computer ‘) (18 /) Users ‘_,.\ Instrument / Documents 2 NRSG ) data 2 Example setup demao files 4

Scareen Config + Stale Name
Comechon D 4-camier APSH scp ! 0:56 AM 402 KB Scp file
Complex Correction D 4-camer APSK selx ) 20 10:58 AM 584 KB Setx file
Recording 5G WG FR2 scp A 110:51 PM 431 KB Scp file
Recording + State 56 MO setx i3 058 AM 133 KB Setx file
3 PM . Scp file

TPM Setx file

212112019 1:58 PM / Scp file

22112019 2201 PM Setx file

912:14 PM

214 PM

[™ Jacquie setx 131 KB Setx file

File name: | Jacquie sefx File type: All Supmned Files [* scp* sgen,*.nrce;* pwsg;* selx) Recall

2. Select Meas Setup > Meas Time and set:
— Search Length to 10 ms
— Result Length to 2 Sub Frame
— Frame Trigger to On

3. Select the Settings tab > Optimize EVM.
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5G New Radio (NR) Measurements using X-Apps
5G Waveform, EVM, and ACP Analysis Using X-Applications

The Optimize EVM function automatically sets the combination of
preamplification, mechanical and electronic attenuation, and IF gain based
on the measured signal peak level.

EVM should be less than 1%.

KEYSIGHT psie o
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5G New Radio (NR) Measurements using X-Apps
5G Waveform, EVM, and ACP Analysis Using X-Applications

Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet
RF1:FREQuency:CW 28GHZ
RF1:POWer:AMPLitude 5dBm
SIGNall:MODE WAVeform

Navigate to the desired waveform file.

SIGNall:WAVeform “D:\Users\Instrument\Documents\demo
waveforms

5GNR_1CC FR2 120kHz SCS 100MHz 256QAM DC punctured
28GHz 34.scp”

SIGNall ON

IQO:CORR:0OPT:DYN:RANG:OBW ON

RF1:0UTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFAL1 :OUTPut ON

On the X-Series Signal Analyzer:

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal
AnalyzerX-Series Signal Analyzer or the PC running the VSA application.

MMEMory:LOAD:EVM: SETup CCO,
“D:\Users\Instrument\Documents\NR5G\data\NRSGEvm\CarrierSetu
p\5GNR 1CC FR2 120kHz

SCS 100MHz 2560QAM DCpunctured 28GHz.scp”

EVM:CCARrier(Q:TIME:LENGth:SEARch 10ms
EVM:CCARrier(0:TIME: LENGth:RESult 2
EVM:CCARrier(:FRAMe:TRIGger ON
EVM:CCARrier0:DC:PUNCture ON
EVM:CCARrier(:PHASe:COMPensation:AUTO OFF
EVM:CCARrier(:PHASe:COMPensation:FREQuency 0 Hz

EVM:OPTimize

M9484C VXG and X-Series SA Measurement Guide



5G New Radio (NR) Measurements using X-Apps
5G Waveform, EVM, and ACP Analysis Using X-Applications

Setting up an 8 CC 28 GHz EVM Measurement

This procedure shows you how to use the X-Series signal analyzer with the
5G NR & V2X X-Series application to observe EVM on an eight-carrier
waveform.

Ensure the equipment and triggers are properly configured. Refer to
“Equipment Setup” on page 11 and “Setting Up Triggers on the Signal
Analyzer using 5G NR Mode” on page 292.

On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. Set Frequency to 28 GHz and Amplitude to 5 dBm.

28.00000000000 GHz

5.00 dBm

ALC ON
3. Select Group 1: Signals block to open.

| Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.
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5G New Radio (NR) Measurements using X-Apps
5G Waveform, EVM, and ACP Analysis Using X-Applications

Frequency Offset

WOW WV VWV VWV

5. In the Vector Modulation Signal Setup:

a. Select the Mode dropdown and set to Waveform File.

|_J_|| > Group 1: Signal' Summary » Signal 1: Setup

General Mode Signal Attenuation

Wavatorm Eile Waveform File 0dB

Trigger Frequency Offset Power
0 Hz 0dB
Markers

Sample Rate
3.000 000 000 000 000 GHz

Reset Phase Accumulator

b. In the left pane, select the Waveform File tab.

c. Use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

and choose

5GNR_8CC_FR2 120kHz SCS 100MHz 256QAM Corrected 28GHz.
wfm

then Select.
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5G New Radio (NR) Measurements using X-Apps
5G Waveform, EVM, and ACP Analysis Using X-Applications

d. Select the General tab > Enable.

— EEE [[_:]» U:LJ » Group 1: Signal Summary » Signal 1: Setup

General Mode Signal Altenuation

(@ cnable

Waveform File Waveform File v 0dB

Trigger Muie Frequency Offset Power
0Hz 0dB
Markers
Sample Rate
122.880 000 000 000 MHz

Reset Phase Accumulator

6. Close the Signal Setup by selecting the Home icon at the top of the
display.

|_JLJ % Group 1: Signal Summary > Signal 1: Setup

7. Select the Adjustments block and select Optimize Dynamic Range with
OBW and Enable System RF Flatness Correction.

Optimize Dynamic Range with OBW This setting filters the system
RF flatness correction coefficients over the instantaneous bandwidth
indicated in the waveform header (or in the “Occupied Bandwidth”
settings area under the Signal block > Occupied Bandwidth setting).
This has the potential to improve EVM performance by not having to
correct for flatness errors outside the requested bandwidth. For
example, if RF flatness correction was done at 2 GHz, but you are
only interested in an 800 MHz section, then applying the correction
flatness to that portion only can improve signal to noise ratio, and
therefore EVM when there is a lot of hardware roll off.

Enable System RF Flatness Correction - Disabling this function
disables the factory calibrated RF channel flatness equalizer.
Depending on the hardware channel response, this may hurt or
improve the EVM. This is due to the dynamic range implications as it
relates to signal to noise ratio. The greater the RF hardware
variations in flatness, the greater the amount of correction is
required, the greater the correction effectively reduces the number of

M9484C VXG and X-Series SA Measurement Guide 303



304

5G New Radio (NR) Measurements using X-Apps
5G Waveform, EVM, and ACP Analysis Using X-Applications

resolution DAC bits that can be used, which degrades the signal to
noise ratio and therefore potentially EVM. The trade-off is to balance
between flatness and signal to noise ratio.

> Output 1: Adjustments

General 1/Q Common Delay Optimizations

L Os —
1/Q Adjustments | Optimize Dynamic Range with OBW

AWGN Swap | &Q _
q[ Enable System RF Flatness Correction

8. Close the Adjustments Setup by either selecting the Back or the Home
icon at the top of the display.

[’j:]\_] > Signal 1: Setup

9. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

10. For multi-channel instruments only: In the top right corner of the display,
set RF Out (All) to On by selecting the switch.

In order to turn on RF for any channel, both the RF Out for the specific
channel (for example, Channel 1 or Channel 2), and RF Out All must be
turned on.
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5G New Radio (NR) Measurements using X-Apps
5G Waveform, EVM, and ACP Analysis Using X-Applications

On the X-Series Signal Analyzer:

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the signal analyzer or the PC running
the VSA application.

1. Select Recall (If accessing the signal analyzer remotely, select the Folder
icon at the bottom of the display) > Demod Info > set Data Type to CC
Setup > Recall From >
S5GNR 8CC FRZ2 120kHz SCS 100MHz 256QAM Corrected 28GHz
_34.scp > Recall.

You must be in the correct analysis mode (in this case, 5G NR & V2X1
>Modulation Analysis mode) to recall the .scp file.

{ Demod Info Recall from File
st T T ) [ [Ty T gy T Yoo e voce [
Screen Config + State A Date Sire Content
Correction CC_FR1_3 SCS_100MHz_2560AM_DC Punciured 11773
Complex Comechion
Reconding
Recomding + State

/2020 438 PV B ME Wi file

1051 FM cp file

438 FPM 131 KB Setx file

[ #cc FR2_ 120kHz SCS_100MHz_2560AM_ Corrected & 1/7/2020 438 PM 4EE KB Scp fie

B 8CC_FRZ__120kHz SCS_100MHz_256QAM_Comredied_ 35 PM 49 ME Wi file
D Al_3nrce &/ 106 PM S8 KB Mrcc file
B 8 RZ__120kHz SCS_100MHz_2560AM_Comrected | 1772020 4:38 FM 3 Setx Nle
[__"] Signal_Studio_5G_100MHz_1CC_FR1 scp 211212021 1:48 PM 67 KB Scp file

[ vxc_A1_3 config sgen 6162020 10:53 AM 904 KB Saen file

Fle name. | 8CC_FR2_ 120kHz 3C3 100MHz 2560AM Conecled 280H: scp File type Al Files (%)

2. Select Meas Setup > Meas Time tab and set:
— Search Length to 10 ms
— Result Length to 2 Sub Frame

— Frame Trigger to On

3. Select Meas Setup > Advanced tab > Advanced Demod Setup and verify
that both Multi-Carrier Filter and DC Punctured are on.
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5G Waveform, EVM, and ACP Analysis Using X-Applications

The multi-carrier filter is used to filter out the unwanted carriers and
minimize leakage into the component carrier of interest.

4. Ensure that RF for Phase Compensation is not selected and the value is
0 Hz, then Close the Advanced Settings table.

Component Carrier | CCO

Sync Mode CP Auto Correlation

DC Punctured

DC Offzet from CC
Center

R
G

AUTO

0 Hz
AUTO

-30.00 dB

On

Report EVM in DB

Time Scale Factor

5. Select Meas Setup > Settings tab > Optimize EVM.
It will take a couple of minutes for the UXA to measure all 8 carriers.

If you are getting a "Sync Error; Sync not found" or "Input Overload -
NOTE Detected; ADC over range" message), go to Amplitude > Attenuation > and

increase the Mechanical Attenuation by 2 dB until the Sync Error is resold.

Notice that the Error Summary measurement has a scroll bar allowing you
to view the results of all 8 component carriers.
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5G Waveform, EVM, and ACP Analysis Using X-Applications

KEYSIGHT Input RF linput Z: 50 0 Atienr 10 dB Trig: External 1 Carrier Ref Freq: 12.000000000 GHz
- Coupling: DC \Comr CCarr RCal Pre: Int off, LNA off #F Gain:-14 dB CC Info: DL, 8 CCs, SISO
[: Align: Auto |Freq Ref Ext (S) uW Path: Bypass

LX) | :#PNO: Best Wide
1 CCO-BWP1

2 CCO-BWP1
1Q Meas Time Detected Allocations

Scale/Div 328 subcarriers_

T

- ETIm EREILE
' : II!.II!I u|||ﬂ 1 il i J|ll|i. |
-5.948 p=3: 120 kHz §.948 |Start: 0.00 symbols Stop: 223.00 symbols

3CCo

4 CCo
Spectrum
Scale/Div 10.00 dB Ref Value 0.00 dBm

Raw Main Time
Scale/Div 10.00 dB Ref Value 10.00 dBm

1 I | I
Width: 110.6 MHz =" Y ||

|start: 0.00 ns

Ctr: 28 GHz il 1 i
Res BW: 500 Hz Info BW: 98.30 MHz Stop: 10.10 ms|
5 CCO Frame Summary ¥ 6 Emmor Summary

CCOo CC1
Channel Power (Active / Total) 65.11dBm/-6.11dBm  -6.04 dBm/-6
VM (RMS / Peak) 0.76 % [ 2.80 % 0.77 Y% |
Frequency Emor (RMS [ Worst) -764.7 mHz / -727.7 mHz . 313.3 mHz / B4l
ymbol Clock Errar 0.004 ppm 0.
-35.08 dBm £ 1Q Offset (SISO) -37.24 dB <
0.76 % -35.08 dBm ime Offset 5

Bync Comelation

]
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet
RF1:FREQuency:CW 28GHZ
RF1:POWer:AMPLitude 5dBm
SIGNall:MODE WAVeform

Navigate to the desired waveform file.

SIGNall:WAVeform “D:\Users\Instrument\Documents\demo
waveforms\5GNR 8CC FR2 120kHz SCS 100MHz Corrected 28GHz.wfm

”

SIGNall ON

IQO:CORR:0OPT:DYN:RANG:OBW ON
IQO:CORR:CHANNel : FLATness ON

RF1:0UTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFAL1 :OUTPut ON

On the X-Series Signal Analyzer:

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or the PC
running the VSA application.

Navigate to the desired waveform file.

MMEMory:LOAD:EVM: SETup CCO,
“D:\Users\Instrument\Documents\NR5G\data\NR5GEvm\CarrierSetu
p\8CC FR2 120kHz SCS 100MHz 256QAM Corrected 28GHz 34.scp ”

EVM:CCARrierQ:TIME: LENGth:SEARch 10ms
EVM:CCARrier(:TIME:LENGth:RESult 2
EVM:CCARrier0:FRAMe:TRIGger ON
EVM:CCARrier0:MCFilter ON
EVM:CCARrier0:DC:PUNCture ON
EVM:CCARrier(:PHASe:COMPensation:AUTO OFF

EVM:CCARrier(:PHASe:COMPensation: FREQuency 0 Hz
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To Optimize EVM for Multi-Carrier Waveforms
POWer :ATTenuation 0dB
[POWer :ATTenuation 2dB], ..

EVM:IF:GAIN:LEVel 0dB
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To View the Results of Two Carriers

Set the top right window (Window 2) to display IQ Meas Time
DISPlay:EVM:WINDow2 :DATA MTIM

Set the top right window to display Component Carrier 1
DISPlay:EVM:WINDow?2:CCARrier CCl

Set the middle right window to display the FFT of the Raw Main Time waveform
DISPlay:EVM:WINDow4 :DATA SPEC

DISPlay:EVM:WINDow4 :CCARrier CCl

Set the bottom right window to display a table of general measurement numeric results
DISPlay:EVM:WINDow6 :DATA DRES
DISPlay:EVM:WINDow6:CCARrier CC1

Set the bottom left window to display the error summary for CCO

DISPlay:EVM:WINDowb :DATA DRES
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Setting Upa 1 CC 3.5 GHz ACP Measurement

Ensure the equipment and triggers are properly configured. Refer to
“Equipment Setup” on page 11 and “Setting Up Triggers on the Signal
Analyzer using 5G NR Mode” on page 292.

On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. Set Frequency to 3.5 GHz and Amplitude to 0 dBm.

3.50000000000 GHz

0.00 dBm

ALC ON
3. Select Group 1: Signals block to open.

| Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.
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Enabled Mode Frequency Offset

>
?
>
>
>
?
>
>

5. In the Vector Modulation Signal Setup:

a. Select the Mode dropdown and set to Waveform File.

|_J_|| > Group 1: Signal' Summary » Signal 1: Setup

General Mode Signal Attenuation

Wavatorm Eile Waveform File 0dB

Mute : =T e
Trigger Frequency Offset Power
0 Hz 0dB

Markers

Sample Rate
3.000 000 000 000 000 GHz

Reset Phase Accumulator

b. In the left pane, select the Waveform File tab.

c. Use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

and choose

5GNR_1CC_FR1 30kHz SCS_100MHz 256QAM DCPunctured.
wfm

then Select.
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d. Select the General tab > Enable.

U:LJ » Group 1: Signal Summary » Signal 1: Setup

General Mode Signal Attenuation

(@ cnable

T — Waveform File v 0dB

Trigger S Frequency Offset Power
0 Hz 0dB
Markers
Sample Rate
122.880 000 000 000 MHz

Reset Phase Accumulator

6. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

7. For multi-channel instruments only: In the top right corner of the display,
set RF Out (All) to On by selecting the switch.

RF Out (All)

In order to turn on RF for any channel, both the RF Out for the specific
channel (for example, Channel 1 or Channel 2), and RF Out All must be
turned on.

On the X-Series Signal Analyzer:
1. Select Mode Preset to set 5G NR V2X mode to a known state.
2. Select Mode/Meas > 5G NR & V2X Mode > ACP Measurement.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

3. Select Frequency and set Carrier Reference Frequency to 3.5 GHz.
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Input Z: 50 Atften: 10 dB Trig: Free Run Carrier Ref Freq: 3500000000 GHz
Com CCorr RCal Pre: Int off, LNA off Gate: Off AvglHold:>10/10

Freq Ref: Ext (S) PW Path: Standard IF Gain: Low Noise Comection: Off

NFE: Off PNQO: Best Wide ICC Info: DL, 8 CCs

1 Graph

I
|| Scale/Div 10.0 dB Ref Value -5.00 dBm

Vldeo BW 1.0000 MHz* %
Sweep 42.4 ms (12001 pts)

Total Car Pwr -1.598 dBm/760.320 MHz

Measure Trace
Total PSD s

Trace Type Trace Average (Active)
Lower Upper
ACP Reference . Reference
Offs Freq Integ BW dBc dBm dBm Car# dBc iE dBm Car# Filter
A 100.000 MHz 98.280 MHz 5311 5769 4 580 ] 5 -3dB
B 200.000MHz 98280 MHz -53.76 -5833 -4 580 3. 582 580 5 -3dB
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet
RF1:FREQuency:CW 3.5GHZ
RF1:POWer:AMPLitude 0dBm
SIGNall:MODE WAVeform

SIGNall:WAVeform “D:\Users\Instrument\Documents\MCS demo
waveforms\5GNR 1CC FR1 30kHz SCS 100MHz 256QAM DCPunctured.w
fmll

SIGNall ON

DM:OPTimization:CHANnel ACP

RF1:0UTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFALI :OUTPut ON

On the X-Series Signal Analyzer:
SYSTem:PRESet

INSTrument : CONFigure: NR5G:ACP
CCARrier:REFerence 3.5GHZ

ACPower :CORRection:NOISe ON
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Using PathWave N763TAPPC to Create a Waveform File then
Automatically Configure the Analyzer to View the Results

PathWave software tools can be used to create, download, and playback
waveforms through the VXG.

This example shows you how to create and analyze a 5G NR signal using the
embedded PathWave software and then automatically configure the analyzer
to make the measurement.

The VXG must have the N7631APPC Signal Generation for 5G NR license
installed.

On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 28 GHz and Power to
-10 dBm.

28.00000000000 GHz

-10.00 dBm

LTE FDD (Beta) LTE TDD (Beta)

5. In the 5G NR setup, select the Waveform tab and observe the Phase
Compensation and Radio Frequency settings.

Phase Compensation is applied by default at baseband for RF
up-conversion. This means it depends on the carrier frequency, and the
waveform should only be played at the carrier frequency it was generated
for, unlike conventional Signal Studio waveforms, which are independent
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from carrier frequency. Phase Compensation is set to Auto by default. The
frequency is coupled with the VXG frequency setting. You can select
Manual to specify a different frequency, or turn it off.

RF Outt {AN)

Cartier Waveform

Marker

Crest Factor Reduction

AWGHN

Routing

TIP Some applications, like power amplifier measurements use the same
waveform at different frequencies and can be time consuming to generate a
separate waveform for each frequency. In this case, you would turn Phase
Compensation Off, so the waveform becomes independent from the carrier
frequency. You need to do the same on the analysis side, or the demodulation
will fail.

6. Select the Carrier tab.

7. Select Full-Filled Config and set Bandwidth to
FR2 100 MHz, Numerology to p= 3:120 kHz, and Modulation to 256 QAM.

If you have a signal analyzer with demodulation bandwidth that is wide
enough to cover the other FR2 bandwidths, 200 MHz or 400 MHz, you can
choose to use a wider bandwidth.

Full Filled Configurations is a great place to start creating your waveform.

You can select FR, bandwidth, and modulation format with a fully
allocated PDSCH data channel. This would represent a spectrally correct
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signal that is typically used in power amplifier measurements. You can
modify the RB allocations and Slot allocations if fully allocated data
channels are not desired.

Bandwidth FR2 100MHz

Numerclogy p=3:120 kHz

™ Duplex Type

Duplex Type

8. Select OK to exit the Full Filled Config setup.

9. From the Carrier panel (in the left pane), select Spectrum Control > DC
Punctured On.

When DC Punctured is enabled, the DC subcarrier is excluded from the
measurement results. This is often helpful to avoid obscuring
measurement results with artifacts of LO feedthrough.

& Generate Carrier  Waveform
1 Fullfilled Config T+ DLTestModel @~ DL FRC Config <+ Auto Frequency Offset [ Export 89600 VSA Selup
General b

0.m

Cell-Specific ¢ etho Centered at Symboal Boundary

Baseband Filter ~
Downlink

10. From the Carrier panel (in the left pane), select Downlink > SS PBCH > SS
PBCH Block and set Lmax to 64 and Active Indices to = 0:7.
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Instead of transmitting all 64 beams, we enable only 8 of them by setting
Active Indices to 0:7.

Carrier

onfig T+ DiTestModel (™ DL FRC Config & AUMD Frequ fae [+ EXport 89600 VSA Setup

General BWP
contral i} i NR-PECH
W cc
DL-SCH
M csi-RS 0:7

B LiE-Coexistence F 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0.0

. PRS F 505 46

Lmax sets the maximum number of possible SS/PBCH blocks in a transmission
opportunity. This value is fixed for a given carrier bandwidth. Typically, higher
frequency and bandwidth carriers use a larger set of SS/PBCH opportunities to
support a larger set of antenna beams.Lmax is either 4 or 8 for FR1 and 64 for
FR2.

11. From the Carrier panel (in the left pane), select Downlink > DL-SCH >
DL-SCHO > Modulation and Coding and set MCS Table to Table 5.1.3.1-2
(256QAM) and MCS to 20.

The Modulation Coding Scheme (MCS) specifies the modulation, coding
and overall spectral efficiency of the PDSCH as specified in 3GPP Table
5.1.3.1.

(%, Generate Painarl | m [+ Import Signal Setup [+ Export Signal Setup

mn Full-filled Config  T* DLTestModel g~ DL FRC Config < Auto Frequenc "+ Export BRG00 VSA Setup

PTRS Settings

HARD Settinas
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12. Select Generate to generate the Waveform, and then select Home to exit
the setup panel.

& Generate Camier | n [+ Impornt Signal Setup [+ Export Signal Setup
mn Full-fHled Cor T D st Model @™ DL FRC Config AUto Frequency O
Gen

Tra

Channel Alocation Summary

13. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.
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Setup Auto Configure Analyzer

1. Select the System menu (triple bar tab at the top left of the window) to
open the System Menu and then select Configure Analyzer.

"~] » Configure Analyzer

| Analyze a rermote signal analyzer is connected, usa the [Auto Configure Analyzer] button 1o sutomatically st up the analyzer to measure

Output Channe

Output 1 e

2. In the System Configuration setup, select the Remote Signal Analyzer
block (on far right) to setup the communication channel to the Keysight
X-Series Signal Analyzer.

Click to change connection

3. Set Connection Type to LAN.

4. In the Connect Remote X-Series Signal Analyzer setup, enter the
Hostname or IP Address for the signal analyzer.

5. Under Set Protocol, select HiSLIP and use the Remote name hislipO.
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6. Select Test Connection to verify, then the Back icon to go back to the
main Configure Analyzer display.

EI'I] » Configure Analyzer » Remote Instrument

Test Connection

7. Select Auto Configure Analyzer to send the VXG settings to the analyzer.

Aute
| Configure )
\ Analyzer /

8. View the results on the signal analyzer.

The System Configuration selection brings up a screen that lets you perform a
Generation-to-Analysis work flow. The “Auto Configure Analyzer” button will
automatically transfer the setup from the source to a Keysight X-Series signal
analyzer, in order to measure the desired signal from the source. If you are gen-
erating a 3GPP 5G New Radio signal, and the 5G New Radio application is
licensed on the analyzer, the analyzer will perform demodulation of the signal.
Otherwise, the analyzer will auto-tune on the signal being generated. The Key-
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sight X-Series Signal Analyzer requires firmware version x.24.00 or greater.

More About the 5G NR Traces

— Trace 1: shows the composite constellation diagram showing different
modulation formats for the different channels/signals present in the
transmitted signal. See Trace 6 (Frame Summary) for the list of channels.
Again, when enabling BWP, SS Block is grayed out. When enabling SS
Block, channels withing BWP are grayed out.

— Trace 2: shows the envelope of the captured raw data. This data is
unprocessed and includes additional points acquired for settling of the
filters involved in subsequent processing, such as the demodulation
filtering.

— Trace 3: shows the FTT of the Raw Main Time waveform.
— Trace 4: shows the general measurement numeric results.

— Trace 5: shows the detected allocations of all channels/signals within the
measurement interval (2 Subframes in this example).

— Trace 6: shows EVM, Power, and Number of RB of the individual
channels/signals.

TIP The Frame Summary table shows Num. RB for PDSCH of 1056 and 1016 for
PDSCH-DMRS. The signal configuration has only 66 RBs. The RB result in the
Frame Summary Table is per Slot. In this example procedure, we changed the
measurement interval to 2 Subframes, which is 16 slots for 120 kHz
numerology (8 slots/subframe). 66 * 16 = 1056. For PDSCH-DMRS, the value
is 1016 because two of the 16 slots overlap with the SS Block which occupies
20 RBs resulting in 20 RBs being punctured from DMRS in these two slots.
Therefore, the total RB Number for DMRS is 1056 - 20 * 2 = 1016.
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Using the equivalent SCPI commands

On the VXG:
SYSTem:PRESet

RF1:FREQuency:CW 28GHZ

RF1:POWer:AMPLitude

RADio:SELect NR5G

RADio:NR5G:WAVeform:

Select p = 3: 120kHz:

RADio:
RADio:

RADio:
"O:7"

RADio:
RADio:
RADio:

GROup:

NR5G:
NR5G:

NR5G:

NR5G:
NR5G:

NR5G:

WAVeform:
WAVeform:

WAVeform:

WAVeform:
WAVeform:

WAVeform:

SIGNall ON

RF1:0UTPut ON

-10dBm

CCARrier:

CCARrier:
CCARrier:

CCARrier:

CCARrier:

CCARrier:

GENerate

BWIDth FR2BW100M

SNUMerology MU3
DLINk:SSBLock:LMAX 64

DLINk:SSBLock:ACTive:INDices

DLINk:SCHO:MCS 20
DLINk:SCHO:MCS:TABLe TABLeb52

For multi-channel instruments, set RF Out (all) to On.

RFALI :OUTPut ON

M9484C VXG and X-Series SA Measurement Guide



M9484C and X-Series Analyzer Measurement Guide

6 5G NR Measurements Using the VSA Software

This section includes the following topics:

— “BG Waveform and EVM Analysis Using VSA Software” on page 326

KEYSIGHT

TECHNOLOGIES

“Setting Up a1 CC 28 GHz EVM Measurement” on page 326
“Setting Up an 8 CC 28 GHz EVM Measurement” on page 339

“Creating a Basic 5G NR Signal Using PathWave N7631APPC
Embedded Software” on page 349

“Creating a DL MIMO Signal Using PathWave N7631APPC Signal
Generation” on page 369
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5G Waveform and EVM Analysis Using VSA Software

The VXG enables 5G testing with a low error vector magnitude (EVM) at high
frequencies. The VXG has extremely good EVM at high power levels. However,
not all signal analyzers can capture this low value. We will use the X-Series
Signal Analyzer with the Vector Signal Analysis (VSA) software to observe EVM.

Setting Up a 1 CC 28 GHz EVM Measurement

Ensure the equipment and triggers are properly configured. Refer to
“Equipment Setup” on page 11.
On the VXG:

1. Select Preset > Preset to set the instrument to a known state.

2. In the Output 1 area, set Frequency to 28 GHz and Power to
5 dBm.

28.00000000000 GHz

5.00 dBm

ALC ON

3. Select Group 1: Signals block to open.

| Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.
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Enabled Frequency Offset

WOW WV VWV VWV

5. In the Vector Modulation Signal Setup:

a. Select the Mode dropdown and set to Waveform File.

|_J_|| > Group 1: Signal' Summary » Signal 1: Setup

General Mode Signal Attenuation

Waveform File Waveform File 0dB

Trigger Frequency Offset Power
0Hz 0dB
Markers

Sample Rate
3.000 000 000 000 000 GHz

Reset Phase Accumulator

b. In the left pane, select the Waveform File tab.

c. Use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

and choose
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5GNR_1CC_FR2 120kHz SCS 100MHz 256QAM DCPunctured
_28GHz.wfm
then Select.

< Back

@ Recent |lj

@ Waveforms N~ Date Modified

Delete
|:| This Computer 4 : "

4000_SamplelQPulse0n(

CC_FR1.wfm Y [3 Rename

Clear Arb Memary

of type  All Formiats {*wfm, *wig, *.bin, *waveform, *.csv, *txt, *.seq, *.mat, * hdf, “.h5, *inc) ~

d. Select the General tab > Enable.

|_I'LJ > Group 1:Signal Summary » Signal 1: Setup

General — Mode Signal Attenuation
@ cnzble

P — Waveform File 0 dB

Mute s
Trigger il

0 Hz 0 dB
Markers

Sample Rate
122.880 000 000 000 MHz

Reset Phase Accumulator

6. Close the Vector Modulation Signal Setup by selecting the Home icon at
the top of the display.

> Group 1 | Summary »
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7. Select the Adjustments block and select Optimize Dynamic Range with
OBW and Enable System RF Flatness Correction.

Optimize Dynamic Range with OBW This setting filters the system
RF flatness correction coefficients over the instantaneous bandwidth
indicated in the waveform header (or in the “Occupied Bandwidth”
settings area under the Signal block > Occupied Bandwidth setting).
This has the potential to improve EVM performance by not having to
correct for flatness errors outside the requested bandwidth. For
example, if RF flatness correction was done at 2 GHz, but you are
only interested in an 800 MHz section, then applying the correction
flatness to that portion only can improve signal to noise ratio, and
therefore EVM when there is a lot of hardware roll off.

Enable System RF Flatness Correction - Disabling this function
disables the factory calibrated RF channel flatness equalizer.
Depending on the hardware channel response, this may hurt or
improve the EVM. This is due to the dynamic range implications as it
relates to signal to noise ratio. The greater the RF hardware
variations in flatness, the greater the amount of correction is
required, the greater the correction effectively reduces the number of
resolution DAC bits that can be used, which degrades the signal to
noise ratio and therefore potentially EVM. The trade-off is to balance
between flatness and signal to noise ratio.

> Output 1: Adjustments

General 1/Q Common Delay Optimizations

. Os —
I/Q Adjustments ¥ Optimize Dynamic Range with OBW

AWGN Swap | &Q —
¥ Enable System RF Flatness Correction

8. Close the Adjustments Setup by either selecting the Back or the Home
icon at the top of the display.

[’}D > Signal 1: Setup

9. Set RF Out to On by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.
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Scareen Config + Stale
Comechon

Complex Correction
Recording

Recording + State
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D A-camier APSK scp ; 0:56 AM 402 KB Scp file

D 4-camer APSK selx i 200 1058 AM 504 KB Setx file
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10. For two channel instruments only: In the top right corner of the display,
set RF Out (All) to On by selecting the switch.

RF Out (All)

e
0| '
- i

In order to turn on RF for any channel, both the RF Out for the specific
channel (for example, Channel 1 or Channel 2), and RF Out All must be
turned on.

On the X-Series Signal Analyzer:

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or
the PC running the VSA application.

1. Select Recall (If accessing the signal analyzer remotely, select the Folder
icon at the bottom of the display) Demod Info > Set Data Type to CC Setup
> Recall From >

5GNR_1CC_FR2 120kHz SCS 100MHz 2560AM DC punctured
28GHz_34.scp >Recall

< Demaod info Recall from File

. -._ﬁ.—f—-.l—ﬁ_\‘—x
@’} Computer ‘) (18 /) Users ‘_,.\ Instrument / Documents 2 NRSG ) data 2 Example setup demao files __,'»

Mame

WG FR2 scp A 110:51 PM 431 KB Scp file
058 AM 133 KB Setx file

3 P 274 KB Scp file

TPM S0 KB Setx file

212112019 1:58 PM 456 KB Scp file

22112019 2201 PM 131 KB Setx file

e

131 KB Setx file

[™ Jacquie setx 131 KB Setx file

File name: | Jacquie sefx File type: All Supmned Files [* scp* sgen,*.nrce;* pwsg;* selx) Recall
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2. Select Meas Setup > Meas Time and set:
— Search Length to 10 ms
— Result Length to 2 Sub Frame
— Frame Trigger to On

3. Ensure that RF for Phase Compensation Auto is not selected and the value
is 0 Hz. Close the Advanced Settings table.

4. Select the Settings tab > Optimize EVM.

The Optimize EVM function automatically sets the combination of
preamplification, mechanical and electronic attenuation, and IF gain based
on the measured signal peak level.

EVM should be less than 1%.

KEYSIGHT -
\ " ol Ik

Al Ause

On the X-Series Signal Analyzer:
— Open the VSA software by selecting Mode Meas > Launch VSA.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.
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In the VSA software:

1. From the menu bar, select File > Preset > All to set the VSA to a known
state.

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or the PC
running the VSA application.

2. Select File > Recall > Recall Setup and navigate to
5GNR_1CC_FR2 120kHz SCS_100MHz 256QAM DC
Punctured 28GHz.setx

3. From the toolbar, select the Pause Icon. m

Pausing the measurement will help to speed up the setup time.
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4. From the menu bar, select Input > Trigger and set Style to External and
Level to 1.0 V.

Digital  Trigaer

Input Trigger Channel n

Delay:
Pasitive i
Huoldof Haldaf#:

Terne Criteria:

Amplitude
Upper 0Hz 0de

Laweer | O H:z udR

Tri:agtr Gk 1
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5. Select the Extensions tab and change the External Trigger location to
Trigger 1 In (if using an N9040B with Option H1G, select Trigger 3) and
Phase Noise Optimization to Best Wide Offset.

Analog Digital Capture Trigger

Logical Instrument:

Adc Dither

Capture Bit Packing

Ext Reference Lock Bandwidth
External Trigger Location

IF Path

IF Path Auto

Instrument User Corrections
LO Dither

Mic re Path Control
Mixer Mode
-ﬁhm'“_nise-.@pﬁm‘u.athn

Phase Noise Optimization

€ phas: e distribution == -
he frequency offset of the Fast Tuning
i Balanced

6. From the menu bar, select MeasSetup > 5G NR Demod Properties > Time

tab.

Playback Trigger External Mixer Extensions
Preset All

Show All

Off
Auto
15 Hz
Trigger 1 In
1GHz
Manual
Off
Off
Preselector Bypass
Normal
Best Close In
Best Close In
Best Wide Offset

Spur Avoidance

— Set Result Length to 10 Subframes.

— Set Meas Interval to 2 Subframes.
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— Select Frame Trigger is Present.

Configuration Input & Antenna Time Decode Advanced

Analysis Region
Result Length: 5 Subframes 0 Slots
Meas Offset: 2 Subframes 0 Symbols
Meas Interval: 3 Subframes 0 Symbols

Time Scale Factor: 1

Analysis Start Boundary Acqguisition Mode
Normal
® Frame
. Reduced acquisition length
Half-frame
) ® Frame tri
Subframe

Slot

First Slot Index: )

Timing Diagram

Result Length 5 Subf. ————

E Meas. Interval 3:0
* Meas. Offset 2.0

Frame Boundary

7. From the toolbar, select the Auto-Range dropdown and select EVM-Table
or Algorithm Based.

— EVM - Table or Algorithm Based performs EVM optimization based
on prescribed table/algorithm instead of using EVM in the feedback
loop. This method of EVM auto-range is normally faster than Meas
Based Iteration, but may not achieve the most optimal setup for
minimized EVM).

— EVM - Meas Based Iteration has a feedback loop around the entire
measurement, uses the measured EVM in the feedback loop, and
tries to adjust hardware parameters to minimize the EVM. It is the
slowest EVM auto-range method, but it should achieve the most
optimal setup for good EVM.

Control  Sowrce  [mput  MWeasSetup  Trace  Markers: Window  Ubilities  Help

= L T ARy

8. Select the Auto-Range icon to run the measurement for EVM optimization.
This may take a few minutes to complete.
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Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet
RF1:FREQuency:CW 28GHZ
RF1:POWer:AMPLitude 5dBm
SIGNall:MODE WAVeform

SIGNall:WAVeform “D:\Users\Instrument\Documents\MCS demo
waveforms
5GNR 1CC FR2 120kHz SCS 100MHz 2560QAM DCPunctured 28GHz.wfm”

SIGNall ON

IQ0:CORR:OPT:DYN: RANG: OBW ON
IQO:CORR:CHAN:FLAT ON

RF1:0UTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFAL1 :OUTPut ON

On the X-Series Signal Analyzer:
INSTrument:SELect VSA89601

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or the PC
running the VSA application.

SYSTem:PRESet

MMEMory: LOAD
“D:Users\Instrument\Documentts\NR5G\data\NR5GEvm\Carrier
Setup\5GNR 1CC FR2 120kHz

SCS 100MHz 256QAM DCPunctured 28GHz.setx”

INITiate:PAUSe

INPut:TRIGger:STYle "EXTERNAL"

INPut:TRIGger:LEVel :EXTernal 1V
INPut:EXTension:PARameters:SET "ExtTriggerLoc", 2

INPut :EXTension:PARameters:SET "PhaseNoiseOptDualLoop", 1
Set the 5G NR Demod Result Length to 10 Subframes:
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NR5G:RLENgth 10
NR5G: SUBFrame: INTerval 2
Set the Acquisition Mode to “Frame Trigger is Present”

nr5g:FRAMe : TRIGger:ENABled 1
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Setting Up an 8 CC 28 GHz EVM Measurement

Ensure the equipment and triggers are properly configured. Refer to
“Equipment Setup” on page 11.

Using the graphical user interface

On the VXG:
1. Select Preset > Preset to set the VXG to a known state.

2. Set Frequency to 28 GHz and Amplitude to 5 dBm.

28.00000000000 GHz

5.00 dBm

ALC ON
3. Select Group 1: Signals block to open.

| Group 1: Signals
File None selected

4. Select the arrow for Signal 1 to open the Signal Setup window.

This screen is only accessible if Option M9484C-8SG (8 virtual signal
generators) is installed. For all other option configurations, continue to the
next step.

Enabled & Frequency Offset

>
?
?
?
?
?
>
>
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5. In the Vector Modulation Signal Setup:

General
Waveform File
Trigger

Markers

General
Waveform File
Trigger

Markers

340

a. Select the Mode dropdown and set to Waveform File.

|_J_|| > Group 1: Signal' Summary » Signal 1: Setup

Mode Signal Attenuation

Waveform File 0dB

Frequency Offset Power

0 Hz 0dB

Sample Rate
3.000 000 000 000 000 GHz

Reset Phase Accumulator

. In the left pane, select the Waveform File tab.

Use File Select to navigate to:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

and choose
5GNR_8CC FR2 120kHz SCS 100MHz 256QAM Corrected 28GHz.
wfm

then Select.

. Select the General tab > Enable.

|_I'L.| > Group 1:Signal Summary » Signal 1: Setup

Mode Signal Attenuation

Waveform File 0 dB

Frequency Offset Power

0 Hz 0dB

Sample Rate
122.880 000 000 000 MHz

Reset Phase Accumulator
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6. Close the Signal Setup by selecting the Home icon at the top of the
display.

|_JLJ % Group 1: Signal Summary > Signal 1: Setup

7. Select the Adjustments block and select Optimize Dynamic Range with
OBW and Enable System RF Flatness Correction.

Optimize Dynamic Range with OBW This setting filters the system
RF flatness correction coefficients over the instantaneous bandwidth
indicated in the waveform header (or in the “Occupied Bandwidth”
settings area under the Signal block > Occupied Bandwidth setting).
This has the potential to improve EVM performance by not having to
correct for flatness errors outside the requested bandwidth. For
example, if RF flatness correction was done at 2 GHz, but you are
only interested in an 800 MHz section, then applying the correction
flatness to that portion only can improve signal to noise ratio, and
therefore EVM when there is a lot of hardware roll off.

Enable System RF Flatness Correction - Disabling this function
disables the factory calibrated RF channel flatness equalizer.
Depending on the hardware channel response, this may hurt or
improve the EVM. This is due to the dynamic range implications as it
relates to signal to noise ratio. The greater the RF hardware
variations in flatness, the greater the amount of correction is
required, the greater the correction effectively reduces the number of
resolution DAC bits that can be used, which degrades the signal to
noise ratio and therefore potentially EVM. The trade-off is to balance
between flatness and signal to noise ratio.

L’H] » Output 1: Adjustments

General 1/Q Common Delay Optimizations
. Os —
1/Q Adjustments | Optimize Dynamic Range with OBW

AWGN Swap | &Q _
™ Enable System RF Flatness Correction

8. Close the Adjustments Setup by either selecting the Back or the Home
icon at the top of the display.

[’}D > Signal 1: Setup

9. Set RF Out to On by selecting the numbered channel indicator switch.
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This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

10. For multi-channel instruments only: In the top right corner of the display,
set RF Out (All) to On by selecting the switch.

RF Out (All)

In order to turn on RF for any channel, both the RF Out for the specific
channel (for example, Channel 1 or Channel 2), and RF Out All must be
turned on.

On the X-Series Signal Analyzer:
— Open the VSA software by selecting Mode Meas > Launch VSA.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

In the VSA software:

1. From the menu bar, select File > Preset > All to set the VSA to a known
state.

All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or
the PC running the VSA application.

2. Select File > Recall > Recall Setup and navigate to

D:Users\Instrument\Documents\NR5G\data\NR5GEvm\Carrier Setup,
then open
5GNR_8CC_FR2 120kHz SCS 100MHz 256QAM Corrected 1.setx

3. From the toolbar, select the Pause Icon. m

Pausing the measurement will help to speed up the setup time.
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4. From the menu bar, select Input > Trigger and set Style to FreeRun.

Analog Digital Capture Trigger

Input Trigger Channel: 1 >
Entry Channel: . 1

Style
Free Run

Slope:
Holdoff Style:
Time Criteria:
Trige

Des
Trigger Qut 1

Playback Trigger

External Mixer Exten

Holdoff:

Timel: Time2:

Actual:

T | Trigger Out 1

5. Select the Extensions tab and change Phase Noise Optimization to Best
Wide Offset. (For an N9040B only, set External Trigger Location to Trigger

31n.)

Analog Digital Capture

Legical Instrument:

4 Misc
Adc Dither
Capture Bit Packing
Ext Reference Lock Bandwidth
External Trigger Location
IF Path
IF Path Auto
Instrument User Corrections
LO Dither
Microwave Path Control
Mixer Mode
Phase Noise Optimization

istribution
y offset of the ¢
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Trigger

Playback Trigger External Mixer Extensions

Preset All

Show All

Off

Auto

15Hz
Trigger 1 In
1 GHz

Manual
OFf
Off

Preselector Bypass
Normal

Best Close In

Best Close In
Best Wide Offset
Fast Tuning
Balanced

Spur Avoidance
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6. From the menu bar, select MeasSetup > 5G NR Demod Properties > Time
tab.

— Set Result Length to 10 Subframes.
— Set Meas Interval to 2 Subframes.

figuration Input & Antenna Time Decode A

10 Subframes 0 Slots

0 Subframes 0 Symbols

Meas Interval: 2 Subframes mbols

Time Scale Factor: 1

start Boundary Acquisition Mode
® Naormal
® Frame

Reduced acquisition length
Half-frame

- Frame trigger is present
Subframe

Slot trigger is present
Slot

First Slot In 0 Use Periodic Trigger

7. Select the Advanced tab select DC Punctured to On.

Configuration Input & Antenna Time Decode Advanced

Transient Period

Length:

Power Change Threshold:

1Q Impairments
1Q Imb. Estimation Mode: = Off
Compensate |Q Offset ¥| DC Punctured

UL Spectrum Flatness

+| Spectrum Flatness Enabled

Test Environment Condition: | Normal ~ Test Tolerance: 1.4 dB
Error Vector Unit
Time Domain: | per Symbol ~ Freq Domain: | per Subcarrier ~

MIMO Condition Number

Control: | Off * | RB Granularity: 1

Auto Set Span Report EVM in dB

Independent SSB/BWP Measurement Extend Frequency Lock Range | 480 kHz

¥| Multicarrier Filter On ¥| Compensate Symbol Clock Offset

#| Per Slot Channel Frequency Response

344 M9484C VXG and X-Series SA Measurement Guide



5G NR Measurements Using the VSA Software
5G Waveform and EVM Analysis Using VSA Software

8. In the bottom center trace window, select the Trace Data menu and select
Demod: > CC Summary.

9. Inthe Spectrum trace window (bottom left window), select Center and
change the frequency to 28 GHz.

10. From the toolbar, select the Autorange dropdown and select EVM-Table
or Algorithm Based.

— EVM - Table or Algorithm Based performs EVM optimization based
on prescribed table/algorithm instead of using EVM in the feedback
loop. This method of EVM auto-range is normally faster than Meas
Based Iteration, but may not achieve the most optimal setup for
minimized EVM).

— EVM - Meas Based Iteration has a feedback loop around the entire
measurement, uses the measured EVM in the feedback loop, and
tries to adjust hardware parameters to minimize the EVM. It is the
slowest EVM auto-range method, but it should achieve the most
optimal setup for good EVM.

File: Edt Confrol  Source [nput  MeasSetup  Trace  harkers Window Utilities  Help

D11 (0] : e mE (R0 QA %

11. Select the Autorange icon to run the measurement for EVM optimization
on all eight channels. This may take a few minutes to complete.
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Using the equivalent SCPI commands
On the VXG:

SYSTem: PRESet

RF1:FREQuency:CW 28GHZ
RF1:POWer:AMPLitude 5dBm
SIGNall:MODE WAVeform

SIGNall:WAVeform “D:\Users\Instrument\Documents\MCS demo
waveforms\5GNR 8CC FR2 120kHz SCS 100MHz Corrected 28GHz.wfm

r”

SIGNall ON

IQO:CORR:0OPT:DYN:RANG:OBW ON
IQ0:CORR:CHAN: FLAT ON

RF1:0UTPut ON

For multi-channel instruments, set RF Out (all) to On.

RFAL1 :OUTPut ON

On the X-Series Signal Analyzer
INSTrument:SELect VSA89601

MMEMory: LOAD: DEMO
"D:\Users\Instrument\Documents\NR5G\data\NR5GEvm\CarrierSetu
p\1CC FR2 120kHz SCS 100MHz 2560AM DC Punctured 28GHz.setx"

INITiate:PAUSe

INPut:TRIGger:STYLe "External"

INPut:TRIGger:LEVel :EXTernal 1V
INPut:EXTension:PARameters:SET "ExtTriggerLoc", 2

INPut :EXTension:PARameters:SET "PhaseNoiseOptDualLoop", 1
NR5G:RLENgth 10

NR5G: SUBFrame: INTerval 2

NR5G:FRAMe : TRIGger:ENABled 1

NR5G:CAGGregation:CONFigure "Contiguous8CC"

NR5G:DC: PUNCtured 1

NR5G:MCFilter:ENABled 1
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FREQuency:CENTer 28 GHz
INPut :ANALog:CRITeria:RANGe:AUTO "EVM", -1
All example waveforms and setup files are located on the VXG at:

D:\Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

You will need to copy over the setup files to the X-Series Signal Analyzer or
the PC running the VSA application.
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Creating a Basic 5G NR Signal Using PathWave N7631APPC
Embedded Software

PathWave software tools can be used to create, download, and playback
waveforms through the VXG.

This example shows you how to create and analyze a 5G NR signal using the
embedded PathWave software. Your VXG must include the N763TAPPC

license.

The VXG must have the N7631APPC Signal Generation for 5G NR license
installed.

On the VXG:
1. Select Preset > Preset to set the VXG to a known state.

2. In the Output area, set Frequency to 28 GHz and Power to
-10 dBm.

28.00000000000 GHz

-10.00 dBm

ALC OFF

3. Select the Radio Apps block to open the Vector Modulation Signal Setup
panel.

4. Select 5G NR to enter 5GNR Signal Mode.

|_|'L| > Apps

vy 2K LTE FDD (Beta) LTE TDD (Beta)
adulation (Beta) : .
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+ Bxpot

Marker
Crest Factor Reduction
AWGN

Routing
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5. In the 5G NR setup, select the Waveform tab and observe the Phase
Compensation and Radio Frequency settings.

RF Outt {AN)

Waveform

Phase Compensation is applied by default at baseband for RF up-conversion.
This means the waveform generation is per the carrier frequency, unlike
conventional Signal Studio waveforms, which are independent from carrier
frequency. Phase Compensation is set to Auto by default. The frequency is
coupled with the VXG frequency setting under the Instrument node. You can
select Manual to specify a different frequency, or turn it off.

Some applications, like power amplifier measurements use the same
waveform at different frequencies and can be time consuming to generate a
separate waveform for each frequency. In this case, you would turn Phase
Compensation Off, so the waveform becomes independent from the carrier
frequency. You need to do the same on the analysis side, or the demodulation
will fail.

350

6. Select the Carriers tab.

7. Select the Full-Filled Config tab and set Bandwidth to FR2 100 MHz,
Numerology to p = 3: 120 kHz, and Modulation to 256QAM.

If you have a signal analyzer with demodulation bandwidth that is wide
enough to cover the other FR2 bandwidths, 200 MHz or 400 MHz, you can
choose to use a wider bandwidth.

Full Filled Configurations is a great place to start creating your waveform.

You can select FR, bandwidth, and modulation format with a fully
allocated PDSCH data channel. This would represent a spectrally correct
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signal that is typically used in power amplifier measurements. You can
modify the RB allocations and Slot allocations if fully allocated data

channels are not desired.

Bandwidth FR2 100MHz

Numerclogy p=3:120 kHz

™ Duplex Type

Duplex Type

8. Select OK to exit the Full Filled Config setup.

9. From the Carrier panel (in the left pane), select Downlink > SS PBCH > SS
PBCH Block and change Lmax to 64 and Active Indices to = 0:7.

Instead of transmitting all 64 beams, we enable only 8 of them be setting
Active Indices to 0:7.

. Generate Carrler

i FulHilied config T+ DL TestModel f™ DL FRC Config <= Auto Frequency Offset [+ Export 89600 VSA Setup

General BWP

spectrum Contral [l I NR-PECH

Cell-Specific W oo MIB

DL-SCH

W csi-Rs : T
B LiE-Coexistence 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0.0
46

W Frs

Lmax sets the maximum number of possible SS/PBCH blocks in a transmission
opportunity. This value is fixed for a given carrier bandwidth. Typically, higher
frequency and bandwidth carriers use a larger set of SS/PBCH opportunities to
support a larger set of antenna beams.Lmax is either 4 or 8 for FR1 and 64 for

FR2.
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10. From the Carrier panel (in the left pane), select Downlink > DL-SCHs >
DL-SCHO > Modulation and Coding and verify that MCS Table is set to
Table 5.1.3.1-2 (256QAM) and MCS to 20.

(5 Genesale arrie ] [+ Impert Signal Setup [+ Export Signal Setup

mm Full-filled Config T DLTe

[+ Impuort Signal Setup [+ Export Signal Setup

T* DLTestModel g~ DLFR

Channel Allocation

12. Select the Home icon to return to the main window and set RF Out to On
by selecting the numbered channel indicator switch.

This enables the RF Out for the indicated channels, in this case Channel 1
if using a multi-channel VXG.

On the X-Series Signal Analyzer:
— Open the VSA software by selecting Mode Meas > Launch VSA.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.
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In the VSA software:

1. From the menu bar, select File > Preset > All to set the VSA to a known
state.

2. Set the Center Frequency to 28 GHz > Span to 100 MHz, then select Auto

Range.

Auto Range samples the current input signal and then sets the full scale
input range to the minimum range that includes the peak voltage sample
of the input signal.

dow  Utilities  Help

R [ & Ul A

3. From the toolbar, select the Pause Icon. !]I

TIP Pausing the measurement will help to speed up the setup time.
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From the menu bar, select Input > Trigger and set Style to External and
Level to 1.0 V.

Analog  Digital | Trigger P

Input Trigger Channel n

Pasitive

Hulda

Time Cri Tirne:

Frequen

apphy

Enter

Whndowr Tf,= P

of | ko

Fhat Top (2mplacc)

EHS

Tri:agtr Gk 1

354 M9484C VXG and X-Series SA Measurement Guide



5G NR Measurements Using the VSA Software
5G Waveform and EVM Analysis Using VSA Software

5. Select the Extensions tab and change the External Trigger location to
Trigger 1 In or Trigger 3 In (Use Trigger 3 if your N9040B has Option H1G,
1 GHz BW) and set Phase Noise Optimization to Best Wide Offset.

Analog  Digttal

Auto
Auto
15Hz

et Location Trigger 3 In

Off

Off

Preselector Bypass
Hormal

Best Wide Offset

6. From the menu bar, select MeasSetup > Measure Type Cellular > 5G NR >
5G NR Modulation Analysis.

7. From the menu bar, select MeasSetup > 5G NR Demod Properties >
Configuration tab.

P Meas01 - 56 NR Demod Properties ? X
Configuration Time Decode Advanced

Save As Quick Setup...  Quick Setups...

Signal Carrier Type:  ‘® Downlink Uplink

e Apply Test Model...
BWP Aggregation

4 Channel Configure... Add Carrier

Reference: CCO =
PDCCH
R Cell ID
0

C5I-RS

Manually apply settings

TIP Use Quick Setups for convenient saving and loading of common
configurations. Quick Setups are factory supplied configurations and cannot
be deleted by users. (This includes Signal Studio Downlink and Uplink
defaults.)
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Save As Quick Setup (saved by the user) can be specific to the current user or
can be made available to others users. These setups can also be deleted.

8. Select the Carrier panel.

The Carrier dialog is used to configure component carrier level
parameters: Cell ID, Bandwidth, and Resource Grid for each Numerology.

Configuration Input & Antenna Time Decode Advanced
Save As Ouick Setup.  Ouick Setups..
Link Direction; '@ Downlink Uplink

Allow Multiple C.

Configure... | -+ Add Carrier

Reference: | CCO = Display: | CCO =

CSI-RS

Results & Filters e
Configure,.,

— SetCellIDto 0

When the checkbox is selected, Cell ID auto-detection is enabled
for the carrier.

Cell ID is carried on PSS and SSS so the SS/PBCH must be transmitted
and enabled for Auto Cell ID to work. It must also be a downlink since
SS/PBCH is only transmitted on a downlink.
— Set Bandwidth to FR2 100 MHz
9. Select the Bandwidth panel and set Numerology to p = 3: 120 kHz

For FR2 100 MHz, the Max RB for 120 kHz numerology is
66 RB. This value will be used when we configure BWP, SS/PBCH, and
PDSCH.
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FR2 only uses 60, 120, or 240 kHz numerologies. This is why 15 and
30 kHz numerologies do not show under the Resource Grid.

Configuration

Input & Antenna Time Decode

Advanced

Save As Queck Setup...  Quick Setups... SO0 Cho

Bandwidth: | FR2 100 MHz
Resource Grid
MNumerclogy Gnd Start Gnd Enabled

ORE

Results & Filters

10. Select the BWP pane, then enable DL-BWP.

This section is used to configure the Downlink BWP allocation within the
component carrier and the control resource set (CORESET). CORESET is

used for PDCCH configuration and will not be used in this example. We
will use the default values of:

— Numerology p= 3: 120 kHz
— RB offset 0 RB
— RB Number 66 RB
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A component carrier with 100 MHz at FR2 has a maximum RB of 66
for 120 kHz numerology. In this example, DL-BWP uses the full
carrier bandwidth of 66 RBs as shown below.

Input & Antenna Time Decode Advanced

Juick Setups... CCo: C00

D
Instial-DL-BWP D

J|DL-BWP

pping Type: | Non-interleaved

Precoder Granularity: Same a3 REG bundle -

TIP VSA supports a single BWP within a component carrier (CC). Signal Studio
and X-Apps support multiple BWPs within a CC. You can use VSA
multi-measurement to analyze multiple BWPs simultaneously.

11. Select the Channel pane > SS/PBCH, enable SS/PBCH and set the
following parameters:

— Lmax to L64

Lmax specifies the maximum number of SS/PBCH Blocks (that is,
beams) in an SS Block period.

— FR1 up to 3 GHz, Lmax = 4
— FR1 3to 6 GHz, Lmax =8

— FR2 6 to 52.6 GHz, Lmax = 64
— SSB Transmitted to 0:7
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For this example, we will not use all 64 SS Blocks; we will activate
only 8 of them. You can also select the Auto Detect Active Block
and set the Det Power Threshold to auto detect the active SS
Blocks.

Configuration Input & Antenna Tirme Decode Advanced

Save As Quick Setup...  Cuick Setups... CC0: CDO

Casriers SS/PBCH

Bandwidth Lmae Lbd = 55B Transmitted:
BWR of | Aurto Detect Actn b Dt Power Threshold:

Channel

Numerology:

18 ms = 2 Hz band ot GENTEr

Results & Filters 5 et boosting  OdB PBCH power boosting |0 dB

IGPP Version: | Latest (3

These following settings use the default values.
RB Offset(60kHz) = 46 RB

kSSB(60kHz) =0

Periodicity =10 ms

Numerology = pu=3 = 120 kHz

Configuratian Input & Antenna Time Decode Advanced

Save s Quick Setup..  Quick Setups.. SO0 Cha

Cartiers
Banduicdth
BWP

Chaninel

Results & Filters
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The frequency location of an SS Block is not fixed. The default value of 46
RB and kSSB of 0 subcarriers places it in the center of the carrier
bandwidth. This value is calculated based on the 60 kHz numerology as
defined by 3GPP (15 and 30 kHz sub-carrier spacing uses 15 kHz
numerology, 120 and 240 kHz spacing uses 60 kHz numerology.)

For example, to calculate the 120 kHz sub-carrier spacing, the value
would be

66RB/2 = 33 RB

This is the center of the carrier bandwidth. However, the SS Block is
20 RB wide, so the start of the SS Block is 23 RB.

23 RBin 120 kHz is 23 * 2 = 46 RB in 60 kHz
This is the default value used in the VSA software for 120 kHz numerology.

12. From the Channel pane, select PDSCH and then set the following

parameters:

— Under Modulation and Config section, set MCS Table to Table
256QAM and MCS to 20.

Configuration Time Decode Advanced

Save As Quick Setup... | Quick Setups...

Add PDSCH Remove PDSC

PDSCH: a

| Enabled RNTI: |1 3GPP Version: | Latest (2018-09/12) ~

Modulation and Coding | Time/Freq Allocation

popoopoobDDDDDDDD

Typel -
nip Source Cell ID B ORB RB Mumber: | 66 RB
np

CORESET ID:

RS Sequence

Power Boosting
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TIP 3GPP has different Tables for PDSCH MCS.
Table 5.1.3.1-2 has 256 QAM as maximum modulation
Table 5.1.3.1-3 has 64 QAM as maximum modulation

Table 5.1.3.1-1 has 64 QAM as maximum modulation, and is for low
spectrum efficiency (LowSE).

See 3GPP TS38.214 for more information.

— Under the Time/Freq Allocation section, set
— Allocated Slots to 0:79
— Slot Formatto 0
— First Symbol to 0
— Last Symbol to 13
— RB Offset to O RB
— RB Number to 66 RB

B MeasD1 - 56 NR Demod Properties 7 ?
Configuration Time Decode Advanced
Save As Quick Setup...  Quick Setups...
Signal

Add PDSCH

Carrier
o PDSCH: a

4 Channel : L . § )
Modulation and Coding | Time/Freq Allocation

lation and Coding Time/Freq Allocation
] Allocate s 0:79

Table: Table 2560AM
MCS:
TB Scaling Factor 5: Mapping Type
Coding Rate: 0.6 5 First Symbol:
Modulation: ) 5 Resulting Format: DDDDDDDDDDDDDD
Transport Block Size: RA Type: Typel -
nip Source Cell ID Off: 0RB RE Number: | 66 RB
np

CORESET ID:

RS Sequence

Power Boosting

Antenna Port
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We will use the default values for RS Sequence, Power Boosting, and
Antenna Port. Power s would not change the DMRS sequences, but they
might be interested in modifying Power Boosting.

13. Select the Time tab and set:
— Result Length to 10 Subframes.
— Meas Interval to 2 Subframes.

— Select Frame Trigger is Present.

Configuration Input & Antenna Time Decode Advanced

Analysis Region
Result Length: 5 Subframes 0 Slots
Meas Offset: 2 Subframes 0 Symbols
Meas Interval: 3 Subframes 0 Symbols

Time Scale Factor: q

Analysis Start Boundary Acquisition Mode

Mormal
® Frame
- Reduced acquisition length
Half-frame
) Frame trigger is present
Subframe
Slot trigger is present
Slot

First Slot Index: 0

Timing Diagram

Result Length 5 Subf. ——

E Meas. Interval 3:0
* Meas. Offset 220

Frame Boundary

14. Select the Advanced Settings tab and select DC Punctured.

5G NR counts the DC subcarrier as a valid subcarrier for rate-matching
purposes. The network decides if the DC subcarrier is modulated or not.
High LO feedthrough will impact demodulation and EVM performance of
the input signal. This setting is off by default.

Use Extend Frequency Lock Range if you cannot lock to the input signal.

Compensate Symbol Clock Offset is used along with timing track to
compensate for clock error in the input signal. The Symbol Clock Error
result is reported in the Summary trace.
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3GPP Conformance Test > Phase is enabled by default. It is specified in
the 3GPP requirement and is used to compensate for phase differences

between symbols caused by up conversion or down conversion. Getting
this setting wrong will cause demod issues.

Configuration Input & Antenna Time Decode Advanced

19 RS

Transient Period

Length:

: R Power Change Threshold: 1
% of FFT Duration: -3.125 %

1Q Impairments

IQ Imb. Estimation Mode: = Off

Compensate |Q Offset +| DC Punctured
UL Spectrum Flatness
| Spectrum Flat Enabled

Test Environment Condition: | Normal * Test Tolerance: | 1.4 dB

Error Vector Unit

Time Domain: | Per Symbol ~ Freq Domain:

Per Subcarrier ~

MIMO Condition Number

Control: = Off ¥ | RB Granularity: 1

Auto Set Span Report EVM in dB
Independent SSB/BWP Measurement v Extend Frequency Lock Range | 480 kHz
Multicarrier Filter On v Compensate Symbol Clock Offset

Per Slot Channel Frequency Response
15. From the menu bar, select Window > Trace Layout > Tile Visible.

This will display all six 5G NR traces on the display.

16. Select the Auto-Range icon to run the measurement for EVM
optimization. This may take a few minutes to complete.
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The VSA has color coding based on channel type, marker coupling to pinpoint
error, symbol level analysis (by changing the measurement interval, and
measurement offset into a single symbol).

364
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More About the 5G NR Traces

Trace A: shows the composite constellation diagram showing different
modulation formats for the different channels/signals present in the
transmitted signal.

Trace B: shows the frequency spectrum.

Trace C: shows the composite error metrics. You can also see the
automatically detected Cell ID value and the Channel Power.

Trace D: shows the EVM versus subcarrier and symbol.

Trace E: shows the detected allocations of all channels/signals within the
measurement interval. (For this example, 2 Subframes) You can see the 8
active SS Blocks in the first four slots.

Trace F: shows the frame summary: EVM Power per RE, Modulation format,
Number of RB and RTNI of the individual channels/signals.

For more information on these traces, see the Online help.

M9484C VXG and X-Series SA Measurement Guide



5G NR Measurements Using the VSA Software
5G Waveform and EVM Analysis Using VSA Software

Trace Filtering

The VSA has per-trace filtering to filter by subsegments and channels.
Subsegment refers to Layers, (in case of MIMO), BWP, and SS Block. In the
downlink, Layers in DL-BWP and SS Block are presented as subsegments. In
the uplink, Layers in UL-BWP are presented as subsegments.

The following traces can be filtered by subsegments and channel types.
— OFDM Meas

— OFDM Ref

— Error Vector Spectrum

— Error Vector Time

— Detected Allocations Time trace can be filtered per channel only

The rest of the traces do not support per-trace filtering.

A Simple Example

We will apply per-trace filtering to Error Vector Spectrum (Trace D) and
Detected Allocations Time (Trace E) traces.

1. From the menu bar, select Trace > Digital Demod.

2. In the Trace Dialog, select Trace D (OFDM Error Vector Spectrum) from the
dropdown.

3. In the Filtered SubSegments area, clear the Layer0 check box.
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This allows you to take a look at SS Block. You can also filter with SS
Block Channels/Signals you want to see by using the Filtered Channel

Type.

Format Coupling ¥ Scale X Scale Average Digital Demod
TraceD ~| + | Visible

Ideal State

Symbol Table Format:

Hex Shape:

Symbol Table Bit Order: e

Auto

Symbol Shape:

Bars

Eye Length: Code Order:

2 Bit Reverse

Time Unit:

sym Show 2D Avg Line
Frequency Unit:

carrier

Filtered SubSegments: Filtered Channel Types:

Select All Clear All Select All Clear All

4. Select Trace E (OFDM Detected Allocations Time) from the Trace dialog.
5. In the Filtered SubSegments area, clear the SS Block0 check box.

This alloys you to look at Layer 0 information, which is the DL-BWP
information.

. In the Filter Channel Types area, Clear All selections, then select just

PDSCH-DMRS.
You now see a gap in two of the DMRS symbols. Why is this?

Notice that the Frame Summary table shows Num. of RBs for PDSCH of
1056 and 1016 for PDSCH-DMRS. The signal configuration only had 66
RBs. Why the change in the measurement result?

The RB result in the Frame Summary table is per Slot. In this example, we
changed the measurement interval to 2 Subframes, which is 16 slots for
120 kHz numerology (8slots/subframe). 66*16=1056. For PDSCH-DMRS,
the value is 1016 because of the 16 slots overlap with the SS Block, which
occupies 20 RBs. This results in 20 RBs being punctured from DMRS in
these two slots, so the total RB Number for DMRS is 1056-20*2 = 1016.

M9484C VXG and X-Series SA Measurement Guide



5G NR Measurements Using the VSA Software
5G Waveform and EVM Analysis Using VSA Software

Using the equivalent SCPI commands

On the VXG:

SYSTem:PRESet

RF1:FREQuency:CW 28GHZ

RF1:POWer:AMPLitude -10dBm

RADio:SELect NR5G
RADi0:NR5G:WAVeform:CCARrier :BWIDth FR2BW100M
RADi10:NR5G:WAVeform:CCARrier:SNUMerology MU3
RADi0:NR5G:WAVeform:CCARrier :DLINk:SSBLock:LMAX 64

RADio:NR5G:WAVeform:CCARrier:DLINk:SSBLock:ACTive:INDices
"O:7"

RADi0:NR5G:WAVeform:CCARrier :DLINk:SCHO:MCS 20
RADi0:NR5G:WAVeform:CCARrier :DLINk:SCHO:MCS:TABLe TABLeb52
RADi10:NR5G:WAVeform:GENerate

GROup:SIGNall ON

RF1:0UTPut ON

For multi-channel instruments, set RF Out (all) to On.
RFALL :0OUTPut ON

On the X-Series Signal Analyzer:

INSTrument:SELect VSA89601

SYSTem:PRESet

FREQuency:CENTer 28 GHz

INPut : ANALog: RANGe : AUTO

INITiate:PAUSe

INPut:TRIGger:STYLe "External"
INPut:TRIGger:LEVel :EXTernal 1V

INPut:EXTension:PARameters:SET "ExtTriggerLoc", 2 (This will
set it to Trigger 3)

NR5G: FRAMe : TRIGger:ENABled 1
INPut:EXTension:PARameters:SET "PhaseNoiseOptDualLoop", 1

MEASure:CONFigure NR5G
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NR5G:CCARrier:CIDentity:AUTO 1 |OR| NR5G:CCARrier:CIDentity

0

NR5G:

NR5G:

NR5G:

NR5G:

NR5G:

NR5G:

NR5G:

NR5G:

NR5G:

NR5G:

NR5G

NR5G:
NR5G:
NR5G:
NR5G:

NR5G:

NR5G

NR5G:
NR5G:
NR5G:
NR5G:

NR5G:

CCARrier:TBANdwidth

DBWP:ENABled 1

"FRTwolOOMHz"

DBWP:NUMerology "Mu3"

DBWP:ROFFset 0
DBWP:RNUMber 66
SSBLock:ENABled 1
SSBLock:LMAX "L64"

SSBLock:AINDexes "0

:7"

DBWP:PDSCh1:MCS:TABLe "Table2"

DBWP:PDSChl :MCS 20

CCAR:PDSCH1:SFI O

:DBWP:PDSChl:SLOT:ALLocated "0:79"

CCAR:PDSCH1:SINDex:FIRSt O

CCAR:PDSCH1:SINDex:LAST 13

CCAR:PDSCH1 :ROFFset

CCAR:PDSCHI : RNUMber

:RLENgth 10

SUBFrame: INTerval 2

0
66

FRAMe: TRIGger:ENABled 1

DC:PUNCtured 1

MCFilter:ENABled 1

FREQuency:LOCK:EXTended 1

NR5G:COMPensate: SYMBol :CLOCk:0OFFset 1

DISPlay:LAYout 3,2

INPut:ANALog:CRITeria:RANGe:AUTO "EVM", -1
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Creating a DL MIMO Signal Using PathWave N763TAPPC Signal
Generation

The VXG must have the N7631APPC Signal Generation for 5G NR license
installed.

This procedure will show you how to configure and analyze a downlink (DL)
multiple input, multiple output (MIMO) signal using PathWave Signal
Generation and the 89600 VSA software. The hardware setup below includes a
2-channel VXG signal generator and a 2+ channel, 33 GHz or higher Infiniium
UXR-Series Oscilloscope.

TIP If you do not have access to a Keysight Infiniium UXR Real-Time Oscilloscope,
a UXR recording waveform file has been included in the Example waveform
file folder:

D:\Users\Instrument\Documents\Keysight\PathlWave
\SignalGenerator\Examples

You will need to copy the 5GNR_UXR_Recording_28GHz.sdf file to the
X-Series Signal Analyzer or the PC running the VSA application. Steps have
been included below to successfully run the recording.

Hardware Requirement

— 2 channel M9484C VXG

— UXR with DDC option:
— UXR000-601: 160 MHz BW or
— UXR000-602: 2 GHz BW

Hardware accelerated DDC decimates oscilloscope captures in real-time
enabling deep captures and fast measurement speed.

Software Requirements

PathWave Signal Generation for 5G NR N7631APPC Use latest release from Keysight.com
89600 VSA software 89601BHNC VSA2023U2 or later

Equipment Setup for the M9484C

— M9484B CH1 front panel RF Out to UXR front panel CH1
— M9344B CH2 front panel RF Out to UXR front panel CH3
— MO9484C front panel Channel 1 Event 2 to UXR rear panel Aux Trig In
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— MO9484C rear panel 10 MHz Out to UXR rear panel 10 MHz Ref In.

MO484C front panel Channel 1 Event 2 to UXR rear panel Aux Trig In

M9484C rear panel 10 MHz Out
to UXR rear panel 10 MHz Ref In A

CH2 RF2 Out UXR

m9484c_UXR_4chan

On the VXG:

1. Select Preset > Preset to set the VXG to a known state.

If a Synchronization Alignment is required, indicated by in the
bottom left corner, tap or click the warning message and choose Perform
Alignment before proceeding.

Instrument Information Gl Synchronization Status
/O Configuration C 1 iy il sig hannels utilizi - e W synchronization on
Alignment

. Immediate
clobal Trigger/Sync
Power On/Presel
Reference
liQ Waveform Synchronization Aignment

Service

Preforences

strument, whar

Perform Alignment Clear Alignment
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2. In the Menu/Tool Bar, select the Triple Bar icon (top left corner of the
display, and then select Configure Channels. Change the signal
configuration from Independent to 2 Tx Coherent > Add > Apply > Apply.

remaining Channels will be set 1o Ind:

1 CHANNEL 2 CHANNELS 4 CHAMNELS

Independent 2 Tx Coherant | 4 Tx Coherent

Nx2 MIMO (Beta) Mxd MIMO (Beta)

Cancel

3. In the Output area for both Channel 1 and Channel 2, set Frequency to

28 GHz, or the frequency you are using, and Power to 0 dBm.

28.00000000000 GHz

0.00 dBm

ALC ON

28.00000000000 GHz

0.00 dBm

ALC ON

4. Select the Apps block to open, then select 5G NR.

|_|'L| > Apps

Custom -V2X LTE FDD (Beta) LTE TDD (Beta)
Modulation (Beta)
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5. Select the Waveform tab and set the Total Number of Antennas 2. This
means that two antenna port signals will be generated.

(m] > App

& Generate Carrler  iNaetien

|+ Exporl B

Markar

actor Reduction

6. Select the Carriers tab > Cell Specific node, and set Bandwidth to FR2
100 MHz. Keep the rest of the default settings.

& Eancmate . A f
, Generate Carrier Wavelorm

wm FulHfilled Config T+ DLTestModel g™ DL FRC Config « Auto Frequency Offset [+ Export B9600 VSA Selup

General Carrier Typa Downlink s

Spectrum Control CelliD 0

Numerology Mode Single Nume
Downlink
Numerology P=3:120kHz v

Max RB b6

k0 1]

Configured Bandwidth

7. Select the Downlink node > SS/PBCH > RB Offset by 60 kHz SCS and set
to 0.
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This automatically changes the Delta Frequency to Carrier Center to
-33.12 MHz. Using 0 RB Offset puts the SSB at the lower edge of the
carrier.

“  Custom Modulation (Beta) ™

(", Generate Carrier Waveform

mm Fultfilled Config T+ DLTestModel g~ DL FRC Config - Aulb Frequency Offset -+ Export 89600 VSA Selup

BWP

NR-PECH e 0:3

5 0,0,0,0,0,00,0,0,0,0,6,0,0,0,0,0,00,0,0,C
[ [lsl MIB

DL-5CH

B csi-rs

33,12 MHZ

. LTE-Coexistence ex 0

| GES 1SS Power Boosting o0ds

8. Select the Downlink node > DL-SCH> Transmission Settings and confirm
DMRS ports is set to 0,1. Set Number of DMRS CDM groups without data
to 2.

You will see the layer number is updated to 2 and each layer is assigned
with a particular DMRS port. You'll also see that Antenna Ports Generated
is automatically set to PO,P1, which will map the multiple antenna port
signals to different antennas (instruments).

Carrler
T* DLTestModel @~ DL FRC Config = Aulo Frequency O
BWP

Spectrum Control . 8S/PBCH

Cellspecific oo

DMRS Setlings

PTRS Settings

HARQ Settings

9. Select the Resource Allocation node and set:
— Allocated Slots to 2:79
— RB Offset to 20
— RB Number to 20
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DL-SCHO will occupy the RBs 20-40 and DL-SCH1 will occupy the rest of
the resources.

", Generate Camer Wavelorm

s FulHilled config T+ DL TestModel | DL FRC Confy - Auto Frequency Offset [+ Expo

General e General Settings
]
Spectium Control SS/PBC Trangmission Settings First Symbol
Last Symbaol

Bandwidth Part
Modulation and Coding

DMRS Set
PTRS Settings
kLl RE Number

HARQ Setlings VRB-to-PRB Mapping

10. Select the Modulation and Coding node and set:
— MCS to 20

— MCS Table to 5.1.3.1-2 (256 QAM)
Notice that modulation is updated to 256 QAM.

Generate Carrier Waveform
mm Fullilled config T+ DLTestModel g~ DL FRC Conflig <+ Aulo Frequency Offsel [+ Export 80600 VSA Setup
General BWP . General Setlings

spectrum Control [l SS/PBCH Transmis

Regource Allocation

DMRS Settings

PTRS Settings

HARQ Sellings

11. Select the DMRS Settings node and notice that DMRS Power Boosting is
set to 3 dB.
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When CDM Group Number is 2, DMRS power boosting becomes 3 dB per
3GPP.

Custorn Modulation (Beta)

, Generate Carrier Waveform

#m FulHfilled Corfig T+ DL TestModel g™ DL FRC Config & Auto Frequency Offsat [+ Export 80600 VSA Setup

BwWP : General Settings
spectrumn Control [ ss/PBC Transmission Settings DMRS PowerBoosting
- e T DMRS Configuration
. Bl Hegource Allocation -
DMRS Duration
Modulation and Coding

B csias

f PTRS Setting
B UE-Coexistence TRS Settings DMRS

N_ID.O Cell ID

12. Under the DL-SCH 0 node, select the + icon to add a new +DL-SCH
(DL-SCH1).

& oenemte Camier  Waveforr [+ Import Signal Setup

wn FulfilledConfig T+ DL Test Model < Aulc Frequency

PTRS Settings

M9484C VXG and X-Series SA Measurement Guide 375



5G NR Measurements Using the VSA Software
5G Waveform and EVM Analysis Using VSA Software

This will create a conflict between DL-SCHO and DL-SCH1. This will be
resolved in a later step.

(%, Generate Camier  Waveform

wn Full-filled Config T+ DLTestModel §° DL FRC Config # Auto Frequency Offset |+ Export 89600 VSA Setup
General BWP | s General Settings
Spectrum Control  [J] SS/PBCH H Transmission Setiings
Cell-Specific Hoci DL-SCH 1 Resource Allocation

Modulation and Coding

[l csiRs

B LTE-Coexistence PTRS Settings
B Prs HARQ Settings

Channel Allocation Summary

13. From the Channels node, select DL-SCH > DL-SCH1 > Transmission
Settings and set DMRS port(s) to 0,1. Change the Number of DMRS CDM
groups without data to 2.

376 M9484C VXG and X-Series SA Measurement Guide



5G NR Measurements Using the VSA Software
5G Waveform and EVM Analysis Using VSA Software

Notice that Number of Layers is updated to 2 and each layer is assigned
with a particular DMRS port. Antenna Ports Generated is automatically
assigned PO,P1, which will map generated multiple antenna port signals
to different antennas (instruments).

™ Apps

", Generate Carrier Waveform
es FulHiledConfig T+ DL TestModel g DLFRC Config < Aulo Frequency Offsel [+ Export B9600 VA Selup

General BWP ! es General Settings Antenna Po

Spectrum Control [ S5/PBC DL-SCHO DMRS portis)

T . Number of
Cell-Specific Resource Allocation

Number of Antenna ports

Mnodulation and Coding

B Csi-RS DMRS Settings
Number

| s

H rrs HARQ Settings

14. Select the Resource Allocation node and set:
— Allocated Slots to 2:79
— RB Offset to 45
— RB Number to 18
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Notice that this resolves the conflict between DL-SCH channels. (The pink
shading is removed from the Channel Allocation graph. To clear the
conflict error message at the bottom of the display, select the Message

icon (bottom, right corner) and select Clear.

Carrigr

mm Fullflled Config T+ DL Teal Mode! g DL FRC Config o Jula Fre

cell-Specific

Channel Allocation Summary

15. Select the Modulation and Coding node, and set MCS to 20.

Use the default MCS Table to Table 5.1.3.1-1 (64QAM). You will see the
modulation is updated to 64QAM.

mu Full-filled Config

HARG Setfings

Channed Allocation Summary Framed ~  p=3 ~ gn Display Detail
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16. Select the Waveform tab > Marker and notice that Marker 2 Source is set
to Frame Start. Select Generate.

™ Apps 56NR sustom Modulation (Beta)

(%, Generate Carrier Waveform

[+ Exporl B9600 VSA Selup

Basic

- = f Mark
ctor Reduction e

Marker 4 Source
AWGN

Routing

17. In the bottom panel, select Spectrum.

You should see a spectrum like the one below.

Carrier waveform

Arenna 0 s

18. Return to the Carriers tab and select Export 89600 VSA Setup. Save the
.setx file to a USB drive to transfer to the VSA. We will also set up the
89600 VSA manually in the next section.
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19. Select the Home icon and set RF Out to On by selecting the numbered
channel indicator switches, and then select RF Out (All) master control
switch to turn the RF output On for both channels or off for both channels.

Adjustmeants

28.00000000000 GHz

0.00 dEm

COFF

28.00000000000 GHz

0.00 dBm

To Setup the VSA Using the Infinilum UXR Real Time Scope

There are two different VSA setup process.

— If you have access to a Keysight Infinilum UXR Real Time Scope continue to the
first step below.

— If you do not have access to a Keysight Infinilum UXR Real-Time
Oscilloscope, a UXR recorded waveform file has been included in the
Example waveform file folder of the VXG. Go to “To setup the VSA Using
a UXR Recorded Waveform File” on page 401

To analyze the signal using the VSA on the UXR307944
1. Open the VSA software.

To access the VSA software, go to the Windows Start menu and find
Keysight 89600 Software (latest installed version) folder and run the
software.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.
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2. From the VSA menu bar, select File > Preset > All to set the VSA to a
known state.

3. To configure the hardware, go to Utilities > Hardware > Configurations.
If it is already configured, go to step 10.

4. Open the Discovered Instruments tab and verify that the UXR is listed, if
not, select the Rediscover Instruments icon.

2= Hardware ? X

Configurations Discovered Instruments

4 TCPIPO
Keysight N9042B Signal Analyzer
t/Agilent PXA Signal Al

Keysi

Keysight/Agilent UXA RF Tuner (TCPIPO:k-n8040b-1220i
b SIM
P USR

5. In the Configuration tab, select the + icon.

2= Hardware ? b4

Current Analyzer Configuration: Anahzer3 - Channels

+ M

4 Anslyrer Configurations Mame: Analyzer3

Analyzer
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6. Scroll down the Possible Logical Instruments and select Keysight/Agilent
Infiniium Series Oscilloscope, and then select the right arrow to move it
under Configuration.

= New Hardware Configuration ? X

es and Analyzers cannot be combined within the same ¢

. Configuration

b Keysight/Agilent Infiniium Series Oscilloscope

Hints

2. Select the instrument(s) to use for each logical instrument in the configuration.

ADC Keysight/Agilent Technologies Infiniium Series Scope TCPIPO:locathost=inst0=INSTR -

¢ the configuration

Cancel

7. From the middle of the dialog box, select the UXR to be used.

2. Select the instrum to use for each logical instrument in the configuration

ADC Keysight/Agilent Technologies Infinirum Series Scope TCPIPO:localhostinstl:INSTR

8. Select OK to create the UXR configuration.
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9. In the Configurations tab, set the Current Analyzer Configuration, select
the Analyzer number for the new configuration. In this example Analyzer 3.

Configurations Discovered Instruments

Current Analyzer Configuration: Analyzer3 - Channels; Baseband: 1 Channel

3 A .
+ {;;.) i Analyzer

4 Analyzer Configurations Group Type:  Analyzer
4 N

/Agilent Infiniium Series Oscilloscope
Infiniium (SIMzInfiniium)
ysight/Agilent Infiniium Series Oscilloscope

Infimiium (SIM:Infinitum)
Analyzer3
4 Keysight/Agilent Infiniium Series Oscilloscope
Infiniium (SIMzInfiniium)

4 Keysight/Agilent Infiniium S

Oscilloscope

ium (SIM:Anfiniium)

7 Stream (US

The following steps perform the exact same function as loading the setup
file you exported the VSA Setup File. At this point you can follow the steps
below, or simply select File > Recall > Recall Setup and select the file you
saved to the VXG.
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10. From the menu bar, select Input > Channels > RF > 2 Channels.

E Vector - Keysight PathWave Vector Signal Analysis (89600 VSA)

File Edit Control Source | Input | MeasSetup Trace Markers Window  Utilities Help

|| C) Channels > ﬂ Baseband: 2 Channel » 1 Channel
_ 1+jQ » | ¥ | 2Channel

T Analog...
X - o~ .
e pectrum Digital.. TS 3 Channel

ng -1 dBm ~ 4 Channel
= Capture...

Trigger...

Playback Trigger...

External Mixer...

Extensions...

User Correction...

Playback User Correction... L r|'."LI|"| e L
. AATE
Data From [ ” 1‘ u
Recording... '

Select Switch: None

Switch...

11. Set the center frequency of both channels to 28 GHz, or the frequency
you are using, and span to 100 MHz.

You can also set the frequency and span of both channels under Meas
Setup > Frequency.

If you are using a UXR, Select Autorange.

Auto Range samples the current input signal and then sets the full scale
input range to the minimum range that includes the peak voltage sample
of the input signal.

1bats | EvcOata fF - /

% Meas01 - MeasSetup 7 X

Frequency ResBW Time Average

Measurement Channek

Center

28 GHz 100 MHz
v

+ Auteo Frequency Step

Time Data:

Zoom v Mirror Frequency

i

[Ty — | weree | euox

w2 O B € ©
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12. From the menu bar, select Input > Trigger and set:
— Style to External
— Levelto1V

Arzlog Digital Trigger

13. From the menu bar, select MeasSetup > Measurement Type > Cellular >
5G NR > 5G NR Modulation Analysis.

14. Change the trace layout to Grid 2x3.

File Edit Control Source Input MeasSetup Trace Markers Window Utilities Help

Bm ®:lLae R
A; OFDM Meas « X | C: Summary Previous Layout

Single
Stack 2
Stack 3

Stack 4

Stack 6

Grid 2x2
Grid 2x3
Grid 3x2
Custom...

Tile Visible
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To improve setup speed, Pause the measurement until all parameters are
correctly configured, then run the measurement.

386

15. Select MeasSetup > 5G NR Demod Properties > Configuration tab and set
that Bandwidth FR2 100 MHz, Carrier Center and Frequency for Phase
compensation are set to 28 GHz. Select the Cell ID checkbox.

= emod Properties

Advanced

Carriers Link [ ion: @ Downlink Uplink

Bandwidth Fordgre + Add Carrier Allow Multiple Carrier Definitions

Reference: CCO = Display: CCO =

Banidwidth

FR2 100 MHz = || 28 GHz

ted EVIM

Configure...

Manually apply settings

Cell ID is carried on PSS and SSS so that SS/PBCH must be transmitted
and enabled for Auto Cell ID to work and must be a Downlink since
SS/PBCH is only transmitted in the DL.

Phase compensation is per the 3GPP requirement, and is enabled by
default. It is used to compensate for phase differences between symbols
caused by upconversion or downconversion. Getting this setting wrong
will cause a demod issue. For this example, it is ON and it is applied at the
center frequency.

16. Select the Bandwidth pane and confirm that numerology is set to
p= 3:120 kHz.
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The Bandwidth panel is used to configure the Resource Grid for each
Numerology. Note that for FR2 100 MHz, the Max RB for 120 kHz

Numerology is 66 RB. We will use this value when we configure the
PDSCH parameters.

Configuration Input & Antenna Time Decode Advanced

Save As Quick Setup...  Quick Setups... -

Carriers

Bandwidth: ~ FR2 100 MHz ~
Bandwidth

Resource Grid
BWP

Numerology Grid Start Grid Size Grid Enabled

4 Channel

0RB

P =4:240kHz: ORB 34 RB
Ref. Point A:  -47.52 MHz at -47.52 MHz from center
Results & Filters .
LTE-CRS Rate Match

Manually apply settings

17. Select the BWP pane and confirm that DL-BWP ID 1 is enabled.
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For each BWP allocation, configure the numerology (i) and RB allocation
information. In this example, we will use the default 120 kHz numerology,
RB Offset = 0 and RB number = 66 RB for a 100 MHz bandwidth signal.

ﬁ Measl1 - 5G NR Demod Properties 7 .
& Antenna Time Decode Advanced

Quick Setups...

Carriers

Initial-DL-BWP ¢
Bandwidth
+|DL-BEWP

DL-

4 Channel DL-BWP
-BW

! Initial-UL-BWP 0

CORESETs

Add CORESET

BWPID: | BWP1 =
-1

pping Type: | Mon-interleaved

Allocated RE Groups (6RBs): | 0:10

Precoder Granularity: Same as REG bundle =

18. Select the Channel pane > SS/PBCH and set:
a. RB Offset (60 kHz) to 0 RB
b. Periodicity to 10 ms
c. Lmax to L64
d. SSB Transmitted to 0:3

For this example we will use 4 of the 64 SS/PBCH Blocks (beams). In an
SSBlock, the period is different fr the different numerologies.

— FR1 up to 3 GHz, L=4
— FR13 GHzto 7.125 GHz, L8
— FR2-1,FR2-2,L =64
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The frequency location of an SSBlock is not fixed. In the VSA software, a
default value of 46 RB and kSSB of 0 subcarriers places it in the center of
the carrier bandwidth. Using O RB Offset puts the SSB at the lower edge
of the carrier.

Configuration Input & Antenna Time Decode Advanced

Save As Quick Setup..  Quick Setups... -

Carriers | SS/PBCH
Bandwidth Lmax: Lo4 ~ SSB Transmitted:

BWP | Auto Detect Active Block Det Power Threshold: | -3

4 Channel
RB Offset(60kHz): Al Numerology:
SS/PBCH

KSSB(60kHz): 0 SCS Common:
PDCCH

PDSCH Periodicity: 10 ms ~ | Half Frame Index: 0

CSI-RS z bandwidth -33.12 MHz from center

Results & Filters
PSS power boosting | 0dB PBCH power boosting | 0 dB

3GPP Version: = R16 Latest (2021-12) ~

19. To configure the PDSCHO, select the PDSCH pane and for PDSCH 0, set:
— MCS Table to Table 256 QAM
— MCS to 20
3GPP has different Tables for PDSCH MCS.
— Table 5.1.3.1-1 has 64QAM as max modulation
— Table 5.1.3.1-2 has 264QAM as max modulation
— Table 5.1.3.1-4 has 1024QAM as max modulation

— Table 5.1.3.1-3 has 64QAM as max modulation and is for
low spectrum efficiency (LowSE). See 3GPP TS38.214 for
more information.

— Allocated Slots to 2:79
— RB Offset to 20 RB
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— RB Number to 20 RB

Add PDSCH

* PDSCH: !

: o Enabled BWPID BWP1 - RNTI: | 1 3GPF Mersion: | R16 Latest
4 {hannel

PDCCH
PDSCH
CSI-RS

0:0.0D.DDDDDEDDDDD

& Filters

Typed

0

CAME R : ccooppobbD

10248 RB R RESET ID: -1

CellID

i Mon-Interleaved «

20. Scroll down and select the Antenna Port dropdown and set:
— Antenna Ports Used,1 to 0:1

— DMRS CDM Group(s) without data to 2 (to match the PathWave
setup)

21. Under the RS Sequence dropdown, we will use the default settings for
DMRS and PTRS. However, this is where you would change the RS
settings.

22. Select the Power Boosting dropdown and verify that DMRS Power
Boosting has automatically been set to 3 dB.
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When "DMRS CDM group without data" is set to 2, the DMRS power
boosting becomes 3 dB per 3GPP definition.

Carriers Add PDSCH Enable Channgls...

Bandwidth
PDSCH: .

BWP

Antenna Port

Ant. Det Threshold:

1
Antenna Por ] C without data: | 2

PRE Bundle Size: Wideband

RS Sequence
OM fig Typel v DMRS-Downlink-ri6 Enable FTRS
RN K : DMRS ] e
DOMRS Max Length 1 b Nip Source Cell ID KPTRS

DMRS Lengt Single-Symbol - Nscid: 0 LPTRS

PasD - Nip” 0 PTRS RE Offset

DMRS Map Ref - N ( AdditionalDMRS-DL-Alt

DMRS Init Dption: NR Standard

Power Boosting

Power Boosting: | 0 dB DMRS Powe

23. To add and configure PDSCH1, select Add PDSCH.
24, Select PDSCH1 and set:

— MCS Table to Table 64 QAM
— MCS to 20

— Allocated Slots to 2:79

— RB Offset to 45 RB
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— RB Number to 18 RB

ick Setup..  Quick Setups..

Remove PDSCH  Clear All Enable Channels..

Bandwidth
F 2 ] .

BWP

= +| Enabled BEWFID BWP1 = RNTE | 1
4 Channel

Modulation and Coding | Time/Freq Allc on

Modulation and Coding TIime/freq Aliocatio

Frame Peri

Results B Filters

-1

RB Number:

Cell ID

25. Scroll down and open the Antenna Port dropdown and set:
— Antenna Ports Used to 0:1
— DMRS CDM group(s) without data to 2.
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26. Select the Power Boosting dropdown and verify that DMRS Power
Boosting is set to 3 dB.

Save As Quick Setup... | Ouick Sef

Carriers Add POSCH  Remove PO Clear All Enable Channels..
Bandwidth
PDSCH: ] .
BwWP
4 (Channel
55/PBCH
Antenna Port

Ref. Antenna Fort:

A Na Ports Inde
Antenna Port: - ! M gre hout data: |

PRB Bundle Size: - User Defined PRE Bundle Size

Jownlink-ria Enable PTRS
DMRS May Length 1 - i Source Cell I - KPTRS

DMRS Length Single-Symbal = : i} LPTRS

DMRS AddPos - it PTRS RE Offset

DMRS Map Ref v B Addrtiona

DMRS [nit Option: MR 5tandard - DMRS Init

Power Boosting

Power Boosting: | 0 dB DMRS Power Boosting: 3 df PTRS Power Boosting: () o

Now you should see the demodulated signal and EVM results per layer in
the Frame Summary for PDSCHO and PDSCH]1.

27. To configure the Analysis region, select the Time tab and set:
— Result Length to 5 Subframes
— Meas Interval to 2 Subframes

— Enable Frame Trigger is present.
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We are using an external trigger for this example so selecting Frame
Trigger is Present will use the external trigger and will speed up the
measurement significantly. If not using an external trigger, set to
Normal.

Configuration Input & Antenna Time Decode Advanced

Analysis Region
Result Length: 5 Subframes 0 Slots
Meas Offset: 2 Subframes 0 Symbols
Meas Interval: 3 Subframes 0 Symbols

Time Scale Factor: 1

Analysis Start Boundary Acqguisition Mode
Normal
® Frame
. Reduced acquisition length

Half-frame

Subframe
Slot trigger is present

Slot

First Slot Index: 0

Timing Diagram

Result Length 5 Subf. ————

E Meas. Interval 3:0
* Meas. Offset 2.0

Frame Boundary

TIP To improve setup speed
Live measurement:

— Use external frame trigger and enable Frame trigger is
present. The real frame boundary must be within +50 ps of
the external trigger.

— If external frame trigger is not available, use Reduced
acquisition length. The reduced acquisition length may fail
to synchronize in scenarios where > 1 frame SSB
periodicity are defined, unless hardware triggering is used.

— Change Analysis Start Boundary to Subframe.

— Reduce Result Length and Measurement Interval.
Playback mode

— Reduce the Result Length and Measurement Interval.

— Set Analysis Start Boundary to Subframe.

— Reduce the number of active traces.
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28. To configure the PBCH and PDSCH decoding, select the Decode tab and
set.

— PBCH Decode to Decoded TB
— PDSCH Decode to Decoded TB
— PDSCH Decoder Algorithm to Offset Min Sum (default)

VSA2023U2 or later releases support a user selectable Decoder Algorithm.

Offset Min-Sum (Default) - Specifies the layered belief propagation
algorithm with offset min-sum approximation. This is faster but less
accurate than Belief Propagation.

Belief Propagation - Specifies the belief-passing or message-passing
algorithm. This is better for accuracy but slow. Use for receiver sensitivity
test where the SNR is very small.

For successful PDSCH decoding (i.e. CRC pass), make sure the RNTI
values (used for scrambling) and Transport Block Size matches between
the transmitted signal and VSA. (Transport block size depends on MCS
table, MCS value, TB Scaling Factor S, and xOverhead under PDSCH
channel setting).

B Mosed1 - 56 MR Bamnod Propertie: ¥ 4

Configuration Input & Antenna Time Decode Advanced

DL Decode Settings

PECH Decode: Decoded TR ~ | PDCCH Decode:  off (Scrambled Bits) ~
PDSCH Decode: Decoded TB

PDSCH Decoder Algorithm:  Ofsat Min Sum =

Decode Advanced Settings

Mumber of lterations:

29. Select the Advanced tab and select the DC Punctured check box.

As part of conformance test, 3GPP has defined different equalizer training
and tracking for EVM measurements. 3GPP Conformance Test is enabled
by default where Tracking, Equalizer Training and EVM Window, and
Symbol Timing is applied per 3GPP conformance test requirement. For
FR1, no tracking is applied. For FR2, Phase Tracking using PTRS is applied.
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5G NR counts the DC subcarrier as a valid subcarrier for rate-matching
purposes. The network decides if the DC subcarrier is modulated or not.
High LO feedthrough will impact demodulation and EVM performance of
the input signal. This is OFF by default.

Configuration Input & Antenna Time Decode Advanced

¥ 3GPP Conformance Test
Tracking: Equalizer Training

EVM Window and Symbol Timing Transient Period

Length:

Power Change Threshold:

1Q Impairments
10 Imb. Estimation Mode:  Off
Compensate 1Q Offset V| DC Punctured
UL Spectrum Flatness
+| Spectrum Flatne
Test Environment Condition:  Mormal ~ Test Tolerance: 14 dB
Error Veector Unit

Time Domain: | PerSymbol = Freq Domain: | Per Subcarrier =
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30. Close the 5G NR Properties dialog, start and new sweep to update the
display, then view the results.

A: OFDM Meas: All Layers ~ E: OFDM Detected Allocations Time: All Layers

=T

— Trace A: Composite constellation diagram showing different
modulation formats for the different channels/signals present in the
transmitted signal. See Trace F (Frame Summary) for the list of
channels and modulation formats.

— Trace C: Summary trace showing composite error metrics.

— Trace D: Error Vector Spectrum showing EVM versus subcarrier and
symbol.

— Trace E: Detected Allocations Time showing the detected
allocations of all channels/signals within the measurement interval.

— Trace F: Frame Summary. EVM, per Layer EVM, Power per RE, Mod
Format, Number of RB, RNTI, and BWP ID of the individual
channels/signals.

One of the most powerful tools in the 89600 VSA is the coupling of
markers across different measurements, traces, and domains. Coupled
markers allow you to understand the identity and characteristics of a
symbol simultaneously in time, frequency, and error.

Place a marker on Traces A, D, and E and couple the markers (Markers >
Couple Markers), and then show the results in a markers window (Window
> Markers).
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Right click on Trace D and select Peak. The exact symbol associated with
this peak EVM can now be understood in terms of time domain symbol
index, frequency domain subcarrier number, channel type, modulation
format, IQ magnitude, and phase values. Other parameters are shown in
the Marker window.

Change the traces so you can see the Constellation diagram, MIMO Info
table, Frame Summary Table (or Slot Summary Table), Summary table, 3D
Power, Decoded Info plus any additional traces.

sl EVMPownr  TAL Froquanc
f(utm)  (sec) (Hz)

atesdasnbaiapanny

s fesederuase dhde

FOS RSO0 AR ER

Ll lala ol o0
»

Lo L Ll
afengfesad s asRs
¥ o e o O o' TRTY

EVM  Fower

per RE L Num. B
(s} (1Bm) Mischslalion | o INTL

— Trace C: MIMO Info table shows EVM, power, and time, frequency
and phase offset for each antenna port.

MIMO Info is a type of Matrix Table that provides sortable rows by column,
selectable column visibility, and copy/paste and export functionality to
share rows of content or complete tables to applications like email, text
editing or spreadsheet programs.

— Trace E: 3D trace showing resource element (RE) power per symbol
and per subcarrier. This is very useful when verifying base station
systems, for example, to make sure the power per each RE is
balanced. You can use a marker to read the power and channel
information. A marker on this trace cannot be coupled with other
traces.

— Press the mouse wheel and rotate the wheel forward to
zoom in, backward to zoom out.

— Hold left-click of the mouse for panning. Note: If marker is
enabled (i.e. not a normal pointer), you will need to hold
Alt in order to pan.
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— Use right click to auto scale, enable the marker, and
change the display to different axes.

— Trace F: The Decoded Info table provides CRC pass/fail for PDSCH
and PBCH plus the high layer information that is carried on PBCH.

If CRC of PDSCH fails, make sure the Transport Block Size matches
between the transmitted signal and VSA (this depends on MCS
table, MCS value, TB Scaling Factor S, and xOverhead under PDSCH
channel setting). Also, make sure the RNTI values match since RNTI
is used for scrambling.

Result and Display Filtering

Meas Setup > NR Demod Properties > Configuration tab > Results & Filters
panel.

Results & Filters
Results & Filters table has three configurable columns
Color — sets the color for each channel (affects all traces that
display channel-specific information)
e By default colors are kept as they were in previous
release.
Is Displayed - Enables or disables the display of the channel in
all traces (supplements the per-Trace filtering under Trace -=
Digital Demod)
¢« Uncheck a box to filter the channel out of the trace
results. This setting does not affect any EVM

calculations.
EVM Include - Includes or excludes the channel in the EVIM

calculations. This also affects trace filtering.

Note 1. Frame Summary tabie doesn’t get affected by Results & Filters
seftings except for the color setfing.

You can try to change colors of some of the channels, and/or filtering out
all channels/signals except for SSBlock (PSS, SSS & PBCH) etc.
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Clear (Uncheck) "Inactive" and "DC" to remove the inactive resources
(subcarriers, symbols) and the DC subcarrier from the display and see the
change in the 3D plot:

Before: After:

_E_:REPoworBD b | E:REPowerSl! 1 |

You can now auto-scale the 3D plot and only see the active
channels/signals being displayed.

Per-Trace Filtering
Trace > Digital Demod

In addition to the Results & Filters, VSA also has per-trace filtering to
filter by subsegments and/or channels. Subsegment means MIMO Layers,
BWP and SSBlock.

The following traces can be filtered by subsegments:
OFDM Meas
OFDM Ref

— Error Vector Spectrum

— Error Vector Time
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— Detected Allocations Time trace

H L L

To setup the VSA Using a UXR Recorded Waveform File
1. Open the VSA software.

To access the VSA software, go to the Windows Start menu and find
Keysight 89600 Software (latest installed version) folder and run the
software.

If accessing the instrument via a Remote Desktop connection, select the
Screen tab (at the top of the display) to open the
Mode/Measurement/View Selector window.

2. From the VSA menu bar, select File > Preset > All to set the VSA to a
known state.
3. To configure the hardware, go to Utilities > Hardware > Configurations.

If it is already configured, continue with step 9.
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4. In the Configuration tab, select the + icon.

2= Hardware ? b4

Configurations Dhscovered Instruments

Current Analyzer Configuration: Anah

Channels: Baseband: 2 Channel

5. Inthe New Hardware Configuration dialog, select Simulate Hardware
and scroll down the Possible Logical Instruments and select
Keysight/Agilent Infiniium Series Oscilloscope, and then select the right
arrow to move it under Configuration.

|22 Mew Hardware Configuration ? >

n the same ¢

wal instrument in the

L Keysight/Agilent Techn infintium Series Scope

nfiguration

6. From the middle of the dialog box, select the UXR to be used.

2. Select the instrume use for each logical instrument in the configuration.

ADC Keysight/Agilent Technologies Infinium Series Scope TCPIPO:localhost:inst0=INSTR ~

7. Select OK to create the UXR configuration.
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8. In the Configurations tab, set the Current Analyzer Configuration, select
the Analyzer number for the new configuration. In this example Analyzer 3.

Configurations Discovered Instruments

Current Analyzer Configuration: Analyzer3 = Channels; Baseband: 1 Channel

Analyzer

Group Type: Analyzer

Analyzer3
4 Keysight/Agilent Infiniium Series Oscilloscope

9. If you do not have access to a Keysight Infiniium UXR Real-Time
Oscilloscope, a UXR recorded waveform file has been included in the
Examples waveform file folder on the VXG.

Go to: D: \Users\Instrument\Documents\Keysight\PathWave
\SignalGenerator\Examples

Copy the MIMO_UXR_Recording.sdf file to the signal analyzer or the PC
running the VSA application.

10. From the Menu Bar, select File > Recall > Recall Recording and select
MIMO UXR Recording.sdf.

Recalling the recording will setup all of the parameters described below. If
you want to become familiar with the VSA setup, continue on with the
remaining steps.
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11. From the menu bar, select Input > Extensions > Sample Mode >FullRate
DDC.

Analog Digital Trigger Playback Trigger External Mixer Extensions
Logical Instrument: Preset

n Show All

4 Misc

CustomTrigCommand

CustomTrigType

ample Rate

_Resamplelocation
SampleMode
UserSampleRate

UserSCPIPrecet

12. From the menu bar, select Input > Channels > RF > 2 Channels.

E Vector - Keysight PathWave Vector Signal Analysis (89600 VSA)

File Edit Control Source | Input | MeasSetup Trace Markers Window Utilities Help

| | C) Channels » ﬂ Baseband: 2 Channel » 1 Channel
I v | 2 Channel

_ Analog... 1+jQ >
o i Custom... 3 Channel

Digital...
ng -1 dBm - __ 4 Channel

Capture...

Trigger...

Playback Trigger...

External Mix

Extensions...

User Correction...

Playback User Correction... I ||-.‘ Wl

—————— 3 Al

I.I“‘-'I.,lI ||“|1.-‘J ! Iil | I".,_|'

My

II.‘I |'n| I i
i

Data From
Recording...
Select Switch: None

Switch...

13. Set the center frequency of both channels to 28 GHz and span to
100 MHz.

You can also set the frequency and span of both channels under Meas
Setup > Frequency.

404 M9484C VXG and X-Series SA Measurement Guide



5G NR Measurements Using the VSA Software
5G Waveform and EVM Analysis Using VSA Software

If you are using a UXR, Select Autorange.

Autorange does not work if you are simulating the waveform with the UXR
recording. Continue with the next step.

Auto Range samples the current input signal and then sets the full scale
input range to the minimum range that includes the peak voltage sample
of the input signal.

25 Meas01 - MeasSetup 7 b4

| Frequency ResBW Time WETAgE
IMeasurement Channek: n B

Span:
100 MHz

| Auto Frequency Step

Time Data:

Zoom v Mirror Frequency

i

Meaumement paased

H" 2 O m € & L

14. From the menu bar, select MeasSetup > Measurement Type > Cellular >
5G NR > 5G NR Modulation Analysis.

15. Change the trace layout to Grid 2x3.

File Edit Control Source Input MeasSetup Trace Markers Window Utilities Help

B BRI R
A; OFDM Meas « X | C: Summary Previous Layout

Single
Stack 2
Stack 3
Stack 4
Stack 6
Grid 2x2
Grid 2x3
Grid 3x2

Custom...

Tile Visible
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16. Select MeasSetup > 5G NR Demod Properties > Configuration tab and set
Bandwidth to FR2 100 MHz, Carrier Center and Frequency for Phase
compensation are set to 28 GHz. Select the Cell ID checkbox.

Measl - 56 NR Dernod Properties i %

(1]

Advanced

Link Direction:  '® Downlink Uplink

Allow Multiple Carrier Definitions

Configure... =+ Add Carrier

4 Channdl Reference: CCO = Display: CCO =

FR2 100 MHz = || 28 GHz

Configure...

Cell ID is carried on PSS and SSS so that SS/PBCH must be transmitted
and enabled for Auto Cell ID to work and must be a Downlink since
SS/PBCH is only transmitted in the DL.

Phase compensation is per the 3GPP requirement, and is enabled by
default. It is used to compensate for phase differences between symbols
caused by upconversion or downconversion. Getting this setting wrong
will cause a demod issue. For this example, it is ON and it is applied at the
center frequency.

17. Select the Bandwidth pane and confirm that numerology is set to
p=3:120 kHz.
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The Bandwidth panel is used to configure the Resource Grid for each
Numerology. Note that for FR2 100 MHz, the Max RB for 120 kHz
Numerology is 66 RB. We will use this value when we configure the
PDSCH parameters.

Configuration Input & Antenna Time Decode Advanced

Save As Quick Setup..  Quick Setups... -

Carriers i ;
Bandwidth: | FR2 100 MHz ~
Bandwidth
Resource Grid
BWP
Numerology Grid Start Grid Size Grid Enabled
4 Channel

u=2:60kHz ORB

p=3:120kHz: ORB 66 RB

u=4:240kHz: ORB 34 RB

Ref. Point A: -47.52 MHz at -47.52 MHz from center
Results & Filters

LTE-CRS Rate Match

Manually apply settings

18. Select the BWP pane and confirm that DL-BWP ID 1 is enabled.
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For each BWP allocation, configure the numerology (i) as well as RB
allocation information. In this lab, we will use the default 120 kHz
numerology, RB Offset = 0 and RB number = 66 RB for a 100 MHz

bandwidth signal.

ﬁ Meas01 - 5G NR Demaod Properties
Configuration Input & Antenna Time Decode Advanced

Save As Quick Setup..  Quick Setups...

Carriers
Initial-DL-BWP ¢

/|DL-BWP
DL-BWP

DL-BWP

! Initial-UL-BWP 0

Results & Filters

BWPID: | BWP1 =

Configured

Ips (6RBs): | 0110

Precoder Granularity:

19. Select the Channel pane > SS/PBCH and set:
a. RB Offset (60 kHz) to O RB
b. Periodicity to 10 ms
c. Lmax to L64
d. SSB Transmitted to 0:3

Same as REG bundle ~

For this example we will use 4 of the 64 SS/PBCH Blocks (beams). In an
SSBlock, the period is different fr the different numerologies.

— FR1 up to 3 GHz, L=4
— FR1 3 GHzto 7.125 GHz, L8
— FR2-1,FR2-2,L =64
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The frequency location of an SSBlock is not fixed. In the VSA software, a
default value of 46RB and kSSB of 0 subcarriers places it in the center of
the carrier bandwidth. Using O RB Offset puts the SSB at the lower edge
of the carrier.

Configuration Input & Antenna Time Decode Advanced

Save As Quick Setup..  Quick Setups... -

Carriers | S5/PBCH

Bandwidth Lmax: Lo4 ~ SSB Transmitted:

BWP | Auto Detect Active Block Det Power Threshold: | -3
4 Channel

Numerology:
SS/PBCH

i SCS Common:
PDCCH

PDSCH eric '8 ~ | Half Frame Index: 0

P bandwidth -33.12 MHz from center
CSI-RS

Results & Filters REEr BREsing
PSS power boosting 0 dB PBCH power boosting | 0 dB

3GPP Version: = R16 Latest (2021-12) ~

20. To configure the PDSCHO, select the PDSCH pane and for PDSCH 0, set:
— MCS Table to Table 256 QAM
— MCS to 20
3GPP has different Tables for PDSCH MCS
— Table 5.1.3.1-1 has 64QAM as max modulation
— Table 5.1.3.1-2 has 264QAM as max modulation
— Table 5.1.3.1-4 has 1024QAM as max modulation

— Table 5.1.3.1-3 has 64QAM as max modulation and is for
low spectrum efficiency (LowSE). See 3GPP TS38.214 for
more information.

— Allocated Slots to 2:79
— RB Offset to 20 RB
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— RB Number to 20 RB

Add PDSCH

* PDSCH: !

: o Enabled BWPID BWP1 - RNTI: | 1 3GPF Mersion: | R16 Latest
4 {hannel

PDCCH
PDSCH
CSI-RS

0:0.0D.DDDDDEDDDDD

& Filters

Typed

0

CAME R : ccooppobbD

10248 RB R RESET ID: -1

CellID

i Mon-Interleaved «

21. Scroll down and select the Antenna Port dropdown and set:
— Antenna Ports Used,1 to 0:1

— DMRS CDM Group(s) without data to 2 (to match the PathWave
setup)

22. Under the RS Sequence dropdown, DMRS and PTRS are default settings,
but this is where you would change the RS settings.

23. Select the Power Boosting dropdown and verify that DMRS Power
Boosting has automatically been set to 3 dB.
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When "DMRS CDM group without data" is set to 2, the DMRS power
boosting becomes 3 dB per 3GPP definition.

Carriers Add PDSCH Enable Channgls...

Bandwidth

Antenna Port

Ant. Det Threshold:

eword Number: 1
Antenna Ports Used: | 0 B o {s) without data: | 2

PRE Bund i Wideband

RS Sequence

OM nfig Typel v DMRS-Dlov k-r16 Enable FTRS

DMRS Max Length 1 - Nip " Source Cell ID KpTRS

DMRS Lengt Single-Symbol - Nscid: 0 LPTRS
L Posi) - Nip. 0 PTRS RE Offset
DMRS Map Ref v |-.,-":,1 ( Ad slDMRS-DL-Alt

DMRS Init Dption: NR Standard

Power Boosting

Power Boosting: | 0 dB DMRS Poy

24, To add and configure PDSCH1, select Add PDSCH.
25. Select PDSCH1 and set:

— MCS Table to Table 64 QAM
— MCS to 20

— Allocated Slots to 2:79

— RB Offset to 45 RB
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— RB Number to 18 RB

Setup.. Quick Setups..

Carriers Add P Remove PDSCH  Clear All Enable Channels...

Bandwidth
PDSCH: ] .

BWP

= +| Enabled BEWFID BWP1 = RNTE [ 1 3GPP Version: | R16 Latest
Channel

eq Allocation
0 Frame Peri
Table 640AM = Allocated
0.0.o.DEoDDDD.DD

TE Scaling Factor 5;
xDverhead: - Mapping Type TypeA
Targe £ 0 0493 mbol: 0
Modulation: el R pppbpbbD
Transport Bloc

RB Number:

Cell ID

26. Scroll down and open the Antenna Port dropdown and set:
— Antenna Ports Used to 0:1
— DMRS CDM group(s) without data to 2.
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27. Select the Power Boosting dropdown and verify that DMRS Power
Boosting is set to 3 dB.

Save As Quick Setup..

Carriers Add POSCH = Remove POSCH  Clear All Enable Channels...

Bandwidth
PDSCH: 0 .

R mm—

Antenna Port
Ref. Antenna Fort: 1000
Jse Antenna Ports |
An Ports Index: 0 Codeword Number:
Antenna Ports Used: | 01 Dk

PRB Bundle Size: Wideband

RS Sequence
Oh s ype d I W Enable PTRS
DMRS Max Length 1 - Qurce Cell 1D v KrTRS
] LpTRS
PTRS RE Offset
AdditionalC

DMRS [nit Option: MR Standard = DMRS Init

Power Boosting

Power Boosting: | 0 dB DMRS Power Boosting: 3

28. To configure the Analysis region, select the Time tab and set:
— Result Length to 5 Subframes
— Meas Interval to 2 Subframes

— Enable Frame Trigger is present. NOTE: if using the UXR recording,
leave Frame Trigger set to Normal.
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The example measurement above uses an external trigger thus we
would use Frame Trigger is Present to speed up the measurement
significantly. If not using an external trigger or are using the UXR
recording, set to Normal.

Configuration Input & Antenna Time Decode Advanced

Analy gion
Result Length: 5 Subframes 0 Slots
Meas Offset: 2 Subframes 0 Symbols
Meas Interval: 3 Subframes 0 Symbols

Time Scale Factor: 1

Analysis Start Boundary Acqguisition Mode

Normal
® Frame
. Reduced acquisition length
Half-frame
) ris present
Subframe
Slot trigger is present
Slot

First Slot Index: 0

Timing Diagram

Result Length 5 Subf. ————

Frame Boundary

TIP To improve setup speed
Live measurement:

— Use external frame trigger and enable Frame trigger is
present. The real frame boundary must be within +50 ps of
the external trigger.

— If external frame trigger is not available, use Reduced
acquisition length. The reduced acquisition length may fail
to synchronize in scenarios where > 1 frame SSB
periodicity are defined, unless hardware triggering is used.

— Change Analysis Start Boundary to Subframe.

— Reduce Result Length and Measurement Interval.
Playback mode

— Reduce the Result Length and Measurement Interval.

— Set Analysis Start Boundary to Subframe.
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— Reduce the number of active traces.

29. To configure the PBCH and PDSCH decoding, select the Decode tab and
set.

— PBCH Decode to Decoded TB
— PDSCH Decode to Decoded TB
— PDSCH Decoder Algorithm to Offset Min Sum (default)

VSA2023U2 or later releases support user selectable Decoder Algorithm.

Offset Min-Sum (Default) - Specifies the layered belief propagation
algorithm with offset min-sum approximation. This is faster but less
accurate than Belief Propagation.

Belief Propagation - Specifies the belief-passing or message-passing
algorithm. This is better for accuracy but slow. Use for receiver sensitivity
test where the SNR is very small.

For successful PDSCH decoding (i.e. CRC pass), make sure the RNTI
values (used for scrambling) and Transport Block Size matches between
the transmitted signal and VSA. (Transport block size depends on MCS
table, MCS value, TB Scaling Factor S, and xOverhead under PDSCH
channel setting).

B Mosed1 - 56 MR Bamnod Propertie: ¥ 4

Configuration Input & Antenna Time Decode Advanced

DL Decode Settings

PECH Decode: Decoded T8 = | PRCCH Decode:  off (Scrambled Bits) -
PDSCH Decode: Decoded TB

PDSCH Decoder Algorithm:  Offset Min Sum

Decode Advanced Settings

Mumber of lterations:

30. Select the Advanced tab and select the DC Punctured check box.
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As part of conformance test, 3GPP has defined different equalizer training
and tracking for EVM measurements. 3GPP Conformance Test is enabled
by default where Tracking, Equalizer Training and EVM Window, and
Symbol Timing is applied per 3GPP conformance test requirement. For
FR1, no tracking is applied. For FR2, Phase Tracking using PTRS is applied.

5G NR counts the DC subcarrier as a valid subcarrier for rate-matching
purposes. The network decides if the DC subcarrier is modulated or not.
High LO feedthrough will impact demodulation and EVM performance of
the input signal. This is OFF by default.

Configuration Input & Antenna Time Decode Advanced

¥ 3GPP Conformance Test

Tracking: Equalizer Training

Transient Period

Length:

Power Change Threshold: 10.dB

IQ Impairments

10 Imb. Estimation Mode:  Off

| DC Punctured

Test Environmen ' Nommal v | Test Tolerance: 14 dB

Error Vector Unit

Time Domain: | Per Symbol = Freq Domain: | Per Subcarrier =
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31. Close the 5G NR Properties dialog to view the results.

A: OFDM Meas: All Layers ~ E: OFDM Detected Allocations Time: All Layers

=T

— Trace A: Composite constellation diagram showing different
modulation formats for the different channels/signals present in the
transmitted signal. See Trace F (Frame Summary) for the list of
channels and modulation formats.

— Trace C: Summary trace showing composite error metrics.

— Trace D: Error Vector Spectrum showing EVM versus subcarrier and
symbol.

— Trace E: Detected Allocations Time showing the detected
allocations of all channels/signals within the measurement interval.

— Trace F: Frame Summary. EVM, per Layer EVM, Power per RE, Mod
Format, Number of RB, RNTI, and BWP ID of the individual
channels/signals.

One of the most powerful tools in the 89600 VSA is the coupling of
markers across different measurements, traces, and domains. Coupled
markers allow you to understand the identity and characteristics of a
symbol simultaneously in time, frequency, and error.

Place a marker on Traces A, D, and E and couple the markers (Markers >
Couple Markers), and then show the results in a markers window (Window
> Markers).
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Right click on Trace D and select Peak. The exact symbol associated with
this peak EVM can now be understood in terms of time domain symbol
index, frequency domain subcarrier number, channel type, modulation
format, IQ magnitude, and phase values. Other parameters are shown in
the Marker window.

Change the traces so you can see the Constellation diagram, MIMO Info
table, Frame Summary Table (or Slot Summary Table), Summary table, 3D
Power, Decoded Info plus any additional traces.

L2 1§

mm‘.‘_ f:"m Diesprosd EVMPoswst  TAE Froquanc
ol P emS] (0Bm) (sec)  (Hz)

atesdasnbaiapanny
R Fesesverase IDdN
F S 0E00 6N ER

(L il
afesgsesadasasfs
¥ o e o O o' TRTY

Tame

EVM  Fower

per RE L Num. B
(s} (1Bm) Mischslalion | o INTL

— Trace C: MIMO Info table shows EVM, power, and time, frequency
and phase offset for each antenna port.

MIMO Info is a type of Matrix Table that provides sortable rows by column,
selectable column visibility, and copy/paste and export functionality to
share rows of content or complete tables to applications like email, text
editing or spreadsheet programs.

— Trace E: 3D trace showing resource element (RE) power per symbol
and per subcarrier. This is very useful when verifying base station
systems, for example, to make sure the power per each RE is
balanced. You can use a marker to read the power and channel
information. A marker on this trace cannot be coupled with other
traces.

— Press the mouse wheel and rotate the wheel forward to
zoom in, backward to zoom out.

— Hold left-click of the mouse for panning. Note: If marker is
enabled (i.e. not a normal pointer), you will need to hold
Alt in order to pan.
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— Use right click to auto scale, enable the marker, and
change the display to different axes.

— Trace F: The Decoded Info table provides CRC pass/fail for PDSCH
and PBCH plus the high layer information that is carried on PBCH.

If CRC of PDSCH fails, make sure the Transport Block Size matches
between the transmitted signal and VSA (this depends on MCS
table, MCS value, TB Scaling Factor S, and xOverhead under PDSCH
channel setting). Also, make sure the RNTI values match since RNTI
is used for scrambling.

Working with Traces

— Trace A: Composite constellation diagram showing different modulation
formats for the different channels/signals present in the transmitted signal.
See Trace F (Frame Summary) for the list of channels and modulation
formats.

— Trace C: Summary trace showing composite error metrics.

— Trace D: Error Vector Spectrum showing EVM versus subcarrier and
symbol.

— Trace E: Detected Allocations Time showing the detected allocations of all
channels/signals within the measurement interval.

— Trace F: Frame Summary. EVM, per Layer EVM, Power per RE, Mod Format,
Number of RB, RNTI, and BWP ID of the individual channels/signals.

One of the most powerful tools in the 89600 VSA is the coupling of markers
across different measurements, traces, and domains. Coupled markers allow
you to understand the identity and characteristics of a symbol simultaneously
in time, frequency, and error.

Place a marker on Traces A, D, and E and couple the markers (Markers >
Couple Markers), and then show the results in a markers window (Window >
Markers).

Right click on Trace D and select Peak. The exact symbol associated with this
peak EVM can now be understood in terms of time domain symbol index,
frequency domain subcarrier number, channel type, modulation format, 1Q
magnitude, and phase values. Other parameters are shown in the Marker
window.
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Change the traces so you can see the Constellation diagram, MIMO Info table,
Frame Summary Table (or Slot Summary Table), Summary table, 3D Power,
Decoded Info plus any additional traces.

od EVMPowor  TAE Froguonc
f(aBm)  {sec) (tz)

atesdasnbaiapanny
R Fe s Ferasy dd
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sedpae e oy Feoe
(TR T IrIoyT %]
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afengfesasanasis
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Time

= % | FDecoded o

EVM  Fower
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— Trace C: MIMO Info table shows EVM, power, and time, frequency and
phase offset for each antenna port.

MIMO Info is a type of Matrix Table that provides sortable rows by column,
selectable column visibility, and copy/paste and export functionality to
share rows of content or complete tables to applications like email, text
editing or spreadsheet programs.

— Trace E: 3D trace showing resource element (RE) power per symbol and per
subcarrier. This is very useful when verifying base station systems, for
example, to make sure the power per each RE is balanced. You can use a
marker to read the power and channel information. A marker on this trace
cannot be coupled with other traces.

— Press the mouse wheel and rotate the wheel forward to zoom in,
backward to zoom out.

— Hold left-click of the mouse for panning. Note: If marker is enabled
(i.e. not a normal pointer), you will need to hold Alt in order to pan.

— Use right click to auto scale, enable the marker, and change the
display to different axes.

— Trace F: The Decoded Info table provides CRC pass/fail for PDSCH and
PBCH plus the high layer information that is carried on PBCH.
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If CRC of PDSCH fails, make sure the Transport Block Size matches
between the transmitted signal and VSA (this depends on MCS table, MCS
value, TB Scaling Factor S, and xOverhead under PDSCH channel setting).
Also, make sure the RNTI values match since RNTI is used for scrambling.

Result and Display Filtering

Meas Setup > NR Demod Properties > Configuration tab > Results & Filters
panel.

BB weasD! - 55 R Do

Results & Filters

Results & Filters table has three configurable columns

Color - sets the color for each channel (affects all traces that
display channel-specific information)

et Time Decode  Advanced

e By default colors are kept as they were in previous

4 Channel x release.

Is Displayed - Enables or disables the display of the channel in
all traces (supplements the per-Trace filtering under Trace -=
Digital Demod)

« Uncheck a box to filter the channel out of the trace
results. This setling dees not affect any EVM
calculations.

EVM Include - Includes or excludes the channel in the EVM

calculations. This also affects trace filtering.

anueily ap gl SExtings Note 1. Frame Summary table doesn’t gef affected by Resuits & Filters
seftings except for the color setting.

You can try to change colors of some of the channels, and/or filtering out all
channels/signals except for SSBlock (PSS, SSS & PBCH) etc.

Clear (Uncheck) "Inactive" and "DC" to remove the inactive resources
(subcarriers, symbols) and the DC subcarrier from the display and see the
change in the 3D plot:

Before: After:

E-RE. ?owuj?_ X | il E: RE Power 30 ~ l
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You can now auto-scale the 3D plot and only see the active channels/signals
being displayed.

Per-Trace Filtering
Trace > Digital Demod

In addition to the Results & Filters, VSA also has per-trace filtering to filter by
subsegments and/or channels. Subsegment means MIMO Layers, BWP and
SSBlock.

The following traces can be filtered by subsegments:
— OFDM Meas

— OFDM Ref

— Error Vector Spectrum

— Error Vector Time

— Detected Allocations Time trace

R A

acted Abocations: Time: All Layers

0 DHMEn Vext FECFEM Lo Vgt Tmis; AN Loy

S #1105 AL

422 M9484C VXG and X-Series SA Measurement Guide



5G NR Measurements Using the VSA Software
5G Waveform and EVM Analysis Using VSA Software

Using the equivalent SCPI commands

On the VXG:
SYSTem:PRESet

RF1:FREQuency:CW 28GHz

RF1:POWer:AMPLitude 0dBm

RF2:FREQuency:CW 28GHz

RF2:POWer:AMPLitude 0dBm

CONFigure TX2

SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal
SIGNal

:MODE

:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:
:NR5G:

:NR5G:

NR

CCARrier0
CCARrier0
CCARrier0

CCARrier0

CCARrier0:

CCARrier0:

CCARrier0

CCARrier0

CCARrier0:

CCARrier0

CCARrier0

CCARrier0:

CCARrier0

CCARrier0

CCARrier0:

CCARrier0

CCARrier0

CCARrier0:

CCARrier0
CCARrier0

CCARrier0

CCARrier0:

CCARrier0
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:DLINk:

:DLINk:

:DLINk:

:DLINk:

:DLINk:

:DLINk:

:DLINk:

:DLINk:

:DLINk:

:DLINk:

:DLINk:

:DLINk:

:TYPE DL
:CIDentity OMIMO
:NUM:MODE SINGLE

:BWID FR1IBW100M

SNUM MU1
SNUM:RB:NUMB 273

SSBL:PERiodicity P10MS

SSBL:RB:OFFSet 0

DLINk:SCHO:DMRS:PORT '0,1"'

SCHO:SLOT "2:19"

SCHO:RB:OFFSet 2

DLINk:SCHO:RB:NUMBer 80

SCHO :MCS:TABL TABL52

SCHO:MCS 20

DLINk:SCHO:DMRS:POWer 3

SCHO : ADD

SCH1:DMRS:PORT 'O, 1"

DLINk:SCHI :DMRS:CGWD:COUN 2

SCH1:SLOT "2:19"

SCH1:RB:0OFFSet 150

SCH1 :RB:NUMBer 100

DLINk:SCH1:MCS:TABL TABL51

SCH1:MCS 20
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SIGNal:NR5G:WAVeform:GENerate

SIGNal ON
SIGNal:NR5G:TRIGger:SYNC:MARKer M2
RE1:0UTPut ON

RF2:0UTPut ON

RFALI :OUTPut ON

On the Analyzer:

INSTrument:SELect VSA89601
SYSTem:PRESet

FREQuency:CENTer 28 GHz

FREQuency:SPAN 122.88 MHz

INPut : ANALog: RANGe : AUTO

INITiate:PAUSe

INP:CHAN:CONF RF,RF

MEASure:CONFigure NR5G
NR5G:DBWP:ENABled 1
NR5G:SSBLock:ENABled 1
NR5G:SSBLock:ROFFset O

NR5G: SSBLock:PERiodicity "PeriodlOMilliseconds"
NR5G:DBWP: PDSChl :MCS: TABLe "Table2"
NR5G:DBWP:PDSCh1:MCS 20

NR5G:DBWP: PDSCh1l:SLOT:ALLocated "2:19"
NR5G:CCARrier:PDSChl:ROFFset 40
NR5G:CCARrier:PDSChl:RNUMber 80
NR5G:CCARrier:PDSChl:ANTenna:PORT:USED 3
NR5G:CCARrier:PDSChl :RCGNumber "Two"
NR5G:DBWP: PDSCh1 : BPOWer :DMRS 3
NR5G:DBWP: PDSCh2 :MCS: TABLe "Tablel"
NR5G:DBWP: PDSCh2:MCS 20
NR5G:DBWP: PDSCh2: SLOT:ALLocated "2:19"

NR5G:CCARrier:PDSCh2:ROFFset 150
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NR5G:CCARrier:PDSCh2:RNUMber 100
NR5G:CCARrier:PDSCh2:ANTenna:PORT:USED 3
NR5G:CCARrier:PDSCh2:RCGNumber "Two"

NR5G: DBWP: PDSCh2 : BPOWer : DMRS 2

NR5G:RLENgth 10

NR5G: SUBFrame: INTerval 2
NR5G:FRAMe : TRIGger:ENABled 1

NR5G:DC: PUNCtured 1

NR5G:MCFilter:ENABled 1

NR5G:COMPensate: SYMBol:CLOCk:0OFFset 1
INPut:TRIGger:STYLe "External"
INPut:TRIGger:LEVel :EXTernal 1V
INPut:EXTension:PARameters:SET "ExtTriggerLoc", 2
INPut :EXTension:PARameters:SET "PhaseNoiseOptDualLoop", 1
NR5G:FRAMe : TRIGger:ENABled 1

NR5G:DECode :MODE "DecodedTB"

DISPlay:LAYout 3,2
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