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Legal Notices 
 

The information in this document is subject to change without notice.  
 
Chroma ATE INC. makes no warranty of any kind with regard to this manual, including, but 
not limited to, the implied warranties of merchantability and fitness for a particular purpose. 
Chroma ATE INC. shall not be held liable for errors contained herein or direct, indirect, 
special, incidental or consequential damages in connection with the furnishing, performance, 
or use of this material. 
 
CHROMA ATE INC.  
66 Hwa-Ya 1st Rd., Hwa-Ya Technical Park, Kuei-Shan Hsiang, Taoyuan Hsien, Taiwan 
 
Copyright Notices. Copyright 2003-2008 Chroma ATE INC., all rights reserved. 
Reproduction, adaptation, or translation of this document without prior written permission is 
prohibited, except as allowed under the copyright laws. 
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Warranty 
 
All Chroma instruments are warranted against defects in material and workmanship for a 
period of one year after date of shipment.  Chroma agrees to repair or replace any assembly or 
component found to be defective, under normal use during this period.  Chroma’s obligation 
under this warranty is limited solely to repairing any such instrument, which in Chroma’s 
sole opinion proves to be defective within the scope of the warranty when returned to the 
factory or to an authorized service center.  Transportation to the factory or service center is to 
be prepaid by purchaser. Shipment should not be made without prior authorization by 
Chroma. 
 
This warranty does not apply to any products repaired or altered by persons not authorized by 
Chroma, or not in accordance with instructions furnished by Chroma.  If the instrument is 
defective as a result of misuse, improper repair, or abnormal conditions or operations, repairs 
will be billed at cost. 
 
Chroma assumes no responsibility for its product being used in a hazardous or dangerous 
manner either alone or in conjunction with other equipment.  High voltage used in some 
instruments may be dangerous if misused.  Special disclaimers apply to these instruments.  
Chroma assumes no liability for secondary charges or consequential damages and in any 
event, Chroma’s liability for breach of warranty under any contract or otherwise, shall not 
exceed the purchase price of the specific instrument shipped and against which a claim is 
made. 
 
Any recommendations made by Chroma for use of its products are based upon tests believed 
to be reliable, but Chroma makes no warranty of the results to be obtained.  This warranty is 
in lieu of all other warranties, expressed or implied, and no representative or person is 
authorized to represent or assume for Chroma any liability in connection with the sale of our 
products other than set forth herein. 
 
 
CHROMA ATE INC. 

66 Hwa-Ya 1st Rd., Hwa-Ya Technical Park, 
Kuei-Shan Hsiang, Taoyuan Hsien, Taiwan 
Tel: 886-3-327-9999 
Fax: 886-3-327-2886 
http://www.chromaate.com 
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Material Contents Declaration 
 
A regulatory requirement of The People’s Republic of China defined by specification SJ/T 
11364-2006 mandates that manufacturers provide material contents declaration of electronic 
products, and for Chroma products are as below: 
 

Hazardous Substances 

Lead Mercury Cadmium Hexavalent 
Chromium 

Polybrominated 
Biphenyls 

Polybromodiphenyl 
Ethers 

Part Name 

Pb Hg Cd Cr6+ PBB PBDE 

PCBA  O O O O O 

CHASSIS  O O O O O 

ACCESSORY  O O O O O 

PACKAGE O O O O O O 

“O” indicates that the level of the specified chemical substance is less than the threshold level 
specified in the standards of SJ/T-11363-2006 and EU 2005/618/EC. 
“ ” indicates that the level of the specified chemical substance exceeds the threshold level 
specified in the standards of SJ/T-11363-2006 and EU 2005/618/EC. 
 
1. Chroma is not fully transitioned to lead-free solder assembly at this moment; however, 

most of the components used are RoHS compliant. 
2. The environment-friendly usage period of the product is assumed under the operating 

environment specified in each product’s specification. 

 
Disposal 

Do not dispose of electrical appliances as unsorted municipal waste, use separate collection 
facilities. Contact your local government for information regarding the collection systems 
available. If electrical appliances are disposed of in landfills or dumps, hazardous substances 
can leak into the groundwater and get into the food chain, damaging your health and 
well-being. When replacing old appliances with new one, the retailer is legally obligated to 
take back your old appliances for disposal at least for free of charge. 
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Revision History 
 
The following lists the additions, deletions and modifications in this manual at each revision. 
 
Date Version Revised Sections 

Apr. 2003 1.1 Modify the “Managing System Available Resources” chapter to add 
“Fixture ID” and “Net Extension” functions. 
Modify the “Editing Test Program” chapter to remove “Universal TP” 
function. 
Modify the “Statistics Process Control (Option)” chapter 
Modify the “Report Wizard (Option)” chapter 
Modify the “On-line Control (Option)” chapter 

Jul. 2003 1.2 Modify the “System Installation” chapter to remove NI CVI Runtime 
Engine and add system restart notice after installed Hasp Driver in 
Windows 98 OS. 

Feb. 2004 1.3 Modify the “System Installation” chapter to change the 8000 SMPS 
ATS main screen.  
Modify the “Editing Test Program” chapter to add the Universal Test 
Program. 
Modify the “Executing Test Program (GO/NOGO)” chapter to add the 
Universal Test Program. 
Modify the “System Controller” section to change 64MB to 512MB. 
Modify the “Software System Requirements” section to support 
Windows XP and change 64MB to 512MB. 

Mar. 2005 1.4 Modify the “System Installation” chapter to change the first screen of 
8000 SMPS ATS installation. 
Modify the “Hardware Configuration” chapter to change the amount 
of loading connections to 12.   

Oct. 2006 1.5 Modify “System Installation” chapter to change the main screen of 
8000 SMPS ATS. 
Modify “Executing Test Program  (GO/NOGO)” chapter to add the 
description of new function. 

Mar. 2007 1.6 Add “Material Contents Declaration”. 

Jan. 2008 1.7 Modify “Hardware Configuration” chapter to add a new 
communication interface.  
Modify “Executing Test Program (GO/NOGO)” chapter to add 
Multi-UUT Barcode prescan function.  
Modify “Report Generator” chapter to add UUT filter function for 
offline report. 
Modify “Managing System Available Resources” chapter to add test 
items classification for new group function.  
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Modify “Editing User Defined Test Item (Option)” chapter to add a test 
item group and security setting.  
Modify “Statistics Process Control (Option)” chapter to add variables 
selection wizard.  
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Preface 
 

About this manual 
 

This manual is to guide you how to use Chroma 8000 Automatic Test System (ATS) to test 
the Switch Mode Power Supply, as well as the features and functions of automatic tests. We 
suggest you to read this manual following the chapter sequence.  In order to perform the 
activities described effectively, we also recommend you to have the basic operation 
knowledge of Windows.  
 

 

Manual Contents 
 
Chapter 1  System Architecture 

This chapter explains the system architecture of Chroma 8000 ATS 
and what it is composed of along with the Switch Mode Power 
Supply ATS software (SMPS) functions and system features. 

 
Chapter 2   System Installation 

This chapter tells you how to install Chroma 8000 ATS.  
 
Chapter 3   Basic Operation 

This chapter shows you how to use SMPS ATS software quickly. 
 
Chapter 4   Hardware Configuration 

This chapter teaches you how to set the configuration of the 
instruments in the ATS for effective testing work.  

 
Chapter 5   Editing Test Program 

This chapter explains what the test program is composed of and how 
to edit the test program to meet your needs.  

 
Chapter 6   Verifying Test Program and Test Item 

This chapter covers the contents of how SMPS ATS software verifies 
the test programs and test items. 

 
Chapter 7   Executing Test Program (GO/NOGO) 

This chapter describes how SMPS ATS software executes the test 
programs and how to set up the execution environment according to 
your needs.  
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Chapter 8   Editing Report Format 
This chapter explains how to edit the report format. 

 
Chapter 9   Report Generator 

This chapter shows you how to create, inquire, save and print the test 
result in the program.  

 
Chapter 10   Managing System Available Resources 

This chapter describes how to set up a user account and its 
permission to control the access personnel effectively, and execute 
the test program, test item and import/export function of an 
instrument device.  

 
Chapter 11   Editing User Defined Test Item (Option) 

This chapter introduces the features and usage of the user defined test 
items provided by SMPS ATS software in detail.  

 
Chapter 12   Statistics Process Control (Option) 

This chapter clearly introduces how to use the statistics drawing 
function to create the statistic process control graphics.  

 
Chapter 13   Report Wizard (Option) 

This chapter describes how to export the saved test data (graphics or 
text) to Microsoft Word. 

 
Chapter 14   On-line Control (Option) 

This chapter tells you how to use this program to integrate the 
devices in the system and simulate the tests manually.  

 
Appendix A  Test Result Log File 

It describes the contents of test result log.  
 
Appendix B Contact Chroma 

It includes the information of how to contact Chroma for software 
and hardware services as well as a reader comments form for your 
comments and recommendations.   

 
 

www.valuetronics.com



SMPS ATS 8000 User’s Manual 

xv     

Conventions 
 
Following conventions are used in this manual.  
 
Bold Indicates the function keys, push buttons, and input/output 

parameters.  
 
Italic Indicates the important notices and references for manuals or 

documents.  
 
Italic Bold   Users can use the program to check, save and print the test results. 
 
Courier New Indicates the text you need to enter such as the driver ID, path, 

directory and execution program name when using the program to 
check, save and print the test results.  

 
‘  ’    Indicates the active window or program. 
 
        Indicates the push button. 
 

[ ]→[ ]   Menu items. 
 
{}    Data list. 
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1. System Architecture 

This chapter describes the architecture and composite of Chroma 8000 Switch Mode Power 
Supply Automatic Test System with detail explanations of Switch Mode Power Supply ATS 
software (SMPS ATS software) main features.  Following listed are the system requirements 
to help you understand the environment you need.  
 
 

1.1 Introduction 

Chroma 8000 Automatic Test System is a system that integrates various instruments for 
Switch Mode Power Supply tests.  It is structured under the open software environment and 
designed specially for testing Switch Mode Power Supplies.  The ATS has the following 
features. 
 

 Integrating various programmable instruments to provide a total solution operating 
environment for easy and efficient use.  

 Providing a complete test program development environment for users to write or 
modify the test program also activates the debugging function to check its correctness.  

 Modular and flexible architecture makes the system easy to upgrade and expand.  
 Adopting the Graphics User Interface (Windows 98, Windows 2000 or Windows NT 

environment), which makes the program very user friendly.  
 Supporting standard interface IEEE-488, RS-232C and I2C. 
 Providing default test items and allowing users to develop the one they need.  
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1.2 Hardware Architecture 

Chroma 8000 Switch Mode Power Supply Automatic Test System should contain the 
following hardware devices:  
 

 System Controller, an IPC (Industrial PC and Peripherals), see section 1.2.1 for its 
functions and specifications.  

 Programmable AC Source, see section 1.2.2 for its functions and specifications. 
 Programmable DC Source, see section 1.2.3 for its functions and specifications.  
 Power Analyzer (PA), see section 1.2.4 for its functions and specifications.  
 DC Electronic Load, see section 1.2.5 for its functions and specifications.  
 Digital Storage Oscilloscope (DSO), see section 1.2.6 for its functions and 

specifications. 
 Digital Multi-Meter (DMM), see section 1.2.7 for its functions and specifications.  
 Timing/Noise Analyzer, see section 1.2.8 for its functions and specifications. 
 Over Voltage Protection and Short Circuit Tester (OVP/Short Circuit Tester), see 

section 1.2.9 for its functions and specifications. 
 Power ON/OFF Controller, see section 1.2.10 for its functions and specifications.  
 Extended module, see section 1.2.11 for its functions and specifications.  
 Frame: The 19” standard chassis for all hardware devices installation.  
 Test fixture: To connect Chroma 8000 SMPS ATS and UUT.  As the UUT is different 

from each other, the fixture needs to be customized as per request. 
 Test table: The table for putting the UUT and computer peripherals, and generally 

provided by user.   
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Figure1-1  Chroma 8000 Hardware Logic Diagram 
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Digital Storage Osc. Scope

Digital Multi-Meter

DC Electronic Load

Timing/Noise Analyzer

Industrial PC

Programmable DC Power Supply

Power Analyzer

Programmable AC Source

OVP/Short Circuit Tester

ON/OFF Controller

 
 

Figure1-2  System Outline 
 
 

1.2.1 System Controller (Industrial PC & Peripheral) 
 

 Central Control Computer: 
Central Control Computer is the center of Chroma 8000 SMPS ATS.  It controls 
various instruments to execute tests and examine the test results; also to save, display, 
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print and analyze the data as well as provide users the operating interfaces.  The 
hardware requirements are as below: 

 
 Intel CPU 500MHz or above 
 8.3GB hard disk drive or above 
 512MB memory or above 
 3.5” floppy disk  
 40 speed CD drive or above 
 SVGA monitor (min. resolution 800x 600) 
 Keyboard 
 PS2 mouse 
 At least 3 slots available for DIO and GPIB cards 
 Parallel printer port 

 
 Peripheral: 

The peripheral is for test results printout. 
 Parallel printer— for detail data printing use. 

 
 

1.2.2 Programmable AC Source 
 
A Programmable AC Source is to provide the input power for UUT and simulate various 
input power situations.  So, it must have enough power, changeable voltage and frequency to 
fulfill the input requirements of a power supply.  
 
Chroma 8000 SMPS ATS supports the programmable AC Source manufactured by Chroma. 
For the models supported please refer to the ‘H/W Configuration’ in the system software.  As 
to the detail specifications and operations of AC Source, please see its user’s manual. 
 
 

1.2.3 Programmable DC Source 
 
A Programmable DC Source is to provide extra power to test the over voltage protection 
function.  It must be able to provide the voltage that larger than the UUT output for over 
voltage protection.  
 
Chroma 8000 SMPS ATS supports the programmable DC Source manufactured by Chroma. 
For the models supported please refer to the ‘H/W Configuration’ in the system software.  As 
to the detail specifications and operations of DC Source, please see its user’s manual. 
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1.2.4 Power Analyzer 
 
Power Analyzer is to calculate the UUT’s efficiency by measuring the various parameters of 
voltage, current, power, frequency, power factor and total harmonic distortion from the 
UUT’s input comparing to its output. 
 
Chroma 8000 SMPS ATS supports the Power Analyzer manufactured by Chroma. For the 
models supported please refer to the ‘H/W Configuration’ in the system software.  As to the 
detail specifications and operations of Power Analyzer, please see its user’s manual. 
 
 

1.2.5 DC Electronic Load 
 
A DC Electronic Load is to simulate the load changes and other status on the UUT when 
running tests so that they can be close to reality. 
 
Chroma 8000 SMPS ATS supports the DC Load manufactured by Chroma. For the models 
supported please refer to the ‘H/W Configuration’ in the system software.  As to the detail 
specifications and operations of DC Load, please see its user’s manual.  
 
 

1.2.6 Digital Storage Oscilloscope 
 
Digital Storage Oscilloscope is to measure and save the UUT’s output voltage waveform for 
data analysis.  In SMPS ATS, the default function for load adjust rate (load effect) 
characteristic test uses the Digital Storage Oscilloscope to measure the output voltage 
waveform and calculate the result after saving it. 
 
Chroma 8000 SMPS ATS supports the Tektronix TDS 3012 Digitizing Oscilloscopes.  For 
the detail specifications and operations of Tektronix TDS 3012 Digitizing Oscilloscopes, 
please see its user’s manual.  
 
 

1.2.7 Digital Multi-Meter 
 
Digital Multi-Meter is to measure the voltage, current and resistance.  In SMPS ATS, Digital 
Multi-Meter is to measure the UUT’s reverse current. 
 
Chroma 8000 SMPS ATS supports the Agilent/ HP 34401A Multimeter.  For detail 
specifications and operation of Agilent/HP 34401A Multimeter, please refer to its user’s 
manual.  
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1.2.8 Timing/Noise Analyzer 
 
Chroma 8000 SMPS ATS uses the unique Timing/Noise Analyzer - Chroma 6011, which is 
able to expand up to 10 input measurement modules and every module can measure the 
timing and noise potential.   In addition, it also provides TTL signal and floating point relay 
to execute the external circuit control. 
 
For detail specifications and operation of Chroma 6011 Timing/Noise Analyzer, please refer 
to its user’s manual.  
 
 

1.2.9 OVP/Short Circuit Tester 
 
Chroma 6012 Over Voltage Protection can simulate OV/UV and short circuit situations to 
make power supply tests more convenient. 
  
For detail specifications and operation of Chroma 6012 OVP/Short Circuit Tester, please 
refer to its user’s manual.  
 
 

1.2.10 ON/OFF Controller 
 
Chroma 6013 ON/OFF Controller is able to control AC and DC input at the same time. 
Besides, it can control the AC power on/off angle and measure the UUT’s import inrush 
current.  
 
For detail specifications and operation of Chroma 6013 ON/OFF Controller, please refer to 
its user’s manual.  
 
 

1.2.11 Extended Module 
 
In order to meet the test functions, this SMPS ATS has to connect the above hardware devices 
with the following extended modules:  
 
1. GPIB card for system controller: The interface device that provides communication 

signals among various instruments.  
2. DIO card for system controller: The interface device that provides Auto Run. 
3. External control template: The DIO card connects to system controller.  It has 16 input 

signal sets and 16 output Open Collector sets, and is the control device for signal input 
and external circuit control.  
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 Note 

The instruments described above are standard equipment.  The instruments shipped should 
follow the actual delivery of shipment.  

 
 

1.3 SMPS ATS Software Overview 

 

1.3.1 Introduction to SMPS ATS Software 
 
The requirements for new generation automatic test environment can no longer be satisfied 
with a proprietary test system.  Test engineers cannot be fulfilled with the test system that 
only has simple and limited functions.  They need a flexible test environment that can be 
changed to adopt various hardware requirements and different test processes.   
 
SMPS ATS software is an open automatic test environment that can fulfill various test 
requirements.  Besides using the built-in standard test items in SMPS ATS, test engineers can 
modify the built-in test items or create new test items for testing needs according to the UUT 
characteristics. 
 
Different model instrument has different precision requirements.  Therefore, test engineers 
may want to exchange the DSO to other brand with higher precision. In consideration of this 
requirement, SMPS ATS is highly flexible in instrument exchange. 
 
SMPS ATS software system uses modular and embedded design that has the following 
features:  
 
1. Structured under Windows environment and used standardized graphics users interface 

that make it very friendly and easy to use. 
2. Flexible programming interface that can modify the designed steps or create new test 

items easily.   
3. Using the implicit compiled function to enhance the test program execution speed.  
4. Able to execute the test items directly and verify the test results immediately. 
5. Able to edit the report print format and support multilingual. 
6. Able to print the data of failed tests for maintenance. 
7. Able to support graphic report functions and can be processed by Microsoft Word. 
8. Able to save the test results for production management analysis.  
9. On-line operation that gives R&D engineers the ability to integrate system devices for 

manual test simulation.  
10. Instrument driver, which uses Dynamic Link Library (DLL) to make instruments easy to 

replace or add. 
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1.3.2 System Module 
 
SMPS ATS software has the following module functions 
 
1. User management: 

Define different user levels, for example, operators can only execute test programs 
while engineers can access all functions.  

2. Hardware device configuration setting: 
Set the interface (GPIB and RS-232C) address configuration and define related 
module/channel for instrument devices. 

3. Test item editing: 
You can write the test process following the test requirements and save the test process 
to database.  The test item can be included to the test program using the test program 
editor.  You can also execute the test items after editing the test process.  

4. Compiling:  
This function is hidden in the internal of test item edit function.  When you finished 
editing a test item, it will compile the test item automatically before saving.  

5. Test program editing:  
You can write the test program using the test items built in the system or customized by 
the test engineers. You can also set parameters or test specifications for the test items.  
The filename extension for test program is .prg, and it is an executable file.  

6. Report format editing: 
You can edit the report format for the test items you need.  The filename extension for 
report format is .rpf.  

7. Test program execution control:  
The test program after compiled uses this function to run tests.  It follows the sequence 
you edited to call the related test items for test; and log the test results, generate and 
print the reports, also to decide the outcome of various test items and readings.   

8. Report printing: 
Report printing can be done off-line.  SMPS ATS software will save the test results that 
needed by test.  This function can be used to print a certain test result of a certain date.  

9. Statistics process control:  
Through this function you can use the test results in the database to perform statistics 
process analysis.  
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1.4 Software System Requirements 

 
Following software and hardware requirements for personal computer is recommended to 
use in Chroma 8000 SMPS ATS software. 
 

 Intel CPU 500MHz or above 
 Microsoft Windows 98 (second edition), Windows 2000, Window XP or NT (SP5 or 

above)  
 Suggested 400 MB hard disk drive or above 
 Minimum 512 MB memory 
 VGA or SVGA color display   
 PS2 mouse 
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2. System Installation 

This chapter describes how to install Chroma 8000 SMPS ATS hardware and software, also 
reminds you of the things to notice to avoid any operation errors.  
 
 

2.1 Installing Chroma 8000 System Hardware 

 
All Chroma 8000 SMPS ATS hardware devices are installed in a 41” height and 19” width 
standard chassis.  Please see the following installation procedures to install the instruments in 
the chassis from top to bottom. (As the system is in open architecture, the installation 
sequence described here is for reference only.  You can rearrange it as you like.)  Below is the 
standard installation procedure for Chroma 8000 ATS instrument devices.  
 
 
Installation Procedure 

 

1. Lay down the empty system rack on the ground with face up.  Padding the bottom with 
cushion plate to avoid damaging the chassis and switch.  

2. Put the instruments from top to bottom in sequence, such as Digital Storage 
Oscilloscope, Digital Multi-Meter, Programmable DC Source, DC Electronic Load, 
Input/Output Terminal, Industrial PC, 6011 Timing/Noise Analyzer, 6012 OVP/Short 
Circuit Tester, 6013 Power ON/OFF Controller, Power Analyzer and Programmable 
AC Source. When putting in an instrument, you need to adjust the alumni bracket to the 
appropriate position and secure it with screws.  

3. Lift up the system from the ground and connect each instrument following the 
connector instruction and the pin assignments list below.  

 

Cable Connections 

 
To explain the connection between the system and the UUT, following example shows the 
ATX Power Supply with 6 outputs.  Figure 2-1 and Figure 2-2 show the connections of the 
system and the HYPERTRONICS connector, HYPERTRONICS connector and Chroma 
A600011 Test Fixture.  As to other test applications for UUT, please connect them as need.   
Note:  The portion within dotted lines in Figure 2-1 is applicable to the test applications for 
D/D Converter UUT only. 
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Figure 2-1  Connection between HYPERTRONICS Female Connector to System 
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Figure 2-2  Connection between HYPERTRONICS Male Connector to A600011 Fixture 

 
Note: There are two short lines put on CN-R and CN-S (CN=connector), it is for controlling 

the third signal of 6011 trigger input (i.e. PS signal) by the 1st TTL output of 6011.   
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HYPERTRONICS Connector Pin Assignment 

 

 B, D modular: 

Part No. W39 000294 W39 000299 

Item LMFST-2P-4C-R3.5-5*4-150CM LMMST-2P-4C-R5.5-5*2-150CM 

Pin No. Female to system Male to A600011 

1 DC load modular input (+) DC load modular input (+)  

2 DC load modular input (-) DC load modular input (-) 

 
 A, C modular: 

Part No. W39 000293 W39 000299 

Item LMFST-2P-4C-R3.5-5*2-150CM LMMST-2P-4C-R5.5-5*2-150CM 

Pin No. Female to 6012 Male to A600011 

1 6012 (1-6) Short/OVP channel input (+) DC load modular input (+)  

2 6012 (1-6) Short/OVP channel input (-) DC load modular input (-) 

 
 E, G, I, N modular: 

Part No. W39 000295 W39 000297 

Item LMFST-2P-2C-R3.5-5*2-150CM LMMST-2P-2C-R5.5*2-150CM 

Pin No. Female to 6012 Male to A600011 

1 6012 (1-6) Short/OVP channel input (+) DC load modular input (+)  

2 6012 (1-6) Short/OVP channel input (-) DC load modular input (-) 

 
 F, H, J, O modular: 

Part No. W39 000295 W39 000297 

Item LMFST-2P-2C-R3.5-5*2-150CM LMMST-2P-2C-R5.5*2-150CM 

Pin No. Female to 6012 Male to A600011 

1 6011 (1-6) Short/OVP channel input (+) DC load modular input (+)  

2 6011 (1-6) Short/OVP channel input (-) DC load modular input (-) 

 
 K modular: (When the system is define to DC output) 

Part No. W39 000279 W39 000299 

Item LMFST-2P-BANANA*4+R3.5-5*2- 
150CM 

LMMST-2P-4C-R5.5-5*2-150CM 

Pin No. Female to system Male to A600011 

1 PA voltage output (+)  (DC) (DC)Test voltage input (+) 

2 PA voltage output (-)  (DC) (DC)Test voltage input (-) 
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 K modular: 

Part No. W39 000310 W13 030000 

Item LBFST-3P-BANANA*4+R3.5-5*2- 
150CM 

LBMST-3P-ACEP-150CM 

Pin No. Female to system Male to A600011 

1 PA test voltage output AC line Test voltage input AC line 

2 PA_6013 test voltage output AC neutral Test voltage input AC neutral 

3 PA_6013 test voltage output AC ground Test voltage input AC ground 

 
 L modular: 

Part No. W39 000298 W39 000307 

Item LAFST 5P-Y1.25-3*4PCS-150CM LAMST 5P-R3.5-5*4-150CM 

Pin No. Female to system Male to A600011 
or user‘s application 

1 6013 AC line output sense To UUT AC line input sense 

2 6013 AC neutral output sense To UUT AC neutral input sense 

3 Reserved Reserved 

4 6013 DC output sense (+)  To UUT DC input sense (+) 

5 6013 DC output sense (-) To UUT DC input sense (-) 

 
 M modular: 

Part No. N29 410200 N29 410200 

Item LAHT (for empty modular (A)? 
HYPERTRONICS CONNECTOR 

LAHT (for empty modular (A)? 
HYPERTRONICS CONNECTOR 

Pin No. Female Male  

1 Reserved Reserved 

2 Reserved Reserved 

3 Reserved Reserved 

4 Reserved Reserved 

5 Reserved Reserved 

 
 P modular: 

Part No. W39 000308 W39 000284 

Item LDFST-17P-BANANA*6*2-150CM LDMST-17P-PRC-2P*6-150CM 

Pin No. Female to system Male to A600011 

1 DC Load Vsense channel 1 (+)  V1 pin A 

2 DC Load Vsense channel 1 (-) V1 pin B 

3 DC Load Vsense channel 2 (+) V2 pin A 

4 DC Load Vsense channel 2 (-) V2 pin B 

5 DC Load Vsense channel 3 (+) V3 pin A 

6 DC Load Vsense channel 3 (-) V3 pin B 
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7 DC Load Vsense channel 4 (+) V4 pin A 

8 DC Load Vsense channel 4 (-) V4 pin B 

9 DC Load Vsense channel 5 (+) V5 pin A 

10 DC Load Vsense channel 5 (-) V5 pin B 

11 Reserved Reserved 

12 DC Load Vsense channel 6 (+) V6 pin A 

13 DC Load Vsense channel 6 (-) V6 pin B 

14 DC Load Vsense channel 7 (+) Reserved 

15 DC Load Vsense channel 7 (-) Reserved 

16 DC Load Vsense channel 8 (+) Reserved 

17 DC Load Vsense channel 8 (-) Reserved 

 
 Q modular: 

Part No. W39 000288 W39 000284 

Item LDFST-17P-PRC-2P*6-150CM LDMST-17P-PRC-2P*6-150CM 

Pin No. Female to system Male to A600011 

1 6011 noise measure channel 1 pin A  N1 pin A 

2 6011 noise measure channel 1 pin B N1 pin B 

3 6011 noise measure channel 2 pin A N2 pin A 

4 6011 noise measure channel 2 pin B N2 pin B 

5 6011 noise measure channel 3 pin A N3 pin A 

6 6011 noise measure channel 3 pin B N3 pin B 

7 6011 noise measure channel 4 pin A N4 pin A 

8 6011 noise measure channel 4 pin B N4 pin B 

9 6011 noise measure channel 5 pin A N5 pin A 

10 6011 noise measure channel 5 pin B N5 pin B 

11 Reserved Reserved 

12 6011 noise measure channel 6 pin A N6 pin A 

13 6011 noise measure channel 6 pin B N6 pin B 

14 6011 noise measure channel 7 pin A Reserved 

15 6011 noise measure channel 7 pin B Reserved 

16 6011 noise measure channel 8 pin A Reserved 

17 6011 noise measure channel 8 pin B Reserved 
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 R modular: 

Part No. W39 000290 N29 430030 

Item ˟˗˙˦˧ˀ˄7ˣˀ˗˕˅ˈˠˀ˄ˈ˃˖ˠ 

 

LDMST 17PIN MALE 8A 
HYPERTRONICS CONNECTOR 

Pin No. Female to system Male  

1 6011 TTL output  1st  pin User define 

2 6011 TTL output  2nd  pin User define 

3 6011 TTL output  3rd  pin To 6011 Trigger input 3 (PS ON signal) 
or user define 

4 6011 TTL output  4th  pin User define 

5 6011 TTL output  5th  pin User define 

6 6011 TTL output  6th  pin User define 

7 6011 TTL output  7th  pin User define 

8 6011 TTL output  8th  pin User define 

9 6011 TTL output  9th  pin User define 

10 6011 TTL output  10th  pin User define 

11 6011 TTL output  11th  pin User define 

12 6011 TTL output  12th  pin User define 

13 6011 TTL output  13th  pin User define 

14 6011 TTL output  14th  pin User define 

15 6011 TTL output  15th  pin User define 

16 6011 TTL output  16th  pin User define 

17 6011 TTL output ground (17-25 pin) 6011 Trigger input 6 pin (ground) 
or user define 

 
 S modular: 

Part No. W39 000285 W39 000302 

Item LDFST-17P-5557-6F+2F -150CM LDMST-17PIN-DB9 (M)+BNC (M) 
-150CM 

Pin No. Female to system Male to fixture A600011  

1 6011 trigger input 1 contact to 6013 
AC ON signal (+) (AC ON signal) 

 (AC ON signal) 

2 6011 trigger input 2 (PG signal) To A600011 PG output  

3 6011 trigger input 3 (PS signal) To A600011 PS input (Ext A.B), TTL 
output pin1 

4 6011 trigger input 4 (User define) Reserved 

5 6011 trigger ground  To A600011 ground 

6 6011 trigger ground and contact to 
6013 AC ON signal (-) 

To A600011 ground 

7 6013 AC ON signal (+) To 6011 trigger input 1 or (by user’s define) 

8 6013 AC ON signal (-) To 6011 trigger input 5 or 6 pin 
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9 Reserved Reserved 

10 6013 DC ON signal (+) To 6011 trigger input 1 or (by user’s define) 

11 6013 DC ON signal (-) To 6011 trigger input 5 or 6 pin 

12 Reserved Reserved 

13 Reserved Reserved 

14 Reserved Reserved 

15 Reserved Reserved 

16 Reserved Reserved 

17 Reserved Reserved 

 
 T modular: 

Part No. W39 000286 N29 430030 

Item LDFST-17P-5557-12P-150CM 
 

LDMST 17PIN MALE 8A 
HYPERTRONICS CONNECTOR 

Pin No. Female to system Male for user‘s application 

1 6011 floating relay 1 group (+) User define 

2 6011 floating relay 2 group (+) User define 

3 6011 floating relay 3 group (+) User define 

4 6011 floating relay 4 group (+) User define 

5 6011 floating relay 5 group (+) User define 

6 6011 floating relay 6 group (+) User define 

7 6011 floating relay 1 group (-) User define 

8 6011 floating relay 2 group (-) User define 

9 6011 floating relay 3 group (-) User define 

10 6011 floating relay 4 group (-) User define 

11 6011 floating relay 5 group (-) User define 

12 6011 floating relay 6 group (-) User define 

13 Reserved Reserved 

14 Reserved Reserved 

15 Reserved Reserved 

16 Reserved Reserved 
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■  U modular: 

Part No. W39 000287 W39 000309 

Item LDFST-17P-5557-20P-150CM LDMST-17P-CONN-20(M)-150CM 

Pin No. Female to system Male for user‘s application 

1 6011 MUX input 1 group (+) User define 

2 6011 MUX input 1 group (-) User define 

3 6011 MUX input 2 group (+) User define 

4 6011 MUX input 2 group (-) User define 

5 6011 MUX input 3 group (+) User define 

6 6011 MUX input 3 group (-) User define 

7 6011 MUX input 4 group (+) User define 

8 6011 MUX input 4 group (-) User define 

9 6011 MUX input 5 group (+) User define 

10 6011 MUX input 5 group (-) User define 

11 Reserved Reserved 

12 6011 MUX input 6 group (+) User define 

13 6011 MUX input 6 group (-) User define 

14 6011 MUX input 7 group (+) User define 

15 6011 MUX input 7 group (-) User define 

16 6011 MUX input 8 group (+) User define 

17 6011 MUX input 8 group (-) User define 
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2.2 Input Power Supply Requirements and Cautions 

 
The table below shows the input voltage and power requirements for the instruments in 
Chroma 8000 SMPS ATS. 
 

Instruments Input Voltage Frequency Power Mode No. 

Programmable AC Source 115 / 250 V 47-63HZ 5000W Chroma 6530 

Programmable DC Electronic 
Load  

115 / 230 V 47-63HZ 180VA max. Chroma 6310 
632802 

Digital Storage Oscilloscope 115 / 230 V 47-63 HZ 130VA max. Tektronix 3012 

Digital Multi-Meter 115 / 230 V 50-60 HZ 115W HP 34401 

Timing/Noise Analyzer 115 / 230 V 50-60 HZ 173W Chroma 6011 

OVP/Short circuit Tester 115 /230 V 50-60 HZ 115W Chroma 6012 

Power ON/OFF Controller 115 /230 V 50-60 HZ 115W Chroma 6013 

Power Analyzer 130 /240 V 50-60HZ 45W Chroma 6532 

Table 2-1  Input Voltage and Power Requirements for Various Instruments 
 
This system is equipped with 230VAC input instruments.  The power is inputted from the 
power inlet at the bottom of the rear plate.  Two AC 230V power inlets are extended for other 
instrument use.  Be sure to check if the power inlets are enough.  If the instrument to be added 
is not using 230VAC input power, you need to connect it separately.  For normal operation 
and prolonging the tenure of use, please make sure that proper input power with stable 
voltage and frequency is supplied. 
  

Caution 

To avoid power overload, which could damage the equipment, do not use the instrument that 
is not for 8000 SMPS ATS.  

 
 

2.3 Installing/Uninstalling SMPS ATS Software 

 
Before using Chroma 8000 system, you need to install the SMPS ATS software to your 
computer hard disk.  Following section describes how to install SMPS ATS software on your 
Windows environment step by step.  
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2.3.1 Installing GPIB Interface Driver 
 

 Please follow the steps described in the GPIB Interface Installation Manual for 
installation.  

 To ensure the parameters in SMPS ATS software will take effect in the Windows system, 
please reboot your computer after completing the above installation procedures.  Before 
starting SMPS ATS software, please insert the SMPS ATS software protection key to the 
LPT1 printer port on your PC.  To avoid system down be sure to remove the protection 
key when the PC is powered off. 

 
 

2.3.2 Installing SMPS ATS Software on Windows 
 

 Your computer should have at least 40 MB space available before installation. 
 Connect the Software Protection Key to LPT1 or USB port. 
 Place the SMPS ATS software CD to CD drive. 
 If you are installing it from CD and your operating system supports Auto Run function, 

the installation program will execute automatically.  Or, you can choose one of the 
following methods to run the SETUP.EXE installation program.  

 
1. Use ‘Run (R)…’ to install 

 

a. Click ‘Start’ button at the lower-left corner on your Windows desktop, and 
select ‘Run(R)…’ command to execute.  

 

b. Then click  Browse(B)…  to select CD drive (D:) for running SETUP.EXE.  

Generally this file is located in the root directory or under Disk1 directory in 
the installation program.  

 

 
Figure 2-3  Run Window 
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c. Click  OK  to start installation. 

 

2. Use ‘Windows File Manager’ to install 
 

a. Click ‘Start’ button at the lower-left corner on your Windows desktop, and 
click ‘Program’, then select ‘Windows File Manager’.   

 
b. Select the disk drive (A: or B:) or CD drive (D: or others) where the 

installation program is in, and double-click SETUP.EXE to start the 
installation process.  

 
c. When installing the screen will appear as Figure 2-4, you can decide if you 

need to install the NI VISA or NI IVI Engine software depending on whether 
they have been installed.  It is suggested to install them following the 
sequence of NI-VISA, and then NI-IVI Engine.  Chroma 8000 System 
Software is to be installed at last. 

 

 
Figure 2-4   Chroma 8000 System Software Installation Main Screen 
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d. Click Chroma 8000 System Software as showed in Figure 2-4 to install 
Chroma 8000 SMPS ATS software, the screen will appear as Figure 2-5.  

 

 
Figure 2-5  System Software Version Information Screen 

 
 Please follow the installation program wizard to complete the work.  
 

 
Figure 2-6  Installation Progress 

 
 You will be requested to enter user name and company name while installing. 
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Figure 2-7   Enter User Name and Company Name 

 
 You can select the type of the hardware. 
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Figure 2-8  Select the type of the hardware 

 
 During installation you can choose the destination location you want.  If you have no 

preference, we suggest you to click  Next > , then the program will create a default 

directory Chroma\SMPS_ATS under C:\Program Files automatically, and 
install all related programs and files under this directory.  Following screen shows you 
the directory created by the installation program wizard.  
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Figure 2-9  Select the Destination Directory 

 
Under C:\Program Files\Chroma\SMPS_ATS system software directory, it has the 
following subdirectories.  The content in each subdirectory is described below.  
 

\Bin SMPS ATS software programs. 
\Data\Db System database. 
\Data\OnLineCtrl The ‘On-line Control’ program parameter setting files. 
\Help To store the help explanation files of each program 

module.  
\HWCfg To store the hardware configuration file (.hwc). 
\Ini Test program information files. 
\Lib Instruments driver libraries. 
\Log Empty at installation, to store the test result statistics data 

logs (use the test program name as subdirectory). 
\Program To store test programs (.prg). 
\Report\Format To store report format files (.rpf). 
\Report\Project To store ‘Report Wizard’ project files. 
\Spc To store ‘Statistics’ project files (.spc). 
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\Visa VISA installation program. 
\UTP\Db Empty when installed, it stores the Universal Test 

Program database files (.mdb). 
\UTP\Ini Empty when installed, it stores the Universal Test 

Program information files. 
\UTP\Log Empty when installed, it stores the test result statistics logs 

of Universal Test Program. 
\UTP\Program Empty when installed, it stores the Universal Test 

Program (.prg). 
 
 

2.3.3 Uninstalling SMPS ATS Software 
 
If you want to remove SMPS ATS software, we suggest you to uninstall it by clicking ‘Start’ 

button, then ‘Setting’ → ‘Control Panel’ → ‘Install/Uninstall Program’, and select 
Remove in the InstallShield Wizard to delete the SMPS ATS software related programs. You 
can also select Repair to reinstall SMPS ATS software or select Modify to change the type of 
the hardware. 
 

 
Figure 2-10  Modify/Repair/Remove SMPS ATS Software 
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In Windows 98 operating system, the system may require a restart to install the Hasp Driver 
during installation process.  Please install the SMPS ATS software again after restarted.  
 

 
Figure 2-11  Restart the System after Installed the Hasp Driver  

 

 
Figure 2-12  Install the SMPS ATS Software Again after Restart  

www.valuetronics.com



Basic Operation 

3-1     

3. Basic Operation 

This chapter briefly introduces the basic operation of SMPS ATS software and the concepts 
of test programs.  For detail operation, please see the later chapters.  
 
 

3.1 Notices Before Power On 

You need to ensure that there is enough and stable AC power to supply all devices used in the 
system before you power on the SMPS ATS for operation.  To reduce the inrush current 
generated at the moment when turning on the machine, and causes impact on the system, we 
suggest you to turn on the machine following the sequences described here.  First turn on the 
AC or DC Source, then OVP/UVP Power Supply, Electronic Load and other instrument 
modules, the last are your PC and other peripherals. 
 
 

3.2 How to Start SMPS ATS Software 

If you already followed the instructions described in Chapter 2 to install SMPS ATS software 
on your hard disk, your computer desktop will appear a shortcut for SMPS ATS software.  
You can double-click the shortcut to activate SMPS ATS software.  You can also click 

‘Program(P)’ to execute SMPS ATS software following the steps listed here, ‘Start’→ 

‘Program(P)’ → ‘SMPS ATS’.  
 
Following Login Screen as Figure 3-1 shows up after executing the SMPS ATS software: 
 

 
Figure 3-1  Login Screen 

 
Please enter correct User ID and Password, then click  Login  to start SMPS ATS software.  
If you are using the software for the first time, please enter ‘root’ for User ID and leave blank 
for Password to login.  For safety, please be sure to add password for ‘root’ after login. You 
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can also click  Option  to start WebCam.  After you login successfully, the screen SMPS 

ATS software main menu will show as Figure 3-2.  
 

 
Figure 3-2  SMPS ATS Software Main Menu 

 
SMPS ATS software main menu is composed of three function groups with 12 selection 
items.  The three groups are Basic, Advance and System as explained below.  
 
Basic Function Group 

 

Test Program To edit test program.  
Report Editor To edit the report output format. 
Report Generator To print the saved test result.  
GO/NOGO For operators to perform tests. 

 
Advance Function Group 

 

Test Item To add and edit the customized test items.  
Statistics To execute the statistics process analysis.  
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Report Wizard To save the test data (graphics or text) and export to Microsoft 
Word. 

On-line Control For R&D engineer to integrate the system devices for manual 
test simulation.  

 
System Function Group 

 

H/W Configuration To set up the hardware configuration for instrument device (ex. 
GPIB address) and select the needed test devices.  

Management To manage user levels and execution of import and export.  
About The statement of SMPS ATS software.  
Exit To quit the SMPS ATS software.  

 
 

3.3 SMPS ATS Software Operation Flow 

Here is the SMPS ATS software operation flow.  
 

˛˂˪ ˖̂́˹i˺̈̅ȧî́
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˥˸̃̂̅̇ ˙̂̅̀ȧ ˘˷i̇í˺

˚ˢ˂ˡˢ˚ˢ ˧˸̆̇

˥˸̃̂̅̇ ˚˸́˸̅ȧ̂̅

ˢ˞ ?

˥˸˿˸ă˸ ˧˸̆̇ ˣ̅̂˺̅à
ʻˠáa˺˸̀˸́̇˂˧˸̆̇

ˣ̅̂˺̅àʼ

Y

ˡ

˥˸̃̂̅̇ ˪i̍a̅˷ ˦ˣ˖ ˔́a˿̌̆ĭ

˧˸̆̇ ˜̇˸̀
˘˷i̇í˺˂˩˸̅i˹i˶ȧî́

ˢ́ˀ˟í˸ ˖̂́̇̅̂˿

 
Figure 3-3  SMPS ATS Software Operation Flow 
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3.4 Setting Instrument Device Configuration 

Click  H/W Configuration  in System group from the SMPS ATS software main menu, it will 

show the instrument configuration window as Figure 3-4.  Please follow the configuration to 
set up parameters, such as GPIB address and RS-232C parameter.  
 

 
Figure 3-4  Instrument Configuration Window 

 

 

3.5 Creating New Test Program 

A test program is composed of many test items.  The system has some built-in test items for 
use right away.  To create a new test program, please select the test item you need first then 
set the test item parameters, finally set the required report format (.rpf file) for report output 
reference.  
 
Click  Test Program  in Basic group from the SMPS ATS software main menu, it will show 

the test program edit window and request for the name of the test program you wish to open.  
If you select ‘Create new TP’ and click  OK  a new blank test program will appear as below. 
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Figure 3-5  Test Program Editor Window 

 
Setting Test Program Info: 

  
Click  Program Info  on the left window, it will display the Test Program Information 
window.  
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Figure 3-6  Test Program Information Dialog Box 

 
Please enter the parameters as per your need.  The Report Format File in Link tab is for test 
result printout.  If you wish to use different filename, please click the button at right to select 
the file needed.  
 
Adding Test Item to Test Program:  

 

First select the Seq. you want to insert in the test item table on the left window.  Assuming it 
is Seq.3, then double-click the test item you want on the right window. (Or you can select the 
test item and click  Insert TI  on the toolbar.)  Thus the test item will be added to Seq.3, and 

the original Seq.3 will be pushed to Seq.4, and so forth.  
 
The test item’s position and sequence can be anywhere you like; however, we suggest that the 
first test item in Pre Test group should be System Setup. 
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Setting Vector:  

 

You can select [View]→[Vector Editor] from the main menu or click  Vector  on the toolbar 

to switch to Vector Editor.  As Figure 3-7 shows, the Vector Set Select is on top of the menu 
and the drop-down selection box enables you to select the Vector type you want to edit.  
There are 4 default vector settings when the system shipped that are Line In Vector, Load 

Vector, Spec. Vector and Ext. Meas. Vector. 
 

 
Figure 3-7  Vector Editor Window 

 

Setting Test Item Parameter:  

 

You can click  Parameter  or double-click the Test Item column in the test program item 
table.  The original test item list area will change to test item parameter editor as Figure 3-8 
shows. 
 
Click the test item you need in the test program item table. The test item parameter editor will 
display the selected test item parameter for editing.  
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After completing the parameter setting, click Test Item on the toolbar, the test item 
parameter editor will return to the test item list area.  
 

 
Figure 3-8  Test Item Parameter Editor Window 

 
Saving Test Program: 

 
After the test program is created, please remember to save it to ensure the modified contents 
will be logged to the storage device.  
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3.6 Verifying Test Program 

After setting the parameters (including Vector and Global Parameter) for every test item, you 
can click  Execution Control  , then the screen will change to the window as Figure 3-9 
shows that indicates the SMPS ATS software is ready to execute the test program edited.  You 
can click  TP Editor  at anytime to return to the test program editor window via test result.  A 

series of retest to verify the parameters you set are ok is required before releasing the test 
program to production line for execution.   Please be sure to run the releasing procedure 
described in the following section.  
 

 
Figure 3-9  Test Program Detail Execution Screen 
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3.7 Releasing Test Program 

Before you execute the test program through GO/NOGO module, please return to the SMPS 
ATS software main menu, and click  Management  in the System group.  The window is 
shown as Figure 3-10.  Switch to Test Program tab and select the test program in the Released 
check box.  Only the released test program can be executed by GO/NOGO program.  
 

 
Figure 3-10  Release Test Program 

 
 

3.8 Executing Test Program 

In the SMPS ATS software main menu, click  GO/NOGO  in the Basic group to enter the 

window as Figure3-11 shows below. 
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Figure3-11  Test Program Open Window 

 
After you selected the test program name and clicked  OK  , the screen will display the 
window as below.  
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Figure 3-12  GO/NOGO Program Screen 

 
When the lower-left corner window appears the message ”Initialize 5 Devices Successfully!”, 
you can click F10 function key on the keyboard or click  Go(F10)  on the toolbar.  SMPS ATS 

software follows the parameters set in the test program for execution.  
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Figure 3-13  GO/NOGO Execution Result Screen 

 
 

3.9 Printing Test Result Report 

There are two ways to run the Report Generator program.  One is in Off-line mode to select 
the  Report Generator  in Basic group from the SMPS ATS software main menu. It will run 
‘Report Generator’ and display ‘Select data of tested UUTs from database’ window.  Another 
way is to call GO/NOGO program automatically during test in On-line mode and send the 
test result to this program.  
 
When executing Off-line, it will appear the ‘Select data of tested UUTs from database’ 
window to let you select the data you want to use for report generation.  You can also use the 

menu function [File]→[Open Log Database] to open this window as Figure 3-14 shows.  
There  are three options in the screen  to filter the UUT.  ‘All’ means to find all UUTs, ‘Pass 
UUT Only’ means to find the UUTs that passed  and ‘Fail UUT Only’  means to find the 
UUTs that failed.  
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Figure 3-14  ‘Select data of tested UUTs from database’ Window 

 
After completed the setting, click   OK   to let the program help you generate the report 
shown in Figure 3-15. 
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Figure 3-15  Report Contents Display 

 
 

3.10 Exiting SMPS ATS software  

There are three ways to exit SMPS ATS software program from the main menu.  
 
1. In the main menu, point to  Exit  in the System group and click, or  

2. In the main menu, point to   x  at the upper-right corner and click, or 
3. In the main menu, press Alt + F4. 
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4. Hardware Configuration 

4.1 Program Execution 

Selecting H/W Configuration in the System group from the SMPS ATS software main menu 
will run ‘Hardware Configuration’ program and read the default configuration file (.hwc) by 
displaying the hardware configuration window as Figure 4-1 Hardware Configuration 
Window shows.  
 

 
Figure 4-1  Hardware Configuration Window 

 
‘Hardware Configuration’ program follows the Registry contents to read the default 
configuration file (.hwc) at initial execution phase and display the hardware configuration 
window according to the configuration file.  If the default .hwc file does not exist, the 
program will inform the user. (The default is config.hwc after the system is initially 
installed.) 
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You can use the menu function [File]→[Save] to save the edited configuration file or use 

[File]→[Save As…] to save it to another file name.  In this program you can open 
different .hwc file, but the system can only have one default .hwc file.  You can use the menu 

function [File]→[Set As System Default] to save the configuration file as default.  Once the 
system default file is defined, it will be executed at initialization.  
 

If you wish to redefine the configuration file, you can use the menu function [File]→[New] 

or [File]→[Open…] to open the existing configuration file as shown below.  
 

 
 
 

4.2 Hardware Configuration Window Description 

The Hardware Configuration Window is divided into three parts - Instrument Window, Model 

Information Window and Module Information Window.  You can adjust the window size 
according to your needs for display.  The window contents are explained below.  
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4.2.1 Instrument Window 
 

 
 
‘Instrument Window’ is used to add and delete the current hardware configuration, and 
display the instrument type, model and quantity configured for test in tree structure.  
There are five levels in the tree structure: the first level is Instrument, an overview of 
instrument category, the second level is Device Type for instrument type, the third level is 
Model for instrument model name, the fourth level is Sub Device Type for the special 
instrument type of the third level, and the fifth level is Sub Model for the special instrument 
model of the third level.  They are explained in the table below.  
 

When it shows ⊕ in the window means there are other instrument devices in the lower level.  
You can click ⊕ to expand it.  Click the instrument and its related info will appear on the 
Model Information Window and Module Information Window. 
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 Type Meaning Example 

First level Instrument An overview of instrument category  

Second level Device Type Instrument type EMU Set 

Third level Model Instrument model number Chroma 6011 

Fourth level Sub Device Type
Special instrument type for some 
particular instruments 

Short Circuit/OVP 

Tester 

Fifth level Sub Model 
Special instrument model name for 
some particular instruments 

Chroma 6012 

 
 

4.2.2 Model Information Window 
 

 
 
It uses Grid to display the instrument related information, including Device Type, Model 

Name, Interface and Parameter for communication interface, as well as if it is Active.  This 
window will display different contents according to the item you selected in Instrument 
Window.  Select the first level will show all Model information, select the second and fourth 
level will display the current instrument Model information that has same Device Type, while 
selecting the third and fifth level will display the current single Model information.  They are 
explained in the table below.  

 

 Select Item Model Information Window Contents 

First level Instrument Display all instrument information. 

Second level Device Type 
Display the current instrument information that has same 
Device Type, for example the figure above displays all AC 
Source instruments in the current configuration.  

Third level Model Only display the current single instrument information.  

Fourth level Sub Device Type Same as second level. 

Fifth level Sub Model Same as third level.  

 
 

4.2.3 Module Information Window 
 
This window displays the instrument Module related info, which contains the following three 
types:  
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1. Single or same Device Type instrument Channel Information, including instrument 

Model Name, Channel Number (CH), Module Name, Spec Index and if Channel is 
Enabled. 

 

 
 
2. Display the Load Connection information of current instrument, in which a row 

represents a load connection. The figure below shows the Spec Index is 1 and 2 Channel 
connected.  The loading is 40% and 60%.  The Channel of Spec Index3 is the second 
load connection and defined in the Enable column for the load connection that will be 
used in the test program. 

 

 
 
3. A certain instrument’s Sub Model information, including Model Name, Channel Number 

(CH), Module Name, Spec Index and if Channel is Active.  This window will display 
different contents according to different operation methods as the table shown below.  
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Operation Select Item Module-Info Window Contents 

Instrument Do not display any information.  

Device Type 
Display all Models’ Channel Information for the same 
Device Type. 

Model Display the Channel Information of current Model.  

Sub Device Type 
Display all SubModels' Channel Information for the same 
Device Type. 

Instrument 
Window 

Sub Model 
Display the Channel Information of current single Sub 

Model. 

Device Type 
Display all Models’ Channel Information for the same 
Device Type. 

Model-Info 
Window 

Model Display the Channel Information of current Model. 

[View / Module 

Information ] 
Display Module Information Window. 

Menu 
[View / Load 

Connection ] 
Display Load Connection Window. 

 

 

4.3 Operation Description 

 
You can use the Instrument Window in the Hardware Configuration Window to add or 
remove the instruments.  The Instrument, Model Information and Module Information 
windows can also be used to modify the instrument settings for user interface, 
communication interface parameter, frequency, etc. 
 
 

4.3.1 Adding New Instrument 
 
To add new models, you can click the Device Type that the new model belongs to under 
Instrument Window.  The function menu will appear, then select ‘Add…’ to show the list of 
instruments, which may change due to different instrument type.  The example below is to 
add a new Chroma 6520.  Click ‘AC Source…’ and it will appear ‘Add Model’ window.  You 
can select the instrument then click OK. 
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4.3.2 Deleting Instrument 
 
1. To delete a single model, click the instrument you wish to delete and select ‘Delete…’ 

from the function menu, for example, Delete Chroma 6520.  

 
 
2. To delete all models under same Device Type, click the Device Type you wish to delete 

and select ‘Delete …’ from the function menu, which may change due to different 
instrument type.  For example, delete all AC Source models. 

 

 
 
3. To delete all models, click the item in Instrument Window, and select ‘Delete All’ from 

the function menu.  
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4.3.3 Configuration Setting and Modification 
 
Hardware configuration setting and modification contain device model number, user 
interface, communication interface parameter, and frequency information, etc.  There is no 
particular sequential relationship among them, however, in some situations when you modify 
a column, the contents of other column in the same row may be modified as well.  For 
example, when you change the user interface from GPIB to RS232, the Parameter column 
will change too.  
 
 

4.3.3.1 Setting User Interface 
 

 There are 7 user interfaces supported: GPIB, RS485, RS232, IO MAP/PC, I2C, 
RS232-I2C and USB interfaces.  

 To set it, click the drop-down menu on the Interface column in Model Information 
Window.  
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4.3.3.2 Setting Communication Interface  
 

 To set it, double-click the grid under Parameter column for the Model you wish to set in 
the Model-Info Window. 

 

 
 

 Different interface shows different parameter setting window.  
 
1. GPIB interface:  

When using GPIB interface, generally it only needs to set the main GPIB Address. 
 

 
 
2. RS232 interface / RS485 interface: 

RS485 parameter setting window is shown below.  RS232 interface parameter setting 
window is same as RS485 except without Address parameter. 
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3. IO MAP/PC interface: 

This is an interface card that inserted in the PC.  Its parameter setting window is as 
below.  

 
 

4. I2C/RS232-I2C interface: 
This interface is able to edit the parameters of I2C device.  If card is used, the card no. 
has to be set, and if RS232 is used for connection, it is necessary to set the RS232 
parameters.  Since there are two normal expressions for I2C Slave Address, please set it 
follow the actual condition.  
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5. USB Interface: 
This interface can only be set when hardware is actually connected.  The system in the  
figure below will detect all serial numbers of this type of hardware on line at present and 
users has to specify the instrument serial number to be connected.  
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4.3.3.3 Setting if Active 
 
For the new instrument added in this program, you can set it not to be used during the test 
process. To set it, click the drop-down menu under the Active column in Model Information 
Window.  
 

 
 
 

4.3.3.4 Setting Channel Information 
 
When adding new instruments, the default channel information will be included.  The 
channel information contains Model Name, Channel Number, Module Name, Spec Index and 
if Active.  You need to complete the setting in Module Information Window described below.  
 
1. Instrument Model Number (Model Name) 

Display the instrument model number.  You cannot change the contents of this column.  
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2. Channel Number (CH) 
Display the channel number of the instrument.  You cannot change this column.  

3. Module name (Module Name) 
Display the instrument module name.  If this Model is unchangeable module, then it 
cannot be modified; on the other hand if the Model is changeable module, you can use 
the drop-down menu on the Module Information Window Module Name column to add 
or delete the module.  

 

 Note    
When you use the drop-down menu to add new Models, the program will automatically find 
and display the modules that fitted to the current status.   For example, in the figure below it 
dose not show Chroma 63107, because C63107 will occupy four channels while channel 3 
has only 2 channels available (channel 3 & channel 4). 
 

 
 
4. Spec Index 

Spec Index is used to set the logic number of the instrument’s channel during the 
system test process.  If the Spec Index of a channel is 1, it means the channel won’t be 
used in the test process.  Please be noted that for the Model in the same Device Type, 
the active Spec Index for Channel has to start from 1, and must be in sequential without 
duplication.  Or, an error message will prompt when saving the file.  To modify the 
Spec Index, you can use the drop-down menu on Spec Index column. 
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5.  If Active 
This is to specify if the Channel is active during the test process.  If yes, the value is 
True, otherwise the value is False.  Currently it will change following the Spec Index.  
When the Spec Index is –1 the value is False, which means inactive.  While the Spec 

Index is not –1 the value is True, which means active. 
 
 

4.3.4 Loading Connection Setting 
 
During the system test process you can set multi Electronic Loads for load connection 

(maximum 12 can be set in this system).  Before setting, you can use [View]→[Load 

Connection] function options, or point to Module Information Window and click the right 
mouse button to switch to the ‘Load Connection’ Window as Figure 4-2 shows. 
 

 
Figure 4-2  Load Connection Information Window 

 
A row stands for a load connection.  L1 to L12 are Load connected, and the ”*” filled in 
means empty.  R1 to R12 stand for the loading ratio of load connection, while Enable column 
shows if the load connection is enabled in the test process.  For example, if you set 4 load 
connections and the first one uses Spec Index for 1, 4, 6 and 8 connection, the loading ratios 
are 10%, 20%, 30% and 40%.  The second connection uses Spec Index for 2 and 3 connected; 
the loading ratios are 40% and 60% respectively.  The third and fourth connections of Spec 
Index are 5 and 7.  Figure 4-3 shows the result.  
 

 
Figure 4-3  Specifying Load Connection 
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To change Load Connection you can click the cell that is not “*”, and use Drag & Drop to 
change it.  After the load connection is changed, please remember to revise the loading ratio 
as well.  You can also set the Active column to specify if use the load connection set in the 
test process.  
 

 Note  

 Load Connection only affects the Spec Index of Electronic Load Device Type. 
 The loading sum of a load connection must be 100%. 
 Before setting a load connection, you need to set the Spec Index of Electronic Load first. 
 In a load connection, it will only display non –1 Spec Index, which means only active 

Channel can set the load connection.  
 If you don’t set the load connection (use default), the program will see every Spec Index 

as non –1 Channel and as an individual load connection.  The loading ratio of that Channel 
will be 100%. 

 After you modified the Load Spec Index, the program will react following the changes of 
Spec Index.  Thus we suggest you to set the load connection after you make sure all Spec 

Indexes of the Electronic Load are set. 
 If there is an empty row between two load connections, the program will move the load 

connection forward when entering next time.  
 As the Figure 4-4 shows below, the parenthesis in Spec. Index column means the 

connection between Logic Channel and sub logic Channel after connected.  Take 2 (1) as 
an example, the number inside the parenthesis stands for the logic Channel (Connection 
column value) after connected.  Thus 1(1) and 2(1) means the logic Channel 1 and logic 
Channel 2 are connected, but treated as logic Channel 1 is connected. 
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Figure 4-4  Load Module Specified Window 
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Figure 4-5  Load Connection Specified Window 
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5. Editing Test Program 

Test program (.prg) is composed of many test items with sequence. These test items include 
the system built-in items and user defined items.  SMPS ATS software divided the test items 
into 3 groups, [Pre Test], [UUT Test] and [Post Test].  Test items in [Pre Test] only execute 
when the test program runs in the execution environment the first time.  [Post Test] test items 
execute when unloading the test program in the execution environment.    As to [UUT Test] 
test items, they will be executed every time the test program runs.  There are three steps to 
create new test program.  
 
1. Follow the execution sequence to select the test items needed. 
2. Edit the execution flow of the selected test items, including 

 Pass Goto 
 Fail Goto 
 Fail Retry 
 Loop To 
 Loop Cycle 

3. Set the parameters for each test item. 
 
Below introduces the operation of test program editor window.  
 
 

5.1 Getting Started 

 
In SMPS ATS software main menu, select  Test Program  option in Basic group, the 
program will inquire you if you want to create a new test program, or open an existing test 
program.  
 

 
Figure 5-1  Create New or Open Dialog Box 
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5.1.1 Creating New Test Program 
 
If you select ‘Create new TP’ option, or click  Program Info…  in the test item editor, the 
dialog box of Figure 5-2 will show up.  It will ask you to enter the information for the new 
test program.  Here explains the major items.  
 

Date This item is in General tab indicating the date that the new test 
program is created.  

Time This item is in General tab indicating the time that the new test 
program is created. 

Report Format File This item is in Link tab to specify the report format file (*.rpf) 
used when printing report on-line. This file type is generated 
by ‘Report Editor’. 

Fixture Model This item is in Link tab to select the test fixture model name 
that used when performing the test or leave it blank.  When a 
model is specified, the GO/NOGO program will check if the 
test fixture model same as the one defined in the test program 
as well as the remaining usage count before testing a UUT. 

Total Load Numbers This item is in UUT Setup tab indicating the Load Channel 
number used in the test program. This number should not be 
larger than the Local Channels defined in ’Hardware 
Configuration’. 

Load Name This item is in UUT Setup tab indicating the show name of 
every Load Channel for each UUT.  

Reverse This item is in UUT Setup tab where checked means it is 
reversed and unchecked means it is not reversed.  

Comments This item is in General tab for entering the notations of the test 
program.  

UUT Type This item is in UUT Setup tab. It supports Single UUT / Multi 
Output and Multi UUT two types of test programs. All Test 
Result variables must be in Load Array data type when Multi 
UUT is set or the Test Item is unable to use.  The item of 
Identical Test Condition can also be selected to indicate that all 
test conditions are the same when Multi UUT is set, and all test 
conditions need to be entered respectively if it is not selected.  

Output Numbers This item is in UUT Setup tab and can only be used under 
Multi UUT.  This item is to set the number of outputs each 
UUT has to define the test program to be Multi UUT/Single 
Output or Multi UUT/Multi Output.  Be noted that the Output 
Numbers must be the factor smaller than Total Load Numbers. 
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Figure 5-2  Test Program Information Dialog Box 

 
In the test program editor, some columns are editable.  Double click the column you want to 
edit can enter into the editing mode.  After you finished entering the columns, click  OK  to 
enter the main menu for test program editing.  
 
 

5.1.2 Opening an Existing Test Program 
 

If you choose ‘Open existing TP’ option, or click [File] → [Open] from the main menu later, 
it will generate the dialog box as Figure 5-3.  It requests for the test program you want to open.  
You can enter the test program name (without .prg) directly or select it from the list box.  
 

Release For the test program not yet released, you can use the same 
filename to save.  For the released test program, it will request you 
to use another filename to save it.  You can use the ‘Management’ 
program to modify this column.  

Date and Time The last time the test program was modified.   
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After specified the test program you want to open, click  OK  or double-click the test program 
to enter the main menu and start editing.  
 

 
Figure 5-3 Open an Existing Test Program Dialog Box 

 
 

5.1.3 Main Menu 
 
The main menu contains two parts as shown in Figure 5-4.  The left part is test item editing 
area, where the name of the edited test program shows on its top.  If the program name has (*) 
in it, it indicates the program has been modified but not yet saved.  Click  Program Info…  
will show the Test Program Information Dialog Box as Figure 5-2.  There are three tabs, [Pre 
Test], [UUT Test] and [Post Test] under the test program. The test program execution will 
follow this sequence.  
 
The main menu right portion displays the test items list at the beginning, which has two tabs.  
The test items in System tab are included when system shipped by default and the test items 
in User tab are for you to edit.  
 
Besides test items list area, you can click Parameter on the toolbar to switch to the test 
parameter editor or click Vector to switch to vector editor, or click Global Pa.  to switch to 
global parameter editor.  The detail descriptions of global parameter editor are in the section 
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beneath.   
 

 
Figure 5-4  Test Program Editor Screen 

 
 

www.valuetronics.com



SMPS ATS 8000 User’s Manual 

 

 5-6  

5.2 Adding and Editing Test Items 

 

5.2.1 Adding Test Item to Test Program 
 
Test item is added by insertion.  First click the place you want to insert in the test item editor.  
Assuming it is Seq 3, double-click the test item list area for the test item you need or click  
Insert TI  on the toolbar after selecting the test item.  Then it will be added to Seq 3 and the 

original Seq 3 will be pushed to Seq 4, and so will the rest of the test items.  
 
 

5.2.2 Cutting, Copying, Pasting, Inserting and Deleting Test 

Items 
 
To facilitate users and avoid repetition work in editing test item, the program provides the 
note pad function for test item editor. 
 

Cut  Put the selected test item in the memory for next step use, and delete it. 
Copy  Put the selected test item in the memory for next step use, and keep it. 
Paste Add the selected test item to the place you want to insert it, and the 

original one will be pushed to next Seq. 
Delete  Delete the selected test item.  

 
You need to select an item before performing the above functions.  Click the Active column 
of the selected test item, the row will be reversed which means it is selected.   You can hold 
down the  Ctrl   or   Shift  key and drag for multiple selections.  If you want to delete the 
selected test item, click  Delete  on the toolbar and a dialog box will prompt to confirm if you 

want to delete it.  Click  Yes  to complete the deletion, or click  No  to cancel.  

 
If you want to insert the selected test item to a certain Seq, you need to click  Cut  or    Copy 

on the toolbar to memorize the selected test item.  Then click the Seq column where the test 
item will be inserted, and click  Paste on the toolbar.  Please be noted that the  Paste 

function key only enables when there is a test item in memory.   
 
 

5.2.3 Execution Flow for Editing Selected Test Item 
 
The test item editor is in table format.  Including the left header, there are 10 columns as 
explained below.  
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Seq Sequence number of test item.  Normally the test program executes 
following the number sequence from small to large.  

Active Check the item to determine if the test item will be executed.  
Test Item Name of the test item.  
Ext. Name Additional description.  
Label Specify a particular test item to be used with Pass Goto, Fail Goto and 

Loop To in order to control test item’s execution flow.  
Pass Goto This column can specify an existing label.  When running tests, if the 

test item passes, it will jump to the test item specified by a label in the 
column for continuous test.  If no label is specified, it will follow the 
Seq number to run the test.  

Fail Goto This column can specify an existing label.  When running tests, if a 
test item fails, it will jump to the test item specified by a label in the 
column for continuous test.  If no label is specified, it will follow the 
Seq number to run the test. 

Fail Retry This column can be filled in with an integer.   When running tests, the 
integer is the retest number will be done if a test item fails. This 
function’s priority is higher than Fail Goto, Pass Goto and Loop To. 
This means it will execute Fail Retry then Fail Goto, Pass Goto and 
Loop To.  

Loop To When running tests, if the test item column specified an existing label 
(must be specified before Seq), it will jump back to the test item 
specified by the label.  This becomes a loop.  For the number of times 
it loops should be defined in the Loop Cycle column.  If no label is 
specified, it will follow the Seq number to run the test.  

Loop Cycle The number of loop cycle (Note 5.1). 
Report Specify if it shows the test item on the report when the Report 

Generator is creating a report of the test data. 
 
Note 5.1:  If users wish to repeat the test items Seq 3 to Seq 5 for 5 times: 
  

Seq Test Item Label Loop To Loop Cycle 

:     

:     

3 TestItem A A   

:     

5 TestItem B  A 5 
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5.3 Setting Parameters for Test Items 

Test item parameters and their types are declared in the Test Item Editor.  The parameter 
types contain floating point, integer, character, string and percentage with two new 
parameters, Vector and Global, which have special editing screens.  We suggest users to enter 
these two screens for editing first, and then start setting the test item parameters after 
completing the edit.  
 
 

5.3.1 Editing Vector Entry 
 
When editing the test item parameters, you will find that you have to input some parameters 
repeatedly.  To save your time in doing such work, SMPS ATS software introduces a new 
parameter type – Vector.  In your test program, you only need to edit the entry data for 
different type Vectors, then any test item in the program that has declared the Vector type 
variable can choose an entry data in this type for use.  
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Figure 5-5  Vector and Test Program Diagram 

 

You can click [View]→[Vector Editor] from the main menu or  Vector  on the toolbar to 
switch to Vector Editor as Figure 5-6 shows.  The Vector Set Select drop-down menu can let 
you select the Vector type you want to edit.  There are four default Vectors, ‘Line In Vector’, 
‘Load Vector’, ‘Spec. Vector’ and ‘Ext. Meas. Vector’ when system ships.  Take ‘Line In 
Vector’ for example, the first row on the table is Vector Name, and the next is the two 
components, Voltage and Frequency in ‘Line In Vector’. 
 
If you need to add a new Vector entry, click the bitmap Append button on the top, a new 
Vector entry data will be added in the table.  Its default name is ”Line In Vector 1”, but you 
can modify it.  The name will be used when you edit the test parameter.  You can also modify 
the default values that are set before shipment for Voltage, Frequency and Range. 
 
To remind you again that in ‘Test Program Editor’ you can double-click the column to enter 
into the edit mode if the table column is editable.  
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The way to edit ‘Load Vector’ is similar to the above.  The major difference is that the Load 
Vector number (the loading of each channel) is set following the Total Load Numbers in 
Figure 5-2 Test Program Dialog Box. 
 
To delete a Vector entry, you can click the entry data to be removed and then click the bitmap 
Delete button on the top to delete it.  
 

 
Figure 5-6  Vector Editor Screen 

 
 

5.3.2 Editing Global Parameter 
 
To transfer parameters between two different test items, the parameters have to be set as 
Global Parameters.  The action is done by ‘Test Item Editor’, while the ’Test Program Editor’ 
is to define the initial value for these Global Parameters to use in test item. 
 

You can select [View]→[Global Pa. Editor] from the main menu or click  Global Pa.  on 
the toolbar to switch to Global Parameter Editor as Figure 5-7 shows.  The Global 

Parameter’s Name in the table with pale yellow backdrop is not editable.  The row number 
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changes following the Total Load Numbers set in Figure 5-2 Test Program Dialog Box.  For 
the Global Parameter belongs to Load you need to enter a value per Channel, and for those 
not belong to Load you only need to enter one value and the rest of the cells will turn gray.  
 

 
Figure 5-7  Global Parameter Editor Screen 

 
 

5.3.3 Editing Test Condition Parameter 
 

You can click [View]→[Parameter Editor] from the main menu or  Parameter  from the 
toolbar, or double-click the Test Item on the test item editor to switch the right pane to test 
parameter editor as shown in Figure 5-8.  The two panes on the screen are cross-referenced.  
Please click the test item you want to edit in ‘Test Item Editor’, or use the arrow keys on 
keyboard to move the cursor to the test item you want to edit.  Now the screen right pane will 
display all test item parameters in the test parameter editor.  
 
Show Name with pale yellow backdrop in the table is not editable. The Value column is 
where you input the parameter.  The value first displayed is default, which was defined in 
Test Item Editor.  Following are the three ways to input a parameter value. 
 

Edit Double-click the column you want to edit to enter into the editing 
mode.  

Combo Box Click the right downward arrow key from the combo box, a menu 
will show up for your selection.  
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Array Type For Load parameter, you need to input a value for every Channel 
if it is Array type.  Due to space restriction, the column is 
extended to above of the screen, and the column number is the 
Total Load Numbers defined in Figure 5-2 Test Program 

Information Dialog Box. Please click the column that displays 
‘Click here’; then point to the column above the screen and start 
editing the parameters.  

 
You can use Combo Box to edit Vector type parameter.  When you click the downward button 
in Combo Box, the menu shows the Vector Name you’ve edited previously for your 
selection.  
 
Some parameters will be compared with Test Result during the test process.  The editing type 
of these parameters is Edit.  If you double-click the parameter column to enter the edit mode 
and key in ‘*’, it means you request the execution environment to ignore the comparison 
action.  
 

 
Figure 5-8  Test Parameter Editor Screen 
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5.4 Printing Test Program 

Test Program Editor provides a simple print function to let you print out the edited test 
program.  The printout contents contain the following three parts.  
 
1. The contents in Figure 5-2 Test Program Information Dialog Box.  
2. Print out all names of test items following the order of [Pre Test], [UUT Test] and [Post 

Test].  
3. Print out all parameters of test items following the order of [Pre Test], [UUT Test] and 

[Post Test]. 
 

You can click [File]→[Print Preview] from the main menu to preview the contents you want 

to print, and click  Print (P)…  on the preview window for printing or click [File]→[Print] 
from the main menu to print it directly.  
 
 

5.5 Saving File 

To save the test program you’ve edited, you can click [File]→[Save] or [File]→[Save As] 

from the main menu.  The difference in-between is the former will use the filename you 
specified in Figure 5-9 dialog box, but it only prompts at the first save not afterwards.  The 
later assumes you want to use different filename to save the file, thus it displays the dialog 
box every time to request you specifying the filename.  
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Figure 5-9  Save As Dialog Box 

 
Please notice that for unreleased test programs you can use the same filename for saving, and 
for the released test programs, you will be asked to save them using other names.  You can 
decide if a test program can be released using the ‘Management’ program in system.  
 
 

5.6 Universal Test Program 

A number of customers expect the PowerPro III system software supports a Universal Test 
Program that can build in the test conditions for various Models with same test procedures. 
Users can specify different model for test according to the actual requirements.  The feature 
of it is that users can utilize Microsoft Access 2000 to edit the contents of Universal Test 
Program without using the Test Program Editor to edit the conditions and specifications.  
Thus it is mostly applied to the test of series models with same test items and procedures.  
The differences are the test conditions and specifications mentioned previously.  Yet, there 
are risks that PowerPro III system is unable to control this kind of test programs for releasing.  
Therefore, users must maintain the test programs of this type carefully to avoid any data 
inconsistency.  
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5.6.1 Entering the Universal Test Program Editing Mode 
 
Click [Edit]→[Option] from the main menu to open the dialog box as shown in Figure 5-10. 

 

 
Figure 5-10  Option Dialog Box 

 
Select Universal Test Program(.prg+.mdb) for Edit mode and the item for Test Program 
Editor to edit is changed to Universal Test Program. 
 
 

5.6.2 Adding a Universal Test Program 
 
Besides the .prg file, a .mdb file is also needed for a Universal Test Program.  Assuming there 
is  .mdb file in the 8000 system, it is suggested to follow the description below to have the 
Test Program Editor create it for you.  
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Click [File]→[New] the test program information dialog box will prompt as Figure 5-11 

shows.  Following is the description of the major items: 
 

UTP Database If a .mdb file is already exists in the 8000 system, choose 
Select an existing .mdb file, otherwise select Create a 

new .mdb file. The Test Program Editor will create a .mdb 
when saving the test program. 

Max Load Numbers It is for Test Program Editor to edit the Load Array variable. 
As the Channel number used for actual test is defined by the 
Models set in .mdb, so the inputted number of Load Channel 
here should be the maximum of all models.  

 

 
Figure 5-11  Universal Test Program Information Dialog Box 

 
Click  OK  to edit the test program by adding the desired test items. If the test conditions and 
specifications are not ready for .mdb file, it is suggested to save the file and exit the editor 
until they are ready.  
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As the selection in Figure 5-11 is to Create a new .mdb file so the Test Program Editor will 
ask the location for saving the .mdb.  It is suggested to save it to the directory of  \UTP\Db in 
case of misplacing.  Next use Microsoft Access 2000 to set the test conditions and 
specifications for the .mdb file.  The .mdb has two tables, [TestData] and [TestStep].  The 
columns with <> cannot be changed for the name attribute or deleted.  
 

 
Figure 5-12  [TestData] Table 

 
In the table of [TestData] each row is a model, and a <TestName> is given to each model for 
GO/NOGO execution.  The column of <LoadNum> is the Load Channel number of 
different model.  Starting from the right of <LoadName> column users are able to add new 
test conditions and specifications columns using the Entry Name as the column name for 
instance, Full Load, Low Load or Half Load. The Entry Name will appear in the drop down 
menu for selection when entering the Test Program Editor next time.  Each entry has its 
<DataType> including Float, Integer, Float(%), Short, Float[L], Integer[L] and Float(%)[L] 
7 types. The Test Program Editor will pick the Data Type matched Entry to add it to the drop 
down menu.  
 

 
Figure 5-13  TestStep Table 

 
In the table of [TestStep], starting from the right of <FieldA> column lists the test items for 
Universal Test Program.  They should be same as the one seen in Test Program Editor; 
however the execution number and sequence are defined according to the index of each 
TestName row.  
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Close the .mdb file will return to the parameter editing screen in Test Program Editor.  Once 
the Edit Type of a parameter is set to Import in Test Item Editor, the drop down menu will 
be applied to the parameter and the same Data Type entry will be selected in .mdb [TestData] 
table to be placed in the drop down menu.  Users can select one of the Entries from the 
column as the Full Load in Figure 5-12. 
 
 

5.7 Menu Description 

[File]→[New] : Add a new test program.  

[File]→[Open…] : Open an existing test program.  

[File]→[Save] : Save the test program you are editing.  For the new test 
program with filename ‘ Untitled’, it will prompt a 
‘Save As’ dialog box for you to specify the filename.  

[File]→[Save As…] : Save the edited test program to another filename.  

[File]→[Import Vector…] : Import the vector from other test program. 

[File]→[Export Vector To 

EXCEL…] 

: Export the vector edited in the test program to Excel. 

[File]→[Print All Seq.(s)…] : Display when the sequence list area is opened and print 
all of the edited sequences.  

[File]→[Print Current 

Selected Seq…]  

: Display when the test parameter editing area is opened 
and print the sequence the cursor is at only.  

[File]→[Print Preview…] : Preview the print result of edited test program.  

[File]→[Print Setup…] : Setup printer.  

[File]→[Print To File(*.txt)…] : Save the edited test program and its variable to txt file. 

[File]→[Exit] : End test program editing and return to SMPS ATS main 
menu.  

   

[Edit]→[Cut] : Memorize the selected test item for next step use and 
delete it.  

[Edit]→[Copy] : Memorize the selected test item for next step use and 
keep it. 

[Edit]→[Paste] : Insert the selected test item to the place you specified 
and the original test item will be pushed down to next 
Sequence. 

[Edit]→[Delete] : Delete all selected test items.  

[Edit]→[Insert Test Item] : Insert a test item from the test item list area at right to 
the left screen.  

[Edit]→[Option] : Prompt the Option dialog box. Users can select if the 
function of  “Add an initial value to each type of vector 
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when creating a new test program” to be enabled.  
Users can also set to use Standard or RD/Report mode 
when switching to the Execution Control for test 
program verification.  
It also sets to edit the standard test program or 
Universal Test Program. 

   

[View]→[Edit Toolbar] : Set if displays the toolbar.  

[View]→[Status Bar] : Set if displays the status bar.  

[View]→[Test Item List] : Switch to test item list area.  

[View]→[Parameter Editor] : Switch to test Parameter Editor.  

[View]→[Vector Editor] : Switch to Vector Editor.  

[View]→[Global Pa. Editor] : Switch to Global Parameter Editor.  

[View]→[Reset Client Size] : Return the main menu left and right proportion to 
default.  

   

[Help]→[Contents] : Display the table of contents for the online 
documentation.  

[Help]→[About TP Editor…] : Display the version information of this program.  
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6. Verifying Test Program and Test 

Item 
 
This chapter describes the verification environment of executing test programs (or test items.)  
It tells you how to use Execution Controller to perform detail tests on the edited test program 
(or test items.)  Detail test means the real-time test on the test program edited by TP Editor or 
on the test items edited by TI Editor.  During the test process it will not log the test program 
readings to database, but provide more control functions than GO/NOGO program for users 
to find the designing problems in the test program (or test item) more efficiently.  
 
 

6.1 Executing Control Program Main Menu 

In SMPS ATS software main menu, click  Test Program  in Basic group and select the test 
program you want to edit by clicking  Execution Control  button on toolbar, it will show the 
window in Figure 6-1.  Similarly you can also do it to a test item by clicking  Test Item  in 
Advance group, and select the test program you want to edit by clicking  Execution Control 

button, it will show the window in Figure 6-2. 
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Figure 6-1  Detail Test for Test Program Execution Control Screen 
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Figure 6-2  Detail Test for Test Item Execution Control Screen 

 
The Detail Test screen arrangement in Execution Control is same as GO/NOGO, please see 
Chapter 7 Executing Test Program (GO/NOGO).  In Detail Test, the test contents display area 
shows all variables of that page.  When edits in TI, the default is to expand various test 
commands; and the default displays up to test item when edits in TP.  Similarly you can 
double-click a test command to get the test command expansion function. 
 

 Program Display Area:  

Detail Test in the main menu has three more buttons than GO/NOGO program that 
provide you with set/cancel Break Point function. 

 
 Set Brk  Set the break point for test command. After setting the 

break point, an icon  (yellow line in the middle) will 
appear in the line to show the test command is set as break 
point.  

 Clear Brk  Clear the break point in the test command.  
 Clear all brks  Clear the break point in the test item.  
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You can point to the test command you want to set break point and click  Set Brk ,  
Clear Brk  or  Clear all brks  button.  Then you will see a small flag appears on the 
selected test command, which means you have set a break point.  You can also click the 
right mouse button on the test command to select  Set Brk ,  Clear Brk  and  Clear all 

brks  functions from the menu item for break point setting and canceling.  
 

 
Figure 6-3  Break Point Setting 

 
 Process Display Area: 

Same as GO/NOGO. 
 

 Test Contents Display Area:  

Detail Test in Test Contents Display Area is to display the various variable contents.   
 

Test Item Variables in Test Program  

Each variable’s presentation is same as GO/NOGO operation. 
 

Setting for Test Execution 

The Detail Test used with Test Program Editor is as below.  
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The Detail Test used with Test Item Editor is as below. 
 

 
 
 

6.2 Setting Test Execution Functions 

This section covers the functions of Execution Control.  Execution Control toolbar is the 
operating center to control the execution or stop operation of a test program.  
 
There are 8 buttons in the Detail Test toolbar when used with Test Program Editor,  Go(F10) , 

Stop(F2) ,  Single(F9) ,  Step ,  Report(F3) ,  Pause ,  Resume  ,  Save Data  as the figure 
shown below. 
 

www.valuetronics.com



SMPS ATS 8000 User’s Manual 

 

     6-6

 
 

The button’s function is same as GO/NOGO, while Detail Test has two more buttons,  Step 
and  Save Data .  
 

 Step Run the test command step by step. 
 Save Data Save the testing data in RD/Report Mode. 

 
The figure shown below is in the status of executing interruption at the break point or paused 
by user in execution flow.  

An icon (red line in the middle) will appear at the break point to show the current break 
point.  
 

Users can execute  Stop ,  Step  and  Resume  functions only. 

  

 
 
For the rest Detail Test functions, please see Chapter 7 Executing Test Program 

(GO/NOGO). 
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7. Executing Test Program 

(GO/NOGO) 
 
This chapter describes the environment for test program execution.  It explains how to use 
Execution Controller to perform GO/NOGO tests with the edited test programs.  During the 
test process it will pass the test result to On-line Report Generator for report output.  
Execution control program will log the test result to database for future statistics process 
control analysis and off-line report printing.  
 
 

7.1 Execution Control Main Menu 

Click  GO/NOGO  on the SMPS ATS main menu will activate the execution control program 
immediately.  Execution Control Program will activate ‘H/W Configuration’ to initialize all 
configured devices and display the result on the test process display area at lower left part of 
the window.  
 
Figure 7-1 is the execution control main menu.  
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Figure 7-1  Execution Control Main Menu 

 
Execution Control Program main menu is composed of three parts including Program 
Display Area, Process Display Area and Test Contents Display Area counterclockwise.  
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 Program Display Area:  

 

 
 

Display all test items of the opened test program in the table.  The row to be executed 
will display in darker color during execution. 

 
There are 6 columns in the table. The first column is the test item sequence in test 
program.  The second column is the name of test item.  The third column is the test item 
command.  The fourth column is the parameter for test command.  The fifth column 
displays the process control setting for test program, and the sixth column displays the 
result after running the test item.   

 
You will see some test items are in lighter color, this means they are set not to execute in 
the program.   

 
In GO/NOGO test, the default for opening a test program is to display test items instead 
of test commands.  You can click  By TestCmd to expand the test commands or click 
By TestItem  to hide them.  You can also double-click any line in the table to 
expand/hide the test commands of that test item.  
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Double-click  

 Process Display Area:  

 

Double-click this area can switch the display of execution process text and result.  You 
can see the execution process by the text displayed or the test result in graphic text. 
 

 

 

 

 

 

 Test Content Display Area:  

 

Test Content Display Area is composed of two parts.  The first part displays the general 
settings for executing test and the second part displays the defined variables in the test 
program after execution.  
 
Setting for Test Execution  
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Program Section 

 Test Program   : Name of the test program. 
 Model Name    : Model name of the test program. 

 

UUT Section 

 Serial No.    : UUT’s serial number. 
 Iterations     : The number for executing the test program.   

(Executed times/Total execution times) 
 Run (%)   : The percentage of the execution progress. 
 Date/Time    : The current system time. 
 Start Time   : The time to start test. 
 Elapsed Time   : The time spent for test. 

 

Fail Rate Section 

 UUT Counts    : The counts of tested UUT.  
 Fail Counts    : The counts of UUT that failed the test.  
 Fail Rate    : The ratio of UUT that failed the test.  

 
When the Fail Rate over the condition set, the green light next to Fail Rate will turn red 
and blink to remind you the UUT Fail Rate is over the limitation set.  

 
Set TestInfo Prompt the Setting dialog box when modifying the test.  The 

function of this button is same as selecting menu [Settings]→

[Test Information…]. 
Reset FailRate Recount the Fail Rate.  Reset the UUT Count to zero and 

recount the Fail Rate.  The function of this button is same as 
selecting menu [Settings]→[Reset FailRate]. 

 
Fixture Section 

 Fixture Model   : The fixture model name you selected in TP Editor. 
 Available Test Count  : The available test count of the current fixture. 

 
Test Item Variables in Test Program 

 

For the tested item, every setting and reading can be found in the ‘Variable Info’ in Test 
Content Display Area.  There are seven options in the screen for you to select the 
variable categories you want to look into and expand the array variable components.  
 

฀Expand Array-type variables Select this item to show every value in array 
when displaying array variables. Otherwise, it 
will show the variable name.  
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฀Pass Readings Select this item to display the readings of Test 
Result variables that meet the specifications.   

฀Fail Readings Select this item to display the readings of Test 
Result variables that do not meet the 
specifications. 

฀Temporary Select this item to display Temporary variables. 

฀Global Select this item to display Global variables. 

฀Test Condition Select this item to display Test Condition 
variables. 

฀TP Variables Select this item to display the variables in test 
program.  

 
The tested item are placed in the drop-down menu in the order of execution sequence.  
You can select a test item and observe the variable value.  
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The table in the middle will fill in with the test items specified in the drop-down menu 
and various variable definitions with values.  The table is divided into seven columns.  
The first column is the variable sequence.  The second column is the variable name.  The 
third column is the variable value. The fourth column is the specification judgment.  The 
fifth column is the variable type.  The sixth column is the test item sequence and the 
seventh column is the test item sequence in the test program.  

 
In the variable name column, if the variable is an array type variable and is not expanded, 
(L) will be added to the name indicating this is a Load number array variable.  If the 
variable name has (4), it means the array variable contains four components.  The digit 
indicates the array variable numbers.  If the variable is in expanded mode, then every 
variable name will add [n], where n means the number of array variable. 

 
In second column it presents the variable contents.  If the value is “…” and an array type 
variable, you can double-click the variable to expand or hide the array variable contents. 

 
The third column indicates if the Test Result variable meets the specification. 
The fourth column shows the variable type, which ”TR” is for Test Result variable, “TC” 
is for Test Condition variable, ”G” is for Global variable, “T” is for Temporary variable, 
“TC(V)” is for Vector Type Test Condition variable, “T(G)” is for Vector Type Global 
variable, and “TP(V)” is for Test Program’s Vector variable.  

 
Click the first column you will see the detail variable description.  
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7.2 Setting Test Execution Function Options 

This section covers the functions of execution control toolbar.  Execution control toolbar is 
the control center for test program execution or stop operation.  
 
The toolbar has four buttons available for use as following.   
 

 
 
Each function is described below.  
 
Click  Go(F10)  or F10 on the keyboard to start the test program from the first test item, and 
save the test result to data after execution.  If there is any PreTest type Test Item, it will 
execute it once at the first time.  You can also click ▼ next to Go(F10) to run the test items in 

[Pre Test] group.  
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Notice:  

 When you select serial number Auto Count, it will automatically add one.  
 When you select Barcode for count, if Enable prescan multi barcode is not selected 

click this button will prompt the window below to receive the UUT serial number 
scanned by Barcode Reader. 

 

 
 

 When you select Barcode for count, if Enable prescan multi barcode is selected click 
this button will prompt a window as shown below.  The Prescan Barcode area can let 
you prescan the UUT’s serial number using Barcode Reader during test.  The 
Processing Barcode area displays the UUT’s serial number that processed currently (it 
supports Multi-UUT only at present.)  
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 When the test program is running, it cannot end the execution control function.  If you 
want to end the execution control function, please click  Stop(F2)  button first to stop 
the test program execution, and then end the execution control function. 

 After the test program execution completed, all instruments will return to their initial 
state, in the mean time the AC Source will stop the power supply for UUT to exchange.  

 
Click  Stop(F2)  or F2 on the keyboard to end test execution, the result will not log to 
database.   
 
Notice:  All instruments will return to their initial state, and in the mean time, AC Source 

will stop the power supply for UUT to exchange. 
 
Click  Single(F9)  or F9 on the keyboard to start executing the specified test item.   
 
Before you click this button, you need to select the test item you want to execute in the test 
program display area.  You can use mouse to select the test items you need.  
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Notice:  Before using  Single(F9)  to execute a test item, you should run the test items 

associated with “Set up” to enable AC Source for power supply.  
 
Click  Report(F3)  or F3 on the keyboard to switch to report editor.  You can see the executed 
report display through report editor.  
 
The two buttons  Pause  and  Resume  do not work in GO/NOGO.   Pause  and  Resume 

are provided for Detail tests use. 
 
 

7.3 Operation Button Functions Description 

This section explains the function of execution menu for various environment setting.  
 
 

7.3.1 File Menu 
 

 
 

[File]→[Open Test Program] Mnemonic key (Ctrl + O). Use dialog box to open 
the edited test program.  

[File]→[Exit] Exit the program and back to SMPS ATS software 
main menu.  

 
Notice: File menu won’t be able to use if hardware initialization fails.  Please examine the 

hardware setting and restart the execution control program.  
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7.3.2 Run Menu 
 

 
 

[Run]→[Go] Alternative key, F10.  Executes test program from 
the first test item and save the tested result to 
database.  Its function is same as the  GO  button in 
execution control toolbar. 

[Run]→[Single] Alternative key, F11.  Executes the test item 
specified.  Its function is same as the  Single 

button in execution control toolbar.  

[Run]→[Step] For Detail test use. 

[Run]→[Stop] Alternative key, F2.  End the test, and the test 
result will not log to the database.  Its function is 
same as the  Stop  button in execution control 
toolbar.  

[Run]→[Pause] For Detail tests use. 

[Run]→[Resume] For Detail tests use.  

[Run]→[Go(pre_TestItems)] Run Pretest Test Items in test program. 

[Run]→[Go(post_TestItems)] Run Posttest Test Items in test program. 
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7.3.3 Settings Menu 
 

 
 

[Settings]→[Reset FailRate] Reset Fail Rate counts to zero and recount the Fail 
Rate. 

[Settings]→[Test Information..] For test information setting.  This menu will 
appear the window of Figure 7-2 for you to input 
test related conditions. 

 

 
Figure 7-2  Test Program Information Setting Window 
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Figure 7-3  Confirming UUT Serial No. in MultiUUT Mode Without Using I/O Card 

 
 Set Serial No.: You can select the UUT serial number to be Auto Count or scanned by 

Barcode Reader during test.  If you use Auto Count to add the serial numbers, you can 
also set the leading or suffix character and initial number as well as the length for serial 
number.  To check if the UUT is connected in MultiUUT mode without using I/O card, 
you can select the option and a dialog box will prompt for you to confirm the connection 
status and serial no. as Figure 7-3 shows.  When item 1 and 3 are selected the system will 
skip them automatically without generating a serial number as they are not connected to 
UUT. If you use Barcode Reader to scan the serial number, you can define barcode’s 
length for test execution check to prevent from entering wrong serial numbers during test.  
Test  button can set the barcode length by calculating it after scanned.  If you don’t want 
to check the barcode length during test, you can set it to zero. If the input serial number 
contains the message you don’t want to keep, you can select the option to extract the 
characters for actual serial number for storage.  

 Set Fail Rate 
You need to set Fail Rate limits from 0% to100 %, and the Fail Rate starts to count after 
how many UUTs are tested.  

 Test Related Information 
 

Customer Name Name of the customer. 
Order Number Purchased order number. 
LOT Number Number of the lot. 
Inspector Name of the inspector. 
Environment The environment temperature at test. 
Iterations UUT retest times. 
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Notice:  

 

 For different test programs, individual test program information can be set.  There is no 
need to set it again when changes it to different test program. 

 Test information is in INI file format and saved to PowerPro installation directory under 
\INI subdirectory.  

 

[Settings]→[Option..] Open Option setting screen 

 
If users use “OP” or the account without permission to access “Test Program” to log in, a 
dialog box will prompt to ask for User ID and password when modifying the data of selected 
option as Figure 7-4 shows.  If there is no permission to access the option for modification, it 
will prompt as Figure 7-5 shows.  
 

 
Figure 7-4  Inputting the User ID and Password with “Test Program” Access Permission 

 

 
Figure 7-5  Unable to Enter for Modification if No Access Permission 

 
Option setting has four tabs, which are explained beneath. 
 
Execution tab:  You can use this tab to set the environment for execution control.   The 

contents in the tab will be logged to the system.  After you finished the 
execution control and reactivate it, all settings on this tab will be loaded 
automatically from the system. 
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H/W Configuration:  
 

Configuration File: It sets the hardware configuration file for test. 
 

Auto Run: Select it if run the test program in automatic execution mode through I/O card 
or Chroma A-B Fixture.  It uses the configuration file set at present. 

 
Enable I/O Card for Multi-UUT Mode: Select the feature will output the single UUT 
test result (Pass/Fail) to the output Bit 9~16 on the first I/O card accordingly.  It does not 
support over 8 UUTs.  
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Configuration: 

 
Open Last Test Program File: It skips the open file dialog box and open the last executed 
test program directly.  You can use this setting to save your time when opening the same 
test program again. 

 
Show Process Text: Select this if you want to display more messages in the process 
display area during execution.  

 
Save Global Variables When Exiting: Select this if you want to save the Global variables 
set by the test program at exiting, so that they can be loaded when the test program enables 
next time.  

 
Stop On Failure: Select this if you want to stop testing when a test item fails to meet the 
spec.   

 
Executing ‘Post Test’ automatically when user press ‘stop’ button or error occurred: 
Select if running Post Test when the test program ends or when the user clicks Stop.  

 

Log Data: You can select if you want to log the test result to database for report and statistics 
analysis use.  
 
Program Type: 

Test Program (.prg): It specifies the file type to be executed to the system’s test program.  
Universal Test Program (.prg+.mdb): It specifies the file type to be executed to 
universal test program, see the chapter of Editing Test Program  for the details of its 
format. 

 
Report 1 tab: You can use this tab to set the report function provided by the execution 

environment.  All contents will be logged in the system.  When you 
finished the execution control and activate it again, all settings in this tab 
will be loaded by system automatically.  
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Report Generator: 
 

Send data to [Report Generator]: If selects, the report generator will enable 
automatically when executing ‘GO’.  

 
Prompting when UUT faile˷: If selects, the system will prompt a window as shown 

below to ask you if showing a report for it when the UUT test result is Fail.  
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The max. number of the last UUT data in [Report Generator]: Enter the maximum 
number of the last UUT data you want to see in the Report Generator.  

 
In Test Print: If selects, it will enable print function automatically to print the test result 
after the test program is completed. During the test program execution, if you wish to send 
the test data to printer through ‘Report Generator’, you can select ‘In Test Print’ and follow 
your needs to set the print condition.  Following explains the functions under ‘In Test 
Print’: 

 
 All Data : Print all test data. 
 Pass Program : Print only when the test program result is passed 
 Fail Program : Print only when the test program result is failed. 
 Pass Sequence : Only print the passed sequence. 
 Fail Sequence : Only print the failed sequence. 

 
In Test Print to File: If selects, it will enable print function automatically to print the test 
result to file and save it after the test program is completed. During the test program 
execution, you can convert the test data to .txt or .rtf file through ’Report Generator’.  To 
execution this function, you need to select ’In Test Print to File’ option and set the 
condition of the file to be saved.  The functions under ‘In Test Print to File’ are same as 
those under ‘In Test Print’ described above.  

 
Please be noted that ‘In Test Print’ or ‘In Test Print to File’ can only be selected when 
'Send data to [Report Generator]’ is selected in advance. 

 
In One File: All test results are saved to same file.  
File Name (.txt): It specifies the filename when running 'In Test Print to File’. 
By UUT SN: It saves the file according to the combination of UUT serial no. and date. 
Different UUT is saved to different file.  
Saving Path: It specifies the directory for placing the file generated by UUT SN. 

 
Report 2 tab: When Send data to [Report Generator] is selected in Report 1 tab, it is  

able to set if to save the report to Excel file when Report Generator is 
running.  
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Save as Excel file when on-line report is running: If selects, it will also save the report 
to Excel file when Report Generator is running.  
 
Station ID: It is part of the filename.  
 
File name: It provides two types of filename settings.  

     
Saving Path: It specifies the path for saving the Excel file. 
 
Excel Separator: There are three separators available for selection.  The column separator 
is necessary when outputting a common document to an Excel file. 
 
Filter out all the Excel Separators on the hardcopy report: In order to control the 
output to Excel report, the separators need to be considered when editing the report format 
file using Report Editor.  However, doing that may create a lot of separators in the 
original report and this option is to filter out the column separators.   
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Data Format tab:  You can use this tab to set the value display format in the running 
environment during execution process.  If setting the integral to 7, 
decimal to 4, you will see the value displays 4 digits (discard the rest 
except the number higher than 5 will be counted) for the decimal in the 
system at next execution.  Please be noted that the data format set only 
affects the display result.  The system still uses the original value for 
calculation internally.  
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7.3.4 Other Menus 
 

 
 

[View]→[Show Report Generator] Alternative key, F3.  Call report generator. 

[View]→[Expand TestItems] Select the test program if you want to expand 
the test items in test program display area.  

[View]→[Toolbar] Select it if you want to display the execution 
control toolbar. 

[View]→[Status Bar] Select it if you want to display the status bar. 

 

 
 

[Help]→[Contents] Display the table of contents for the online 
documentation. 

[Help]→[About ExeCtrl] Display the version information of this 
program. 

 

 

7.4 AutoRun Function 

GO/NOGO can be operated manually by operator for testing; in addition it supports the 
control function for automatic test.   Its action is to invoke the test program execution via I/O 
Card input signal and output the test result to I/O Card output signal.   The I/O Card usage is 
not exclusive for GO/NOGO; users can call the I/O Card test commands directly to drive all 
of the I/O Card signals.  Thus, you need to avoid those I/O signal bits when designing the Test 
Program. 
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7.4.1 Set I/O Card 
 
First, add a new I/O Card device in ‘H/W Configuration’ as Figure 7-6 shows below. 
 

 
Figure 7-6  Add an I/O Card 

 

Then, click [Settings]→[Option..] in ‘GO/NOGO’ to select AutoRun function. ‘GO/NOGO’ 
always uses the first card as the object for automatic control.  However, if I/O card is not set 
in ‘H/W Configuration’ or not initialized successfully, AutoRun option will be grayed out 
and is not available for selection.  
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Figure 7-7   AutoRun Function 

 
The input port Bit 1,2 and output port Bit 1,2,3 on the first card set in  ‘H/W Configuration’ 
are reserved for ‘GO/NOGO’ process control as the figure defined below.  
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Note: If the Enable I/O Card for Multi-UUT Mode is checked in Execution tab, the input 
port Bit 9~16 are reserved for UUT 1~UUT 8 for detecting the signal if UUT is connected, 
while the output port Bit 9 ~ 16 are reserved for UUT1 ~ UUT8 to display the test result.  
 
It will generate the output signal as shown in the above figure and two input signal to control 
the test progress during test. 
 
Output signal: In Test Bit, Pass Bit, Fail Bit. 
Input signal: Run Trigger, Stop Trigger. 
 
The test signal actions are described as below: 
 
(1) First check the Run Trigger input signal before the test starts.  The test starts if it is in 

TTL HIGH Level; otherwise the test will not start until this signal turns HIGH.  (Once 
the test starts, this signal is ignored until the UUT is done.   You need to wait for this 
signal to turn HIGH for testing the next UUT. 

(2) Once the test started, setting In Test Bit = TTL HIGH, Pass Bit = TTL LOW, and Fail 
Bit = TTL LOW means the test is in process. 

(3) After the test started, the test will stop if the Stop Trigger input signal is in TTL HIGH 
Level. 

(4) When the test finishes, setting In Test Bit = TTL LOW means the test is done and 
follows the test result that is PASS or FAIL to set Pass Bit or Fail Bit to TTL HIGH. 

(5) Return to (1) and restart. 
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You can use these signals to control the start of the test.  Also you can utilize the PASS/FAIL 
result for different management.  
 
 

7.5 Executing Universal Test Program 

To execute the Universal Test Program, first set the Program Type to Universal Test 

Program (.prg+.mdb) in the Execution tab of Options dialog box as shown below: 
 

 
 
When the dialog box of editing test program is opened again, the Universal Test Program is 
ready.  Select the desired Universal Test Program and click GO or press the function key F10 
will prompt the dialog box of Select Test Name and Input Serial No as follows: 
 

www.valuetronics.com



Executing Test Program (GO/NOGO) 

     7-27 

 
 
The Universal Test Program is mainly applicable for testing series models.  Customers can 
create different test conditions and specifications for various models in Access 2000.  Each of 
the Test Name in the List Box of the dialog box maps to a Model, and the Model related info 
is display at right.  First select a Test Name and key in the Serial No, then click  OK to 
execute it.  
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8. Editing Report Format 

8.1 Run Program 

 
In SMPS ATS software main menu, click [Report Editor] in the Basic group to run report 
editor.  The program will ask you to select the report format file you want to edit beforehand.  
You can select the file and click OK to start editing or click Cancel to let the program open a 
report format file for you.  
 

 
Figure 8-1  Open Report Format File Window 

 
After selecting the file, the screen will appear Report Editor main menu as Figure 8-2 shows. 
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Figure 8-2  Report Format Editing Screen 

 
 

8.2 Environment Description 

 
 The Caption on the main menu shows the string “Report Editor – ” with the edited report 

format filename (“Chroma” in the example).  If you click Cancel when selecting the 

report format file, it will be named “Untitled”.  Please use [Report]→[Save As] to save 

it to the filename you want after completing the editing.   
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 Test Item Category and Test Items are two drop-down menus on the main menu 
upper-left part.  The Test Item Category drop-down menu can let you select the types of 
“System-defined items” and “ User-defined items”.  The Test Items drop-down menu 
below allows you to select the test item you want to edit the report format for.  In 
addition, there is a Progress Bar under the drop-down menu to show the progress of 
reading the current report format of the test item.  

 

 
 

 The right portion of the main window is report format editing area.  You can edit the 
report output format you need in this editing area.  This means every test item’s report 
output format is displayed and edited separately.  The report format in editing will update 
immediately when you select different test item.  All of the characters can be used in the 
editing area except “#”.  This is because we use ”#” character to form a Pattern for 
variable such as “###.##”.  This variable Pattern has 3 integral and 2 decimal, and its 
length is 6-character long.  Please do not use over 80 ascii characters in a text line in the 
editing area to avoid any data lost at printing.  
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 The Available Variables window is located at the lower left area that lists the available 
variables for the current Test Item.  The displayed information contains Type, Call 

Name, Show Name and Data Type.  There are three variable types: TC (Test 
Condition), TR (Test Result) and GR (Global Variable).  For Data Types, they are 
Integer, Float, Percent, Long, String, Char, Integer [L], Float [L], Percent [L], Float [ ], 
Integer [ ] and Vector Type. 

 
 If the variable’s Data Type is Integer [L], Float [L] or Percent [L], this means it is a Load 

related variable.  The program will follow the current format and the load number to 
expand automatically when generates the report.  

 
 If the variable’s Data Type is Integer, Integer [L] or Integer [ ], you can set its display 

type to Integer, Binary and Hexadecimal when generates report. 
 

 
 

 The three drop-down menus on the lower main window set the variable length, and the 
format including the number for Integral and Decimal.  This information will be 
referred to form a Pattern variable when you add a variable to the editing area.  For 
example, the format 6.3 variable in the figure below will form the Pattern to become 
######.###, and its length is 10. 
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 Referenced Variables window at the window lower right lists the variables you selected 
for report format.  The variable information displayed contains Call Name, Data Type 

and Number Type. 
 

 If the Data Type of the variable you selected is Vector, the program will display a 
window for you to choose the variable as the figure shows below.  Similarly, if you 
choose the variable Data Type as Integer, Integer [L] or Integer [], you can set its display 
type when generates report.  Meanwhile, the Referenced Variables window displays the 
variable Call Name to be ” Vector Name / Variable Name”. 

 

 
 
 

8.3 Operating Instruction 

 

8.3.1 Adding Variable to Editing Area 
 
Select the test item you want to edit in the Test Item window before adding variables to 
editing area.  Then click a variable in the Available Variables window for variable length 
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setting.  If Number Type can be set, you can also set its display type.  Click Add >> button to 
add the variable at the pointer position where is between Referenced Variables window and 
editing area in the upper main window. (Variable in editing area is in Pattern format.) 
 

 
 
 

8.3.2 Deleting Variable from Editing Area 
 
If you only want to delete one variable, we suggest you to click the variable to delete in the 
Referenced Variables window, then click << Delete button.  The variable will be removed 
from the Referenced Variables window; in the mean time the mapped Pattern in editing area 
will be removed too.  
 
 

8.3.3 Checking the Variable in Editing Area 
 
The variable in editing area is displayed in Pattern format.  If you want to know this 
variable’s information, you can click the Pattern and its information will be reversed in 
Referenced Variables window and Available Variables window as Figure 8-2 shows.  
 
You can also drag the variables in the Referenced Variables window, the variable pattern in 
the editing area will be reversed and the Available Variables window will appear the 
information of current variable.  
 
 

8.3.4 Setting Font and Color for Editing Area 
 

You can use [View]→[Set Color] menu to set the text color in editing area.  In the window 
below, click the color area to display the color palette for selection.   You can save the current 
setting as default by clicking Set Default button. And you can click the button Use Default 

to retrieve the default color saved before.  
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Figure 8-3 Set the Font Color in Editing Area 

 

You can use [View]→[Set Font] menu to set the text font used in editing area.  From the 
following window you can select font, style and size.  We suggest you to use the font that 
every character is in the same size such as Courier New so that the report will display with 
alignment.  
 

 
Figure 8-4  Set the Font in Editing Area 

 
 

8.3.5 Hint Window 
 
In the Available Variables window, point to a variable and click, it will prompt a Hint 
Window.   Hint Window has further information than Available Variables window as the 

figure shown below.  You can use [View]→[Show Hint Window] menu to select whether to 
display the Hint Window or not.  
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Figure 8-5  The Hint Window 

 
 

8.3.6 Setting Character Set 
 

Click [View]→[Set Char Set] to set the character set used by the program.  
 

 
Figure 8-6 Setting the Character Set 
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8.3.7 About Report Editor 
 

Click [Help]→[About] to get the version information of this program.  
 

 
 
 

8.3.8 Menu Description 
 

[Report]→[New] Add a new report output format file. 

[Report]→[Open] Open an existing report format file (*.Rpf). 

[Report]→[Save] Save the report output format edited.  If you are 
editing a new report format (with Untitled 
filename), the dialog box ‘Save as…’ will appear 
for you to specify the filename you want to save 
as.  

[Report]→[Save As] Save the edited file to another filename. 

[Report]→[Exit] End the program and return to SMPS ATS 
software main menu.  

  

[View]→[Set Editing Area 

Color] 

Set the text color in editing area. 

[View]→[Set Font] Set the text font in editing area.  

[View]→[Set CharSet] Set the character set currently used. 

[View]→[Show Hint Window] Set if you want to show the Hint Window. 

  

[Help]→[Contents] Display the table of contents for the online 
documentation. 

[Help]→[About] Display the version information of this program. 
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9. Report Generator 

 

9.1 Program Execution 

There are two ways to execute report generator.  In Off-line mode, select Report Generator 

from the Basic group in SMPS ATS software main menu to run the program, and it will 
display the ‘Select data of tested UUTs from database’ window.  Or, in On-line mode, the 
report generator is called automatically by ‘Execution Control’ program during test and 
receives the test result from it. 
 

 
Figure 9-1  Window for Selecting the Data to be Printed 

 

www.valuetronics.com



SMPS ATS 8000 User’s Manual 

 

     9-2

The Report Generator main window appears after you selected the data for print in Off-line 
mode.  The program will follow the Test Program, Test Date and UUT Serial No. you 
selected with the Test Item Report Format File to generate the final report.  
 

 
Figure 9-2  Report Generator Main Window 

 
 

9.2 Environment 

The program main window has an editing window (also called data display area) that is used 
to display the final result from report generator.  It is read-only.  As the data display area can 
only show one UUT report, we can use Tab to separate each UUT report as Figure 9-3 shows.  
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Figure 9-3  A Tab Page in Data Display Area 

 
Tabs quantity equals to the UUT serial numbers selected in ‘Select data of tested UUTs from 
database’ window, which means a Tab per UUT.  The tab title is the UUT serial number.  To 
view a certain UUT report, you can click the serial number tab, and the program will 
automatically generate the report and display it on the data display area.  
 
The Indicator on the main window Status Bar shows the mode, Off-line or On-line, where the 
current program is in.  As it needs time to generate a report, the Progress Bar on Status Bar 
will activate to show you the progress when it switches to different tab for another report.  
 

 
Figure 9-4  Status Bar in Main Window 

 
 

9.3 Operation 

‘Execution Control’ automatically saves the UUT test result and data to database during 
testing in On-line mode so that you can generate the report Off-line at any time.  The program 
cannot generate reports if there is no previous test data as it uses the figures resulted from the 
test process in Off-line mode.  
 
 

9.3.1 ‘Select data of tested UUTs from database’ Window 
 
When running the program Off-line, the ‘Select data of tested UUTs from database’ window 

appears to let you select the report you wish to generate.  You can also click [File]→[Open 

Log Database] to open this window.  Following are the operations steps. 
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Figure 9-5  Selecting the Data to be Printed 

 
1. Use the Test Program’s drop-down menu on the window to select the test program for 

opening.  The program will follow your selection to update the window contents for 
Report Format File and Test Date.   

 
2. Latter you can use the Test Date drop-down menu to select the test date and select   All , 

Pass UUT Only  or  Fail UUT Only  and than click  Search UUT…  to filter out the 
desired UUT.  The Tested UUT Serial No window will show the S/N of tested UUT in 
that date.  In addition you can also use Report Format File drop-down menu ̇o select the 

matching report format.  
 
3. When selecting Serial No, you can use  Select All  or  Select None  button to select all 

of them or cancel the selection.  You can drag selections to select multiple UUTs 
continuously.  To select multiple UUTs discontinuously, you can hold down the  Ctrl 
key and then click the UUT serial numbers. 
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4. If you wish to know the sequence of a UUT, select a UUT serial no. and then click 
[Show] →[Sequences…] to prompt a window as Figure 9-6 shows.  The Sequences of 

the UUT list box will show the sequence of the UUT. 
 
5. After completed the setting, click OK button to let the program generate the report for 

you. 
 

 
Figure 9-6  Select Sequence Window  

 
 

9.3.2 Data Display Area 
 
Data display area contains two parts, Header Information and report contents of test item 
sequences.   Every UUT has a piece of Header Information while the numbers of test items 
are defined by the test program contents.  
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Figure 9-7  The Data Display Area 

 

 Note 

For the test item contents, users can use the  Report Editor  program in main menu for 
editing.  The readings can be retrieved from  GO/NOGO  test program.  Detail information 
please see Chapter 7 and 8 in this manual.  

 
 

9.3.3 Selecting/Switching UUT Report 
 
Click the UUT Serial No. tab, the program will automatically generate the UUT report and 
display it on the display data area.  
 
 

9.3.4 Header Information 
 
Header Information contains Test Program Name, Serial No., Model Name, Lot Number, 
Order Number, Inspector, Environment, Customer, Elapsed Time, Test Result and System 
Time.  You can click [Show] →[Header] to set if displaying the header information.  The 
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format of header information can be edited by the Report Editor program in the main menu, 
and the changed result will be saved in the report format file.  
 

 

Figure 9-8  The Header Info of UUT 

 
 

9.3.5 Setting Color for Editing Area 
 

You can use [View]→[Set Color] to set the color of editing area as the window shows in 
Figure 9-9.  Click the color area will show up a color window for you to select.   To save the 
selected color as default in Figure 9-9, click  Save As Default  button.  You can use  Load 

Default  at anytime to retrieve the default color set previously.  
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Figure 9-9  Setting the Text Color in Editing Area 

Description: 
 

Text Color for general text  
Background Color for background color. 
Variable / Spec Color for settings. 
Variable / Pass Color for pass reading. 
Variable / Fail Color for fail reading. 
Variable Not Found Cannot find the variable, replace it with “?”.  
Variable Format Error The digit number in variable format is not enough. Unable 

to display the correct value and replaced it with “X”.  
Seq. Ext. Name The first line on each test item’s report that contains Seq. 

No, Seq. Name, Seq. Ext. Name, Elapsed Time and etc. 
The Seq. Ext. Name is able to specify different color. 

 
 

9.3.6 Setting Font for Editing Area 
 

You can use [View]→[Set Font] to set the font for data display area as the window shows in 

Figure 9-10.  You can select the font, typeface and size, or use [View]→[Reset Font (Report 

Format File)] to return to the program default font.  
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Figure 9-10  Setting the Font in Data Display Area 

 

 Note 

The program default font is Courier New, standard typeface and size 11. 

 
 

9.3.7 Displaying /Printing Test Item 
 

You can use [Show]→[Sequences] to select displaying partial test sequences in the report.  
The ‘Selected Sequence’ window appears as Figure 9-11 shows. 
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Figure 9-11  Selecting Test Sequence 

 
You can use  Select All  or  Select None  button to select all of the selections or cancel them.  
To select multiple test sequences continuously, you can drag the selections.  For selecting 
multiple test sequences discontinuously, you can hold down the Ctrl key and click the UUT 
sequence desired.  
 

To display all test sequences, you can use [Show]→[All Sequences] to do it.  As for printing 

partial report, please select the test sequences and click [File]→[Print] to print.  
 
 

9.3.8 ‘Print Preview’ Function 
 

You can click [File]→[Print Preview] to enter the print preview mode.  Print preview 
displays the print simulation of data display area on screen. 
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Figure 9-12  Print Preview 

 

 Note 

Print Preview and Print use Courier New font.  It cannot be set by data display font setting.  

 
 

9.3.9 Printing 
 

To print the contents in data display area without preview, you can click [File]→[Print] to do 
it.  It will appear ‘Print’ window to let you select printer, print range and copies.  You can 
click  OK  to confirm the printing. 
 

www.valuetronics.com



SMPS ATS 8000 User’s Manual 

 

     9-12 

 
Figure 9-13  Print Window 

 
 

9.3.10 ‘Save/Save All’ Function 
 

You can use [File]→[Save Current Tab] to save the current report as text (TXT) file that can 
be opened by text editor, or as Rich Editor Format Files (RTF) that can be opened by 
Microsoft Word and WordPad.  The difference is RTF file can save the format information 
including font, color and size. 
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Figure 9-14  Save As Window 

 

You can click [File]→[Save All] to save all UUT reports.  The program will ask you for the 
filename that you want to save to one by one.  You can give it a new name or use the program 
default, which is UUT’s Serial No.  
 
 

9.3.11 Print Option 
 

You can click [File]→[Print Option] to set the print options including page break, header 
and page number display. 
 
When page break is selected, the program will check the remaining lines on each page 
automatically to see if there is enough space for printing another test item report. It avoids 
separating one test item report into two pages as possible.  Header is the text to be added on 
top of the page during printing.   This program limits 3 lines maximum for the header.  
 
When page number is selected, the program will add a page number in the middle at the 
bottom of the page during printing, for example, “P 1/20” indicates there are total 20 pages 
and this is page 1.  
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Figure 9-15  Print Option 

 
 

9.3.12 Mail Option 
 
The SMPS ATS system software can mail the report generated by Report Generator as an 

attachment to a specified e-mail box via the ‘MailGen’ program.  You can click [File]→ 

[Mail Option] to set when to send the mail and the recipient e-mail address. There are 3 tabs 
for this dialog box.  Here explains the contents of first tab. 
 

 
Figure 9-16  MailGen 
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The selections in this tab contain mail task enabling/disabling and list of test programs for 
sending. The test program will appear in the dialog box for selection when there is test data of 
a certain test program located in the installation directory of SMPS ATS system software. 
‘UUT Testing Date / Time’ column indicates the last UUT test time sent of this test program. 
The UUT tested from hence will be sent when the next sending time reaches.  You can 
modify the ‘UUT Testing Date / Time’ column in order to control what UUT to be sent.  
 
 

9.3.13 Menu  
 

[File]→[Open Log Database…] Set for the report to be opened and generated. 

[File]→[Save Current Tab…] Save the current UUT report. 

[File]→[Save All…] Save all UUT reports. 

[File]→[Print (“Courier New” 

Only…] 

Print directly.  

[File]→[Print Preview] Preview the print contents. 

[File]→[Print Setup…] Set the printer.  

[File]→[Print Option…] Define the print options including skip page, header 
and page number.  

[File]→[Exit] End the program and return to SMPS ATS software 
main menu. 

  

[View]→[Toolbar] Set if display the toolbar.  

[View]→[Status Bar] Set if show the status bar.  

[View]→[Set Font…] Set the font for data display area. 

[View]→[Reset Font (Report 

Format File)] 

Use default font.  

[View]→ [Set Color…] Set the color for data display area. 

  

[Show]→[Header] Set if display the Header Information. 

[Show]→[Pre and Post Test 

Sequences] 

Set if show the report contents of Pre and Post test 
items.  

[Show]→ Sequences Name and 

Pass / Fail] 

Set if show the test item name and its test result.  

[Show]→[Step No] Set if show the test step no.  

[Show]→[Sequences No] Set if show the sequence number of test items. 

[Show]→[TI Name] Set if show the test item name.  

[Show]→[Sequences Elapsed 

Time] 

Set if show the time spend for the execution of each 
test item. 

[Show]→[Separator] Set if show the separator line between two test 
items.  
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[Show]→[Separator Option…] Set the separator line style between two test items.  

[Show]→[Start Position of 

Sequences Pass / Fail…] 

Set the position of sequence pass and fail in the 
report. 

[Show]→[Sequences…] Set to display partial test sequences report. 

[Show]→[All Sequences] Set to display all test sequences report.  

  
[Options]→[Auto Mail…] Set when to send the mail and recipient’s mail 

address. 
[Options]→[Fail Reading…] Set if add an ID character before Fail Reading. 

  

[Help]→[Contents] Display the table of contents for the online 
documentation. 

[Help]→[About RptGen]  Display the version information of this program.  
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10. Managing System Available 

Resources 
 
In SMPS ATS software main menu select  Management  option from System group to enter 
Management function.  It has User (for management), Activity Log (for browsing), Test 
Program (for management), User Defined Test Item (for import/export), Instrument (for 
instrument and driver management), H/W Configuration (for instrument configuration file 
management), Log Data  (for test result data management), Fixture ID (for test fixture ID 
management) and Net Extension (for network related extension) nine sub-functions.  They 
are described as below.  
 
 

10.1 User – User Management Function 

Click ‘User’ tab to display User Management Function screen.  In this system user level is 
divided by functions of which can be used.  Every user has a user level.  If two users use the 
same Level Name, the functions these two users can use are the same.  
 
 

10.1.1 User Name 
 
In ‘User’ tab click User ID to show the defined user and its related information.  It has User 
Name, Level Name, Expired Date, Comment and Active columns.  
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Figure 10-1  User Management Window 

 

 
Figure 10-2  Add New User Dialog Box 

 
 Add  Add new user.  Input all information for the items listed above with user 

password.  
 Edit  Edit the selected user information.  
 Delete  Delete the selected user.  
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10.1.2 User Level 
 
In ‘User’ tab click User Level to show the defined user level with the functions of which can 
be used.  
 
It has two default user levels in the system.  They are op and supervisor.  The op user level 
will automatically go to GO/NOGO function, while the supervisor user level can use all 
functions when entering the system.  These two user levels cannot be deleted or modified.  
 

 
Figure 10-3  User Level Setting Window 

 
 Add  Add new user level.  The Edit and Delete button will change to Update 

and Cancel button after clicked this button.  Click Update button after 
completing input, or click Cancel button to cancel the action. 

 Edit  Edit the selected level. The Edit and Delete button will change to 
Update and Cancel button after clicked this button.  Click Update button 
after completing input, or click Cancel button to cancel the action. 

 Delete  Delete the selected user. 
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10.2 Activity Log – User Activity Log Browsing 

Function 
 
Click ‘Activity Log’ label to show the user activity log browsing function screen.  This 
system will log the time the user enters and exits SMPS ATS software as well as what 
functions the user had used. 
 

 
Figure 10-4  User Activity Log Browsing Window 

 
 Clear  Clear all user activities log. 
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10.3 Test Program – Test Program Management 

Function 
 
Click ‘Test Program’ label to show the test program management function screen.  It can 
change the release status of test programs, and import/export or delete them.  
 
The test programs exported and the report format data used will be logged in the files with tpx 
extension when exporting test programs.  The same file will be read when importing them.  
Through the import/export test program function, you can use different Chroma 8000 
systems for same test program without reediting the test program. 
  

 
Figure 10-5  Test Program Release Window 

 
Export  Export the selected test programs including the report format files used 

and the hardware configuration files. 
Import  Import test programs including the report format files used and the 

hardware configuration files. If same test program with same filename 
exists in the system, or the test program is not yet released, it will inquire 
for permission to overwrite. If there exists different released test 
programs in the system but in the same filename, import is not allowed. 

Delete  Delete the selected test programs.  
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10.4 User Defined Test Item – Import/Export 

Function 
 
Click the ‘User Defined Test Item’ label to show the user defined test item import/export 
function screen.  It can export, import or delete the user defined test items.  Through these 
functions you can use different Chroma 8000 systems for same user defined test item without 
reediting it. 
 
As Figure 10-6 shows below the tree directory at left is able to classify the test items.  Click 
the  “User Define Test Item” node  and select Add → New TI Group Item  to add a new 

group such as “A”.  Every group has three types of test items including UUT-Testʿ Pre-Test 

á˷ Post-Testˁ 

 

 
Figure 10-6  User Defined Test Item Import/Export Window  

 

As Figure 10-7 shows Rename and Delete will appear when right click the node to allow 
you to rename or delete the group. (Note: The group cannot be deleted when there is test item 
underneath.) 
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Figure 10-7  Delete or Rename the Group  

 
As Figure 10-8 shows Move to ‘xxx’ will appear when right click the test item.  It is able to 
move the test item to other group where xxx is the group name for instance “A” in the above 
example.  
 
When the test item exports it will be logged in a file with the extension .tix and this type of 
file will be read when importing test items.  
 

 
Figure 10-8  Move the Test Item to Different Group  

 

Active Enable/disable the selected test item.  Once the test item is disabled, ‘Test 
Program Editor’ cannot access this test item.  

Export  Export the selected test items.  
Import  Import test items.  If the system already has the test item with same name, it 

will inquire if you want to change the name.  
Delete  Delete the selected test items.  Notice: Once you delete the test item, all 

test programs that used this test item cannot edit it in ‘Test Program 
Editor’. 
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10.5 Instrument – Instrument and Driver 

Management Function 
 
Click ‘Instrument’ label to show the instrument and driver management function screen. 
When the instrument is needed but not in the screen, please contact the dealer or Chroma to 
see if the instrument driver is available.  When the instrument and its driver are exported, 
they will be saved to a file with inx extension.  The same file type will be read when 
importing.  
 

 
Figure 10-9  Instrument and Other Driver Program Management Window 

 
Export  Export the selected instruments and its driver programs.  
Import  Import instruments and its driver programs. If the system already has 

the instrument with same name, it will inquire if you want to overwrite. 
Delete  Delete the selected instruments.  
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10.6 H/W Configuration – Configuration File 

Management Function  
 
Click  ‘H/W Configuration File’ tab to display the instrument hardware configuration file 
management function screen.  You can export, import or delete the hardware configuration 
file using this function.  
 
When using the export function, it will log the selected hardware configuration files to a file 
with hwx extension, and this type of file will be read when importing the hardware 
configuration file. 
 

 
Figure 10-10  Hardware Configuration File Management Window 

 
 Export  Export the selected hardware configuration files.  
 Import  Import the hardware configuration files.  After selected the hwx 

filename extension, the program will list all hardware configuration files 
in one window for you to select.  If there is duplicate hardware 
configuration file, the system will ask you if you want to change the 
filename.  

 Delete  Delete the selected hardware configuration files.  
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10.7 Log Data - Test Result Data Management 

Function 
 
Click ‘Log Data’ tab to display the screen for test result data management.  With this function 
you can export, import or delete the test result data.  You can use the test result data to do 
report printing and statistic analysis in different Chroma 8000 systems via the export and 
import function. 
 
When exporting the test data, the test result data is logged in a file with filename extension 
lgx.  This file will be read when importing the test result data.  
 

 
Figure 10-11  Log Data Window 

 
 Export  Export the selected test result data.  
 Import  Import the test result data.  
 Delete  Delete the selected test result data.  
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10.8 Fixture ID – Fixture Model Management 

Click ‘Fixture ID’ to show the Fixture Model management screen where can export, import 
or delete the fixture model. Only the models list in this screen can be utilized in test program 
to work with Fixture ID Card for status check.   For details see Fixture ID Card User’s 
Manual. 
 
The export function will log the selected models to a file with extension name fix, and this 
file is read during import. Once the Fixture ID Editor created a new model ID for fixture, first 
export it to a fix file using the Export utility in Fixture ID Editor and then it can be imported 
to the system. 
 

 
Figure 10-12  Fixture ID Management 

 
 Export  Export the selected models.  
 Import  Import the suitable fixture models. When the extension filename fix is 

selected, the program will list all models in one window for selection.  
 Delete  Delete the selected models.  
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10.9 Net Extension – Network Related Extension 

Function 
 
Click ‘Net Extension’ tab to display the screen for network related extension function.  It has 
Remote TP function only at present of which can export the test programs to a specified 
remote directory, and allow different Chroma 8000 systems to open them directly in 
GO/NOGO program for test, thus the test programs can be centralized for management. 
 

 
Figure 10-13  Net Extension Window 

 
 Setting…  To enable/disable the Remote TP function and set the directory where 

Remote TP is in.  All Chroma 8000 systems that use Remote TP have to 
enable Remote TP and set correct director path.  The enabled Remote 
TP affects GO/NOGO only so that it can only open the test program of 
Remote TP without change the rest of the function in Chroma 8000 
system. 

 Upload  Export the selected test program in Chroma 8000 system to remote.  

 Download  Import the selected test program from remote to Chroma 8000 system. 

 Delete  Delete the selected test program in remote.  
 
Local H/W Config:  If a hardware configuration file required by Chroma 8000 system is 
different from the Remote TP, the Local hardware configuration can be selected in the Local 
H/W Config column at the right of the table.  
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11. Editing User Defined Test Item 

(Option) 
 
Test Item Editor is the tool developed specially for SMPS ATS software testers. It lets testers 
to define the test process flow based on their needs and to name it as well as to integrate it to 
SMPS ATS software.  The test item you added is called User Defined Test Item to 
differentiate from the default test item set in SMPS ATS software.  
 
Test items are divided into six types.  System Default and User Defined are the two major 
types.  Each major one has three groups, which are Pre Test, UUT Test and Post Test.  
Following explains the timing for using these three groups.  

 
Group Name Description 

Pre Test Before executing the test program for the first time in the running 
environment, the test item in this group will be executed by test 
program.  

UUT Test Every time the test program executes in the running environment, the 
test item in this group will be executed by test program.  

Post Test Before the running environment exits, the test item in this group will 
be executed by test program. 

 
Below describes the detail of each type.  
 

Type 
System / User 

Defined 

Pre Test/ UUT Test 

/Post Test 
Description 

1 System Pre Test System default for Pre Test 

2 System UUT Test System default for UUT Test 

3 System Post Test System default for Post Test 

4 User Defined Pre Test  User Defined for Pre Test 

5 User Defined UUT Test User Defined for UUT Test 

6 User Defined Post Test User Defined for Post Test 

 
Test Item editor contains five tabs.  The detail descriptions are as below.  
 

Tab Name Description 

Test Procedure This tab lists the Test Commands in the Test Item and displays 
them line by line as writing BASIC language.  It calls function 
line by line and runs jump function to reach the test purpose.  
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Condition This tab lists the conditions or specification values the Test Item 
will use and displays them line by line.  When you edit the Test 
Command in Test Procedure tabʿ you can fill in the Call Name to 

the Parameters column in Test Procedure tab. This tab’s contents 
will appear in the parameter window when you edit a Test Item 
parameter in Test Program.  

Result This tab lists the results that the Test Item will use and displays 
them line by line.  When you edit the Test Command in Test 
Procedure tab, you can fill in the Call Name to the Parameters 
column in Test Procedure tab. 

Temporary  This tab lists the temporary variables the Test Item will use and 
displays them line by line.  When you edit the Test Command in 
Test Procedure tabʿ you can fill in the Call Name to the 

Parameters column in Test Procedure tab. 
Global This tab lists the global variables the Test Item will use and 

displays them line by line.  When you edit the Test Command in 
Test Procedure tabʿ you can fill in the Call Name to the 

Parameters column in Test Procedure tab. 
 
A test item is composed of the above five items.  Similar to the program language procedure 
or function, the test procedure maps to the procedure flow, which has variables.  These 
variables are inducted to four types.  The first type is Test Condition, which is also called 
input variable to log the parameter value and specification you reserved.  This type Test 
Condition appears on the test item editor screen in Chapter 1.  The second type is Test Result, 
which is used to log the last test result.  The third type is Temporary Variable to log the 
temporary value in calculation process.  The last type is Global Variable that enables test item 
to pass some values to other test items.  
 
Please be noted that the editing environment must request the declared variable Call Name is 
unique in a test item.  In addition please do not use special symbols such as comma “,”, 
semicolon “;”, star ”*”, backslash ”\” or number ”#” as part of Call Name.  For 
example, ”Volt,age” may cause problem when creating the statistic report.  
  
Figure 11-1 uses C language program Function to explain Test Item and its relationship 
between variable declarations and flow control. 
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Figure 11-1  Mappings between Test Item, Test Program, and C language 
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11.1 How to Create a Test Item 

Click  Test Item  button in SMPS ATS software main menu to enter the Test Item Editor 

main menu.  It will prompt the dialog box as Figure 11-2 shows.  You can select [New Test 
Item] to create a new item or select [Open Test Item] to open an existing one.  
 

 
Figure 11-2  New/Open Test Item 

 
Of course these two methods for creating new or modifying existing test item are also 
provided in Test Item Editor function menu.  
 

1. You can select [Test Item]→[Open] to open an existing test item for modification and 
save it as new one.  

2. You can select [Test Item]→[New] to edit the contents of Conditionʿ Resultʿ Temporary 

̂̅ Global.  Then create the Test Procedure line by line.  

 
Editing environment will automatically add a variable with the Call Name of ”TestResult” in 
Result tab when you create a new set of test items.  This variable is required for every test 
item; however you are unable to see this variable on the screen.  So you need to be careful not 
to use ”TestResult” as variable Call Name.  
 
 

11.2 How to Edit a Test Item 

Select [Test Item]→[Open] will prompt the dialog box as Figure 11-3 shows.  If the Test 
Item selected is System type, then the editor will ask you to input a new name to save it as 
new because the system default test item is not allowed for modification.  If the selected type 
of Test Item is User, different “Test Item Group” can be chosen.  The group classification is 
set in Management and the test items without classification is placed in “Unclassified” by 
default. 
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Figure 11-3  Open Test Item 

 

If you select [Test Item]→[New] it will prompt the dialog box as Figure 11-4 shows.  Editor 
will automatically categorize the test item to User (user defined) before saving it.  
 

 
Figure 11-4  New Test Item 
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Click [Test Item]→[Save As] a dialog box will appear as Figure 11-5 shows and users can 

click  Security to set security as Figure 11-6 shows.  Users can specify Complete or Read 

only protection.  Users are unable to open the test item if he or she has no password when in 
Complete protection mode.  Users can open the test item without password when in Read 
only protection mode; however for the encrypted test items editing and save are still not 
allowed and are unable to be processed line by line during program execution.  
 

 
Figure 11-5  Saving Test Item  

 

 
Figure 11-6  Setting Security Password 

 
The [Edit] item in the main menu has [Cut], [Copy], Paste], [Insert] and [Delete] five 
actions.  These actions can be performed at the row where the pointer is in the active tab (see 
Figure 11-7).  The editing functions are different from each column in the tab.  Following 
explains them by tab.  
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Figure 11-7  Editing by Row 

 
 

11.2.1 Data Type 
 
In order to meet the test requirement of your test program for inputting different settings and 
saving the measurement values from other instruments, this system software supports the 
data type listed below, except Vector.  Following is the detail description of each data type.  
 

Type Application Description 

Float TC/TR/TT/GV Floating point. 

Integer TC/TR/TT/GV Integral. 

Float% TC/TR/TT/GV Floating point. When the report generator appears, it 
will automatically add a % symbol to this variable.  

Short TC/TR/TT/GV Short integral. 

String TC/TR/TT/GV Text string without fixed length. 

Byte TC/TR/TT/GV Single byte. 

Float[L] TC/TR/TT/GV Float Array is 32.  L is the maximum UUT output 
numbers supported, which are 32 in this system.  
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Integer[L] TC/TR/TT/GV Integer Array is 32.  L is the maximum UUT output 
numbers supported, which are 32 in this system. 

Float%[L] TC/TR/TT/GV Float% Array is 32.  L is the maximum UUT output 
numbers supported, which are 32 in this system. 

HexString TC/TR/TT/GV Hexadecimal string from left to right maps to the 
low bit to high bit in memory.  

Float[ ] TC/TR/TT/GV Float Array without fixed size. 

Integer[ ] TC/TT/GV Integer Array without fixed size. 

LineInVector TC/TT/GV Vector type.  This type consists of two Member 
Data.  
1. Voltage: Float 
2. Frequency: Float 

LoadVector TC/TT/GV Vector type.  This type consists of one Member 
Data.  
1. Loading Value: Float[L] 

SpecVector TC/TT/GV Vector type.  This type consists of two Member 
Data.  
1. Minimum Spec: Float[L] 
2. Maximum Spec: Float[L] 

ExtMeasVector TC/TT/GV Vector type.  This type consists of three Member 
Data. 
1. Function Type: Integer[L] 
2. Ext. Meas. Minimum Spec: Float[L] 
3. Ext. Meas. Maximum Spec: Float[L] 

Chart TR/TT Data structure for DSO graphic file. 

Picture TR/TT Data structure for saving DSO result. 

 
Note:  Application description 

TC→ Test Condition tab variable 

TR→ Test Result tab variable 

TT→ Temporary tab variable 

GV→ Global tab variable 

 
 

11.2.2 Editing Test Procedure 
 
Test Procedure tab lists the test item execution flow.  Click the Test Command the screen 
right window will appear the test commands in tree structure by command type as Figure 
11-8 shows.  If you need the parameter contents for test command, click the Parameters 
column on the test command you want to edit and two windows will appear at the right of the 
screen.  The upper window displays the parameter contents, while the lower window is the 
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area for variable or constant.  See Figure 11-23.  For the jump condition test commands like 
“Goto” and “If_Then”, you can fill in the label name in the Label column.  
 

 
Figure 11-8  Select Test Command Screen 

 
The right window is divided into two panes in Figure 11-9.  The upper one shows the contents 
of the parameter activated by the pointer in the left window and it will follow the function 
prototype defined in Test Command column (please see Figure 11-12) to list the variable 
mapping position.  The lower pane provides you a way to select parameter.  The program will 
fill in the parameters automatically to the reversed area in the upper pane.  Parameter Type 
group in the lower pane can define the parameters you need from Condition and Result tabs.  
The system can help you filter out the same type parameters.  
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Figure 11-9  Select Input Parameter 

 
If the parameter type you selected is Vector then the screen will prompt a window as Figure 
11-10 to let you further define its entry data.  
 

 
Figure 11-10  Vector Type Entry List Box 

 
Following table explains the way to edit each column. 
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Column Description How to edit 

Active Enable or disable the Test 
Command of this row 

Click to select/ unselect it.  

Label List the label of every Test 
Command.  It can be used as the 
parameter in the jump condition 
test command such as  “If_Then”. 

Double-click it and enter the 
data from keyboard.  

Test Command Power Supply ATS provides a 
bunch of test command sets and 
this column shows one of them.  

Click it the screen will show 
the test command set to include 
all of them in Figure 11-8.  If 
click the right mouse button, 
the screen will show a message 
dialog box as Figure 11-11 to 
display the Test Command 
help.  

Parameters Test Command parameter.  As the 
parameter number is different 
from every Test Command, thus 
the parameters are separated 
by ”,”. 

Double-click will appear two 
windows as in Figure 11-9.  
The upper-right window lists 
parameter’s position, while the 
lower one has parameter 
attribute, which is up to the 
Test Command’s parameter.  
When you select a certain 
parameter attribute, a list box 
of related parameter will show 
up for selection.  

Description Explanation text. Double-click it and enter the 
data from keyboard.  

 

 
Figure 11-11  Test Command Help Window 
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11.2.3 Declaring Test Condition 
 
Condition tab lists input parameter or specifications of the Test Item.  The way to edit the 
columns in this tab is different.   You can double-click it and enter the data from keyboard or 
edit the dialog box prompted or select the condition from the drop-down list box by clicking 
the mouse. 
 

 
Figure 11-12  Test Condition Parameter Editing Screen 

 
Following table explains the way to edit the columns in condition tab.  
 

Column Description How to edit 

Show Name Parameter name.  Used for Help. Double-click it and enter the data 
from keyboard.  

Call Name Parameter name.  The parameters 
in the same test item should be 
unique when using in running 
environment.  

Double-click it and enter the data 
from keyboard.  
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Data Type Parameter’s data type. After clicked for selection, a 
drop-down ListBox of all data types 
like float and integer, etc. will show 
up. 

Edit Type Parameter’s edit type. This type 
will affect the test program editing 
function screen if in EditBox.  If 
in ComboList, then it lists the 
items such as CC, CR and CV.  

After clicked for selection, a 
drop-down ListBox of EditBox and 
ComboList edit type will show up.  

Min. The minimum value of the 
parameter. 

Same as “Default” column 
description. 

Max. The maximum value of the 
parameter. 

Same as “Default” column 
description. 

Default The default value of the 
parameter.  

Double-click it and enter the data 
from keyboard.  If this parameter 
maps to the Load Array data type, 
the window as Figure 11-15 will 
prompt.  If the data type is Vector, it 
will show the window as Figure 
11-16. 

Format The parameter format displays in 
test program editing function.  

Click to prompt a drop-down list 
box.  

Enumerative 
Items 

If ”Edit Type” column is 
ComboList, it will enumerate the 
item values and display strings 
that defined in the list box. 

Double-click it enables you to edit 
Figure 11-17 for enumerated data 
editing.  

 
Notice: If you don’t want to specify the value for Min. and Max. columns, you can set them  

    to Don’t Care (*) in ‘Test Program Editor’.  
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Figure 11-13  General Editing Type 
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Figure 11-14 List Box Selection Type 
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Figure 11-15  Array Type Value Editing Screen 

 

 
Figure 11-16  Vector Type Value Editing Type 
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Figure 11-17  Enter Enumerate Entry 

 
 

11.2.4 Declaring Test Result 
 
Result tab lists the variables that used by test commands to save the measurement readings in 
the test item.  Besides the editing methods described in the previous Condition tab, you can 
specify the specification you want to compare the “Min. Spec.” and “Max. Spec.” columns 
for every variable as Figure 11-19 shows. 
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Figure 11-18  Test Result Variable Editing Screen 

 
Following table explains the way to edit the columns in Result tab.  
 

Column Description How to edit 

Show 
Name 

Parameter name.  Used for Help. Double-click and enter the data 
from keyboard.  

Call Name Parameter name.  The parameter in the 
same test item should be unique when 
using in running environment.  

Double-click and enter the data 
from keyboard.  

Data Type Parameter’s data type. After clicked for selection, a 
drop-down ListBox of all data 
types like Float and Integer, etc. 
will show up. 

Min-Spec Minimum specification for parameter.  
When executing a row of parameters 
measured from instrument, they will be 
compared with Min-Spec for analysis. 

After clicked for selection, a 
drop-down ListBox of all same 
data type Call Name in Condition 
tab will show up. 
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Max-Spec Maximum specification for parameter.  
When executing a row of parameters 
measured from instrument, they will 
be compared with Max-Spec for 
analysis. 

After clicked for selection, a 
drop-down ListBox of all same 
data type Call Name in Condition 
tab will show up. 

 

 
Figure 11-19  Test Specification Setting 

 
 

11.2.5 Declaring Temporary Variable 
 
Temporary tab lists the temporary variables that will be used by Test Item.  The editing 
methods of each column in this tab are the same as editing the Condition tab.  
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Figure 11-20  Temporary Variable Editing Screen 

 
 

11.2.6 Declaring Global Variable 
 
Global lists the global variables that will be used by Test Item.  Different from Condition, 

Result, and Temporaryʿ Global variable can be adopted by any of the six test item categories.  

The test items in the same category can access the variables declared here.  If you want to 
access the global variable declared in different categories, you can specify it using the 
Linkage column.  First enter the global variable of other category in the Call Name column, 
and select “External” in Linkage.  
 
Except Linkage column, the editing methods for the rest columns are the same as editing in 
Condition tab.  
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Figure 11-21  Global Variable Editing Screen 

 
 

11.3 Auxiliary Functions 

Under [Test Item] you will see [Over All Check], [Compile], [Redundant Var. Check], 
[Test Command Check], [Local Var. Rename…], [Parameter Find…] and  [Find Next] 
options.  Their functions are explained as below.  
 
 

11.3.1 Over All Check 
 
Though every test item will check the variable type before saving, you can execute the 
function to check variable type anytime during editing.  
 
 

11.3.2 Compile 
 
To compile is to build up an internal table index to expedite the test program (.prg) execution 
speed.  Similarly you can run the variable type check function anytime during editing.  
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11.3.3 Redundant Var. Check 
 
You can use this function to check which parameter has been used and which has never been 
used.  
 
 

11.3.4 Test Command Check 
 
You can use this function to check what test command in Test Item is different from the one 
defined in database.  
 
 

11.3.5 Local Var. Rename… 
 

You can use this function to rename the parameter.  After you selected [Utility]→[Local Var. 

Rename…] option, the screen will prompt the dialog box below.  Once you clicked  OK , all 

related areas will be renamed to the new parameter name.  
 

 
Figure 11-22  Local Variable Renaming Dialog Box 

 

 

11.3.6 Parameter Find… 
 
When your test item process gets more and more complicate, this function provides you a 

rapid way to find a parameter location in ‘Test Procedure’.    After you selected [Utility] → 

[Parameter Find…] option, the screen will prompt a dialog box as Figure 11-23.  Once  OK 

is clicked, the pointer will stop at the Label column in ‘Test Procedure’ tab where the 
parameter is found.  Notice: The Up and Down directions in Figure 11-23 are to define the 
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searching direction from the pointer position in ‘Test Procedure’.  Thus please make sure the 
pointer position in ‘Test Procedure’ before open the dialog box.  

 

 
Figure 11-23  Parameter Find Dialog Box 

 

Figure 11-24 and Figure 11-25 shows the pointer change in screen before and after finding.  
 

 
Figure 11-24  Before Finding the Parameter 

 

www.valuetronics.com



SMPS ATS 8000 User’s Manual 

 

     11-24 

 
Figure 11-25  After Finding the Parameter 

 
 

11.3.7 Find Next 
 
You can use this function to continue finding the next parameter.  
 
 

11.3.8 Option… 
 
This function supplies a dialog box for you to set the parameter need for Detail Test when you 
switch to execution environment.   Please see the descriptions in section 11.6. 
 
 

11.4 Printing Page Contents 

Click [Test Item] → [Print] will display the print dialog box.  Click OK to print the current 
tab contents in text format from printer.  
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11.5 How to Run Instant Test 

 
If the computer where the test item editor is in connects to Chroma 8000, you can test the test 
items you edit directly in the current editing environment without compiling it to an 
executable program.  
 

You can select [Utility] → [Option…] function to set the UUT basic parameter as Figure 

11-26 shows, then click Execution Control button on the toolbar for running tests as Figure 

11-27 shows. 

 
Figure 11-26  Running Environment Setting Dialog Box 

 
Before you switch to running environment for test execution, please make sure that the 
variables declared in Default column are correctly input in Test Condition and Global tabs as 
the running environment will read them to become the parameter settings in test commands.  
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Figure 11-27  Running Environment Detail Test Screen 

 
 

11.6 Menu Description 

[Test Item]→[New] Add a new test item. 

[Test Item]→[Open…] Open an existing test item.  

[Test Item]→[Save] Save the current edited test item.  

[Test Item]→[Save As…] Save the current edited test item with different 
name.  

[Test Item]→[Print…] Print directly. 

[Test Item]→[Print Preview] Preview the printout. 

[Test Item]→[Print Setup…] Set the printer.  

  
[Edit]→[Cut] Cut the data row where the pointer is positioned.  

[Edit]→[Copy] Copy the data row where the pointer is positioned. 

[Edit]→[Paste] Paste the copied data on the row where the pointer 
is positioned.  

[Edit]→[Insert] Insert a blank data row at the place where the 
pointer is positioned.   

[Edit]→[Delete] Delete the data row where the pointer is 
positioned. 

  
[Utility]→[OverAll Check] Run variable type check. 

[Utility]→[Compile] Run internal compiling. 

www.valuetronics.com



Editing User Defined Test Item (Option) 

     11-27 

[Utility]→[Option…] Set the parameters for running environment.  

[Utility]→[Redundant Var. Check] Check the variable that never been used. 

[Utility]→[Test Command Check] Check if the name of test command is legal.  

[Utility]→[Local Var. Rename…] Rename the local variable name in test item.  This 
function is only valid when clicked ‘Call Name’ 
column.  

[Utility]→[Parameter Find…] Find a parameter in ‘Test Procedure’ tab. This 
function is only valid in ‘Test Procedure’ tab.  

[Utility]→[Find Next] Find the next matched parameter in ‘Test 
Procedure’ tab.  This function is only valid in ’Test 
Procedure’ tab.  

  

[View]→[Toolbar] Display/hide toolbar. 

[View]→[Status Bar] Display/hide status bar.  

  

[Window]→[Cascade] Arrange the current opened windows to appear in 
serial.  

[Window]→[Tile] Arrange the current opened windows to appear in 
parallel. 

[Window]→[Arrange Icons] Arrange the current icons.  

  
[Help]→[Contents] Display the table of contents for the online 

documentation. 
[Help]→[About] Display the version information of this program. 

  

[Exit] End the program and return to SMPS ATS 
software main menu.  
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12. Statistics Process Control (Option) 

Statistics Process Control function is able to analyze the logged UUT test result.  The main 
function contains Process Capability Analysis, Xbar&R Chart, Xbar&S Chart, Pareto Chart, 
np Chart, p Chart, c Chart and u Chart eight types in total.  This function can save the various 
charts to graphic Bitmap File.  
 
In addition to the statistics process control function, it also provides the function to export 
result contents to an Excel or text file so that you can send the logged test result to other tool 
program for use. 
 
 

12.1 Open Statistics Log File 

In SMPS ATS software main menu click Statistics option to show the ‘Statistics’ window as 

Figure 12-1.  
 
There are two tabs in Statistics.  The first tab is “Data Source Setting” to let you set the start 
and end date you want to set for statistics.  Detail descriptions please see section 12.2.  The 
second tab “Constraint Setting” is for you to define the constraint conditions to filter out the 
test data.  Details please refer to section 12.3. 
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Figure 12-1  Statistics Window 

 
Before doing statistics analysis, you need to open the statistics log file (*.spc).  Click 

Open to select an exist statistics log file as Figure 12-2 shows (the default directory is 
\Spc under the installed directory.)  Figure 12-2 will appear the test program name specified 
in statistics log file when you select it.  
 
You can start to select the statistics data source after opening the statistics log file.  Please see 
section 12.2 for detail description. 
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Figure 12-2  Opening a Statistics Log File 

 
 

12.2 Selecting Statistics Data Source 

Use ‘Data Source Setting’ tab to select statistics data source.  The test program name logged 
in statistics log file will appear in the Test Program column.  Then set the starting and ending 
dates in the Log Data column in Figure 12-3 to select the test data between this time period.  
 

www.valuetronics.com



SMPS ATS 8000 User’s Manual 

 

     12-4 

 
Figure 12-3  Setting Start and End Date of Statistics Data 

 
Next, set the Log Data Search Path.  Select Use Default Log Data Directory or Use Path 

List to search the test result data in the specified directories.  It can combine the test data 
from two or more PowerPro III test platforms for statistics process chart creation.  
Meanwhile, if there is any retest data to replace the original data, the Merge Retest Data box 
needs to be selected.  
 

 Use Default Log Data Directory Use system default test result logged directory. 
 Use Path List    Use the user defined directory group. 

 
 Add Directory     Add user defined directory by selecting the directory.  The 

window lower part will appear the test result log database file in 
the selected directory as Figure 12-4 shows. 
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Figure 12-4  Adding User Defined Directory 

 
 Delete  Delete the user-defined directory where the pointer is positioned. 

 
Notice:  

 For Merge Retest Data, the same serial number will be treated as retest data.  
 When uses Merge Retest Data, you must check if the retest data uses the same test 

program, otherwise errors may occur.  
 The UUT test date is based on the date that the test data is selected.  

 
The guidelines for replacing original data with retested data: 
 
If a UUT’s Serial No. is found in the retest data, the original test data will be replaced with 
retest data and the rest will remain the same.  In addition, if constraints are set for filtering the 
test data, both original and retested data need to be filtered.  The data passed will be displayed 
for statistics analysis use.  

 
  Set the statistics data start and end date format to be YYYY/MM/DD 

YYYY : Western calendar year, ex. 2000. 
MM : Month, ex. 05, which is May. (Range: 1~12) 
DD : Date, ex. 25. (Range: 1~31) 
So the date format is 2000/05/25. 
Use the up and down arrow keys to change the date.  Please be noted that the start date 
needs to be earlier than end date.  
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12.3 Setting Constraints for Filtering Test Data 

Selecting Constraint Setting tab to set constraints for filtering the test data.  This tab has 
SerialNo Constraint and Variable Constraint two parts. The settings are the same except 
SerialNo is fixed with the parameter “SerialNo”, while the parameter for Variable is a 
drop-down menu. The drop-down menu for Variable provides the filter condition parameters. 
The OP provides operands (=, <>, <, >, >=, <=) for selection, while the Value is for condition 
value setting.  Click  Add  after finished entering these three constraints can convert them to 
database inquiry conditions and list them as below.  On the contrary, click  Delete  button can 
delete the selected database inquiry condition from the list as Figure 12-5 shows.  
 

 
Figure 12-5  Setting Constraint Condition to Filter Out Test Data 

 
After setting the statistics data source and constraint for filtering, you can start to retrieve the 
test data for analysis.  The usage of various charts is introduced below. 
 
 

www.valuetronics.com



Statistics Process Control (Option) 

     12-7 

12.4 Process Capability Analysis 

Click  (Process Capability Analysis) to display the screen as Figure 12-6 shows.  SPC 
Log Setting filters all result variables to the left.  The right side displays the value of the 
selected variable.  When you change the left part for different result variable, the right part 
test value will be updated accordingly. Click  Select Wizard  will prompt a dialog box as 
Figure 12-7 shows.  The required variables can be selected rapidly via the condition setting, 
and the conditions can be saved to file.  
 

 
Figure 12-6  Process Capability Analysis Parameter Setting - Data 
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Figure 12-7  Variable Selection Wizard  

 

 
Figure 12-8  Process Capability Analysis Parameter Setting – Statistics 
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Figure 12-9  Process Capability Analysis Parameter Setting – Print Setting 

 
Logged Variable Table: Figure 12-6  Process Capability Analysis Parameter Setting - Data) 
Display the related information of reading variable.  The important columns are explained as 
follows.  
 

No. Reading variable sequential number. 
Variable Reading variable name. 
Test Item Test item name.  
Sel Reading variable check box.  The preview or print out of 

statistics chart will contain this reading variable if selected.  
Remark Reading variable notes. 
MaxSpec The referenced maximum specification variable name for 

reading variable. 
MinSpec The referenced minimum specification variable name for 

reading variable. 
Variable ID Reading variable ID.  

 
Notice:  

 Sel column check box is able to provide continuous printing function for multiple 
reading variable statistics charts.  
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 Select All Select all reading variables.  All check boxes will be in selected 

mode.  
 UnSelect All Unselect all reading variables.  All check boxes will be in 

unselected mode.  
 
Value Table: Display a certain reading variable of the test result.  The important columns are 
explained as follows. 
 

No. Test reading sequential number. 
Serial No Serial number for the unit under test (UUT). 
Value Value of test reading.  
Result Test reading PASSES or FAILS.  
Sel Test reading check box.  The preview or print out of statistics 

chart will include this test reading for statistics analysis if 
selected.   

Variable ID Reading variable ID. 
 

 Select All  Select all reading variables.  All check boxes will be in selected 
mode.  

 UnSelect All  Unselect all reading variables.  All check boxes will be in 
unselected mode.  

 
Process Capability Analysis Parameter Setting contains two tabs as below.  
‘Parameter Setting’ tab: (Figure 12-8 Process Capability Analysis Parameter Setting - 
Statistics)  

 
1. Spec. Max Set the maximum specification value for selected variable to 

calculate Cp, Ca and Cpk values. 
2. Spec. Min Set the minimum specification value for selected variable to 

calculate Cp, Ca and Cpk values. 
3. Sigma (Cpk) Select the way to calculate Sigma. (n: used to calculate the entire 

mother group; n-1: used to estimate the entire mother group) 
4. Number of Bins Set the bin numbers of a bar chart.  
 
Use Sturges Rule Get the maximum and minimum value from all readings for bar 

chart bins and follow the example to count bins.  The formula is 
1+3.3*log (Size of (X)).  

Use Custom Define 

Bins 

The maximum and minimum bin numbers defined by user. 

Number Self defined bin number. 
Bin Max Maximum bin numbers.  
Bin Min Minimum bin numbers.  
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Display Histogram Select if use bar chart.  

 

Notice:  
 If Spec. Max and Spec. Min are not defined, this program will retrieve the maximum 

and minimum value from all reading variables to fill in these two columns.  
 For One Side Limit chart analysis, you need to enter –9999 to Spec. Max and Spec. Min 

columns if no maximum or minimum specification for system to create One Side Limit 
chart analysis.  

 It won’t be able to calculate or create chart if the Sigma in selected data is near to 0.  
 
‘Print Setting’ tab:  As Figure 12-9 Process Capability Analysis Parameter Setting – Print 
Setting shows, only Title and Condition can be set.  The rest columns are not available for 
setting and will print out along with the chart.  

 
Title Set the title for printing.  You can enter any title name.  
Model Name Model name for UUT.  This column is for display only.  It cannot 

be modified.  
Test Item Name Name for Test Item.  This column is for display only.  It cannot 

be modified.  
Variable Name Name for variable.  This column is for display only.  It cannot be 

modified. 
Condition Setting for test condition.  You can follow the actual test 

condition to enter the description.  A text dialog box as Figure 
12-10 will appear after you clicked  Edit Condition  to let you 
select suitable Test Condition variable contents from the test 
programs and create the description for this column.  

 

www.valuetronics.com



SMPS ATS 8000 User’s Manual 

 

     12-12 

 
Figure 12-10  Editing Test Condition Setting 

 
Selectable test items are listed at the upper left.  In Process Capability Analysis Chart you 
only need to select the test item that current reading variable is at.  The lower left window 
displays all test condition variables for the above test items.  The upper right of the window is 
the editing area where the red numbers are the variables selected from left.  The lower right of 
the window shows the variables selected.  
 
Displaying Statistics Chart  

 

First select the reading variables for statistics chart creation, and then select the test readings 

at right to be calculated.  Last set ‘Parameter Setting’ and ‘Print Setting’ tabs and click  

Print Preview button on the toolbar to get the Process Capability Analysis Chart as Figure 
12-11. 
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Figure 12-11  Process Capability Analysis Result 

 
The statistics chart result appears in preview format.  The upper part shows the UUT basic 
information in this test item following by the statistics chart.  The lower part displays the 
statistics numbers, and the last shows the bin results.  The buttons on the window are 
explained as follows.  
 
 Print Print the result of this statistics chart. 
 Next Page Preview the statistics chart result for the following page. 
 Prev Page Preview the statistics chart result for the previous page.  
 Two Page Preview the statistics chart by displaying two pages at a time. 
 Zoom In Enlarge the preview of current statistics chart. 
 Zoom Out Shrink the preview of current statistics chart.  
 Close Stop previewing the statistics chart.  
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Saving Statistics Chart 

 

First select the reading variables for statistics chart creation, and then select the test readings 

for statistics calculation.  Click  Save to Image File from the toolbar, it will appear 
dialog box as Figure 12-12  The left part lists the selected variable, which is named in 
VariableName_Sequence_LoadNo.  Property setting is at the right to set if the Header, chart, 
data and size need to be saved as individual bitmap file.  The lower right is the directory and 
filename where the file will be saved.  The filename can be user defined or automatically set 
by system in _ChartName, where ChartName will change to the variable name at saving. The 
file type .bmp or .jpg can be selected.  
 

 
Figure 12-12  Saving Charts to Bitmap Files 

 
Saving Computed Data 

 
Select the variables at left for Statistics Chart creation, and select the test readings at right for 

computing. Click Save Computed Data to Excel File from the toolbar, it will appear a 
Transfer Setup dialog box as Figure 12-13 shows and Figure 12-14 to save the computed 
data. 
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Figure 12-13   Dialog Box of Transfer Setup  

 

 
Figure 12-14  Saving Computed Data 
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12.5 Xbar&R Chart 

To create Xbar&R Chart, you can click  (Xbar&R) on the toolbar to display the Statistics 
Xbar&R Chart Parameter Setting screen as Figure 12-15.  The left window shows the 
variables filtered out by SPC Log Setting function in the test program.  The right window 
displays the test readings of selected variables.  When you select different variable at the left, 
the right side will update with new test readings for this variable.  The other two tabs are 
Xbar&R Chart parameter settings that covered in the following sections.    
 

 
Figure 12-15  Statistics Xbar&R Chart Parameter Setting – Data Table 
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Figure 12-16  Statistics Xbar&R Chart Parameter Setting – Parameter Setting 

 

 
Figure 12-17  Statistics Xbar&R Chart Parameter Setting – Print Setting 
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Logged Variable Table:  (Figure 12-15  Statistics Xbar&R Chart Parameter Setting – Data 
Table)  Display the reading variable related information.  The important columns are 
explained as follows.  
 

No. Reading variable sequential number. 
Variable Name of reading variable.  
Test Item Name of the test item. 
Sel Reading variable check box.  The preview or print out of 

statistics chart will contain this reading variable if selected.  
Remark Reading variable notes. 
MaxSpec The referenced maximum specification variable name for 

reading variable. 
MinSpec The referenced minimum specification variable name for 

reading variable. 
Variable ID Reading variable ID.  

 
Notice:  

 Sel column check box is able to provide continuous printing function for multiple 
reading variable statistics charts. 

 
Select All  Select all reading variables.  All check boxes will be in selected 

mode.  
UnSelect All  Unselect all reading variables.  All check boxes will be in 

unselected mode.  
 

Value Table:  Display a certain reading variable of the test result.  The important columns are 
explained as follows. 
 

No. Test reading sequential number. 
Serial No Serial number for the unit under test (UUT). 
Value Value of test reading.  
Result Test reading PASSES or FAILS.  
Sel Test reading check box.  The preview or print out of statistics 

chart will include this test reading for statistics analysis if 
selected.   

Variable ID Reading variable ID. 
 

 Select All  Select all test reading variables.  All check boxes will be in 
selected mode.  

 UnSelect All  Unselect all test reading variables.  All check boxes will be in 
unselected mode.  
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 ‘Parameter Setting’ tab: (Figure 12-16  Statistics Xbar&R Chart Parameter Setting – 
Parameter Setting)  
 

1. Sample Size Set the sample numbers.  
2. Std Err Multiplier Display the standard error multiplier for Spec. Max/Min. 
3. Spec. Max/Min Set the value of selected variable maximum and minimum 

specification for Cp, Ca and Cpk values calculation.  
4. Sigma (Cpk) Select the method to calculate Sigma. (n: used to count the 

entire mother group; n-1: used to estimate the entire 
mother group.) 

5. Limit Source Set maximum/minimum limit source.  
 

 From Selected Data Calculate the control line using the selected test readings. 
 Use Std Mean,R0 Use the Std Mean and R0 as standard value to calculate 

the control line. 
 Use Std Mean,Sigma Use the Std Mean and Sigma as standard value to calculate 

the control line. 
Std Mean Set standard mean value. 
Sigma or R0 Set standard sigma value or standard R0. 

 
Notice: 

 
 Statistics Xbar&R Chart will also count Cp, Ca and Cpk value, thus the Spec. Max/Spec. 

Min needs to be entered.  
 If Spec. Max and Spec. Min are not specified, the program will fill in the column with 

the maximum/minimum value read from the variable readings.  
 For One Side Limit chart, you need to enter –9999 to Spec. Max and Spec. Min columns 

if no maximum or minimum specification for system to create One Side Limit chart 
analysis. 

 It won’t be able to calculate or create chart if the Sigma in selected data is near to 0. 
 
‘Print Setting’ tab: (Figure 12-17 Statistics Xbar&R Chart Parameter Setting – Print Setting)  
 

Title Set the title for printing.  You can enter any title name.  
Model Name Model name for UUT.  This column is for display only.  It 

cannot be modified.  
Test Item Name Name for Test Item.  This column is for display only.  It 

cannot be modified.  
Variable Name Name for variable.  This column is for display only.  It 

cannot be modified. 
Condition Setting for test condition.  You can follow the actual test 

condition to enter the description.  A text dialog box as 
Figure 12-10 will appear after you clicked Edit Condition 
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to let you select suitable Test Condition variable contents 
from the test programs and create the description of this 
column.  

 

Displaying Statistics Chart 

  

First select the reading variables for statistics chart creation, and then select the test readings 
at right to be calculated.  Last set ‘Parameter Setting’ and ‘Print Setting’ tabs, and click Figure 
12-18. 
 

 
Figure 12-18  Statistics Xbar&R Chart 

 
The statistics chart result appears in preview format.  The upper part shows the UUT basic 
information of this test item following by the statistics chart.  The right part displays the 
statistics numbers, and the bottom displays the result value of each point.  
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Saving Statistics Chart 

 
First select the reading variables for statistics chart creation, and then select the test readings 

for statistics calculation.  Click  Save to Image File from the toolbar, it will appear 
dialog box as Figure 12-19.  The left portion lists the selected variable, which is named in 
VariableName_Sequence_LoadNo.  Property setting at the right is to set if the Header, chart, 
data and size need to be saved as individual bitmap file.  The lower right is the directory and 
filename where the file will be saved.  The filename can be user defined or automatically set 
by system in _ChartName, where ChartName will change to the variable name at saving. File 
type .bmp or .jpg can be selected. 
 

 
Figure 12-19  Saving Charts to Bitmap Files 

 
Saving Computed Data 

 

Select the variables at left for Statistics Chart creation, and select the test readings at right for 

computing. Click Save Computed Data to Excel File from the toolbar, it will appear 
dialog box as Figure 12-20 shows. 
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Figure 12-20  Saving Computed Data 

 
 

12.6 Xbar&S Chart 

To create Xbar&S Chart, you can click  (Xbar&S) on the toolbar to display the Statistics 
Xbar&S Chart Parameter Setting screen as Figure 12-21.  The left part of window shows the 
variables filtered out by SPC Log Setting function in the test program.  The right portion of 
window displays the test readings of selected variables.  When you select different variable at 
the left, the right side will update with new test readings for this variable.  The other two tabs 
are Xbar&S Chart parameter settings that are covered in the following sections. 
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Figure 12-21  Statistics Xbar&S Chart Parameter Setting - Data Table 

 

 
Figure 12-22  Statistics Xbar&S Chart Parameter Setting – Parameter Setting 
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Figure 12-23  Statistics Xbar&S Chart Parameter Setting – Print Setting 

 
Logged Variable Table: (Figure 12-21) Display the reading variable related information.  
The important columns are explained as follows. 

 
No. Reading variable sequential number. 
Variable Name of reading variable.  
Test Item Name of the test item. 
Sel Reading variable check box.  The preview or print out of 

statistics chart will contain this reading variable if selected.  
Remark Reading variable notes. 
MaxSpec The referenced maximum specification variable name for 

reading variable. 
MinSpec The reference minimum specification variable name for 

reading variable. 
Variable ID Reading variable ID.  

 
Notice:  

 Sel column check box is able to provide continuous printing function for multiple 
reading variable statistics charts. 
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Select All  Select all reading variables.  All check boxes will be in 
selected mode.  

UnSelect All  Unselect all reading variables.  All check boxes will be in 
unselected mode.  

 

Value Table: Display a certain reading variable of the test result.  The important columns are 
explained as below. 
 

No. Test reading sequential number. 
Serial No Serial number for the unit under test (UUT). 
Value Value of test reading.  
Result Test reading PASSES or FAILS.  
Sel Test reading check box.  The preview or print out of 

statistics chart will include this test reading for statistics 
analysis if selected.   

Variable ID Reading variable ID. 
 

Select All  Select all test reading variables.  All check boxes will be in 
selected mode.  

UnSelect All  Unselect all test reading variables.  All check boxes will 
be in unselected mode.  

 

‘Parameter Setting’ tab: (Figure 12-22) 
 

1. Sample Size Set the sample numbers.  
2. Std Err Multiplier Display the standard error multiplier for Spec. Max/Min. 
3. Spec. Max/Min Set the value of selected variable maximum and minimum 

specification for Cp, Ca and Cpk values calculation.  
4. Sigma (Cpk) Select the method to calculate Sigma. (n: used to count the 

entire mother group; n-1: used to estimate the entire 
mother group) 

5. Limit Source Set maximum/minimum limit source.  
 

 From Selected Data Calculate the control line using the selected test readings. 
 Use Std Mean,s0 Use the Std Mean and s0 as standard value to calculate the 

control line. 
 Use Std Mean,Sigma Use the Std Mean and Sigma as standard value to calculate 

the control line. 
Std Mean Set standard mean value. 
Sigma or s0 Set standard sigma value or standard s0. 
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Notice: 

 Statistics Xbar&S Chart will also count Cp, Ca and Cpk value, thus the Spec. Max/Spec. 
Min needs to be entered.  

 If Spec. Max and Spec. Min are not specified, the program will fill in the column with 
the maximum/minimum value read from the variable readings.  

 For One Side Limit chart, you need to enter –9999 to Spec. Max and Spec. Min columns 
if no maximum or minimum specification for system to create One Side Limit chart 
analysis. 

 It won’t be able to calculate or create chart if the Sigma in selected data is near to 0. 
 
‘Print Setting’ tab: (Figure 12-23)  
 

Title Set the title for printing.  You can enter any title name.  
Model Name Model name for UUT.  This column is for display only.  It 

cannot be modified.  
Test Item Name Name for Test Item.  This column is for display only.  It 

cannot be modified.  
Variable Name Name for variable.  This column is for display only.  It 

cannot be modified. 
Condition Setting for test condition.  You can follow the actual test 

condition to enter the description.  A text dialog box as 
Figure 12-10 will appear after you clicked Edit Condition 
to let you select suitable Test Condition variable contents 
from the test programs and create the description of this 
column.  

 
Displaying Statistics Chart  

 

First select the reading variables for statistics chart creation, and then select the test readings 

at right to be calculated.  Last set ‘Parameter Setting’ and ‘Print Setting’ tabs, and click  

Print Preview button on the toolbar to get the Statistics Xbar&S Chart as Figure 12-24. 
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Figure 12-24  Statistic Xbar&S Chart 

 
The statistics chart result appears in preview format.  The upper part shows the UUT basic 
information of this test item following by the statistics chart.  The right part displays the 
statistics numbers, and the bottom displays the result value of each point. 
 
Saving Statistics Chart 

 

First select the reading variables for statistics chart creation, and then select the test readings 

for statistics calculation.  Click  Save to Image File from the toolbar, it will appear 
dialog box as Figure 12-25.  Left part lists the selected variable, which is named in 
VariableName_Sequence_LoadNo.  Property setting at the right is to set if the Header, chart, 
data and size need to be saved as individual bitmap file.  The lower right is the directory and 
filename where the file will be saved.  The filename can be user defined or automatically set 
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by system in _ChartName, where ChartName will change to the variable name at saving. The 
file type .bmp or .jpg can be selected.  

 

 
Figure 12-25  Saving Charts to Bitmap Files 

 

Saving Computed Data 

Select the variables at left for Statistics Chart creation, and select the test readings at right for 

computing. Click Save Computed Data to Excel File from the toolbar, it will appear 
dialog box as Figure 12-26 shows. 
 

 
Figure 12-26  Saving Computed Data 
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12.7 Pareto Chart 

This system uses Pareto Chart to calculate the UUT’s results and treat the fails during various 
test sequences as flows. 
 

To create Pareto Chart, click (Pareto Chart) on the toolbar to display the Pareto Chart 
basic data screen as Figure 12-27.   The upper part shows the UUT fail or pass (0 = fail, 1 = 
pass) result during every test sequence. 
 

 
Figure 12-27  Pareto Chart Basic Data Screen – Data Table 
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Figure 12-28  Pareto Chart Basic Data Screen – Print Setting 

 
UUT Table: (Figure 12-27) Display UUT related information.  The important columns are 
described as below.  
 

No. The UUT sequential number.  
Sel UUT test result check box.  The preview or print out of 

statistics chart will contain this reading variable if selected 

Serial No. The UUT serial number. 
 

The rest of columns show the test sequence result pass or fail (1/0).  
 
Select All  Select all UUT test results.  All check boxes will be in 

selected mode.  
UnSelect All  Unselect all UUT test results.  All check boxes will be in 

unselected mode.  
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Print Setting tab: (Figure 12-28) 
 

Title Set the title for printing.  You can enter any title name.  
Model Name Model name for UUT.  This column is for display only.  It 

cannot be modified.  
Test Item Name Name for Test Item.  This column is for display only.  It 

cannot be modified.  
Variable Name Name for variable.  This column is for display only.  It 

cannot be modified. 
Condition Setting for test condition.  You can follow the actual test 

condition to enter the description.  A text dialog box 
Figure 12-29 will appear after you clicked Edit Condition 

as to let you select suitable Test Condition variable 
contents from the test programs and create the description 
of this column. 
 

 
Figure 12-29  Editing Various Test Condition Setting 

 
The upper left part in the window lists test items for selection.  You only need to select the test 
item of current reading variable in process capability analysis chart.  The lower left part in the 
window shows the test condition variables for the above test items.  The upper right part of 
the window is the editing area where the number in red is the variable selected from left.  The 
lower right displays the selected variables. 
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Displaying Statistics Chart 

 

Select the UUT result that will be analyzed and calculated from the above table, then set 

Print Setting tab, and click  Print Preview button from the toolbar to get the Pareto Chart 
as Figure 12-30. 
 

 
Figure 12-30  Pareto Chart 

 
The statistics chart result appears in preview format.  The upper part shows the UUT basic 
information of this test item following by the statistics chart.  The lower part displays the fail 
quantity and percentage ratio of various test sequences by volume order. 
 
Saving Statistics Chart 

 

First select the reading variables for statistics chart creation, and then select the test readings 

for statistics calculation.  Click  Save to Image File from the toolbar, it will appear 
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dialog box as Figure 12-31.  The figure left part lists the chart name Pareto.  Property setting 
at right is to set if Header, chart, data and size need to be saved in individual bitmap file.  The 
lower right is the directory and filename where the file will be saved.  The filename can be 
user defined or automatically set by system in _Pareto. The file type .bmp or .jpg can be 
selected.  
 

 
Figure 12-31  Saving Charts to Bitmap Files 

 

 

12.8 np Chart  

 
The np Chart used in this system is to analyze the test result of every UUT.  The failed results 
are treated as np for np Chart generation.  
 

To create a np Chart, you can click (np Chart) on the toolbar to display the np Chart 
parameter setting screen as Figure 12-32.  The top of the table shows the UUT test result 
while the bottom shows the np Chart parameters as described below.  
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Figure 12-32  np Chart Parameter Setting – Data Table 

 

 
Figure 12-33  np Chart Parameter Setting – Parameter Setting 
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Figure 12-34  np Chart Parameter Setting – Print Setting 

 
UUT Table: (Figure 12-32) Display the UUT related information.  The important columns 
are described as below.  
 

No. The UUT sequential number.  
Sel UUT test result check box.  The preview or print out of 

statistics chart will contain this reading variable if selected 

Serial No. The UUT serial number. 
UUT Pass/Fail (1/0) Display the UUT test result is passed (1) or failed (0). 

 
Select All  Select all UUT test results.  All check boxes will be in 

selected mode.  
UnSelect All  Unselect all UUT test results.  All check boxes will be in 

unselected mode.  
 

‘Parameter Setting’ tab: 
 
1. Sample Size Set the sample numbers. 
2. Std Err Multiplier Display the standard error multiplier for Spec. Max/Min. 
3. Limit Source Set the maximum/minimum limit source. 
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 From Selected Data Calculate the control line using the selected UUT test 
result. 

 Use Std p0 Use the Std p0 as standard value to calculate the control 
center line. 

Std p0 Set standard p0 value using n*p0 as the control center line 
(n is the sample size). 

 
‘Print Setting’ tab: (Figure 12-34).  Only Title and Condition can be set, the rest of columns 
are unable to set but will print out with chart.  

 
Title Set the title for printout. 
Model Name Model name for UUT.  This column is for display only.  It 

cannot be modified. 
Condition Setting for test condition.  You can follow the actual test 

condition to enter the description.  A text dialog box 
Figure 12-29 will appear after you clicked Edit Condition 

to let you select suitable Test Condition variable contents 
from the test programs and create the description of this 
column. 

 
Displaying Statistics Chart 

 

Select the UUT result that will be analyzed and calculated from the above table, then set the 

Parameter Setting and Print Setting tabs, and click  Print Preview button from the toolbar 
to get the np Chart as Figure 12-35. 
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Figure 12-35  np Chart 

 
The statistics chart result appears in preview format.  The upper part shows the UUT basic 
information of this test item following by the statistics chart.  The lower part displays the fail 
quantity and percentage ratio of various test sequences by volume order. 
 
Saving Statistics Chart 

 

First select the reading variables for statistics chart creation, and then select the test readings 

for statistics calculation.  Click  Save to Image File from the toolbar, it will appear 
dialog box as Figure 12-36.  The figure left part lists the chart name NP Chart.  Property 
setting at right is to set if Header, chart, data and size need to be saved in individual bitmap 
file.  The lower right is the directory and filename where the file will be saved.  The filename 
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can be user defined or automatically set by system in _NPChart.  The file type .bmp or .jpg 
can be selected.  

 
Figure 12-36  Saving Charts to Bitmap Files 
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12.9 p Chart 

The p Chart used in this system is to analyze all UUT test results of everyday.  The failed 
number is calculated as the p rate for p Chart generation.  
 

To create a p Chart, click (p Chart) from the toolbar to display the p Chart parameter 
setting screen as Figure 12-37.  The top of the table shows the UUT test result while the 
bottom shows the p Chart parameters described below. 
 

 
Figure 12-37  p Chart Parameter Setting – Data Table 
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Figure 12-38  p Chart Parameter Setting – Parameter Setting 

 

 
Figure 12-39  p Chart Parameter Setting – Print Setting 
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Data Table: (Figure 12-37) Displays the UUT related information.  The important columns 
are described as below. 
 

No. The sequential number by date order.  
Sel The date test result check box.  The preview or print out of 

statistics chart will contain this date test result if selected. 
Date The date of test. 
UUT Pass Counts The pass counts of a certain date’s UUT test result.  
UUT Fail Counts The fail counts of a certain date’s UUT test result. 
UUT Total Counts The total counts of a certain date’s UUT test result. 
 
Select All  Select all UUT test results.  All check boxes will be in 

selected mode.  
UnSelect All  Unselect all UUT test results.  All check boxes will be in 

unselected mode.  
 

 ‘Parameter Setting’ tab: (Figure 12-38) 
 
1. Sample Size Set the sample numbers.  
2. Std Err Multiplier Display the standard error multiplier for Spec. Max/Min. 
3. Limit Source Set the maximum/minimum limit source. 
 

 From Selected Data Calculate the control line using the selected UUT test result. 
 Use Std p0 Use the Std p0 as standard value to calculate the control 

center line. 
Std p0 Set standard p0 value. 
 

‘Print Setting’ tab: (Figure 12-39)  
 
Title Set the title for printout. 
Model Name Model name for UUT.  This column is for display only.  It 

cannot be modified. 
Condition Setting for test condition.  You can follow the actual test 

condition to enter the description.  A text dialog box as 
Figure 12-29 will appear after you clicked Edit Condition 

to let you select suitable Test Condition variable contents 
from the test programs and create the description of this 
column. 
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Displaying Statistics Chart 

 

Select the date of UUT result that will be analyzed and calculated from the above table, then 

set ‘Parameter Setting’ and ‘Print Setting’ tabs, and click  Print Preview button from the 
toolbar to get the p Chart as Figure 12-40. 
 

 
Figure 12-40  p Chart 

 
The statistics chart result appears in preview format.  The upper part shows the UUT basic 
information of this test item following by the statistics chart.  The right part displays the 
statistics numbers, and the bottom displays the result value of each point. 
 
Saving Statistics Chart 

 

First select the reading variables for statistics chart creation, and then select the test readings 

for statistics calculation.  Click  Save to Image File from the toolbar, it will appear 
dialog box as Figure 12-41.  The figure left part lists the chart name P Chart.  Property setting 
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at right is to set if Header, chart, data and size need to be saved in individual bitmap file.  The 
lower right is the directory and filename where the file will be saved.  The filename can be 
user defined or automatically set by system in _PChart.  The file type .bmp or .jpg can be 
selected. 
 

 
Figure 12-41  Saving Charts to Bitmap Files 
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12.10 c Chart 

The system uses c Chart to analyze and calculate the fail count result by treating the logged 
test result readings of a UUT under a test item as c.  
 

To create c Chart, click (c Chart) on the toolbar to display the c Chart Parameter Setting 
screen as Figure 12-42.  The left window shows the test sequences of the test programs.  The 
right window displays the UUT test readings pass or fail counts of the selected test sequence 
from the left.  The other tabs are settings for c Chart parameters described as follows.  
 

 
Figure 12-42   c Chart Parameter Setting – Data Table 
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Figure 12-43  c Chart Parameter Setting – Parameter Setting 

 

 
Figure 12-44  c Chart Parameter Setting – Print Setting 
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Sequence Table: (left window of Figure 12-42) Display test sequences, detail column 
descriptions are as below.  

 
Seq Serial number of the test sequences.  
Sel Test sequence check box.  The preview or print out of 

statistics chart will contain the readings if selected. 
 

Notice:  

 Sel column check box provides continuous printing function for multiple test sequence 
c Charts.  

 
Select All  Select all test sequences.  All check boxes will be in 

selected mode.  
UnSelect All  Unselect all test sequences.  All check boxes will be in 

unselected mode.  
 

UUT Table: (right window of Figure 12-42)  Display the UUT related info.  The important 
columns are explained as follows.  

 
No. The sequential number of UUT test result.  
Sel The UUT test result check box.  The preview or print out of 

statistics chart will contain the test result if selected. 
Serial No. The serial number of UUT. 
Pass Count The pass counts of all UUT test readings in test sequences.  
Fail Count The fail counts of all UUT test readings in test sequences. 
Total Count The total counts of all UUT test readings in test sequences. 
 
Select All  Select all UUT test results.  All check boxes will be in 

selected mode.  
UnSelect All  Unselect all UUT test results.  All check boxes will be in 

unselected mode.  
 

‘Parameter Setting’ tab: (Figure 12-43) 
  
1. Sample Size Set the sample numbers.  
2. Std Err Multiplier Display the standard error multiplier for Spec. Max/Min. 
3. Limit Source Set the maximum/minimum limit source. 
 

 From Selected Data Calculate the control line using the selected UUT test result. 
 Use Std c0 Use the Std c0 as the standard value to calculate the control 

center line. 
Std c0 Set standard c0 value as the control center line. 
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‘Print Setting’ tab: (Figure 12-44)  
 

Title Set the title for printout. 
Model Name Model name for UUT.  This column is for display only.  It 

cannot be modified. 
Test Item Name Name of Test Item.  This column is for display only.  It 

cannot be modified. 
Condition Setting for test condition.  You can follow the actual test 

condition to enter the description.  A text dialog box as 
Figure 12-29 will appear after you clicked Edit Condition 

to let you select suitable Test Condition variable contents 
from the test programs and create the description of this 
column. 

 
Displaying Statistics Chart 

 

Select the date of UUT result that will be analyzed and calculated from the above table, then 

set ‘Parameter Setting’ and ‘Print Setting’ tab, and click  Print Preview button on the 
toolbar to get the c Chart as Figure 12-45. 
 

 
Figure 12-45  c Chart 
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The statistics chart result appears in preview format.  The upper part shows the UUT basic 
information of this test item following by the statistics chart.  The right part displays the 
statistics numbers, and the bottom displays the result value of each point. 
 
Saving Statistics Chart 

 

First select the reading variables for statistics chart creation, and then select the test readings 

for statistics calculation.  Click  Save to Image File from the toolbar, it will appear 
dialog box as Figure 12-46.  The figure left part lists the selected variable, which is named in 
TestItemName.  Property setting at right is to set if the Header, chart, data and size need to be 
saved in individual bitmap file.  The lower right area is the directory and filename where the 
file will be saved.  The filename can be user defined or automatically set by system in 
_ChartName where ChartName will change to the test item name at left window. The file 
type .bmp or .jpg can be selected. 

 

 
Figure 12-46  Saving Charts to Bitmap Files 
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12.11 u Chart  

The system uses u Chart to analyze and calculate the fail count rate using the logged test 
result readings of a UUT under a test item everyday to divide it by the readings quantity and 
come up the u Chart.   
 

To create c Chart, click (u Chart) on the toolbar to display the u Chart parameter setting 
screen as Figure 12-47.  The left window shows the test sequences of the test programs.  The 
right window displays the UUT test readings pass or fail counts of the selected test sequence 
from the left of every test date.  The other tabs are settings for u Chart parameters described 
as follows. 
 

 
Figure 12-47  u Chart Parameter Setting 
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Figure 12-48  u Chart Parameter Setting – Parameter Setting 

 

 
Figure 12-49  u Chart Parameter Setting – Print Setting 
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Sequence Table: (left window of Figure 12-47) Displays the test sequences, detail columns 
descriptions are as follows.  
 

Seq Serial number of test sequences.  
Sel Test sequence check box.  The preview or print out of 

statistics chart will contain the readings if selected. 
 

Notice:  

 Sel column check box provides continuous printing function for multiple test sequence 
u Charts. 

 
Select All  Select all test sequences.  All check boxes will be in 

selected mode.  
UnSelect All  Unselect all test sequences.  All check boxes will be in 

unselected mode.  
 

Data Table: (right window of Figure 12-47) Display the UUT related information.  The 
important columns are explained as below. 
 

No. The sequential number of UUT test result.  
Sel The UUT test result check box.  The preview or print out of 

statistics chart will contain the test result if selected. 
Date The date of test.  
UUT Pass Counts The UUT pass counts of a selected test sequence at a certain 

date.  
UUT Fail Counts The UUT fail counts of a selected test sequence at a certain 

date. 
UUT Total Counts The total UUT counts of a selected test sequence at a certain 

date. 
 
Select All  Select all test date results.  All check boxes will be in 

selected mode.  
UnSelect All  Unselect all test date results.  All check boxes will be in 

unselected mode.  
 

‘Parameter Setting’ tab: (Figure 12-48) 
 
1. Sample Size Set the sample numbers.  
2. Std Err Multiplier Display the standard error multiplier for Spec. Max/Min. 
3. Limit Source Set the maximum/minimum limit source. 
 

 From Selected Data Calculate the control line using the selected UUT test result. 
 Use Std u0 Use the Std u0 as the standard value to calculate the control 
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center line. 
Std u0 Set standard u0 value. 
 

‘Print Setting’ tab: (Figure 12-49)  
 
Title Set the title for printout. 
Model Name Model name for UUT.  This column is for display only.  It 

cannot be modified. 
Test Item Name Name of Test Item.  This column is for display only.  It cannot 

be modified. 
Condition Setting for test condition.  You can follow the actual test 

condition to enter the description.  A text dialog box as Figure 

12-29 will appear after you clicked Edit Condition to let 

you select suitable Test Condition variable contents from the 
test programs and create the description of this column. 

 
Displaying Statistics Chart 

 
Select the test date of test item that will be analyzed and calculated from the above table, then 

set ‘Parameter Setting’ and ‘Print Setting’ tabs, and click  Print Preview button on the 
toolbar to get the u Chart as Figure 12-50.  
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Figure 12-50  u Chart 

 
The statistics chart result appears in preview format.  The upper part shows the UUT basic 
information of this test item following by the statistics chart.  The right part displays the 
statistics numbers, and the bottom displays the result value of each point. 
 
Saving Statistics Chart 

 

First select the reading variables for statistics chart creation, and then select the test readings 

for statistics calculation.  Click  Save to Image File from the toolbar, it will appear 
dialog box as Figure 12-51 shows below.  The figure left part is the selected variable, which is 
named in TestItemName.  Property setting at right is to set if the Header, chart, data and size 
need to be saved in individual bitmap file.  The lower right area is the directory and filename 
where the file will be saved.  The filename can be user defined or automatically set by system 
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in _ChartName where ChartName will change to the test item name at the left window. The 
file type .bmp or .jpg can be selected. 
 

 
Figure 12-51  Saving Charts to Bitmap Files 

 
 

12.12 Exporting Result Log Text File 

This system allows exporting the test result to a text file.  You can use other applications such 
as Microsoft Excel to manage the exported text file easily for various types report creation.  
 

Click  on the toolbar to display all variable readings setting screen as Figure 12-52.  The 
columns are explained as below.  
 

Sel  Check the variable to export. 
Seq The variable sequence in test program.  
Variable Name The name of variable. 
TestItem The test item where the variable is. 
LoadNo Array variable index value.  If the variable is not array variable, 

the index value is 0. 
VariableID The ID for variable.  
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Figure 12-52  All Reading Variables in Test Program 

 
You can select the output file format in Figure 12-52.  When select “Save as One File Name”, 
the data will be saved in specified filename.  If select “Save as MultiFile Name”, the date will 
be saved 256 columns a file, and the filename will be “specified filename” + “_?” +  “.txt”. 
The reference information for title can be selected from File Header of which are Test Item 
Information, Test Item Name and Max Min Specification.  
 
Note: The “?” indicates a number starting from 1.  
 
Click the  Other Option  button in Figure 12-52will show the selection menu as in Figure 

12-53. 
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Figure 12-53  Other Option for Text File 

 
Check the Sel column in the table for variables to export in Figure 12-52.  Then go to another 
tab (Data Table), the checked variable will expand the serial number that meets the selection 
condition to a table as Figure 12-54 shows. 
 
The columns are explained as follows. 
 
First column:     Sel     Check the row to export. 
Second column:   S/N    The UUT serial number that matches the selection. 
Third column: Following are the various variable names.  Column is named in 
   VariableName_LoadNo_SeqNo 

www.valuetronics.com



Statistics Process Control (Option) 

     12-57 

 
Figure 12-54  Reading Variable Export Report 

 
Click  Save to Text / Excel File  on Figure 12-54 to display the dialog box as Figure 12-55 

shows.  You can select the directory and filename to export an Excel or a text file and save the 
selected contents from Figure 12-54.  
 

 
Figure 12-55  Save As Dialog Box 
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Note: For the “Sel” column in the table of this application, you can always move the pointer 
to the “Sel” title bar and click it in order to Select All or UnSelect All.  
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13. Report Wizard (Option) 

13.1 Getting Started 

 
In Chroma 8000 main menu select ‘Report Wizard’ from ‘Advance’ will execute ‘Report 
Wizard’ and display its main menu as below.  
 

 
Figure 13-1  Report Wizard Main Menu 

 
 

13.1.1 Execution 
 
Before generating a report, you need to specify the test program you want to generate report 
for through the Report menu on the main window.  Or, you can select to load the Report Set 
that saved previously.  
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Figure 13-2  Report Function Menu 

 

Note: Every project has test programs.  
 

To generate report for new test program, click [Report]→[Select Test Program] and the 
program will inquire for the name of the test program.  Be noted of the ‘Prg’ and ‘Log’ 
columns in the dialog box. Once a test program *.prg is created, it can enter the Report 
Wizard to start editing the report items.  However, it has to wait until the test data is generated 
to be able to preview the edited report items or create report.  
  

 
Figure 13-3  Selecting Test Program 

 
To load the existing Report Set that has test programs, please select ‘Load Existing Report 
Set’. The program will prompt a dialog window to inquire you for the project name.  The 
yellow areas, which are read-only in the window, represent the selected test program and its 
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description.  The area below shows the information of existing projects including project 
names, test program names, and the data/time saved as well as if they have been released. 
 

 
Figure 13-4  Selecting to Load Existing Report Set 

 
 

13.1.2 Main Function Window 
 
The program will appear the main function window after you selected the test program or 
loaded the project.   In the meantime it will load Microsoft Word with the test program you 
are editing and list its name in the title bar as shown below.  
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Figure 13-5  Report Set Tab in the Program Main Function Window 

 
Note:  It may take longer time to load Microsoft Word at the first time.  It depends on your 
computer speed.  
 
The program divides the main functions into 8 tabs.  They are Report Set, Header, Form, 
Waveform, Correlation, Description, Test Plan and Preview Panel.  The tabs can be switched 
and every tab contains a Report Entity.  You can switch the tabs as need and edit the contents. 
 
Note: When the program first starts it will be in Report Set tab as showed above.  
 
The tree area at right displays the released report items for the current test program.  In this 
program only released report items will be added to Report Set for report generation.  When 
you move among different report items, the yellow area will show its description.  For detail 
information please see section 13.2.6 Report Set. 
 
Following lists the function group in the main window toolbar.  It contains New, Load, Save, 
Save and Release, Preview, and Delete functions that are explained in detail as follows.  
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New  Clear all settings in the current tab and generate new report item. 
Load  Load the related existing report item of the current tab.  
Save  Save the editing report item of the current tab.  It is mainly for 

the unfinished report item.  
Save and Release Release the edited report item in the current tab. 
Preview  Preview the editing report item of the current tab.  However, you 

cannot preview project tab but generate the report directly. 
Delete  Delete the selected editing report item.  
Report Setting Print the settings of various report items. 
Exit  Leave the program. 

 
Notice:  

 Partial function in main window toolbar may be different in report item.  During 
operation you can use these functions for various report item actions. 

 When you execute Preview function, the program will switch the focus to Preview tab.  
Please switch back to the original tab after previewed the result. 

 The program will not save the current setting when executing Preview. 
 You can save the current setting at anytime during editing the report items even the 

editing is not completed.  
 Execute ‘New’ and ‘Load’ will clear all settings in current report item.  As the program 

won’t remind you of this, you need to ‘Save’ or ‘Save and Release’ the current report 
item then execute ‘New’ and ‘Load’ function.  

 Execute ‘Exit’ will leave the program, however the program will remind you to save the 
modified report item. If you wish to keep the current settings, please ‘Save’ or ‘Save and 
Release’ the current report item and then execute ‘Exit’. 

 

 

13.1.2.1 Loading Report Item 
 
You can load the report item at anytime.  The report item loaded is different according to the 
tab you are at.  Following is the example of Correlation.  You can select an existing report 
item and click  OK , wherein the yellow area is read-only.  
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Figure 13-6  Loading Report Item Window 

 
 

13.1.2.2 Saving Report Item 
 
You can save the report item at anytime.  The saved report item is different according to the 
tab you are at.  Following is the example of Header.  You can select an existing report item to 
overwrite the data, also enter new report item name in the yellow area to save it.  
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Figure 13-7  Saving Report Item Window 

 
Notice:  

 An error message will prompt if you try to overwrite a released report item.  You can 
overwrite the existing but not yet released report item, however the program won’t 
remind you of it.  Please be careful when using it. 

 

 
Figure 13-8  Trying to Overwrite a Released Report Item 
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13.1.2.3 Saving and Releasing Report Item 
 
You can release the report item at anytime.  The released report item is different according to 
the tab you are at.  Unlike ‘Save’, the report item cannot be modified if it has been released.  
Following is the example of Waveform.  You can select an existing report item to overwrite 
the data, also enter the name of new report item in the yellow area and release it.  Similarly 
you cannot release an already released report item.  
 

 
 
 

13.2 Operation 

Following sections cover the tab of each function and its operation.  
 
 

13.2.1 Report Header 
 
You can add a new Header report item to place the title, parameter (such as test module name, 
and test time, etc.) or logo for completeness in the report you wish to generate. 
 
To edit Header report item, switch to Header tab. 
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Figure 13-9  Header Report Item Tab Window 

 
For convenient operation, the Header design is fixed in three by three format for earlier 
version and five by five for later version as showed below.  It includes Image, Title and 
Option. 
 

 
Figure 13-10  Header Format 
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13.2.1.1 Setting Header 
 
1. Editing text: 

Double-click any Header cell and use keyboard to edit the reversed text in the cell as 
shown below.  

 

 
Figure 13-11  Editing Header Text 

 
2. Inserting/Deleting Image: 

You can only insert or delete images at ‘Image here’ cell in the Header upper left corner.  
Click the right mouse button at the cell to add new image, then select  Insert Image 
from the menu, a dialog window will appear to let you specify the file to add. 

  

 
Figure 13-12  Adding Header Image 

 
You can click right-click the specified image and select  Delete Image  from the menu 
to delete image from Header. 
 

 
Figure 13-13  Deleting Header Image 
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Notice:  

 It will follow the cell size to adjust the image display when loading an image.  The 
image you see may not in its original size.  You can change the cell size for display.  
However, when generating report in Word you can resize the image as need. 

 Image can only be set in the upper left corner in this program.  However, you can move 
it to any place you want in a Word report. 

 Every Header can insert one image file at most, generally company Logo is preferred; 
however, it only supports the Bitmap file format today.  

 
3. Setting Option:  

You can set it to display the options such as Model Name and Load Count, etc. in the 
program.  The option can be selected from the drop-down menu of the cell as the figure 
shown below. 

  

 
Figure 13-14  Setting Header Option 

 
After selecting the option, the program will display ”$” to separate it from the editing 
text.  The program will get the correct data to show on the report when generating it.  

 
 

13.2.1.2 Previewing Header 
 
You can preview the Header result before generating report to Word.  After you clicked 
Preview, a dialog window will appear to let you specify the result of UUT Serial Number 
report to preview.  
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Figure 13-15  Selecting UUT for Preview Header 

 
Note: The UUT Serial Number selected here is for temporary preview only not for report 
generation.  The program will ask you for the UUTs that you want to generate the report for 
when you actually do it.   
 
Latter the program will switch to Preview tab and generate the preview result of the Header 
report item as shown below.  
 

 
Figure 13-16  The Result in Preview Window 

 
 

13.2.2 Report Form 
 
To display the UUT’s test conditions, readings or test results during report generation; you 
can add a new Form for the report in order to place them.   
 
Switch to Form tab to edit the Form of the report. 
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Figure 13-17  Form Report Item Tab Window 

 
 

13.2.2.1 Form Toolbar 
 
The Toolbar appears on the window is for Form only.  You can move the mouse pointer and 
stop at a toolbar button for 1 second; the program will show its function Hint.  Some 
functions may not be executed in some situations as the buttons may be disabled.  
 
The functions are described as follows. 
 

 
 

 

Report Editing Mode: You can edit report in this mode. 

 

Variable Setting Mode: You can set variable in this mode.  
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To generate new form for this report item.  The program will inquire you if you 
haven’t set the report format. 

 

To load the existing report format.  This action will clear the setting in current 
tab including variables.  

 

To save the current report format but not variable settings.  

  

 

To define a Test Item Group. 

  

 

To specify the range for variable settings. 

 

To clear the specified variable range.  This action will clear all variables that 
set in the range.  

  

 

Set variable: Specify the cell variable in variable setting mode. 

 

Clear variable: To clear the cell variable in variable setting mode. 

  

 

Cut: To cut the selected area without variable information in report editing 
mode. 

 

Copy: To copy the selected area without variable information in report editing 
mode.  

 

Paste: To paste the copied data without variable information in report editing 
mode.  

  

 

Merge the cell: To merge the selected cells. 

 

Cancel the cell merge: To cancel merging the selected cells.  

  

 

Add a new row: To add a new row at the end of the report. 

 

Insert a new row: To insert a new row at the current row.  

 

Delete a row: To delete the current row.  
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Add a new column: To add a new column at the rightmost of the report. 

 

Insert a new column: To insert a new column at the current column. 

 

Delete a column: To delete the current column. 

 
Notice:  

 Only set and clear variable functions are available in variable setting mode.  The rest 
functions are disabled but can be executed in report editing mode.  

 You need to specify the variable setting range for ‘By Test Item Form’ and ‘By TI 
Group Form’ before entering variable setting mode.  

 If you execute the function to clear the specified variable range, it will also clear the set 
variables in the range.  

 Variable setting range cannot exceed one row.  
 Variable setting range cannot merge cells. 
 Cut and paste cannot handle the merged cell and are inactive to variable.  
 Do not destroy the merged cell in a column or a row when adding one.  If the newly 

added row/column is in the variable setting range, the program will automatically 
expand the variable setting range.  

 Do not destroy the merged cell in a column or a row when deleting one.  If the deleted 
row/column is in the variable setting range, the program will automatically change the 
variable setting range.  If there is a variable defined in the column/row for deletion, the 
program will delete it automatically.  

 The functions in toolbar will follow your current action or setting status to decide if they 
are executable.  For the function not executable will be disabled.  

 
 

13.2.2.2 Form Type 
 
There are five types of Form in the program as explained below.  
 
(1) By Test Item Form : To generate report for a particular Test Item.  If there are several 

Test Items in the test program, the program will list all test data 
of the Test Items. 

(2) By TI Group Form : To generate report for all Test Items in Test Item Group, which is 
the union of several Test Items.  You need to specify the Test 
Items to be the member for Test Item Group before using it. 
When specifying the variable, you can only specify the one that 
owned by all members.  

(3) By Sequence ：Semi free format. Specify the test item and variable name of 
each variable, the Load parameter will expand automatically. 

www.valuetronics.com



SMPS ATS 8000 User’s Manual 

 

     13-16 

(4) Free Format 

Form(By Sequence) 
: Free format.  You need to specify the test item, variable name 

and Load No. for each variable.  
(5)Free Format 

Form(BY TI) 

: Free format.  You need to specify the test item, variable name 
and Load No. for each variable. If a Test Item is repeated several 
times in a test program, the program will list all test data of that 
Test Item. 

 
 

13.2.2.3 Specify Form Type 
 
You need to select the Form type before setting the variable.  If you specify new form or new 
form format, the program will inquire you for the Form type.  You don’t need to set the form 
type if you are loading an existing Form.   When you are loading an existed form format, if 
the form type is not defined, the program will ask you for it.  You can start editing Form 
format and specify Form parameter.  
 

 
Figure 13-18  Selecting Form Type 

 
1. After selecting ‘By Test Item Form’, click  Next>>  button will show a dialog window 

for you to specify the Test Item name. 
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2. After selecting ‘By TI Group Form’, you need to use the drop-down menu to select the 
name for TI Group, and then click  Finish  button.  If the drop-down menu is blank it 
means you have not defined a Test Item Group.  For Test Item Group setting, please 
refer to section 13.2.2.4 Setting Test Item Group. 

3. If selected By Sequence or Free Format form then there is no need for other setting.  
You can start editing right away.  

 

 
Figure 13-19  Setting Test Item Name 

 
 

13.2.2.4 Setting Test Item Group 
 
If you wish to include several different Test Items in the generated report, you need to specify 
a Test Item Group first then insert different Test Items to it. 
 
To set Test Item Group, you can execute Test Item Group function defined on the Form 
toolbar.  A Test Item Group window will prompt for you to create a new or modify an existing 
Test Item Group.  Click Create New TI Group to create a new group, or choose Modify TI 
Group to modify an existing one, then click  Next>>  button for the following step. 
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Figure 13-20  Setting Test Item Group – Step 1 

 
The left area lists all Test Items in the Test Program, while the right area lists the Test Items 
that already added to Test Item Group in step 2.  You can use  Add=>  and  <=Del  or 
double-click Test Item to add Test Item to Group or delete from it. 
 

 
Figure 13-21  Setting Test Item Group – Step 2 

 
You need to name the Test Item Group after selected the members.  For management in the 
future, you can also fill in the description (which is omissible) for Test Item Group.  
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13.2.2.5 Editing/Setting Form 
 
Form has two modes: ‘Edit Form’ mode and ‘Set Variable’ mode.  ‘Edit Form’ mode can let 
you set the report layout including Form columns and rows, merged cell, load and save Form 
format, etc.  ‘Set Variable’ mode can let you set the variable to display for a certain cell when 
generating the report.  These two modes cannot be executed at the same time.  You need to use 
the icon on Form toolbar to switch them.  
 
1. Editing Form 

You need to switch to ‘Edit Form’ mode to edit Form.  Double-click the cell to edit or 
input text.  You can also use Copy, Paste, Merge, Insert Row, and Delete Row, etc. 
functions on the Form toolbar to perform the work.  

 
2. Saving/Loading/Clearing Form Format 

The edited Form can be saved for future use.  You can use load, save and clear 
functions on the Form toolbar to complete the work.  

 
3. Defining Variable Range 

Before setting variable, you need to define the range for it.  You can select the range 
and use Form toolbar to set it.  The program will use different color to show the range 
for variable setting. 
  
Notice:  Variable setting range cannot exceed one column. 

 
4. Specifying Variable 

a. You need to switch to ‘Set Variable’ mode before specifying the variable. 
b. You can only set variable within the defined range.  
c. Double-click it or use the ‘Set Variable’ button on the toolbar for variable setting. 
d. You can define the six major options for variable: Available Variables, UUT SN, 

Name of Test Item (TI Name), Name Test Item Extension (TI Ext. Name), Load 
Name and so on as showed below.  You can select the variable and click  OK  or 
double-click the variable to confirm the selection. 
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Figure 13-22  Specifying Form Variable Dialog Window 

 
e. If chose ‘Available Variable’, you need to select a variable from the list in yellow 

area. (i) If this variable is associated with Load, then when report generates it will 
follow the test program load number to expand to several variables.  You can select 
the variables to expand ‘Auto Right’ or ‘Auto Down’.  It will affect the report 
generation type. (ii) If you selected a Vector, please select one of the variables from 
the lower left window.  

 

            
 

f. You can also define the ‘Variable Format’.  ‘Use Default’ uses six integrals and three 
decimals for display format.  
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Notice:  

 The dialog window for specifying variables will be different from the Form types.  For 
example, Test Sequence is selectable in Free Format Form, but it is not selectable in ‘By 
Test Item Form’ and ‘By TI Group Form’. 

 You can use the sorting function to sort variable’s Type, Call Name or Data Type by 
double-clicking to find out the variable that you want to set quickly.  

 Form uses different colors to indicate the current status during setting variables: (1) 
Blue: means no variable set in the range; (2) Green: means the variable set in the range; 
(3) Red: means the variables are setting in the range; (4) Yellow/White: means unable to 
set the range.  

 
 

13.2.2.6 Previewing Form 
 
Before generating report to Word, you can preview the Header result.  Clicked Preview 
function on the function bar to display a dialog window so that you can specify the report 
generation result for the UUT Serial No. you want to preview.  
 

The Preview result shows on Preview tab.  If you want the preview result, you can switch to 
Form tab and Release the edited Form.  Before doing that you can return to Project tab and 
add the edited Form to a project for generating the report to Word. 
 
 

13.2.3 Waveform Item 
 
You can add a Waveform item to place the Waveform figure if you have its data in the test 
program. 
  
The Waveform item supports PCX, BMP, JPG and TIF formats. To edit it, switch to 
Waveform tab first.  
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Figure 13-23  Waveform Tab Window 

 
 

13.2.3.1. Setting Waveform 
 
After switching to Waveform tab, you can start to create a new Waveform. 
 
Click  New  button in the toolbar to show a wizard-type dialog box for you to create a new 
Waveform step by step.  In step 1, you need to select the Waveform type.  If you select By 

Test Item Name, you need to specify one test item as well. RptWizard will generate the 
report of the test item.  If there are several test items in the test program, the program will list 
all waveform data of the test items.  If you want to show several waveform data of different 
test items, you can select Free Format, and RptWizard will ask you to select sequence and 
call name of every waveform data.  Click  Next >  to go to step 2. 
 

www.valuetronics.com



Report Wizard (Option) 

     13-23 

 
 
You can show several waveform data in a Waveform. You can specify the column and row 
numbers to do so. The number greater than 5 is not admitted. When you change the numbers, 
the right area will show the layout result. 
 

 
 
After  clicked  Finish  , all the information you edit will show in the left area of main window. 
You have no chance to modify them. The result of layout will show in the right area of main 
window. There are 6 waveform data in the Waveform in this example. The string "(not 

defined)" means that this position is not yet assigned variable. You can double click the left 
button of the mouse in one rectangle to assign variable.  If you select By Test Item Name, the 
combo box will be disable because you have done it in step 1. The contents in the bottom edit 
box and the waveform data will be showed in the report both together. 
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If you need a Form to display the Waveform related information such as Output/Input 
Voltage, etc., you can click  Condition Setting  button to show a wizard-type dialog box for 
you to select an existing and released Form.  If there is no Form in the database, you can 
switch to Form tab and edit the Form you need.  You can click  Reset Condition  button to 
clear the associated Condition Setting of the Waveform. If select Free Format, you have 
only one choice, Type I, which means all conditions will be show in the beginning of the 
Waveform. 
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Figure 13-24  Condition Setting 

 
In step 2, the edited and released Form(s) are listed in the left box.  The right box lists the 
sequences for you to specify its condition.  Click  Add=> will send the selected Form in the 
left list box to the selected sequence in the right grid.  If the Form is By Test Item or By TI 

Group, you have to specify the Seq. number of the Form as well.  The Position Order at 
lower right can specify the Condition to be placed in front of the Waveform or behind it.  
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13.2.3.2. Previewing Waveform 
 
You can use Preview function to preview the result of generated report.  The Preview result 
shows on Preview tab.  If you want the preview result, you can switch to Waveform tab and 
release the edited Waveform.  Before doing that you can return to Report Set tab and add the 
edited Waveform to a project for generating the report to Word.  
 

 
Figure 13-25  Waveform Preview 

 
 

13.2.4 Description Item 
 
You can add a description item to the report you wish to generate for text insertion such as 
chapter title or addendum.  
 
Switch to Description tab to edit the Description item. 
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Figure 13-26  Description Tab Window 

 
It is easy to edit the Description item.  Just enter the text you wish to insert in the report and 
press Ctrl + Enter to go to the next line. Click  Set Font…  if you wish to change the font 
size.  The program will prompt a standard font selection dialog box for you to choose the font 
type, style and size.  
 
Every computer has different types of fonts available for use.  If you edit a Description to 
output to another computer for report generating, please ensure there is the same font for the 
Description to avoid displaying crashed fonts or creating unexpected result.  
 
 

13.2.5 Correlation Item 
 
You can add a Correlation report item in report.  To edit it, please switch to Correlation tab. 
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13.2.5.1 Setting Correlation 
 
After switching to Correlation tab, use the drop-down menu to select test item, X- Axis 
variable name and UUT, then click  Apply  button to set it.  At this time Correlation display 
can be set.  The program can sift out the test sequences and variable names that contain 
Correlation data.  If the Test Sequence drop-down menu has no data, it means there is no Test 
Sequence that has Correlation data, please try another test program.  
 

 
Figure 13-27  Correlation Tab Window 

 
After set the X-Axis variable, you can select several Y-Axis variables to complete the 
Correlation setting.  Please use the drop-down menu to select Y-Axis test sequence, Y-Axis 
variable name and Legend Name, then click  + Add  button to add the settings.  The program 
will load the variable related information, and its loading time depends on the amount of data.  
 

www.valuetronics.com



Report Wizard (Option) 

     13-29 

 
Figure 13-28  Correlation Variable Setting 

 
You can set the Correlation Title, X-Axis Caption and Y-Axis Caption for Correlation at the 
lower right area.  
 
If you need a Form to display Correlation related information at report generation, you can 
click  Condition Setting  button to prompt a dialog window for you to select an existing and 
released Form.  If there is no Form in the window, please switch to Form tab and refer to 
section 13.2.2 Form Report Item Description to edit the Form you need.  To cancel 
Correlation associated Condition setting, click  Reset Condition  button.  
 
 

13.2.4.2. Previewing Correlation 
 
You can use Preview function to preview the generated result.  The Preview result shows on 
Preview tab.  If you want the preview result, you can switch to Correlation tab and Release 
the edited Correlation.  Before doing that you can return to Report Set tab and add the edited 
Correlation to a project for generating the report to Word. 
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Figure 13-29  Correlation Preview 

 
Note: If X-Axis variable and Y-Axis variable both are True Array Type data variables.  
 
 

13.2.6 Report Set 
 
After the report items for report generation are set and released, you can start editing your 
Report Set item.  
 
To edit Report Set item, please switch to Report Set tab first.  
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Figure 13-30  Report Set Tab Window 

 
 

13.2.5.1 Setting Report Set 
 
In Report Set tab window the left area lists the report items in the current Report Set.  As the 
figure showed above the Report Set has four report items.  The right area lists the Released 
report items in the current test program.  In this program only the Released report item can be 
added to Report Set for report generation.  When you move around different report items the 
area below will appear the report item description. 
 
To add a report item, you can move to a report item at right and double-click it. 
 
You can also use the Report Set toolbar on the top to delete the report item from Report Set or 
change its generation sequence.  Following is the detail description of Toolbar.  
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Delete the report item the pointer is at.  

 

Delete all report items in current project. 

  

 

Move the report item one row upward. (Change the report item generating 
sequence.) 

 

Move the report item one row downward. (Change the report item generating 
sequence.) 

 

Move the report item to the top. (Change the report item generating sequence.) 

 

Move the report item to the bottom. (Change the report item generating 
sequence.) 

  

 

Generate all report items in this project to Word.  This button will be disabled if 
there are no report items in Report Set. 

 
 

13.2.6.2 Generating Report to Word 
 
When all settings are finished you can use the rightmost button on Report Set Toolbar to 
generate report to Word for the current Report Set.  At this time the program will ask you for 
the UUT data for report generation. If you wish to have the report of all UUTs to be generated 
in one Word file, you can uncheck the “Merge UUT(s) Add a new document per UUT”. 
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Figure 13-31  Setting Information for Report Generation 

 
You can always use the Save function to save the unfinished Report Set or load an existing 
Report Set during setting.  
 
Notice:  

 The difference between saved Report Set and released Report Set is that the released 
Report Set can be added to the current Report Set (this means to add all report items to 
the released Report Set) but saved Report Set is unable to do that.  

 
 

13.3 Report Wizard and Word 

 

13.3.1 Execution Process 
 
1. The program will open a new file to place the current report automatically every time a 

report is generated to Word. 
2. Start transmitting the data 
3. It switches to Word automatically for you to check the result of generated report.  
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Notice:  

1. Please do not operate Word during data transmission, or it may interrupt data 
transmission.  The transmission time depends on the data amount.  It may take a few 
minutes.  Please be patient for the completion message.  The progress bar in the 
program will show you the report generation status.  

2. This program will load Word to transmit report data when activated.  It will not load 
again afterwards. Thus do not close Word before exiting the program, or the data would 
not be able to display.  If you closed word accidentally, you can exit the program and 
rerun it to allow the program to load Word automatically.  

 
 

13.3.2 Moving Picture/Changing Size 
 
When the picture border appears, drag the picture to change the size.  You can drag the 
picture to move it around.  
 
 

13.3.3 Word Print Preview  
 
It is better that you run Preview to make sure the printout meets your need.  Please execute 

Word function menu by clicking [File]→[Print Preview]. 
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13.3.4 Setting Word Print Option 
 
If the printout does not meet your needs, you need to set the Print options by executing Word 

function menu [File]→[Page Setup]. 
 

 Orientation: If the print width exceeds the paper width, you can change the orientation 
to Landscape. 

 
 Setting Margin: You can set the print margin to present the report in best shape. 
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14. On-line Control (Option) 

SMPS ATS software ‘On-line Control’ is designed specially for developer.  It integrates the 
system devices to simulate tests manually.  It contains the following seven features. 
  

 Performance and specification evaluation 
 Test strategy verification 
 Failure analysis 
 UUT debugging 
 Test Item debugging 
 Test fixture debugging 
 Test system familiarization 

 
SMPS ATS software ‘On-line Control’ program executes the following actions. 
 
1. Instrument Parameter Setting 

The On-line Control operating screen provides parameter setting for various 
instruments.  After users entered the setting value, ‘On-line Control’ has to get the 
settings from input components, and then call the mapping Test Command to transfer 
the settings to instruments.  ‘On-line Control’ must read the Setting table from each 
instrument in order to provide the setting screen for users and enable the action.  

 
2. Measurement 

In the On-line Control operating screen, the instrument may be able to provide the 
readings once the user finishes a setting action.  In order to let users get the instrument 
readings at any time, ‘On-line Control’ should use Timer to read the readings from 
instrument.  As to what readings should be read, ’On-line Control’ should read the 
Reading table and its contents to add the read action to Timer reading process. 

 
3. Graphs 

The graphs here include Reading Trend Graph, Setting and Reading Graph and 
Oscilloscope Waveform Graph, where the Oscilloscope Waveform Graph needs the 
base oscilloscope to support test commands.  

 
 

14.1 Getting Started 

As ‘On-line Control’ has mass Visual Components, it consumes large memory resources. The 
required memory will increase following the incremental of components.  We suggest user’s 
computer to equip with 128MB RAM.  Before executing ‘On-line Control’ program, and 

www.valuetronics.com



SMPS ATS 8000 User’s Manual 

 

 14-2 

close other unnecessary applications.  The computer would appear different font size or hang 
when the memory is not enough.  
 
In SMPS ATS software main menu, select  On-line Control  from Advance group, the 
program will show the source for selecting hardware configuration.  If Test Program is 
selected, the screen will be prompted follow by window position and hardware parameter 
setting files.  These files can be saved during exit.  After the selection the program will follow 
the settings defined in the hardware configuration for various instrument devices to initialize 
the instruments.  The progress bar in the middle shows the progress.  It takes around 15 to 20 
seconds.  The more instruments the more time it takes.  
 

 
Figure 14-1  Selecting H/W Configuration Source 

 

 
Figure 14-2  Selecting Test Program for H/W Configuration 
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Figure 14-3  Selecting  Setting and Window Position 

 

 
Figure 14-4  System Initializing Window 

 
Latter it enters into ‘On-line Control’ main screen.  The upper left window shows the 
Readings, and error messages are in the middle while the graph is at the bottom.  The upper 
right window shows the parameter settings of various instruments with DSO waveform graph 
in beneath.  The windows can be rearranged as you like.  
 

The window size and position will change according to the resolution when the program 
executes.  You can also adjust them.  In ‘On-line Control’, the program will record down the 
size and position of each window for you before exit.   Thus you don’t need to adjust it again 
at next time. 
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Figure 14-5  On-line Control Main Screen  
 
 

14.2 Operating Environment  

‘On-line Control’ changes the frequently used options in main menu to buttons on the toolbar, 
in which you will see all instrument buttons that are available for use in SMPS ATS software.  
If a button is disabled means the hardware configuration file does not have the instrument or 
no parameter is defined in the database for setting or reading the instrument.  On the contrary 
if a button is enabled, it means the hardware configuration has the instrument and the 
database has the parameter for instrument setting or reading.  If the button is down, it means 
the instrument setting window is on the screen.  You can double-click the instrument button 
on the toolbar to move it on the top if other windows overlap it.  Figure 14-5 On-line Control 
explains the windows associated with.  
 
 
 
 

 

Message Window Message Window 

Reading Display 
Window 

Instrument 
Control Window 

DSO Waveform  
Window  Reading Graph 

Display  Window 
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Reading Display Window 

 
The Reading Display Window on the upper left window in Figure 14-5 is to display the 
measurement readings of various instruments.  You can determine which instrument and 
what parameter to display.  Also you can adjust the number of reading grids on the window 
dynamically.  
 
Defining Reading Display Window Grid Numbers 

 

The grids in the Reading Display Window mean the readings can be displayed.  As the screen 
resolution is different from user’s monitor, ‘On-line Control’ let user define the column and 
row numbers for grid.  You can click [Reading]→[Cell Number of Reading...] to modify it.  

 

 
Figure 14-6  Reading Display Window Grid Setting Dialog Box 

 
Instrument Control Window 

 

The Instrument Control Window on the upper right window in Figure 14-5 is to adjust the 
settings of various instruments.  You can determine which Instrument Control Window to 
display or not.  
 
Reading Graph Display Window 

 

The Reading Graph Display Window on the lower left window in Figure 14-5 is to display 
the parameter change trend through time in graph.  You can select Check Box ( □ ) in the cell 

of Reading Display Window to display the parameter readings in graph.  This window only 
allows for six readings, which means six curve lines on the screen at most.  You can change 
the line color you like.  
 
Changing Graph Display Window Line Color 

 

You can click [System]→[Graph Line Color...] to modify it.  
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Figure 14-7  Line Color Setting Dialog Box 

 

DSO Waveform Window 

 

The DSO Waveform Window in the middle right window in Figure 14-5 is designed specially 
for Digital Storage Oscilloscope to capture its screen. 
 
Message Window 

 

The Message Window on the lower right window in Figure 14-5 is to display the current test 
command execution status and screen update information.  
 
 

14.3 Setting Instrument Parameter 

‘On-line Control’ program provides a single window for all parameters of an instrument.  The 
window height and width are adjusted based on the parameters set for the instrument and 
Channel numbers.  The window gets wider if there are more channels as the typical example 
of the Electronic Load instrument control window below.  
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Figure 14-8  Instrument Control Window 

 
You can click [Configuration]→[Device Name] to modify the number of parameters for 

display as the dialog box shown below.  
 

 
Figure 14-9  Instrument Parameter Setting Dialog Box 
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The Active column above the left table is for you to select the parameters.  When you skip 
one row to another the channel information at the right table will change accordingly.  You 
can modify the Channel Show Name and valid range as well as initial setting for each 
parameter.  Click  OK  button to exit the dialog box after completed the modification. 
Every grid is a setting in Instrument Control Window.  Above the grid displays the parameter 
Show Name while beneath is for you to input the interfaces that  ‘On-line Control’ defines.  
There are five of them.  
 

 Radio Box (for numbers under 4) 
 Knob (for integral and floating point type, numbers are unlimited, non-Load) 
 Slide (for integral and floating point type, numbers are limited, Load) 
 Button (for Boolean type, On/Off) 
 Combo Box (for numbers over 4) 

 
What parameters for which components are defined in the database and not allowed for any 
modifications.  Please contact our program designer for service if you wish to modify it.  
 
When the program executes the first time, all settings in the Instrument Control Window are 
initial values.  You can change them to the value you want but be careful not to exceed the 
valid range or the program will prompt error message and request you to re-enter it.  After 
you changed the control components in the Instrument Control Window, the program will set 
the parameters checked at left column to the instrument.  
 
The parameter maximum numbers allowed is defined in the database and not allowed for any 
modifications.  Please contact our program designer for service if you wish to modify it. 
 
 

14.4 Measurement 

‘On-line Control’ puts all readings in one ‘Readings Display Window’.  As mentioned before 
you can modify the table column and row numbers for window grids.  Before reading you can 
click [Reading]→[Spec of Reading...] to show Figure 14-10 dialog box as below.  
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Figure 14-10  Spec for Reading Dialog Box 

 
When the focus on left table skips to another row, the parameter information at the right table 
at right changes too.  You can edit the Channel Show Name, minimum and maximum spec 
for reading.  Click  OK  to exit the dialog box after completed the modification. 
 
To add a reading to ‘Readings Display Window’, you can point to a blank grid and click the 
right mouse button to appear Figure 14-11 dialog box: 
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Figure 14-11  Selecting Instrument’s Readings Dialog Box 

 
If the parameter you selected has multiple channels, you need to pull down the Combo Box 
on the dialog box and select the Channel Show Name, then click  OK  to exit the dialog box.  
The selected parameter will appear on the grid where the mouse pointer is at as shown below.  
 

 
 
Above the cell appears the parameter Show Name and the spec at left with a slider at right is 
in green if normal and turns to red if exceeds the reading specification.  The lower part is an 
editor for displaying readings.  When the program begins, all readings are ‘*’ in the 
‘Readings Display Window’ for all instruments.  Once you change a control component value 
in Instrument Control Window’, ‘On-line Control’ program will start the read action 
repeatedly at fixed time.  The screen will update the readings periodically until you click 
[Reading]→[Stop Reading]. 
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To delete a reading from ‘Readings Display Window’, you need to move the mouse pointer to 
the Show Name of a window grid and click the right mouse button.  The program will ask 
you if you are sure to delete it.  Click  Yes(Y)  to confirm the deletion.  
 
 

14.5 Graphs 

‘Readings Graph Display Window in Figure 14-12 is to show the parameter variation trend 
through time in graph curve line.  You can select the Check Box ( □ ) in the cell of ‘Reading 

Display Window’ to show the parameter readings in curve line graph. 
  

 
Figure 14-12  Readings Graph Display Window 

 
The window left part is a screen, which contains three components. 
 

 V Scale 
To adjust the scale unit vertically.  

 V Offset 
To adjust the 0 scale offset vertically.  

 Number of Points 
To adjust the number of dots for display horizontally. 

 
No matter it is the instrument setting or readings, if the check box on the left of Show Name 
is enabled, you can check the parameters for curve lines drawing, which are six maximum.  
Once you change a component value in ‘Instrument Control Window’, ‘On-line Control’ 
program will draw the parameter reading in curve line graph in the window.  You can 
compare the differences and relationship among various parameters.  
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14.6 Capturing DSO Waveform Graph 

SMPS ATS software’s ‘On-line Control’ is designed specially for capturing the waveform 
from Digital Storage Oscilloscope (DSO), so that you can see it on computer screen directly 
as Figure 14-13 shows. 
 
If you set several DSOs in ‘H/W Configuration’, Figure 14-13 will show Device 1, Device 
2,…, Device n options to indicate that the waveform showed is for which DSO.  
 

 
Figure 14-13  DSO Waveform Window  

 
You can click  Refresh  button in Figure 14-13 to refresh the screen for the specified DSO. 
Click  Option…  to select  refreshing the screen manually by clicking Refresh or changing 
the screen continuously. Click  Save…   to save the screen to the specified path in hard disk.  
It supports BMP and JPG formats. 
 
Besides capturing the DSO screen, it also supports waveform graph mode.  The 3 buttons at 
lower right are same as described previously.  There are 9 reading functions and Channel 
waveform type for selection in Option.  Right click the 9 readings will appear a reading 
window.  Once the setting is done, the readings can be retrieved continuously.  To disable it 
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right click it again.  The Cursor function at upper right corner is same as DSO.  Vertical or 
Horizontal measurement as well as different channel switch can be set.  When Cursor is 
selected it can be drag and drop to the specified position.  
 

 
Figure 14-14  DSO Waveform Graph Window 

 

 
Figure 14-15  Selecting DSO Waveform Update Method 
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Figure 14-16  DSO Reading Dialog Box 

 
 

14.7 Menu Description 

 

[System]→[Pre. Setting Conf...] Select the setting values for instrument before 
the program enters into main menu.  

[System]→[Miscellaneous Test 

Command...] 

Send commands without any parameters to 
instrument.  

[System]→[Load Name...] Edit each output terminal name of Load 
instruments of which for menu display only.  

[System]→[Graph Line Color...] Define the pen color for Graphic Display 
Window. 

[System]→[Reset Setting and Reading] Clear the settings and readings on the menu of 
all window components and return to the 
instrument initial state.  

[System]→[Save] Select if saving the current setting and 
window position.  
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[System]→[Exit] Exit the program and return to SMPS ATS 
software main menu.  

  

[View]→[Toolbar] Display/Hide Toolbar. 

[View]→[Message Window] Display/Hide test command message window. 

[View]→[Former Window Position…] Read the window position and size of a 
certain previous window.  

[View]→[Reset Position and Size] Reset the position and size of each window to 
its default.  

  

[Reading]→[Cell Number of Reading...] Set the cell number of  ‘Reading Display 
Window’. 

[Reading]→[Spec of Reading...] Edit the Show Name, Min Spec and Max Spec 
of each instrument reading. 

[Reading]→[Go] Start to read the instrument state periodically.  

[Reading]→[Stop Reading] Stop to read the instrument state periodically.  

  

[Show/Hide Setting]→[Device Name] Display/Hide an instrument (ex, AC Source, 
DC Source and Load) control window.  

[Show/Hide Setting]→[Show All] Display all Instrument Control Windows. 

[Show/Hide Setting]→[Hide All] Hide all Instrument Control Windows. 

  

[Configuration]→[Device Name] Specify if display the setting for an 
instrument. 

  

[Help]→[Contents] Display the table of contents for the online 
documentation. 

[Help]→[About On-line Control…] Display the version information of this 
program.  
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Appendix A Test Result Log File 
 
All test result log files are in SMPS ATS software working directory under Log subdirectory.  
Every test program has its log file directory and contents.  So all logs are divided by test 
program.  
 
Assuming the test program named “MyPrg.prg”, a subdirectory named MyPrg will be created 
under Log directory.  This subdirectory logs the test results the test program executed. Here 
two types of Microsoft Access database files (.mdb) are defined, TestInfo.mdb and 
MyPrg@yyyymmdd.mdb, where yyyy is for western year, mm is for month, dd is for date.  
The table contents are described as follows.  

 
1. TestInfo.mdb: Log testes UUT serial number, including two tables {UUTRetest} and 

{TPInfo} as listed below.  
 
{UUTRetest} data table:  Serial number for tested UUT and times for retest.  

 
SerialNo Text for UUT’s serial number.  
RetestTime Data and time of the test.  
Times Integer for the number of times the UUT tested, "0" means the 

first test, "1" means the first retest.  
 

{TPInfo} data table:  Test program information. 
 

Key Text for name.  
Value Text for content. 

 
Following are the definition of logs.  

 

Key Value 
TPFileName The name of test program.  

TPFilePath The directory for saving test program.  

Author The author of test program.  

Comment The comment for test program.  

ReportFile The report format file for test program.  

ModelName The Model name for test program.  

LoadNum The Load number set by test program.  

Load1 The name for the first Load. 

Load2 The name for the second Load. 

…  
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MajorVer The major version number of test program.  

MinorVer The minor version number of test program. 

DateTime The time generated by test program (20000304171256 means 
year 2000 March 4th 17:12:56) 

PreSeqNum The total number of PreTest sequences in test program. 

PreSeq1 The name of the first PreTest sequence. 

PreSeqExt 1 The description of the first PreTest.  

… Add by the number of PreSeqNum.   

PostSeqNum The total number of PostTest sequences in test program.  

PostSeq1 The first name of PostTest sequence.  

PostSeqExt1 The description of the first PostTest sequence.  

… Add by the number of PostSeqNum. 

SeqNum The total number of UUT Test sequences in test program.  

Seq1 The first name of UUT Test sequence.   

SeqExt1 The description of the first UUT Test sequence.  

… Add by the number of SeqNum. 

 
2. MyPrg@20000531.mdb (for example): The database to log test result of everyday in 

different log files by date.  There are seven data tables: {SPCLogData} , 
{SPCLogDataBinary} , {SPCSpec} , {SPCSpecBinary} , {SPCVar} , {HeaderInfoSet} 
and{SPCVectorGlobal} as explained below.  

 
{SPCLogData} data table: Save numeric type values of everyday test result as explained 
below.  

 
SerialNo Text for UUT serial number.  
VarID Long integer for variable sequential number defined by 

‘Execution Controller’ following the Test Program. 
Value Numerical readings.  
Result Byte (number),”0” is Fail and ”1” is Pass.  
RetestTimes Integer for the retest times, the index value in index database 

TestInfo.mdb{UUTRetest} . 
RunStep Integer for the execution step.  

 
{SPCLogDataBinary} data table: Save nonnumeric type values of everyday test result as 
explained below. 

 
SerialNo Text for UUT serial number.  
VarID Long integer for variable sequential number defined by 

‘Execution Controller’ following TestProgram. 
Value Binary value for the content is decided by parameter type. 
Result Byte (number),”0” is Fail and ”1” is Pass.  
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RetestTimes Integer for the retest times, the index value in index database 
TestInfo.mdb{UUTRetest} . 

RunStep Integer for the execution step.  
 
{SPCSpec} data table: To log the input parameter numeric value (mainly for spec.)  As the 
input parameter will not change during execution, so it is logged into data table.  The various 
columns are described as below.  
 

SeqNo Number for the sequential number of test item in test program 
starting from ”0”. 

TestItemName Text for the name of test item.  
LoadNo Number for Element Index, the variable is 0 if not Array 

related. 
CallName Text of the Call Name for input parameter.  
Value Number for numeric value of parameter.  
DataType Number for variable type.  
DataFlag Number for variable type.  Following Bit to decide the state. 

0x01: Fail, 0x02: Invalid, 0x04: Less, 0x08:Greater, 
0x10:Don’t care. 

Remark Reminder, which is not used.  
 
{SPCSpecBinary} data table: To log the input parameter nonnumeric value (mainly for spec.)  
As the input parameter will not change during execution, so it is logged into data table.  The 
various columns are described as below. 
 

SeqNo Number for the sequential number of test item in test program 
starting from ”0”. 

TestItemName Text for the name of test item. 
LoadNo Number for Element Index, the variable is 0 if not Array 

related. 
CallName Text of the Call Name for input parameter. 
Value Binary value for the content is decided by parameter type. 
DataType Number for variable type.  
DataFlag Number for variable type.  Following Bit to decide the state. 

0x01: Fail, 0x02: Invalid, 0x04: Less, 0x08: Greater, 0x10: 
Don’t care.  

Remark Reminder, which is not used. 
 
{SPCVar} data table: To log all reading variables related information.  This data table is in 
fact a variable mapping table.  Before inquiring the test result, you should cross check the 
variable information for its sequential number and use it to inquire the variable numeric value 
in MyPrg@19991101.mdb   (for example).  The columns are described below.  
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VarID Number for unique variable sequential number defined by 
‘Execution Controller’ following the Test Program. 

SeqNo Number for the sequential number of test item in test program 
starting from ”0”. 

LoadNo Number for Element Index, the variable is 0 if not Array 
related. 

TestItemName Text for the name for test item.  
CallName Text of the Call Name for input parameter. 
MaxSpec Text for the reading maximum spec maps to the input 

parameter Call Name. 
MinSpec Text for the reading minimum spec maps to the input 

parameter Call Name. 
DataType Number for variable type. 
Remark Reminder, which is not used. 

 
{HeaderInfoSet} data table: To log the UUT information.  
 

SerialNo Text for the UUT serial number.  
ModelName Text for the UUT model name.  
LotNumber Text for the UUT lot number. 
OrderNumber Text for the order number.  
Environment Text for the environment temperature during test.  
Inspector Text for the name of inspector.  
Customer Text for the name of customer.  
ElapsedTime Text for the time testing spends.  
SystemTime Text for the system time during test. 
RetestTimes Integer for retest times.  It is the index value for index database 

(Retest.mdb). 
 
{SPCVectorGlobal} data table: To log the Global and Vector contents during test.  
 

Type Number for variable type, 19:Global, 20~29 are Vector.  
Others not defined.  

Index Number for Vector: The Element number of the Vector. 
Global: Define Global variable sequence (0~5). 
(System/User)*(Pre/UUT/Post). 

IndexName Number for Vector: Vector name. Global: “Global” string.  
CallName Text for the name of variable.  
LoadNo Number for Element Index, the variable is 0 if not Array 

related. 
Value Number for value.  
Remark Reminder, which is not used. 
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Appendix B Contact Chroma 
 
 
For your convenience, this appendix contains a form for you to log the problems you found 
when operating the product or any comments in using this manual that can help us solve the 
technical problems in the future.  Please copy and fill in the Quality Process form before 
mailing it to us.  Your help is highly appreciated.  
 
You can contact us via the phone and fax numbers listed below or mail it to the following 
address.  
 
 
CHROMA ATE INC. 
66 Hwa-Ya 1st Rd., Hwa-Ya Technical Park, 
Kuei-Shan Hsiang, Taoyuan Hsien, Taiwan 
Tel: 886-3-327-9999 
Fax: 886-3-327-2886 
http://www.chromaate.com 
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Chroma’s Continuous Quality Process 

READER COMMENTS 

(Fax this form to 886-3-327-2886) 
 
Chroma welcomes all comments and recommendations to improve future editions of this 
publication. 
 

Your Name:  Company:  

Address:  

State:  Country:  Zip:  

Tel. No:  Fax No:  Date:  

Manual Title:   

 
COMMENTS / RECOMMENDATIONS 
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